#ubuntu-meeting: Ubuntu Backports Team meeting

Meeting started by ddstreet at 16:10:26 UTC (full logs)

Meeting summary

  1. previous action items (ddstreet, 16:10)
    1. ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over) (ddstreet, 16:11)
      1. ACTION: ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over) (ddstreet, 16:11)
      2. ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over) (ddstreet, 16:11)
      3. ACTION: ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over) (ddstreet, 16:11)
      4. ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html (ddstreet, 16:11)
      5. ACTION: ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html (ddstreet, 16:11)
      6. ddstreet review cockpit backport uploads (ddstreet, 16:11)
      7. ddstreet ping email to keep thread alive: clarification on specific wording for no-bug-required backport exceptions (ddstreet, 16:11)
      8. ACTION: ddstreet ping email to keep thread alive: clarification on specific wording for no-bug-required backport exceptions (ddstreet, 16:12)
      9. ddstreet sched next mtg oct 25 (ddstreet, 16:12)
      10. mapreri upload (more of) all the tools (carried over, in progress) (ddstreet, 16:12)
      11. ACTION: mapreri upload (more of) all the tools (carried over, in progress) (ddstreet, 16:12)
      12. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over) (ddstreet, 16:12)
      13. ACTION: mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over) (ddstreet, 16:12)
      14. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over) (ddstreet, 16:12)
      15. ACTION: mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over) (ddstreet, 16:12)
      16. mapreri start thread on ML about how to use bug status to define meaing in process (carried over) (ddstreet, 16:12)
      17. ACTION: mapreri start thread on ML about how to use bug status to define meaing in process (carried over) (ddstreet, 16:13)
      18. teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over) (ddstreet, 16:13)
      19. ACTION: teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over) (ddstreet, 16:13)
      20. (unassigned) consider documenting an SLA for reviewing uploaded backport packages (ddstreet, 16:13)
      21. ACTION: (unassigned) consider documenting an SLA for reviewing uploaded backport packages (ddstreet, 16:13)
      22. (unassigned) check if backports pocket uploads and/or approvals go to a ML (carried over) (ddstreet, 16:13)
      23. ACTION: (unassigned) check if backports pocket uploads and/or approvals go to a ML (carried over) (ddstreet, 16:13)
      24. (unassigned) if no ML for backports uploads/approvals, check on how to create one (carried over) (ddstreet, 16:14)
      25. ACTION: (unassigned) if no ML for backports uploads/approvals, check on how to create one (carried over) (ddstreet, 16:14)

  2. open ML threads (ddstreet, 16:14)
    1. clarification on specific wording for no-bug-required backport exceptions (ddstreet, 16:14)
      1. https://lists.ubuntu.com/archives/ubuntu-backports/2022-February/022680.html (ddstreet, 16:15)
      2. ACTION: clarification on specific wording for no-bug-required backport exceptions (carried over) (ddstreet, 16:15)
      3. staging grub 2.12 backports in backports pocket during 24.04 developement cycle (ddstreet, 16:16)
      4. https://lists.ubuntu.com/archives/ubuntu-backports/2023-October/023128.html (ddstreet, 16:16)
      5. https://lists.ubuntu.com/archives/ubuntu-backports/2023-November/023150.html (my reply asking for clarification) (ddstreet, 16:17)
      6. ACTION: staging grub 2.12 backports in backports pocket during 24.04 developement cycle (ddstreet, 16:19)
      7. Backport uploads to non-LTS releases (ddstreet, 16:21)
      8. https://lists.ubuntu.com/archives/ubuntu-backports/2023-October/023129.html (ddstreet, 16:21)
      9. ACTION: ddstreet update exception list to add cockpit, cockpit-machines, cockpit-podman (ddstreet, 16:28)
      10. https://wiki.ubuntu.com/UbuntuBackports#Allowed_in_non-LTS_releases (ddstreet, 16:28)

  3. open bugs needing discussion (ddstreet, 16:29)
    1. ACTION: ddstreet review cockpit uploads to non-LTS releases (ddstreet, 16:29)

  4. AOB (ddstreet, 16:30)
    1. ACTION: ddstreet note in wiki exceptions are evalated on a case by case basis (ddstreet, 16:30)
    2. next mtg date (ddstreet, 16:31)
      1. ACTION: ddstreet email mapreri (and list) to pick next mtg date (probably in jan) (ddstreet, 16:32)


Meeting ended at 16:35:23 UTC (full logs)

Action items

  1. ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
  2. ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
  3. ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html
  4. ddstreet ping email to keep thread alive: clarification on specific wording for no-bug-required backport exceptions
  5. mapreri upload (more of) all the tools (carried over, in progress)
  6. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
  7. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
  8. mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
  9. teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over)
  10. (unassigned) consider documenting an SLA for reviewing uploaded backport packages
  11. (unassigned) check if backports pocket uploads and/or approvals go to a ML (carried over)
  12. (unassigned) if no ML for backports uploads/approvals, check on how to create one (carried over)
  13. clarification on specific wording for no-bug-required backport exceptions (carried over)
  14. staging grub 2.12 backports in backports pocket during 24.04 developement cycle
  15. ddstreet update exception list to add cockpit, cockpit-machines, cockpit-podman
  16. ddstreet review cockpit uploads to non-LTS releases
  17. ddstreet note in wiki exceptions are evalated on a case by case basis
  18. ddstreet email mapreri (and list) to pick next mtg date (probably in jan)


Action items, by person

  1. ddstreet
    1. ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
    2. ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
    3. ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html
    4. ddstreet ping email to keep thread alive: clarification on specific wording for no-bug-required backport exceptions
    5. ddstreet update exception list to add cockpit, cockpit-machines, cockpit-podman
    6. ddstreet review cockpit uploads to non-LTS releases
    7. ddstreet note in wiki exceptions are evalated on a case by case basis
    8. ddstreet email mapreri (and list) to pick next mtg date (probably in jan)
  2. teward
    1. teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over)
  3. UNASSIGNED
    1. mapreri upload (more of) all the tools (carried over, in progress)
    2. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
    3. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
    4. mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
    5. (unassigned) consider documenting an SLA for reviewing uploaded backport packages
    6. (unassigned) check if backports pocket uploads and/or approvals go to a ML (carried over)
    7. (unassigned) if no ML for backports uploads/approvals, check on how to create one (carried over)
    8. clarification on specific wording for no-bug-required backport exceptions (carried over)
    9. staging grub 2.12 backports in backports pocket during 24.04 developement cycle


People present (lines said)

  1. ddstreet (95)
  2. teward (34)
  3. meetingology (21)


Generated by MeetBot 0.4.0