16:10 <ddstreet> #startmeeting Ubuntu Backports Team
16:10 <meetingology> Meeting started at 16:10:26 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:10 <meetingology> Available commands: action, commands, idea, info, link, nick
16:10 <ddstreet> #topic previous action items
16:10 <ddstreet> i think almost all these are carry-overs so i'll run through them quick
16:11 <ddstreet> #subtopic ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:11 <ddstreet> #action ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:11 * meetingology ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:11 <ddstreet> #subtopic ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
16:11 <ddstreet> #action ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
16:11 * meetingology ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
16:11 <ddstreet> #subtopic ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html
16:11 <ddstreet> #action ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html
16:11 * meetingology ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html
16:11 <ddstreet> #subtopic ddstreet review cockpit backport uploads
16:11 <ddstreet> i did this one! :-)
16:11 <ddstreet> #subtopic ddstreet ping email to keep thread alive: clarification on specific wording for no-bug-required backport exceptions
16:12 <ddstreet> #action ddstreet ping email to keep thread alive: clarification on specific wording for no-bug-required backport exceptions
16:12 * meetingology ddstreet ping email to keep thread alive: clarification on specific wording for no-bug-required backport exceptions
16:12 <ddstreet> #subtopic ddstreet sched next mtg oct 25
16:12 <ddstreet> did that one too! :)
16:12 <ddstreet> i'll run thru mapreri's as well since he's not here
16:12 <ddstreet> #subtopic mapreri upload (more of) all the tools (carried over, in progress)
16:12 <ddstreet> #action mapreri upload (more of) all the tools (carried over, in progress)
16:12 * meetingology mapreri upload (more of) all the tools (carried over, in progress)
16:12 <ddstreet> #subtopic mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
16:12 <ddstreet> #action mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
16:12 * meetingology mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
16:12 <ddstreet> #subtopic mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
16:12 <ddstreet> #action mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
16:12 * meetingology mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
16:12 <ddstreet> #subtopic mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
16:13 <ddstreet> #action mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
16:13 * meetingology mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
16:13 <ddstreet> #subtopic teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over)
16:13 <ddstreet> assume i should carry this over teward?
16:13 <teward> ye
16:13 <ddstreet> #action teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over)
16:13 * meetingology teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over)
16:13 <teward> #NeverEnoughCycles
16:13 <ddstreet> #subtopic (unassigned) consider documenting an SLA for reviewing uploaded backport packages
16:13 <ddstreet> #action (unassigned) consider documenting an SLA for reviewing uploaded backport packages
16:13 * meetingology (unassigned) consider documenting an SLA for reviewing uploaded backport packages
16:13 <ddstreet> #subtopic (unassigned) check if backports pocket uploads and/or approvals go to a ML (carried over)
16:13 <ddstreet> #action (unassigned) check if backports pocket uploads and/or approvals go to a ML (carried over)
16:13 * meetingology (unassigned) check if backports pocket uploads and/or approvals go to a ML (carried over)
16:14 <ddstreet> #subtopic (unassigned) if no ML for backports uploads/approvals, check on how to create one (carried over)
16:14 <ddstreet> #action (unassigned) if no ML for backports uploads/approvals, check on how to create one (carried over)
16:14 * meetingology (unassigned) if no ML for backports uploads/approvals, check on how to create one (carried over)
16:14 <ddstreet> indeed i always think i'll be able to find time but rarely do
16:14 <ddstreet> ok that's all previous items
16:14 <ddstreet> #topic open ML threads
16:14 <ddstreet> #subtopic clarification on specific wording for no-bug-required backport exceptions
16:15 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2022-February/022680.html
16:15 <ddstreet> i think we need to carry this one
16:15 <teward> yup
16:15 <ddstreet> #action clarification on specific wording for no-bug-required backport exceptions (carried over)
16:15 * meetingology clarification on specific wording for no-bug-required backport exceptions (carried over)
16:16 <ddstreet> #subtopic staging grub 2.12 backports in backports pocket during 24.04 developement cycle
16:16 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2023-October/023128.html
16:17 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2023-November/023150.html (my reply asking for clarification)
16:17 <ddstreet> teward not sure if you read his email yet, but i'm not totally clear on what he's asking about?
16:18 <ddstreet> juliank in case you're around ^
16:18 <teward> i havent - i have a ton of higher priority CC-hat emails drifting around
16:19 <ddstreet> ok, let's just leave this one in the ML then, my reply was recent so let's give him some time to follow up
16:19 <ddstreet> i'll keep it on the open threads
16:19 <ddstreet> #action staging grub 2.12 backports in backports pocket during 24.04 developement cycle
16:19 * meetingology staging grub 2.12 backports in backports pocket during 24.04 developement cycle
16:19 <teward> i mean I don't see a benefit of this being in backports if its quirky and not stable
16:19 <ddstreet> right, me neither
16:20 <ddstreet> i assumed i must have misunderstood what he was proposing
16:20 <teward> grub* is one of those things I dont think can be safely backported either without extreme care, hence why SRU/security processes cover it
16:20 <teward> (using backports as staging isnt what backports is for)
16:21 <ddstreet> yeah total agreement on that
16:21 <ddstreet> #subtopic https://lists.ubuntu.com/archives/ubuntu-backports/2023-October/023129.html
16:21 <teward> (this is what Experimental is for Debian Unstable but I digress)
16:21 <ddstreet> #undo
16:21 <meetingology> Removing item from minutes: SUBTOPIC
16:21 <ddstreet> #subtopic Backport uploads to non-LTS releases
16:21 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2023-October/023129.html
16:21 <ddstreet> this is for the cockpit uploads to the non-LTS releases
16:22 <ddstreet> our current policy is to only allow specifically exempted packages to get backported to non-LTS
16:22 <ddstreet> my email was just to revisit that (in general, not specifically for cockpit pkgs)
16:23 <teward> i think cockpit is an exception not the rule.  the problem with interim releases is a lot of times backporting in interim can happen but then get lost in the chain
16:23 <teward> historically it overloaded backporters
16:23 <ddstreet> so it's probably better to keep the restriction but allow an exception for cockpit you think?
16:24 <ddstreet> i'm fine either way, and i can see how it would overload us if it becomes more common
16:24 <teward> imo there will always be exceptions
16:24 <teward> on an adhoc basis or as needed
16:24 <teward> but yes cockpit is one i would give as an exception
16:24 <teward> and also add to our no-bug-needed backports list (its a special case)
16:25 <ddstreet> i don't think we currently have any formal exception process for it currently, you think we need to define one, or just have informal exception agreements during our normal meetings?
16:25 <teward> if it becomes more common, we can create formal processes.  for now as long as we are quorate on exceptions we should be OK
16:26 <teward> i dont see us granting a lot of exceptions
16:26 <ddstreet> agreed
16:26 <ddstreet> ok so we're quorate (since we have 2/3 today) and we both agree to keep the non-LTS restriction but also to give an exception to cockpit (and cockpit-podman, cockpit-machines) for non-LTS and no-bug-required
16:27 <ddstreet> right?
16:27 <ddstreet> i can update our wiki page to add its exception if so
16:27 <teward> if you are in agreement with me on all that then yes
16:27 <ddstreet> yep i am
16:27 <ddstreet> ok i'll update the exception list
16:27 <teward> then go right ahead and update the wiki
16:27 <teward> yep
16:28 <ddstreet> #action ddstreet update exception list to add cockpit, cockpit-machines, cockpit-podman
16:28 * meetingology ddstreet update exception list to add cockpit, cockpit-machines, cockpit-podman
16:28 <ddstreet> #link https://wiki.ubuntu.com/UbuntuBackports#Allowed_in_non-LTS_releases
16:28 <ddstreet> for my reference
16:28 <ddstreet> ok i think that's all the ML threads unless i missed something
16:29 <ddstreet> #topic open bugs needing discussion
16:29 <ddstreet> I don't see any open bugs, and i went through the upload queues earlier today
16:29 <ddstreet> i'll handle the cockpit uploads to non-LTS releases
16:29 <ddstreet> #action ddstreet review cockpit uploads to non-LTS releases
16:29 * meetingology ddstreet review cockpit uploads to non-LTS releases
16:29 <teward> perfect
16:30 <ddstreet> #topic AOB
16:30 <ddstreet> i think we've covered everything?
16:30 <ddstreet> anything else?
16:30 <teward> ddstreet: make a note that exceptions are evaluated on a case by case basis
16:30 <ddstreet> yep
16:30 <ddstreet> #action ddstreet note in wiki exceptions are evalated on a case by case basis
16:30 * meetingology ddstreet note in wiki exceptions are evalated on a case by case basis
16:31 <ddstreet> next mtg date?
16:31 <ddstreet> #subtopic next mtg date
16:31 <ddstreet> i think 4 wks gets into the holidays
16:31 <teward> and are for exceptional cases NOT regular cases (so there has to be real strong support for an exception case for it to be approved)
16:31 <teward> ye 4 weeks is right in holiday weeks
16:31 <teward> we may be able to skip and just do an early january meeting in place of it
16:31 <teward> if theres no objections
16:31 <ddstreet> yeah let's move it to jan
16:32 <ddstreet> works for me
16:32 <teward> (email mapreri though to make sure they are OK with it)
16:32 <ddstreet> yep
16:32 <ddstreet> #action ddstreet email mapreri (and list) to pick next mtg date (probably in jan)
16:32 * meetingology ddstreet email mapreri (and list) to pick next mtg date (probably in jan)
16:33 <ddstreet> i think either jan 3 or jan 10 is most likely, probably jan 10 in case any of us is out right after the new year
16:33 <ddstreet> but i'll email
16:33 <teward> i'm always around by jan3 xD
16:33 <ddstreet> lol i *probably* will be over my hangover by then ;-)
16:33 <teward> IT Security never sleeps though so.  :P
16:34 <ddstreet> yeah you might be around jan 1 in that line of work :)
16:34 <teward> well thats a day off but technically you're right
16:34 <teward> emergency or smth
16:34 <ddstreet> hope that pager doesn't go off at 12:01am jan 1 ;-P
16:34 <teward> lol
16:35 <teward> well i am gonna go get food i'm hungry
16:35 <ddstreet> sounds good and i think we're wrapped up!
16:35 <ddstreet> thanks!
16:35 <teward> if theres no other business?
16:35 <teward> perfect thank you!  *disappears to lunch*
16:35 <ddstreet> #endmeeting