#ubuntu-meeting: Ubuntu Backporters Team meeting

Meeting started by ddstreet at 16:04:15 UTC (full logs)

Meeting summary

  1. previous action items (ddstreet, 16:04)
    1. ddstreet update tooling, requestbackport, backportpackage (carried over) (ddstreet, 16:05)
      1. ACTION: teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (ddstreet, 16:11)
      2. ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over) (ddstreet, 16:11)
      3. ACTION: ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over) (ddstreet, 16:12)
      4. ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over) (ddstreet, 16:12)
      5. ACTION: ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over) (ddstreet, 16:13)
      6. ddstreet update policies wiki page to remove 'draft' header (done) (ddstreet, 16:13)
      7. ddstreet add link to policies wiki page, to main wiki page https://wiki.ubuntu.com/UbuntuBackports (done) (ddstreet, 16:13)
      8. ddstreet schedule next mtg 2023-02-15 same time (done) (ddstreet, 16:13)
      9. mapreri upload (more of) all the tools (carried over, in progress) (ddstreet, 16:13)
      10. ACTION: mapreri upload (more of) all the tools (carried over, in progress) (ddstreet, 16:14)
      11. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over) (ddstreet, 16:14)
      12. ACTION: mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over) (ddstreet, 16:15)
      13. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over) (ddstreet, 16:15)
      14. ACTION: mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over) (ddstreet, 16:16)
      15. mapreri start thread on ML about how to use bug status to define meaing in process (carried over) (ddstreet, 16:16)
      16. ACTION: mapreri start thread on ML about how to use bug status to define meaing in process (carried over) (ddstreet, 16:16)
      17. mapreri to look into backporting dh-python (see unit193 and yt-dlp) (ddstreet, 16:16)
      18. ACTION: mapreri to look into backporting dh-python (see unit193 and yt-dlp) (ddstreet, 16:17)
      19. mapreri draft response email re: charter to TB (ddstreet, 16:17)

  2. open mailing list threads (ddstreet, 16:18)
    1. clarification on specific wording for no-bug-required backport exceptions (ddstreet, 16:19)
      1. ACTION: ddstreet reply to no-bug-required backport exception ML thread to keep thread alive (ddstreet, 16:20)
      2. TB mailing list charter email (ddstreet, 16:20)
      3. https://lists.ubuntu.com/archives/technical-board/2023-March/002713.html (ddstreet, 16:21)
      4. https://lists.ubuntu.com/archives/technical-board/2023-March/002714.html (ddstreet, 16:22)
      5. https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023027.html (luna, 16:22)
      6. https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023027.html (ddstreet, 16:22)
      7. ACTION: (unassigned) consider documenting an SLA for reviewing uploaded backport packages (ddstreet, 16:29)

  3. open bugs needing discussion (ddstreet, 16:32)
    1. https://bugs.launchpad.net/ubuntu/+source/memtest86+/+bug/1998834 (ddstreet, 16:32)
    2. ACTION: ddstreet sponsor lp: #1998834 (ddstreet, 16:35)

  4. AOB (ddstreet, 16:36)
    1. ACTION: ddstreet sched next mtg Apr 12 (ddstreet, 16:48)


Meeting ended at 16:50:49 UTC (full logs)

Action items

  1. teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar)
  2. ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
  3. ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
  4. mapreri upload (more of) all the tools (carried over, in progress)
  5. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
  6. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
  7. mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
  8. mapreri to look into backporting dh-python (see unit193 and yt-dlp)
  9. ddstreet reply to no-bug-required backport exception ML thread to keep thread alive
  10. (unassigned) consider documenting an SLA for reviewing uploaded backport packages
  11. ddstreet sponsor lp: #1998834
  12. ddstreet sched next mtg Apr 12


Action items, by person

  1. ddstreet
    1. ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
    2. ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
    3. ddstreet reply to no-bug-required backport exception ML thread to keep thread alive
    4. ddstreet sponsor lp: #1998834
    5. ddstreet sched next mtg Apr 12
  2. mapreri
    1. mapreri upload (more of) all the tools (carried over, in progress)
    2. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
    3. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
    4. mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
    5. mapreri to look into backporting dh-python (see unit193 and yt-dlp)
  3. teward
    1. teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar)
  4. UNASSIGNED
    1. (unassigned) consider documenting an SLA for reviewing uploaded backport packages


People present (lines said)

  1. ddstreet (116)
  2. mapreri (75)
  3. luna (22)
  4. teward (18)
  5. meetingology (16)
  6. Eickmeyer (1)
  7. ubottu (1)


Generated by MeetBot 0.4.0