16:04 <ddstreet> #startmeeting Ubuntu Backporters Team
16:04 <meetingology> Meeting started at 16:04:15 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:04 <meetingology> Available commands: action, commands, idea, info, link, nick
16:04 <ddstreet> I'll go thru the previous action items, but I've been busy and sick the last 2 weeks so I haven't got anything done
16:04 <ddstreet> #topic previous action items
16:05 <ddstreet> #subtopic ddstreet update tooling, requestbackport, backportpackage (carried over)
16:05 <mapreri> I also had some troubles in the past month :(
16:05 <ddstreet> #action ddstreet update tooling, requestbackport, backportpackage (carried over)
16:05 * meetingology ddstreet update tooling, requestbackport, backportpackage (carried over)
16:05 <mapreri> hold on
16:05 <ddstreet> ok
16:05 <ddstreet> ah sorry that did see some work didn't it
16:06 <mapreri> I think this is actually done?  Probably need a check, and I'm aware of one bug in backportpacakge (uses the wrong -v value for dpkg-gencahgnes)
16:06 <ddstreet> #undo
16:06 <meetingology> Removing item from minutes: ACTION
16:06 <mapreri> my right hand is quicker than my left hand today, looking at those typos :3
16:06 <ddstreet> so we should just add an action for someone to verify that then right?
16:06 <mapreri> imho yep
16:06 <ddstreet> lol
16:06 <teward> i'm here
16:06 <mapreri> hey teward !
16:06 <teward> 6 min late but i aws having some issues
16:07 <teward> i was*
16:07 <teward> (had to reboot router)
16:07 <ddstreet> hey! and we were just about to assign it to you since you were gone xD
16:07 <teward> assign what lol
16:07 <mapreri> ahah
16:07 <ddstreet> we think the tooling (backportpackage, etc) has been updated, just need one of us to verify it's good, you want to take that?
16:08 <mapreri> [01 05:05:59 PM] <mapreri> […]I'm aware of one bug in backportpacakge (uses the wrong -v value for dpkg-gencahgnes)
16:08 <teward> yeah i'll take verification ,just send me the list of what all in the tooling needs verified/tested
16:08 <teward> because without the list i'm going to not be 100% accurate
16:08 <mapreri> well…
16:09 <teward> *is running on 75% mental capacity after migraines all day yesterday*
16:09 <luna> can relate to migranes :(
16:09 <mapreri> I'd just want to say "make sure there are NO bugs" :P
16:09 <teward> ;P
16:10 <teward> mapreri: "backportpackage, etc." is vague, do you have the full list of tooling?
16:10 <teward> backportpackage and what else?  (dead)
16:10 <mapreri> backportpackage and requestbackport, are the two tools
16:10 <ddstreet> ok so i'll action teward looking at those 2 tools
16:10 <teward> check i'll poke it, updated in Lunar you mean or updated elsewhere?  just making sure i have the right target versions when i test in containers
16:10 <mapreri> yes, lunar
16:11 <ddstreet> #action teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar)
16:11 * meetingology teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar)
16:11 <ddstreet> #subtopic ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:12 <ddstreet> anyone else want this one? i will get to it eventually but it's been carried a while
16:12 <mapreri> I'll leave it with you :3
16:12 <ddstreet> ok :)
16:12 <ddstreet> #action ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:12 * meetingology ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:12 <ddstreet> #subtopic ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
16:13 <ddstreet> #action ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
16:13 * meetingology ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
16:13 <ddstreet> #subtopic ddstreet update policies wiki page to remove 'draft' header (done)
16:13 <ddstreet> done
16:13 <ddstreet> #subtopic ddstreet add link to policies wiki page, to main wiki page https://wiki.ubuntu.com/UbuntuBackports (done)
16:13 <ddstreet> also done
16:13 <ddstreet> #subtopic ddstreet schedule next mtg 2023-02-15 same time (done)
16:13 <ddstreet> done, obviously :)
16:13 <ddstreet> #subtopic mapreri upload (more of) all the tools (carried over, in progress)
16:14 <mapreri> aye
16:14 <ddstreet> this probably will be carried over for a while right?
16:14 <mapreri> carried over still
16:14 <ddstreet> #action mapreri upload (more of) all the tools (carried over, in progress)
16:14 * meetingology mapreri upload (more of) all the tools (carried over, in progress)
16:14 <ddstreet> #subtopic mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
16:15 <ddstreet> #action mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
16:15 * meetingology mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
16:15 <mapreri> right, I need to poke this some more… I wonder if I'll get to dirty my hands and write a patch eventually…
16:15 <ddstreet> #subtopic mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
16:16 <mapreri> yeah, haven't done that sorry
16:16 <ddstreet> #action mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
16:16 * meetingology mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
16:16 <ddstreet> #subtopic mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
16:16 <ddstreet> #action mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
16:16 * meetingology mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
16:16 <ddstreet> i havent' seen an email so will assume it's carried
16:16 <mapreri> I would like to carry this over some more until at least I get back on track with my pile of unread emails
16:16 <ddstreet> ack
16:16 <ddstreet> #subtopic mapreri to look into backporting dh-python (see unit193 and yt-dlp)
16:16 <mapreri> otherwise I'm just going to add water to my own drowning self
16:17 <ddstreet> you want to keep this or just let it drop?
16:17 <mapreri> pls keep it
16:17 <ddstreet> ack
16:17 <ddstreet> #action mapreri to look into backporting dh-python (see unit193 and yt-dlp)
16:17 * meetingology mapreri to look into backporting dh-python (see unit193 and yt-dlp)
16:17 <luna> (carried over)
16:17 <ddstreet> ah right, i'll add that to the agenda when i edit it, thanks
16:17 <ddstreet> #subtopic mapreri draft response email re: charter to TB
16:17 <mapreri> well, the TB was quicker than me, so drop this i guess
16:18 <luna> guess TB in this case is not Thunderbird?
16:18 <ddstreet> sounds good; if amurray is around, we could discuss it now some
16:18 <mapreri> luna: technical board
16:18 <luna> ah
16:18 <ddstreet> ok that's all the previous items
16:18 <ddstreet> #topic open mailing list threads
16:19 <ddstreet> #subtopic clarification on specific wording for no-bug-required backport exceptions
16:19 <ddstreet> no movement on this one i think
16:19 <mapreri> (see above thing about unread mails…)
16:19 <ddstreet> yep
16:19 <ddstreet> i'll add an action to reply on this thread just to keep it alive
16:20 <ddstreet> #action ddstreet reply to no-bug-required backport exception ML thread to keep thread alive
16:20 * meetingology ddstreet reply to no-bug-required backport exception ML thread to keep thread alive
16:20 <ddstreet> #subtopic TB mailing list charter email
16:20 <mapreri> did you have a chance to read my reply from 1h ago?
16:20 <ddstreet> so i see amurray and mapreri have followed up on this thread
16:21 <ddstreet> yep, i think we are in agreement
16:21 <mapreri> I'd like to understand if my opinion is too different from yours
16:21 <mapreri> opinion*s*
16:21 <ddstreet> for reference:
16:21 <ddstreet> #link https://lists.ubuntu.com/archives/technical-board/2023-March/002713.html
16:22 <ddstreet> #link https://lists.ubuntu.com/archives/technical-board/2023-March/002714.html
16:22 <luna> https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023027.html
16:22 <ddstreet> right thanks, i was linking to TB list
16:22 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023027.html
16:23 <ddstreet> mapreri I think your summed-up proposal sounds perfect
16:24 <ddstreet> teward you have a chance to review the emails?
16:24 <mapreri> I'll take that as some praise :3
16:24 <ddstreet> mapreri++ i'd give you karma if we had a karma bot here :)
16:24 <teward> ddstreet: as they've come in yes, but i haven't had any objections or complaints so my non-voice on the emails can be treated as acceptance without objection
16:24 <mapreri> having ddstreet claim some propositions are "perfect", duh ^^
16:24 <teward> so JGTM
16:24 <teward> LGTM*
16:24 <teward> ffs keyboard.
16:24 <Eickmeyer> !cookie | mapreri
16:24 <ubottu> mapreri: Wow! You're such a great helper, you deserve a cookie!
16:24 <mapreri> :D
16:25 <ddstreet> lol nice
16:25 <luna> read the email now and LGTM
16:25 <mapreri> ddstreet: technically my irc bouncer then runs pisg on the log, so the ++ does mark it as karma there :P
16:26 <ddstreet> so i guess we can wait for amurray response on the ML then and continue the discussion there, if needed
16:26 <luna> +1
16:26 <mapreri> I think so, yes.
16:26 <mapreri> although
16:26 <mapreri> one detail that popped out in my reply, I forgot whether we discussed it already before: do we want to write done a SLA somewhere?
16:27 <ddstreet> i think it would definitely be helpful - both to us, as well as uploaders
16:27 <ddstreet> should we figure out one now?
16:28 <ddstreet> my first though is something like at least 2 weeks, though that (probably) seems long to uploaders
16:28 <mapreri> that's going to be awkward right now.  please add a note of some kind and let's come back to this later on.  especially perhaps after somebody from TB comments on my mail
16:28 <ddstreet> personally i only check the upload queue once a week though
16:28 <ddstreet> sounds good
16:28 * mapreri mumbles something about Debian's NEW
16:29 <ddstreet> #action (unassigned) consider documenting an SLA for reviewing uploaded backport packages
16:29 * meetingology (unassigned) consider documenting an SLA for reviewing uploaded backport packages
16:29 <ddstreet> what's debian's new?
16:29 <mapreri> the new queue
16:29 <luna> ddstreet: newly packages uploaded to ftp.debian i think
16:29 <mapreri> where new packages pending ftp-master review stay
16:29 <luna> ah
16:29 <mapreri> luna: well, you are right :)
16:30 <ddstreet> doesn't ubuntu queue have that also?
16:30 <mapreri> yes
16:30 <mapreri> but Debian's queue doesn't have any expectations
16:30 <mapreri> there have been packages pending for more than 1 year sometimes
16:30 <ddstreet> oh wow
16:30 <mapreri> heh
16:30 <mapreri> as a contributor you really need to have faith sometimes
16:30 <ddstreet> though i think some of ubuntu's queue still have old-timers in them as well
16:31 <ddstreet> yeah, e.g.: https://launchpad.net/ubuntu/bionic/+queue?queue_state=0&queue_text=
16:31 <mapreri> normally those in ubuntu get stuck because of some reason, however, not because "nobody feels like reviewing this [for many many months]"
16:31 <ddstreet> poor networking-mlnx, been there for 2.5 years
16:31 <ddstreet> true
16:32 <mapreri> anyway, any other topic? :)
16:32 <ddstreet> i think we're on to open bugs
16:32 <ddstreet> #topic open bugs needing discussion
16:32 <ddstreet> i think the only open one is memtest86+
16:32 <ddstreet> #link https://bugs.launchpad.net/ubuntu/+source/memtest86+/+bug/1998834
16:32 <ddstreet> i believe this just needs a sponsor?
16:33 <mapreri> exactly
16:33 <mapreri> sigh, I really don't like if the absence of sponsors in this case reflects poorly on us :(
16:33 <mapreri> but I also don't want to give expectations that we are happy to sponsor whoever comes along :\
16:34 <mapreri> how vexing.
16:34 <ddstreet> indeed, though i think that's a more widespread issue than just backports bugs
16:34 <mapreri> yes, totally
16:35 <ddstreet> i can volunteer to sponsor this one, though i agree it would be great if ubuntu-sponsors got more active
16:35 <ddstreet> #action ddstreet sponsor lp: #1998834
16:35 * meetingology ddstreet sponsor lp: #1998834
16:35 <mapreri> thank you
16:35 <ddstreet> yep np
16:36 <ddstreet> are there any other backport bugs i missed?
16:36 <mapreri> none afaik
16:36 <luna> nope
16:36 <ddstreet> #topic AOB
16:36 <mapreri> I have one AOB.
16:37 <mapreri> So, unit193 brought to my attention that he accidentally did a gallery-dl bpo to kinetic, whom somebody approved.  Now, I don't think that's problematic per se, although we decided to forbid general bpos to non-LTSs.
16:38 <teward> wasn't me who poked it, but it might've been someone else
16:38 <ddstreet> i think i approved that
16:38 <ddstreet> but did we decide to not approve anything to non-lts?
16:38 <mapreri> now, in this case I'd just say it's really not something problematic, but this made me wonder if somebody checked whether we have the ability to, say, remove a package from the bpo pocket?
16:38 <mapreri> ddstreet: we did, yes
16:38 * ddstreet makes a note of that
16:38 <ddstreet> sorry :)
16:39 <mapreri> "Backports to non-LTS are not accepted (with exceptions)." is on our wiki page :)
16:40 <mapreri> back to my question, do anybody know if that's something that comes from our ACL, or do we need to poke AA in case we ever wants to remove something?
16:40 <ddstreet> yep
16:40 <ddstreet> sorry 'yep' was to comment about wiki
16:40 <ddstreet> re: removal i don't know, but i assume we would need to poke AA
16:41 <ddstreet> should we see if we can remove the gallery-dl in kinetic?
16:42 <mapreri> that was my implied question
16:42 <mapreri> also, how we would even try? :3
16:42 <ddstreet> i'm not even sure how to do it, probably a cli would be needed
16:42 <mapreri> should we bother investigating?
16:42 <ddstreet> i dont see any way looking at the LP web pages
16:42 <mapreri> or just live happy for now?
16:42 <mapreri> I'd expect to be some API, at least
16:43 <ddstreet> yeah i'm sure it's possible with the LP api
16:43 <ddstreet> since we don't care about non-LTSes, I'd say we can just leave it there
16:44 <ddstreet> and I will be sure not to look at the non-LTS queues anymore (or just reject stuff in them :-)
16:44 <mapreri> indeed, let's just forget for now then ^^
16:44 <mapreri> it's a trivial problem anyway
16:45 <ddstreet> any other business from anyone? besides next mtg date?
16:45 <luna> not from me
16:46 <ddstreet> ok for next mtg, if we're going out 4 weeks as usual, i can't make Mar 29
16:46 <luna> same
16:46 <mapreri> let's do 5th apr then?
16:46 <luna> works for me
16:46 <ddstreet> i can't do that either, i could do Apr 12?
16:46 <ddstreet> or i could go earlier, Mar 22?
16:47 <luna> both 5th and 12th April works for me (22th March does not)
16:47 <ddstreet> if we want to stick to Wed
16:47 <mapreri> that *might* be problematic for (I might have some construction workers at home, not sure yet), but otherwise fine for me
16:47 <ddstreet> should we push to Apr 19?
16:47 <mapreri> I think we could go with 12th
16:47 <ddstreet> ok sounds good
16:47 <mapreri> teward: ? :)
16:48 <teward> either day works
16:48 <ddstreet> #ddstreet sched next mtg Apr 12
16:48 <ddstreet> oops
16:48 <ddstreet> #action ddstreet sched next mtg Apr 12
16:48 * meetingology ddstreet sched next mtg Apr 12
16:48 <mapreri> ddstreet turns into a bot command
16:49 <mapreri> easier to summon
16:49 <luna> *notes in my Google calendar*
16:49 <luna> summer time then right?
16:49 <ddstreet> lol i would not want to see myself as a bot, i would not be helpful :)
16:49 <luna> so 17:00 UTC instead of 16 UTC
16:49 <mapreri> alright, I'll sign off, I have another mtg in another channel in 10 mins /o\
16:49 <luna> or am i thinking wrong?
16:49 <mapreri> oh, damn DST
16:49 <ddstreet> yep we've been using USA DST schedule so it will be DST
16:50 <mapreri> let me check a thing
16:50 <luna> 1 hour earlier or later?
16:50 <luna> DST always screws me up
16:50 <ddstreet> 15:00 utc
16:50 <luna> thanks
16:50 <mapreri> if this becomes 15 UTC it should be fine
16:50 <luna> added to my google calendar
16:50 <ddstreet> great, thanks everyone!
16:50 <ddstreet> #endmeeting