23:01 <ochosi> #startmeeting Xubuntu Community Meeting
23:01 <meetingology> Meeting started Fri Jan 10 23:01:28 2020 UTC.  The chair is ochosi. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
23:01 <meetingology> 
23:01 <meetingology> Available commands: action commands idea info link nick
23:01 <ochosi> #chair JackFrost
23:01 <meetingology> Current chairs: JackFrost ochosi
23:01 <ochosi> #chair bluesabre
23:01 <meetingology> Current chairs: JackFrost bluesabre ochosi
23:01 <bluesabre> o/
23:02 <ochosi> hi and welcome everyone!
23:02 <ochosi> #info Agenda at https://wiki.ubuntu.com/Xubuntu/Meetings
23:02 <ochosi> #topic Open action items
23:02 <ochosi> we carried over nothing from the last meeting
23:03 <ochosi> and since nobody added any AIs since then i guess we have none..?
23:03 <bluesabre> I think a lot of folks didn't know about the meeting
23:03 <bluesabre> I saw a mention of it, and it was on the calendar :D
23:03 <ochosi> tonight?
23:03 <ochosi> i sent out the usual mail and put it on the calendar
23:03 <ochosi> and on the wiki page
23:04 <JackFrost> Yep, I didn't.  So I guess now might be a good time to ask what 4.15 has in store for us, or specifically, what we're going to do with it.
23:04 <bluesabre> I feel like I didn't see the mail
23:04 <ochosi> hmm
23:04 <bluesabre> Anyhoo, we're here now :D
23:04 <JackFrost> https://lists.ubuntu.com/archives/xubuntu-devel/2020-January/thread.html ?
23:04 <ochosi> wtf
23:05 <ochosi> https://imgur.com/0b5Vigf.png
23:05 <ochosi> i didn't receive a rejection mail or anything
23:05 <ochosi> and i didn't check the archive, because... why would i?
23:05 <ochosi> :/
23:06 <bluesabre> lol
23:06 <ochosi> soooorry (i guess)
23:06 <bluesabre> Not you, or us, so all good
23:06 <ochosi> but i'm happy i managed to schedule a time/day that works :D
23:06 <ochosi> so yeah, let's skip ahead and talk about 4.16
23:06 <ochosi> or 4.15
23:06 <ochosi> #topic Updates and announcements
23:07 <JackFrost> (I also didn't discard your mail from the list!)
23:07 <ochosi> #info Xfce 4.15 is progressing well and there are a few more releases around the corner
23:08 <ochosi> since 4.16 will switch to client side decorations for XfceTitledDialog that begs the question whether we go s/mate/gnome in our application set (evince,..)
23:08 <ochosi> also, gtk-dialog-use-header will be enabled by default upstream
23:08 <bluesabre> #info The new dark theme, Greybird-dark was just released
23:08 <ochosi> which means all GtkDialog based windows should use CSD
23:08 <bluesabre> Working on getting that packaged :)
23:09 <ochosi> cool
23:09 <ochosi> so regarding what we're going to do with 4.15, i'd slap it into a PPA for testing
23:09 <ochosi> and then think about it again once 20.04 is released
23:10 <ochosi> if you want a sneak preview (ahead of my upcoming blog post about this), here's the xfce settings manager in the new layout: https://imgur.com/sj98Abn.png
23:11 <ochosi> so visually it's not a big departure
23:11 <ochosi> or a standalone config dialog: https://imgur.com/5nRhS6H.png
23:12 <ochosi> JackFrost: does that answer your question?
23:13 <JackFrost> Well not really, I'd guess the specific question is ppa:xubuntu-dev/experimental ?
23:13 <ochosi> yeah, i guess so
23:13 <bluesabre> Sure, I think that's fine
23:13 <JackFrost> OK, I'll only be picking them up as they hit Debian experimental this time.
23:14 <bluesabre> Makes sense :)
23:14 <ochosi> does debian experimental pick up devel releases?
23:14 <ochosi> (sry, i'm rather ignorant there)
23:15 <JackFrost> Depends on if corsac feels like it, but usually yeah.
23:15 <bluesabre> Other news from the theming perspective, the Yaru folks might have a surprise for us soon (nothing more to say about that for now)
23:15 <ochosi> enigmatic
23:16 <bluesabre> Saw a 4.15 thing get uploaded to debian the other day
23:16 <ochosi> is it good, bad or ugly? (the surprise)
23:16 <bluesabre> Good
23:16 <bluesabre> :)
23:16 * ochosi keeps his fingers crossed
23:16 <JackFrost> ...What I'd think of as 'good' or what everyone else does? :P
23:16 <bluesabre> Well
23:16 <ochosi> :'D
23:16 <bluesabre> That remains to be seen
23:16 <bluesabre> ;)
23:17 <ochosi> okok, i'll stop biting my nails and we can move on
23:17 <ochosi> unless you want to know more regarding 4.15
23:17 <JackFrost> Nope.
23:17 <ochosi> k
23:17 <bluesabre> Got anything planned for 4.14.x?
23:17 <ochosi> yeah
23:18 <ochosi> that's what i would move on to
23:18 <ochosi> #subtopic Xubuntu 20.04 Planning
23:18 <JackFrost> gtk-dialog-use-header doesn't really look like a user setting, but glade or whatnot, right?
23:18 <ochosi> it's a user setting
23:18 <ochosi> you can try with xfconf-query if you want
23:19 <ochosi> (i can paste the command)
23:19 <JackFrost> AH, fantastic.  Thanks.  I'll :x now.
23:19 <ochosi> it'll be part of my blog post ;)
23:19 <bluesabre> :)
23:20 <ochosi> the only agenda item i added could go here or into discussion
23:20 <ochosi> it's about checking up on 4.14.x releases
23:21 <ochosi> so i would suggest we spend a few minutes to go around the most important components and see if we want a point release :)
23:21 <bluesabre> :)
23:21 <ochosi> and then info it
23:21 <bluesabre> I think xfce4-settings has a few fixes waiting in it
23:21 <ochosi> #info xfce4-panel 4.14.2 shall be released shortly
23:22 <bluesabre> And xfce4-taskmanager drops the stuck floating legend, fixing one of our lp bugs
23:22 <ochosi> #info xfce4-settings 4.14.2 shall be released shortly
23:23 <bluesabre> xfce4-weather-plugin has some bugs I'm aware of that I need to fix and release
23:23 <ochosi> #info xfdesktop 4.14.2 shall be released shortly
23:23 <ochosi> (some of those means we need to bug others, other releases can be done by me or sean)
23:23 <bluesabre> xfce4-screensaver has a few newly reported bugs with patches
23:23 <bluesabre> yeah
23:24 <ochosi> #info xfce4-session 4.14.1 shall be released shortly
23:24 <bluesabre> nice
23:25 <ochosi> so there are quite a few
23:25 <bluesabre> JackFrost: aware of any critical releases?
23:25 <ochosi> even though the powermanager has only commit, it's a nice one
23:25 <JackFrost> Nope.
23:26 <bluesabre> Got another catfish release I'll hopefully land this weekend
23:26 <bluesabre> We might also need to revisit our docs a bit this cycle
23:27 <bluesabre> Oh
23:27 <ochosi> i thnk that's about it from the core components
23:27 <bluesabre> And the wallpaper contest
23:27 <bluesabre> Sorry, brain dumping :)
23:28 <bluesabre> ochosi: yeah, can't think of others that have anything major pending
23:28 <ochosi> docs and wallpaper contest are both fine, but i have to admit i probably won't have time for either
23:28 <ochosi> i mean helping with the selection, yes, that's just one session
23:28 <ochosi> but setting it all up and communicating it, probably not
23:28 <bluesabre> Once I have a handle of the requirements, I'll put a schedule together
23:29 <ochosi> k
23:30 <ochosi> anything else you would like to discuss in planning?
23:30 <bluesabre> xubuntu-wise, I think that's all I have
23:31 <ochosi> k, same here
23:31 <ochosi> #topic Discussion
23:32 <bluesabre> hi
23:32 <bluesabre> :)
23:32 <ochosi> :)
23:32 <bluesabre> So, we should probably look at the release schedule
23:33 <ochosi> we had one point we may carry over from last time, which is announcing that we need people to work on our website (since knome isn't around a lot)
23:33 <ochosi> bluesabre: wanna take an action item?
23:33 <ochosi> :>
23:33 <bluesabre> Sure
23:33 <ochosi> and yeah, then let's look at the schedule
23:34 <ochosi> #action bluesabre to send an email to the xubuntu / xubuntu-devel list about looking for a new web lead (someone who doesn't hate wordpress)
23:34 * meetingology bluesabre to send an email to the xubuntu / xubuntu-devel list about looking for a new web lead (someone who doesn't hate wordpress)
23:34 <bluesabre> Release schedule: https://wiki.ubuntu.com/FocalFossa/ReleaseSchedule
23:35 <bluesabre> Feature freeze at the end of February
23:35 <ochosi> 2/27 - Feature Freeze / Debian Import Freeze
23:35 <bluesabre> We're not doing too bad for time :)
23:35 <ochosi> seems like the next relevant date
23:35 <ochosi> since we're not really planning any new features so far, i guess UI freeze may be more relevant even
23:36 <ochosi> 3/19 - User Interface Freeze
23:36 <bluesabre> Xfce 4.14 has been pleasantly stable, so there's not a lot of things to worry about adding or fixing
23:36 <ochosi> indeed
23:36 <bluesabre> Unless there's tons of broken stuff and nobody's reporting bugs
23:36 <ochosi> :D
23:36 <bluesabre> Definitely possible.
23:36 <ochosi> some people are reporting bugs, and i actually fix some of them every once in a while
23:37 <ochosi> the good thing is most of them also affect 4.15 so i have extra motivation to fix them anyway
23:37 <bluesabre> good dev ochosi
23:37 <ochosi> we're in a much better place than with 4.12
23:37 <ochosi> the porting made bug fixing for older releases totally unpleasant
23:37 <ochosi> and also felt more like a waste of time
23:38 <bluesabre> What's the package that we use for the color profiles? Has it been updated for focal?
23:38 <ochosi> ah
23:38 <ochosi> i think so
23:38 <ochosi> i think i even asked JackFrost to put it in a PPA for me and i tested it
23:38 <ochosi> the main issue with it is gone (100%cpu and multiple daemons spawned)
23:38 <JackFrost> But did you close the resulting bug? ;)
23:39 <ochosi> i thought you did :p
23:39 <ochosi> i can take a look...
23:39 <bluesabre> #chair kryten
23:39 <meetingology> Current chairs: JackFrost bluesabre kryten ochosi
23:39 <kryten> <3
23:39 <franksmcb> I'm sorry to interrupt the flow. I've done a bunch of ISO testing without any issues presenting themselves.
23:39 <pleia2> thanks franksmcb :)
23:39 <bluesabre> hey franksmcb!
23:39 <JackFrost> LP 1845800
23:39 <ubottu> Launchpad bug 1845800 in xiccd (Ubuntu) "xiccd consumes 100% CPU" [Undecided,Fix released] https://launchpad.net/bugs/1845800
23:39 <bluesabre> Thanks for the testing :)
23:40 <franksmcb> Howdy bluesabre
23:40 <franksmcb> No worries, if there is something specific you want tested for please reach out
23:40 <ochosi> #chair pleia
23:40 <meetingology> Warning: Nick not in channel: pleia
23:40 <meetingology> Current chairs: JackFrost bluesabre kryten ochosi pleia
23:41 <ochosi> #chair pleia2
23:41 <meetingology> Current chairs: JackFrost bluesabre kryten ochosi pleia pleia2
23:41 <ochosi> JackFrost: closed it now: https://bugs.launchpad.net/ubuntu/+source/xiccd/+bug/1845800
23:41 <ubottu> Launchpad bug 1845800 in xiccd (Ubuntu) "xiccd consumes 100% CPU" [Undecided,Fix released]
23:41 <bluesabre> franksmcb: definitely, will do
23:41 <ochosi> we can link that to our roadmap actually
23:43 <ochosi> didn't we once vote on installing a color emoji font? https://bugs.launchpad.net/ubuntu/+source/xubuntu-meta/+bug/1766976
23:43 <ubottu> Launchpad bug 1766976 in xubuntu-meta (Ubuntu) "Please consider installing fonts-noto-color-emoji by default" [Low,Confirmed]
23:43 <bluesabre> ochosi: yeah, didn't get enough votes for a decision iirc
23:44 <ochosi> oh wow, only 2 people voted..?
23:45 <ochosi> no, 5
23:45 <ochosi> isnt 5 enough?
23:47 <bluesabre> Not sure, internet connection really bad right now
23:47 <bluesabre> Might have been 10 members at that time
23:47 <JackFrost> With regards to post-20.04, we'll have to look for project leads again. :P
23:48 <ochosi> do we need a new council?
23:48 <JackFrost> We will post-20.04
23:48 <ochosi> right
23:48 <ochosi> good to know
23:50 <bluesabre> Maybe we'll have some new faces apply :)
23:51 <ochosi> that'd be nice
23:52 <JackFrost> Seems like nothing else?
23:53 <ochosi> yup
23:53 <ochosi> i'm done
23:54 <ochosi> i'd move on to doing those xfce releases i mentioned earlier...
23:54 <bluesabre> :)
23:54 <bluesabre> I have nothing else
23:54 <bluesabre> kryten, pleia2?
23:54 <ochosi> franksmcb?
23:54 <pleia2> nothing from me
23:54 <kryten> Noope!
23:55 <ochosi> #action JackFrost to schedule the next team meeting
23:55 * meetingology JackFrost to schedule the next team meeting
23:55 <bluesabre> Easy to escape with a nick change ;)
23:56 <ochosi> #endmeeting