22:02 <ochosi> #startmeeting Xubuntu Community Meeting
22:02 <meetingology> Meeting started Thu Apr  5 22:02:39 2018 UTC.  The chair is ochosi. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
22:02 <meetingology> 
22:02 <meetingology> Available commands: action commands idea info link nick
22:02 <knome> hullo
22:02 <bluesabre> hiiii
22:02 <pleia2> hello
22:03 <ochosi> #chair ochosi knome bluesabre
22:03 <meetingology> Current chairs: bluesabre knome ochosi
22:03 <ochosi> hi everyone :)
22:03 * bluesabre is wired in at a coffee shop
22:03 <bluesabre> hi ochosi
22:03 <ochosi> noice
22:03 <ochosi> enjoy that coffee!
22:03 <knome> bluesabre, a coffee IV?
22:04 <bluesabre> Something like that
22:04 <ochosi> #topic Open action items
22:04 <ochosi> are there any..?
22:04 <ochosi> (there aren't on the agenda, but then again)
22:04 <knome> not from meetings
22:04 <ochosi> some coordination regarding social-media-ing of final beta testing..?
22:04 <ochosi> but i presume that has been done
22:05 <ochosi> i noticed at least on the things i use
22:05 <knome> it's past that time, yes
22:05 <ochosi> and this has been a fairly awesome cycle wrt new testers anyway
22:05 <knome> i'm pretty sure pleia2 worked hard to get it done because this time i didn't do anything :)
22:05 <ochosi> hehe
22:05 <ochosi> well done pleia2
22:05 <bluesabre> :)
22:05 <knome> not that i do anything else than twitter anyway... :P
22:06 <pleia2> and thanks to flocculant for reminding me to do the things ;)
22:06 <ochosi> good teamwork then (knome doing nothing, flocculant doing the reminding and pleia2 doing all the work)
22:06 <pleia2> lol
22:06 <bluesabre> lol
22:06 <knome> well i didn't step on anybody's toes or tell them they did it wrong...!
22:06 <ochosi> anyway, if there are no open action items i'll move along
22:07 <knome> ack from me
22:07 <bluesabre> carry on
22:07 <ochosi> #topic Updates and Announcements
22:07 <ochosi> btw, i forgot...
22:07 <knome> #undo
22:07 <meetingology> Removing item from minutes: TOPIC
22:07 <knome> there you go ;)
22:07 <ochosi> who's all here?
22:08 <ochosi> jd109: wanna introduce yourself?
22:08 <ochosi> or any other new faces?
22:08 <jd109> Hi
22:08 <jd109> what to say
22:08 <knome> (those who haven't typed anything, just make any noise now)
22:08 <jd109> How is everyone doing
22:08 <jd109> I am one of the wallpaper submitters
22:08 <ochosi> ah cool
22:08 <bluesabre> Fantastic
22:08 <ochosi> submitters or also winners?
22:09 <ochosi> (great in any case!)
22:09 <jd109> have the winners been announced?
22:09 <ochosi> i think so - knome ?
22:09 <pleia2> no, but we've reached out to them
22:09 <ochosi> right
22:09 <ochosi> that's what i meant
22:09 <jd109> I have been keeping an eye out
22:09 <pleia2> alas, if you haven't heard from us, you are not one of the finalists
22:09 <Unit193> WHich one(s) did you submit?
22:09 <jd109> lol
22:09 <pleia2> but the competition this time was fierce, we've never had so many high quality submissions
22:10 <pleia2> it was hard deciding
22:10 <bluesabre> Yeah, it was pretty great
22:10 <jd109> um quite a few
22:10 <jd109> the arch
22:10 <jd109> the opera house
22:10 <jd109> the flowers in the tea house
22:10 <jd109> Pilatus
22:10 <knome_web> i hit some lag that might mean i need to use this webclient...
22:10 <jd109> and sesto
22:11 <jd109> just those 5
22:11 <ochosi> alrighty
22:12 <jd109> yeah there were lots of good submissions
22:12 <ochosi> anyway, thanks for showing up and we're glad if you wanna stick around!
22:12 <jd109> thanks
22:12 <knome_web> did i miss the #subtopic?
22:12 <ochosi> there are lots of ways to contribute - not just wallpapers ;)
22:12 <jd109> I agree I have been testing the latest iso too
22:12 <ochosi> knome_web: not really, i didn't want to discuss the walls really, just have jd109 introduce himself
22:12 <knome_web> aha, goodie :)
22:13 <ochosi> that's great
22:13 <ochosi> testing helps a lot too
22:13 <knome_web> (there i go!)
22:13 <ochosi> anyway, let's move the meetnig along a bit
22:13 <bluesabre> jd109: the perspective on the arch one is really awesome btw :)
22:13 <ochosi> #topic Updates and Announcements
22:13 <knome> &n
22:13 <knome> not that.
22:13 <jd109> thanks!
22:13 <knome> but hello from here again...
22:13 <bluesabre> hello again knome
22:13 <ochosi> #subtopic Wallpaper contest results
22:14 <ochosi> knome: you're on
22:14 <knome> great!
22:14 <knome> so
22:14 <knome> since i'm going to post to our blog soon, no spoiling here, but:
22:14 <knome> #info We have 6 winning wallpapers from 6 different contestants!
22:15 <ochosi> \o/
22:15 <knome> #info We're still working with the contestants, but at least 5 of the winning submissions will be included in 4k resolution (woot!)
22:15 * pleia2 has envelopes queued up to send them all stickers
22:15 <knome> #info Blog will be updated soon with winners' names and winning submissions :)
22:16 <knome> yes, we also have the addresses for all winners so we're good to with our prizes as well!
22:16 <ochosi> do we want to make all contributions available somewhere on the website?
22:16 <knome> they are already available on the contests website :)
22:16 <ochosi> oh crap :D
22:16 <bluesabre> :D
22:16 <knome> and yes, we will link to that page and for now it shouldn't disappear
22:17 * ochosi should better shut up
22:17 <knome> disclaimer: the 4k versions aren't available on the contests page
22:17 <ochosi> yeah, that's fine though
22:17 <ochosi> as long as they are included in the release
22:17 <knome> we'll have to figure out if we want to make them available somewhere apart from the package and its bzr branch
22:18 <knome> mostly a question of bandwidth usage i guess
22:18 <knome> and finally
22:18 <knome> #info A huge thank you everybody for submitting! We had a total of 162 submissions compared to less than 100 last time. We have an awesome (and I hope a growing) community!
22:19 <bluesabre> <3
22:19 <ochosi> +1000
22:19 <jd109> Thanks for running the contest!
22:19 <pleia2> yeah, it was really great
22:19 <knome> no problem!
22:20 <knome> that's all from me :)
22:20 <bluesabre> (thanks to the team for getting your votes in a timely manner too)
22:21 <knome> yes
22:21 <knome> next time we will make voting easier...
22:21 <knome> (even easier than it was now)
22:21 <bluesabre> :)
22:21 <ochosi> alrighty, perfect
22:21 <ochosi> any other topics for updates and announcements..?
22:21 <bluesabre> Sure
22:22 <knome> f-f-f-freezes
22:22 <bluesabre> #subtopic Release Schedule
22:22 <Unit193> knome: I kept having to refresh the page for the indicator on each image to refresh after voting yay/nay.
22:22 <bluesabre> #info Bionic Final Beta should be landing soon, today/tomorrow
22:22 <pleia2> hooray
22:22 <bluesabre> #info Translations are due next week
22:23 <bluesabre> #info Final Freeze is the 23rd
22:23 <knome> there shouldn't be much changed apart from the slideshow?
22:23 <bluesabre> #info Final Freeze is the 26th
22:23 <knome> i mean at least that will have time to land?
22:23 <bluesabre> knome: yeah, will be doing a batch of translation updates this weekend probably
22:23 <bluesabre> And bug fixes
22:23 <knome> ahha
22:23 <bluesabre> #undo
22:23 <meetingology> Removing item from minutes: INFO
22:23 <bluesabre> #info Final Release is the 26th
22:24 <knome> :)
22:24 <bluesabre> Contributors, come and get it :)
22:24 <bluesabre> That's it for dates
22:24 <knome> pleia2, maybe a social media run for making people translate the slideshow?
22:24 <bluesabre> oh
22:24 <bluesabre> one more
22:24 <bluesabre> :)
22:25 <bluesabre> #info Release Candidate on the 19th
22:25 <pleia2> knome: if we have some very clear instructions as to how to do this, we absolutely should
22:25 <ochosi> bluesabre: so i presume we can still get today's thunar release in?
22:25 <knome> pleia2, we should be able to make it relatively brief...
22:26 <bluesabre> ochosi: pretty sure, yeah
22:26 <ochosi> bluesabre: plus i pushed two small icon fixes today that should also go in
22:26 <ochosi> (small but not irrelevant)
22:26 <bluesabre> ochosi: will take a look and upload sometime in the next 36 hours
22:26 <ochosi> awesome, thanks a bunch
22:27 <ochosi> anything else regarding the release schedule?
22:27 <bluesabre> Nope
22:28 <ochosi> k, any other subtopics for "updates and announcements"?
22:28 <bluesabre> None from me
22:28 <knome> i don't think - yet
22:28 <knome> either on the last meeting of the cycle or first after
22:28 <knome> :)
22:28 <ochosi> Unit193, pleia2 ?
22:29 <Unit193> ochosi: Hi!
22:29 <pleia2> nothing from me
22:29 <ochosi> :]
22:29 <knome> or the hiding krytarik
22:29 <pleia2> :D
22:29 <Unit193> Well, there's the new thunar we should try and "slip" in.
22:29 <Unit193> Oh, numlockx is fixed.
22:29 <bluesabre> hooray!
22:29 <ochosi> @lurkers: rise from ye dwellings!
22:30 <ochosi> noice
22:30 <ochosi> alright then
22:31 <ochosi> #topic Discussion
22:31 <ochosi> #subtopic Icon changes after UIF (ochosi)
22:31 <ochosi> so i just briefly wanted to run something by you
22:31 <ochosi> there have been a few changes in our icon theme's upstream (elementary)
22:31 <ochosi> they have started to rework the palette
22:32 <ochosi> and you can see this already in bionic because i pulled in quite a few reworked icons
22:32 <ochosi> now we have e.g. some inconsistent greens
22:33 <ochosi> http://i.imgur.com/ppHvVhK.png
22:33 <ochosi> left is new, right is old
22:33 <ochosi> i could spend some more time updating these icons to the new green
22:33 <ochosi> but we're past UIF
22:33 <ochosi> so the main question is: does this qualify as bugfix?
22:33 <knome> meh
22:33 <ochosi> or: would you even care enough for me to do the work and for us to push this?
22:34 <bluesabre> I'd say... not really a bugfix. But the purpose of the freezes is to make sure we're not crunched for time with replacing screenshots and the like
22:34 <knome> i don't think it's a bugfix, but i don't think the UIFe paperwork or getting the ack is too much work if we want this in
22:34 <knome> on another note: will this rework finish before the release?
22:35 <ochosi> well we're already in this semi-consistent state
22:35 <knome> or in other words, will we release with all-consistent icons even with the UIFe paperwork and uploading thingy?
22:35 <ochosi> so there's really not much to lose
22:35 <ochosi> hard to say, it's a lot of icons
22:35 <knome> and to go even further: do we want to release an SRU?
22:35 <ochosi> even if the work is repetitious and anyone could help, i doubt anybody apart from me will contribute
22:36 <bluesabre> That's the nature of these things :)
22:36 <ochosi> as we dont use the icons in screenshots in our docs i consider an SRU absolutely doable
22:36 <ochosi> bluesabre: the nature of icon updates is that i have to work on them alone..? :D
22:36 <bluesabre> What sort of work load is involved? Surely it's more than search & replace?
22:37 <ochosi> well i have to open every icon and add a new gradient, replacing the old one
22:37 <ochosi> i doubt the svgs are consistent enough to be able to script this
22:37 <knome> i didn't mean the SRU would be not doable even if we had screenshots or that
22:37 <ochosi> most of them are in the actions/ subfolders though
22:37 <ali1234> i would be willing to have a go at scripting if you can explain what needs to be done
22:37 <knome> the question is if we think that getting this consistency is important enough for an SRU on itself
22:38 <ochosi> (and i already fixed a lot of icons already)
22:38 <ochosi> ali1234: that'd be awesome!
22:38 <knome> because the SRU process is a different beast than an UIFe
22:38 <bluesabre> Yeah
22:38 <knome> and that said...
22:38 <ochosi> knome: i know, my main target would be UIFe
22:38 <knome> if we think we will be doing an SRU, then don't sweat on the UIFe's now
22:38 <knome> but if we think we can get it all in by release, then for sure i vote for some more sweat for ochosi - and can do the UIFe paperwork
22:40 <bluesabre> I think it'd be a nice to have.
22:40 <ochosi> right
22:40 <bluesabre> The difference isn't drastic, but any additional polish we can have is welcome
22:41 <knome> definitely - we're kind of in a state where i'd rather go all way than leave the inconsistency there
22:41 <bluesabre> If we enter SRU territory, it gets painful
22:41 <ochosi> (so the two current commits are in fact fixes of icons that were broken - we should get those in anyway)
22:41 <knome> bluesabre, i vote for more polish only for the polish speaking users!
22:41 <ochosi> ok, so then i propose the following:
22:41 <ochosi> 1) bluesabre uploads the two commits that are bugfix as bugfix
22:41 <ochosi> 2) ochosi tries the scripted approach with ali1234
22:41 <ochosi> 3) if 2) fails ochosi tries to update the icons manually (as many as possible)
22:41 <ochosi> 4) knome does the paperwork for UIFe
22:41 <jd109> can I make a suggestion
22:41 <ochosi> sure
22:41 <jd109> if It is not stepping on toes
22:41 <bluesabre> :)
22:41 <ali1234> how many icons are we talking about, approximately?
22:42 <jd109> how about switch the greens on the new icons
22:42 <knome> ochosi, ack from me on that proposal
22:42 <jd109> back to be consistent with all the others
22:42 <jd109> it would be much less work
22:42 <ochosi> jd109: not really, the new greens outnumber the old ones by far
22:42 <jd109> oh okay
22:42 <jd109> :-(
22:42 <ochosi> ali1234: hmm, maybe 50?
22:43 <knome> (and even if not, then we would be "outdated" for two years until the next LTS)
22:43 <ali1234> 50 x 8 different sizes each or 50 total?
22:43 <knome> pretty sure ×
22:43 <ochosi> 50 total
22:43 <bluesabre> oh wow
22:43 <knome> really?
22:43 <ochosi> x8 would include the symlinks
22:43 <bluesabre> Seems obvious
22:43 <bluesabre> Let's go for it :D
22:43 <ochosi> hey - i've done a lot of work already!
22:43 <ali1234> i guess svg doesn't have different sizes
22:43 <ochosi> :)
22:43 <knome> yes indeed, let's go for it
22:43 <ochosi> >900 icon updates in this cycle
22:44 <bluesabre> with just one ochosi... we need more ochosis to be more productive
22:44 <knome> ochosi, now the proposal with #action and we're good to go ;)
22:44 <ochosi> just one more follow-up question
22:44 <ochosi> i can also clear out some other inconsistencies
22:44 <knome> like?
22:44 <ochosi> where icons look very different in different sizes
22:45 <ochosi> e.g. MS excel files look totally different in 128px
22:45 <knome> if the changes are trivial (eg. don't take a huge amount of time), go for it
22:45 <knome> we can bunch this all up as an "consistency" update
22:45 <ochosi> 128px: http://i.imgur.com/a01oBEf.png
22:45 <ochosi> 64px and below: http://i.imgur.com/gPuWqVn.png
22:46 <knome> hah, yes
22:46 <ochosi> that's really confusing and misleading
22:46 <ochosi> i just noticed it a short while ago
22:46 <knome> indeed
22:46 <ochosi> (i obviously don't work with office files "enough")
22:46 <knome> yes, i'm all for fixing this as well while we are at it
22:46 <bluesabre> hence your sanity
22:46 <ochosi> lol
22:46 <bluesabre> I agree
22:47 <bluesabre> One nice UIFe bug to cover it all
22:47 <knome> yep
22:47 <ochosi> #action bluesabre will push beaaf3f6f47fb1e80fb7821fe69b3513a707cfbe and 28120d05e011ec89412d33d7dc5897d7f6bcf8ee from elementary-xfce to xubuntu-artwork as bugfix
22:47 * meetingology bluesabre will push beaaf3f6f47fb1e80fb7821fe69b3513a707cfbe and 28120d05e011ec89412d33d7dc5897d7f6bcf8ee from elementary-xfce to xubuntu-artwork as bugfix
22:47 <knome> and not even by a stretch, it really is one thing
22:47 * bluesabre is prepared
22:47 <ochosi> #action ochosi and ali1234 will try to script the gradient swap-out for most icons that need updating
22:47 * meetingology ochosi and ali1234 will try to script the gradient swap-out for most icons that need updating
22:48 <ochosi> #action ochosi will manually update whatever icons are left over from the script approach
22:48 * meetingology ochosi will manually update whatever icons are left over from the script approach
22:48 <ochosi> #action knome will file the UIFe paperwork once the branch is ready
22:48 * meetingology knome will file the UIFe paperwork once the branch is ready
22:48 <ochosi> #action bluesabre will again be doing the uploading honours
22:48 * meetingology bluesabre will again be doing the uploading honours
22:49 <knome> i'm filing the bug now that it's ready for subbing appropriate teams to it
22:49 <ochosi> what's the latest point in time for getting the UIFe approved?
22:49 <bluesabre> Lots of xubuntu-artwork uploads in the next few days :)
22:49 <knome> ochosi, as long as it happens before the release...
22:49 <ochosi> yeah, but how many days before
22:49 <ochosi> i can't remember what was a realistic window
22:49 <knome> i think we don't want to go into the final freeze territory
22:50 <bluesabre> ochosi: RC is the 19th, archive probably locked at that point
22:50 <ochosi> ok
22:50 <ochosi> so i have roughly 10 days
22:50 <ochosi> sounds do-able
22:50 <ochosi> thanks, we can move on to other discussion items (if there are any)
22:50 * bluesabre believes in ochosi
22:50 <knome> yes, i have one
22:50 <ochosi> k go ahead
22:51 <bluesabre> I need to relocate, bbiab
22:51 <knome> #topic Discussion
22:51 <knome> #subtopic 18.04 Community Wallpaper Contest Winners
22:51 <knome> https://xubuntu.org/news/18-04-community-wallpaper-contest-winners/
22:51 <knome> done :)
22:52 <ochosi> noice
22:52 <ochosi> well done
22:52 <jd109> Nice!
22:52 <ochosi> any other discussion items?
22:52 <knome> not from me
22:52 <ochosi> (we're slowly but surely running out of meeting time)
22:55 <ochosi> ok, if not...
22:55 <ochosi> #topic Schedule next meeting
22:56 <ochosi> #action Unit193 to schedule the next meeting
22:56 * meetingology Unit193 to schedule the next meeting
22:56 <knome> iiiiit's Uniiiiiiiit193!
22:56 <pleia2> thanks for chairing, ochosi
22:56 <ochosi> weeeee
22:56 <bluesabre> back
22:56 <ochosi> thanks everyone for participating
22:56 <ochosi> hah, right in time for the wrap-up, bluesabre
22:56 <knome> thank you ochosi
22:56 <jd109> thanks!
22:56 <ochosi> #endmeeting