22:01 <bluesabre> #startmeeting Xubuntu Community Meeting
22:01 <meetingology> Meeting started Fri Oct 27 22:01:17 2017 UTC.  The chair is bluesabre. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
22:01 <meetingology> 
22:01 <meetingology> Available commands: action commands idea info link nick
22:01 <flocculant> bluesabre: got fot it :D
22:01 <flocculant> for :D
22:01 <bluesabre> Who's around?
22:01 <ochosi> o/
22:01 <flocculant> me !!!!!!!!!!!
22:02 <flocculant> o/
22:02 <bluesabre> #chair ochosi flocculant slickymaster Unit193
22:02 <flocculant> :(
22:02 <bluesabre> #chair ochosi flocculant slickymaster Unit193
22:02 <meetingology> Current chairs: Unit193 bluesabre flocculant ochosi slickymaster
22:02 <slickymaster> can't say I'm not, now
22:02 <bluesabre> :D
22:02 <bluesabre> Sneaky
22:02 <flocculant> gah
22:02 <bluesabre> Anybody else want a chair ;)
22:02 <flocculant> ...
22:03 <bluesabre> Let's get started then
22:03 <bluesabre> #topic Open action items
22:03 <bluesabre> (and there are none)
22:03 <bluesabre> #topic Updates and Announcements
22:03 <flocculant> bluesabre:
22:03 <bluesabre> #info Blueprints are up: https://blueprints.launchpad.net/ubuntu/+spec/xubuntu-b-development
22:03 <bluesabre> #info The archive is open
22:03 <bluesabre> #info PPAs are ready
22:03 <bluesabre> #info Feature Definition Freeze on November 30th: https://wiki.ubuntu.com/FeatureDefinitionFreeze
22:04 <flocculant> can I jump in right at the start
22:04 <bluesabre> flocculant: go for it
22:04 <flocculant> make a statement and then we can all go 'argue' mode
22:04 <flocculant> ok ... so
22:05 <flocculant> we has bugs
22:05 <flocculant> we has isues
22:05 <flocculant> we has xfce doing stuff
22:05 <flocculant> we has xfce doing stuff for the other year
22:05 <flocculant> and year
22:05 <flocculant> WE have 6 months
22:06 <flocculant> to count for 3 years
22:06 <flocculant> can we PLEASE decide soon
22:06 <flocculant> then we can ALL test
22:07 <flocculant> that is the Xubuntu 18.04 QA statement
22:07 <flocculant> akxwi-dave's not done this 3 year lie
22:07 <flocculant> I have
22:07 <flocculant> not again.
22:07 <flocculant> Full Stop.
22:08 <flocculant> bluesabre: thanks ;)
22:08 <bluesabre> Cool, good discussion material :D
22:08 <Unit193> Right, so 4.13 is a *development* release, by the name alone it really shouldn't be in an LTS.
22:08 <flocculant> :D
22:08 <bluesabre> yes
22:08 <bluesabre> Discussion
22:08 <bluesabre> so one sec
22:09 <bluesabre> #info Roadmap (all blueprints at https://blueprints.launchpad.net/ubuntu/+spec/xubuntu-b-roadmap)
22:09 <bluesabre> Anything else we want to #info?
22:10 <bluesabre> (for announcements)?
22:10 <flocculant> not from me :D
22:10 <ochosi> me neither
22:10 <slickymaster> nothing here also
22:11 <bluesabre> Allllrighty, onwards :)
22:11 <bluesabre> #topic Discussion
22:11 <flocculant> soory ;)
22:12 <bluesabre> We'll move things around a bit
22:12 <ochosi> i vaguely remember we've been there before with 4.12
22:12 <bluesabre> #subtopic Xfce 4.13/4.14
22:12 <flocculant> I'll wait now - but I have points here
22:12 <bluesabre> Agreed that 4.13 is development and we definitely don't want a lot of dev-y things in there
22:13 <bluesabre> But I also think there are some things that are more stable now than in the 4.12 branch
22:13 <bluesabre> Thunar was *stable* and a nightmare
22:13 <Unit193> We're Ubuntu based, means we have PPAs.  Lets use them, then we can have updates all cycle and not be stuck with 4.13.2 when 4.13.6 was released months ago.
22:13 <flocculant> point
22:13 <ochosi> yeah, PPAs make a lot of sense
22:13 <slickymaster> yep
22:14 <flocculant> do we have somewhere we can 'point' and call that IT
22:14 <Unit193> Thunar has out of tree plugins, the new version has no capability for them.  It's also at this point something that "if it works, don't touch it" in my mind. :D
22:14 <bluesabre> Yes, Thunar was the extreme example, I don't want the dev version :D
22:14 <ochosi> i also agree with bluesabre, some things are more stable/maintained in the devel cycle. plus it's quite hard to really fully assess the stability of the components
22:14 <flocculant> can we just now chuck in gtk3
22:15 <bluesabre> At the same time, we also already have some gtk3 components that are dev-level
22:15 <Unit193> Yeeah..
22:15 <flocculant> what do we have there we can use and force through ppa?
22:15 <Unit193> bluesabre: As a slight reminder, don't touch libxfce4ui.
22:16 <bluesabre> Unit193: sure thing
22:16 <flocculant> can I just make an important point - especially from 'out' view
22:16 <bluesabre> flocculant: We have our ~xubuntu-dev PPAs which are about as official as we want to get
22:16 <bluesabre> -staging can be a safe place to land bug fixes before they land in SRUs
22:16 <flocculant> what are we talking about that we expect tobe gtk3 in 18.04
22:17 <bluesabre> That's what this discussion is about :D
22:17 <flocculant> bluesabre: cabn we ignore ppa ftm
22:17 <bluesabre> Yes.
22:17 <flocculant> yea yea - so what?
22:17 <bluesabre> So focusing...
22:17 <flocculant> give me a list :D
22:17 <Unit193> Panel plugins are generally low impact.
22:18 <bluesabre> And we already have most of them
22:18 <bluesabre> xfce4-notifyd is stable now
22:18 <flocculant> pa for the most part is drop in
22:18 <bluesabre> yes
22:19 <bluesabre> and moreso soon
22:19 <flocculant> :)
22:19 <bluesabre> exo is stable
22:20 <bluesabre> xfce4-settings is dev, but stable (haven't heard otherwise), but probably going to hold until the rest of xfce core is ready
22:20 <ochosi> xfpm will get another release
22:20 <ochosi> and is also stable
22:20 <flocculant> what I would like to do for testing this stuff is quit4e simple, run artful - add this ppa
22:20 <bluesabre> Right
22:21 <flocculant> can we do that?
22:21 <bluesabre> Want to nail down what we want before I start uploading to a PPA
22:21 <bluesabre> and to the archive
22:21 <bluesabre> Might be a discussion that goes for a few days
22:21 <flocculant> that's you're calls
22:21 <ochosi> yeah, i'd say we should first get the list
22:21 <flocculant> nd that's fine
22:21 <flocculant> a
22:22 <bluesabre> But definitely glad to start the discussion
22:22 <flocculant> I want to be able to say run artful - add this ppa
22:22 <bluesabre> flocculant: yes, and we will have that
22:22 <flocculant> cool
22:22 <ochosi> bluesabre: we could have two "levels" of PPAs for artful
22:22 <ochosi> so we can start with 2 lists
22:22 <flocculant> if qa has that then we can push forward
22:23 <Unit193> I've been pushing everything to xfce4-gtk3.
22:23 <ochosi> one that we're confident about, a second one that we're less confident about
22:23 <bluesabre> or we don't push for the things we don't trust
22:23 <flocculant> Unit193: a weeklyish of numbers on that ppa would be helpful
22:23 <ochosi> yeah, but the whole "trust" thing is tricky
22:24 <Unit193> ochosi: +1
22:24 <Unit193> I don't trust xfpm past 1.4.4 :3
22:24 <ochosi> why's that?
22:24 <bluesabre> so we could possibly have xubuntu-dev/stable and xubuntu-dev/experimental if we want to go that route
22:24 <flocculant> qa position is simple - we'll test - if we have #'s thats great
22:24 <flocculant> point
22:24 <ochosi> yeah, something like that
22:24 <Unit193> Tried it out, didn't exactly go so well, reverted.
22:25 <flocculant> important point
22:25 * flocculant waits
22:26 <bluesabre> Unit193: thoughts on the 2-ppa system?
22:26 <Unit193> bluesabre: Eg, I always push to experimental, wait for someone to tell me to copy over?
22:26 <flocculant> #if 'we' have some clue as to something that might land in ppa which could kill everything off - we can use the tracker to point testers to it
22:26 <flocculant> eg
22:26 <bluesabre> primary target those who want to test things for us
22:26 <flocculant> DON@T UOGRADE warning :p
22:27 <Unit193> bluesabre: I kind of need something to guide me so I don't go "Oh new $package, uhh...Where the heck does this go?  No clue, I'll just pop it in my repo for now." and forget.
22:27 <flocculant> but that takes some communication - whiche even though we're hours apart we're quite good at
22:28 <bluesabre> Unit193: yeah, I think that's a good idea. experimental can be a landing place for all those
22:28 <ochosi> i think everything can go to experimental
22:28 <flocculant> my position is a single ppa if poss
22:28 <flocculant> ochosi: ack
22:28 <ochosi> and the things that are on our whitelist for bionic go to staging
22:28 <flocculant> dev'y peeps
22:29 <bluesabre> flocculant: the stable ppa would be the way to go for that, and we can have specific calls for testing for items in exp if needed
22:29 <ochosi> another trivial one is xfce4-volume-pulse. i ported it recently
22:29 <flocculant> can we not point people to experimental and stagin?
22:29 <flocculant> bluesabre: surely we need them to do 'breaky' stuff?
22:30 <flocculant> ppa-purge always worked for me
22:30 <flocculant> mmm
22:30 <Unit193> ochosi: I've seen it, but in light of pa-plug does it matter?  I'm presuming it doesn't do alsa, so you'd not be able to do volumeicon-alsa+xfce4-volumed anymore? :P
22:30 <ochosi> true
22:30 <bluesabre> flocculant: for staging/exp, we can do the same as we do for SRUs, add -proposed, install the package, remove -proposed
22:30 <flocculant> could we not
22:30 <bluesabre> If we keep the processes the same, it's easier for contributors coming from anywhere in ubuntu
22:31 <flocculant> stuff we really want = staging, not too sure = exp ?
22:31 <ochosi> yup, that would be my thought
22:31 <flocculant> I'd love to make it simple for testers
22:31 <bluesabre> -staging is for updates we plan to land in the archive soon
22:31 <flocculant> and then it's simpler for us
22:31 <bluesabre> usually for already released series
22:32 <flocculant> bluesabre: ok - so add a ppa?
22:32 <bluesabre> But glad to do what we can to help qa
22:32 <flocculant> dude
22:32 <flocculant> we'll test what you give us :)
22:32 <bluesabre> (sorry, everybody is really rapid fire right now)
22:32 <flocculant> ye
22:32 <flocculant> a
22:33 <bluesabre> Not used to having meetings with multiple attendees :D
22:33 <flocculant> take 5
22:33 <flocculant> catch up on consensus
22:33 <flocculant> :)
22:33 <ochosi> should we start a piratepad for the two lists of components though?
22:33 <bluesabre> ochosi: sounds good to me, want to start that?
22:33 <flocculant> ochosi: ie staging and defintes?
22:33 <ochosi> i mean we can do that in parallel to this meeting and keep it open
22:33 <flocculant> also
22:33 <ochosi> flocculant: yup
22:34 <flocculant> what xfce possibles do we want to have - and are they stable enough?
22:35 <flocculant> is the other one
22:35 <ochosi> http://pad.ubuntu.com/PyIIYsyIfn
22:35 <Unit193> What I'm reading here: "There will be multiple PPAs, for different things due to different levels of desire and testing needs." and what I'm interpreting that as: "Unit193 will always upload to experimental, people can copy over what's needed" :P
22:35 <Unit193> ochosi: That's not a piratepad, fyi.
22:36 <ochosi> potato potato
22:36 <bluesabre> Unit193: yes. experimental where all packages can land
22:37 <Unit193> I can live with that.
22:37 <Unit193> I can also point my package tracker thingy at it.
22:37 <bluesabre> and stable where approved (we will ship in bionic/oldstable) packages will be copied to when approved
22:39 <bluesabre> Good to have that agreed on
22:40 <bluesabre> #action bluesabre to create "stable" and "experimental" PPAs
22:40 * meetingology bluesabre to create "stable" and "experimental" PPAs
22:40 <Unit193> Basically, as long as we don't confuse flocculant or Unit193, we're good!
22:40 <Unit193> What happens with xfce4-gtk3?
22:40 <bluesabre> Yup
22:40 <bluesabre> I'm not sure yet what we do with our existing PPAs
22:40 <flocculant> Unit193: :)
22:41 <bluesabre> I think -gtk3 still has a purpose, staging may no longer with stable
22:41 <Unit193> flocculant: Also, whatever you want from me, please ask.  I'm generally accommodating enough, but I can't read minds. :3
22:42 <bluesabre> :)
22:42 <Unit193> bluesabre: -staging was pre-SRU stuff, xfce4-gtk3 is what experimental sounds like.
22:42 <flocculant> bluesabre: can we back set 'fairl unused ppa's to artful' assuming then that someone like me would just sety it to Steve Majors?
22:42 <flocculant> if I wanted to
22:42 <bluesabre> flocculant: I really have no idea what that sentence means
22:43 <flocculant> so all our 'we want this stuff tested' was at right version
22:43 <flocculant> bluesabre: Steve Majors was the 6 Million Dollar Man
22:44 <bluesabre> flocculant: I know what that is, but nothing more :D
22:44 <flocculant> oic failr  - fairly unused
22:45 <bluesabre> We'll have the new PPAs only running artful and bionic, and will drop a when c starts
22:45 <flocculant> so - I'd move to bionic cos I update daily - not monthly
22:45 <bluesabre> So we have everything running the env we want
22:45 <flocculant> k - I think that's the same thing :D
22:45 <bluesabre> Unit193: I think we can drop the -gtk3 ppa in favor of experimental then
22:46 <flocculant> yea
22:46 <flocculant> that's my position
22:46 <bluesabre> Unit193: you want the task to decomm that PPA (after copying over)?
22:46 <Unit193> bluesabre: I can do that, if you put it as blocked by yours.
22:47 <bluesabre> Unit193: certainly :)
22:47 <bluesabre> #action Unit193 to decommission the xfce4-gtk3 ppa in favor of experimental
22:47 * meetingology Unit193 to decommission the xfce4-gtk3 ppa in favor of experimental
22:47 <flocculant> bluesabre Unit193 ochosi - what I would like from qa pov - is anything that's likely 18.04 bound in one place
22:48 <flocculant> if themesis a pain - then I'll make 1 exception :D
22:48 <bluesabre> That's where we're heading with this plan :)
22:48 <flocculant> I thought so :D
22:49 <flocculant> I just ned something concretish to tell peopl
22:49 <flocculant> e
22:49 <flocculant> or akxwi-dave does - cos all tasks :p
22:49 <bluesabre> flocculant: I'll also add a new template for xfpanel-switch to grab our new panel plugins to make it easier for artful users to get set up
22:49 <ochosi> noice
22:50 <flocculant> bluesabre: you wanto hold fire there
22:50 <flocculant> cos defaults ....
22:50 <bluesabre> Yeah, we can't replace panel defaults in an already created session, so that's the next best thing for the panel
22:51 <flocculant> bluesabre: but we can have new defaults? or the whole world is on dos6 :D
22:51 <flocculant> if only
22:52 <ochosi> could ask testers to create new sessions too, if it's not just about panel settings
22:52 <bluesabre> yeah
22:52 <ochosi> s/sessions/accounts/
22:52 <flocculant> xubuntu council - I would like us to loom at defaults
22:52 <flocculant> bah
22:52 <flocculant> s/loom/look
22:53 <bluesabre> technically we have new defaults available in the daily ppa and can land them in exp/stable when we make them
22:53 <flocculant> yea but testing
22:53 <flocculant> we've already had 2 weeks of the time we never get :D
22:54 <bluesabre> I'm not sure what the question is :D
22:54 <Unit193> Log out, flip to TTY, rm -rf ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml then log back in.
22:54 <flocculant> anyway - point was leave defaults till that discussion
22:54 <flocculant> bluesabre: ^^
22:54 <bluesabre> gotcha
22:54 <Unit193> Right, and here's where the daily PPA is nice, so as not to confuse with experimental.
22:54 <flocculant> yea
22:54 <flocculant> I think we need 2 for sure
22:55 <flocculant> definites/mm reallys
22:55 <flocculant> whichever way we look - we've got freezes to work with
22:56 <bluesabre> Yep
22:56 <flocculant> MY point is that - if we've got less ppa's to get people loooking
22:56 <flocculant> tghen we tghen arrow in on issues
22:56 <bluesabre> Correct
22:57 <bluesabre> And we don't miss things by running things that won't be included in bionic
22:57 <bluesabre> like all the -gtk3 bits of xfce
22:57 <flocculant> rather than me seeing something on ppa785 and akxwi-dave seeing the sqame thing on 364 - but same package
22:57 <bluesabre> Yup
22:58 <flocculant> yea cool
22:58 <bluesabre> So we'll get that straightened out quickly
22:58 <flocculant> 2 ppa's for the whole cycle wou;ld be great for me
22:58 <flocculant> people ppa
22:58 <flocculant> kev ppa
22:58 <bluesabre> And we'll work on the list for the next few days
22:58 <ochosi> yup
22:58 <flocculant> type thing
22:58 <bluesabre> Anything else we want to discuss?
22:59 <flocculant> bluesabre: this is topic 1 :S
22:59 <bluesabre> Concerns, team deadlines, etc?
22:59 <ochosi> from my side that's the main part
22:59 <Unit193> Q: ...Does that mean we'll have to put daily builds in experimental? :/
22:59 <bluesabre> Unit193: I think daily should stay in daily
22:59 <flocculant> goodgood job it's one topic :D
22:59 <Unit193> Good, I don't want those. :3
22:59 <bluesabre> They might be months away from any release
23:00 <flocculant> oh what
23:00 <bluesabre> flocculant: The topics I had were Dev/QA Coordination, Artful -> Bionic testing PPAs, Package updates: Xfce 4.14 components, PulseAudio Plugin, StatusNotifier Plugin ... and we've smashed them all together :D
23:00 <bluesabre> flocculant: the daily things
23:01 <bluesabre> #action bluesabre, ochosi, and Unit193 to review xfce component list for stable/experimental
23:01 * meetingology bluesabre, ochosi, and Unit193 to review xfce component list for stable/experimental
23:01 <flocculant> ththatbah
23:02 <flocculant> sao
23:02 <bluesabre> Just so we have it on the todo
23:02 <flocculant> terminal in bionic hangs and kills irssi
23:02 <flocculant> seemingly :p
23:02 <bluesabre> :)
23:03 <bluesabre> Anything else?
23:03 <flocculant> cos oh what - was me doing an 0_0
23:03 <bluesabre> :D
23:03 <flocculant> nee to think there - not meeting thing, just you 2 and qa
23:04 <flocculant> s/nee/need
23:04 <ochosi> i'll need to leave quite soonish
23:04 <Unit193> bluesabre: Sidebar after meeting?
23:04 <ochosi> anything else i can contribute to tonight?
23:05 <flocculant> ochosi: just quickly
23:05 <bluesabre> Unit193: sure thing
23:06 <flocculant> ochosi: I notice that shimmer stuff comes through rapid - and I kind of know to go look at changelog and ignore 'translation' but how would berty using the ppa have a clue?
23:07 <ochosi> you mean the shimmer PPA?
23:07 <flocculant> everyone needs to obviously be aware that berty is just some person - for the logs
23:07 <flocculant> ochosi: yea
23:08 <ochosi> tbh i'm not even sure anymore what's inside these days, i build everything from git...
23:08 <bluesabre> Those are daily builds, so not much can be determined just by the package
23:08 <ochosi> icon theme and greybird?
23:08 <ochosi> or more?
23:08 <flocculant> I also see words in xfce-dev about ignore anything languagishy
23:08 <ochosi> yeah, we discussed ignoring it in the git log on the web frontend
23:08 <flocculant> as it stands
23:09 <ochosi> anything else will be hard/impossible/meaningless
23:09 <flocculant> non-ppa - check changelog - some words
23:09 <ochosi> for greybird there can be needed changes, but we can try to push them through the new PPAs instead of the shimmer PPA
23:10 <ochosi> and the icon theme should come through xubuntu-artwork anyhow
23:10 <flocculant> ppa- check changelog - ha ha ha ha ha ha - do what buddy, do one, no information her
23:10 <flocculant> e
23:10 <flocculant> I know - I'll go off if I care and find it
23:10 <bluesabre> I would just look at the release pages to see what's new, https://github.com/shimmerproject/Greybird/releases, https://github.com/shimmerproject/elementary-xfce/releases, not a ton of activity on either besides fixes
23:11 <ochosi> exactly
23:11 <bluesabre> We can probably add links to the PPAs for things that are less clear (like artwork)
23:11 <ochosi> i try to write meaningful release messages though
23:11 <ochosi> so all changes should be reflected there in a "management summary"
23:11 <flocculant> bluesabre: that works for you beCAUSE YOU KNOW git
23:11 <flocculant> sorry for odd caps
23:11 <bluesabre> flocculant: that's not gitty, it's paragraphy :D
23:11 <flocculant> :d
23:11 <ochosi> this is really a *management* summary
23:12 <ochosi> anyone can read and understand
23:12 <ochosi> and if you don't know what certain widgets are, it'll be hard to explain in text anyway..
23:12 <ochosi> at least you can google with those release notes
23:12 <flocculant> I always end up at some random lp page log knowing that a + is soimething added and a - is a loss
23:13 <flocculant> and that mostly all the shimmer stuff is + random language - random langauge
23:14 <bluesabre> yeah, stay away from the commits :)
23:14 <bluesabre> it's not meant to be understandable
23:14 <flocculant> omg the Sapnish guy forgot the word for toilet - never mind someone will remember in the end
23:14 <ochosi> the two links above don't go to commits (if you haven't clicked yet)
23:14 <flocculant> bluesabre: ack - but only way to see ppa changes :D
23:15 <ochosi> yeah, that's a feature request for PPAs :)
23:15 <bluesabre> flocculant: right, but there is nothing we can do with that, lp limitation
23:15 * bluesabre shrugs
23:15 <bluesabre> Anything else?
23:17 <Unit193> I think my stuff is after-meeting?  Not entirely sure.
23:17 <bluesabre> Uploads?
23:17 <Unit193> Varies.
23:18 <flocculant> bluesabre: yea - understood that :p
23:18 <bluesabre> We can just do it after then :)
23:18 <bluesabre> #topic Schedule next meeting
23:18 <ochosi> ok, if there's nothing else where you need my direct input i'll be on my way
23:18 <flocculant> nothing more here
23:18 <bluesabre> pleia2: sorry for stealing you meeting slot...
23:18 <bluesabre> #action pleia2 to schedule next meeting
23:18 * meetingology pleia2 to schedule next meeting
23:18 <bluesabre> #endmeeting