19:00 <knome> #startmeeting Xubuntu community meeting
19:00 <meetingology> Meeting started Thu Dec  5 19:00:05 2013 UTC.  The chair is knome. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:00 <meetingology> 
19:00 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:00 <knome> who's here for the meeting (or otherwise hanging out?)
19:00 <knome> !team | Meeting time!
19:00 <ubottu> Meeting time!: bluesabre, elfy, GridCube, jjfrv8, knome, micahg, mr_pouit, ochosi, pleia2, skellat, Unit193
19:00 <jjfrv8-work> o/
19:00 <pleia2> o/
19:00 <slickymaster> o/
19:00 <ali1234> o/
19:01 <knome> #topic Items carried on
19:01 <knome> #subtopic Open action items from previous meeting
19:01 <knome> #action knome to prepare the website for the desktop of the week
19:01 * meetingology knome to prepare the website for the desktop of the week
19:01 <knome> TBD
19:01 <knome> #action micahg to talk to barry about python2.7/3 situation
19:01 * meetingology micahg to talk to barry about python2.7/3 situation
19:01 <knome> micahg, ?
19:02 <knome> micahg, "#action micahg to talk to barry about python2.7/3 situation"
19:02 <skellat> o/
19:02 <ochosi> o/
19:02 <knome> micahg-work, is that done, or shall we carry on?
19:02 <micahg-work> WRT 14.04, python 2.7 is staying in main, so we're good
19:02 <knome> okay, i guess if we're good, then that's a good thing ;)
19:02 <knome> #undo
19:02 <meetingology> Removing item from minutes: <MeetBot.items.Action object at 0x16dcf90>
19:02 <knome> #topic Team updates
19:03 <knome> Team, please use #info and #action as appropriate.
19:03 <Noskcaj> o/
19:03 <knome> ochosi, updates?
19:04 <ochosi> #info ochosi is testing getting rid of gnome-icon-theme in 14.04 to reduce overhead
19:04 <knome> that's ++
19:04 <ochosi> #info Everyone can test that by using the shimmer daily PPA (bluesabre put up trusty packages today)
19:04 <skellat> #info skellat is satisfied with testing whiskermenu via no-change backport to 12.04 and is willing to vote on a proposal to make it default
19:04 <knome> https://launchpad.net/~shimmerproject/+archive/daily
19:05 <ochosi> thanks knome
19:05 <ochosi> gottcode, the author of whiskermenu is also here, if you have questions
19:06 <skellat> #info skellat has made no-change backport versions available in ppa:skellat/tests for those willing to try whiskermenu who are not yet on trusty
19:06 <knome> we can either 1) vote if we want to make whiskermenu default and then reconsider further actions or 2) build up a full proposal of the new panel layout (which is ought to change), including how whiskermenu is integrated, and vote on that as a whole
19:06 <knome> https://launchpad.net/~skellat/+archive/tests
19:07 <knome> i'm preferring 2)
19:07 <ochosi> hm, quick question, who of you has tried whiskermenu so far?
19:07 <skellat> o/
19:07 <knome> not yet, but but.. i've seen screenshots!
19:07 <jjfrv8-work> o/ in Precise
19:07 <ali1234> i've tried it briefly. it's not something i would use.
19:08 <ali1234> (and so i can't really comment on whether it's good or bad)
19:08 <Noskcaj> I tried it and prefer it, but try to stick to the default desktop so i'm not using it now
19:08 <knome> since i don't use menus, i don't know how i would "test" whiskermenu in a daily environment..
19:08 <ochosi> ali1234: well you know the difference between the standard menu and whiskermenu feature-wise
19:08 <slickymaster> I haven't tried, but like knome I saw screenshots
19:08 <elfy> ochosi: I've used it a bit and fin dit fine
19:08 <jjfrv8-work> It's my default now
19:08 <ochosi> knome: you can bind it to a shortcut and use it instead of appfinder to launch apps
19:08 <Unit193> I didn't try it because it didn't look like something I would prefer, I'll try it at some point.
19:08 <knome> i know the difference as well, and i generally have no exceptions to include it
19:08 <ochosi> ok
19:09 <knome> ochosi, i don't use appfinder either ... :)
19:09 <elfy> well we need to decide whether our users would find it useful then
19:09 <knome> ultimately, even if we included whiskermenu in the default panel layout, people can get the normal menu back
19:09 <Unit193> Nor do I, except to function as xfrun.
19:09 <ochosi> well fine, despite this not being a formal voting process, i got some feedback, i think i can do the panel-proposal
19:09 <elfy> not on whether we do - especially if some of us don't use menus at all
19:09 <skellat> :-)
19:10 <knome> and with the possible patch/app done by ali1234, we might be able to make panel layout editing easier
19:10 <knome> ali1234, can you #info the progress on that?
19:10 <ochosi> yup, that's very true
19:10 <knome> because i think we want that documented...
19:10 <ali1234> #info ali1234 made a tool to easily change panel layouts: https://github.com/ali1234/panel-switch/
19:11 <elfy> sorry - can't sit here - have fun
19:11 <ali1234> #info command line only at the moment, but it does the job. needs someone to design a gui
19:12 <ochosi> ali1234: wanna set up a page in the xubuntu wiki for that?
19:12 <knome> i think that's a cool idea.
19:12 <ali1234> not really, but if you create it, i'll fill in the details
19:12 <knome> i can create that
19:12 <knome> #action knome to create a wikipage for panel layout switcher
19:12 * meetingology knome to create a wikipage for panel layout switcher
19:12 <knome> just remind me after the meeting and i'll get that item done right now
19:13 <knome> other updates?
19:13 <skellat> I'm ready for the agenda item
19:13 <skellat> I hope ali1234 is too
19:13 <knome> heh, sure
19:13 <knome> let's move forward
19:13 <knome> #topic Announcements
19:13 <knome> anybody have any?
19:14 <knome> okay.
19:14 <knome> #topic New and emerging items
19:14 <Noskcaj> Maybe that whiskermenu 1.2.2 is out, will be in ubuntu some time this week. parole 0.5.4 is also out, once again will be uploaded soon
19:15 <knome> yeah, new versions will be landing in trusty for a long time to go
19:15 <knome> #subtopic Fixing the Gtk2 sound indicator in Saucy, in a way that can be SRU'd (ali1234)
19:15 <skellat> If I may speak first to this sound indicator issue
19:15 <knome> go ahead
19:16 <skellat> We already have at least one user, Richard Elkins, actually advocating on our -devel mailing list that users switch away to Mint.  The bug comments have been getting a bit out of hand with people complaining that this is "a simple fix" yet not putting forward patches or debdiffs.
19:16 <skellat> I'm very thankful for the work ali1234 has done.
19:16 <skellat> And I defer to him to explain it at this time.
19:17 <ali1234> ok... so first let me explain why it is broken
19:17 <ali1234> the indicator is in two parts: the bit that draws the menu, and the dbus backend that communicates between the menu and pulseaudio, music players etc
19:18 <ali1234> the indicator obviously cmes in gtk2 and gtk3 versions. they both come with a backend service, which is launched on dbus activation. both versions of the backend have the same dbus name, so what happens in practice is you always get the gtk3 version of the backend
19:18 <ali1234> this working in raring, but the backend was completely rewritten in saucy, so this no longer works
19:19 <ali1234> the "simple fix" posted on the bug comments isn't really a fix at all: it will break many things
19:19 <ali1234> so i finally got annoyed enough to look into fixing it properly, and it turned out to be very easy
19:19 <knome> ok, how do we get this in? :>
19:20 <ali1234> all that is required is to change the dbus name so that the gtk2 indicator asks for a different dbus name, ie "com.canonical.indicator.sound-gtk2" instead of "com.canonical.indicator.sound"
19:20 <ali1234> this turns out to be a 4 line patch
19:20 <knome> does that fix the issue for xubuntu, but doesn't break the same thing for other flavors?
19:20 <ali1234> i had initially thought this wouldn't work, because music players wouldn't know to use the different dbus name, but it turns out for some reason this is not an issue and it works fine
19:20 <ochosi> knome: i guess we need to do a debdiff or something and then get a sponsor to SRU it?
19:21 <ali1234> this fixes the problem for anyone using the gtk2 indicator still, and does not affect any other flavours at all
19:21 <skellat> ali1234: Would a suitable sponsor be available to navigate this through the SRU process?
19:21 <ali1234> i don't see why not
19:21 <ali1234> i have a debdiff, and a ppa with the fixed package
19:21 <knome> that's the the social requirements
19:21 <knome> skellat, want to run through those with ali1234?
19:22 <knome> skellat, (and then the sponsorship queue)
19:22 <micahg-work> if it's that small, I can certainly sponsor it
19:22 <knome> ok, cool
19:22 <ochosi> well 4 lines? :>
19:22 <knome> that's huge ;)
19:22 <ochosi> s/if// ;)
19:22 <micahg-work> I like 4 line patches :)
19:22 <ali1234> i'm not sure whether to do it through a MR against "gtk2 indicators"
19:23 <ali1234> it needs fixing in trusty and saucy
19:23 <micahg-work> don't you need 2 MRs though?
19:23 <ali1234> micahg-work: yes, but only because i had to change the packaging as well as the code
19:23 <knome> ali1234, except that we're looking to handle the issue differently in trusty (gtk3 indicators support)
19:23 <ali1234> and they are done in different repos i think... but i can't figure out how this stuff is managed
19:23 <micahg-work> well, doesn't the service name need to change as well?
19:23 <ali1234> knome: if the gtk2 indicator will still be in the repos, then i want it to work, even if we don't use it
19:24 <knome> ali1234, sure, fix approved ;)
19:24 <ali1234> micahg-work: the service and indicator are all in the same package
19:24 <micahg-work> ah, ok
19:24 <ali1234> let me show you the debdiff...
19:24 <ali1234> micahg-work: http://paste.ubuntu.com/6526233/
19:25 <ali1234> so basically it changes the service name in both halves of the indicator, and then adjusts the packaging so that the service file is included (normally it isn't because it would conflict with the gtk3 one, as they would have the same name)
19:27 <micahg-work> ok
19:27 <micahg-work> I can do this Sat night (can't do it right now as I need to compare some stuff and it'll take a bit more than just a test build)
19:28 <knome> micahg-work, do you need the formal SRU progress followed by that, or will you just handle it?
19:28 <ali1234> that comment in debian/rules should probably also go, since it's no longer true
19:28 <micahg-work> ali1234, lines 30-32 of the paste need a space in the pattch
19:28 <ali1234> this is why i'd rather do a MR against a upstream repo :)
19:28 <micahg-work> knome, if someone can fill in the paperwork for the bug, that would help, I can upload to trusty/saucy once I verify the packaging piece
19:28 <knome> micahg-work, cheers
19:29 <knome> skellat, since you are familiar with both the issue and the SRU process, would you be willing to help ali1234 file the paperwork?
19:29 <micahg-work> ali1234, that's fine, but all this should be going away in trusty anyways, right?
19:29 <skellat> knome: Yes
19:29 <knome> skellat, thanks!
19:29 <ali1234> micahg-work: maybe for xubuntu but i think lubuntu still uses it?
19:29 <micahg-work> skellat, just assign the saucy (if it exists) + default tasks to me
19:29 <knome> #action skellat and ali1234 to look at the SRU progress for indicator-sound-GTK2
19:29 * meetingology skellat and ali1234 to look at the SRU progress for indicator-sound-GTK2
19:30 <ali1234> i mean theoretically the gtk2 indicators should have gone away a long time ago
19:30 <micahg-work> (it might already be assigned to me)
19:30 <knome> #action micahg-work to SRU indicator-sound-GTK2
19:30 * meetingology micahg-work to SRU indicator-sound-GTK2
19:30 <knome> do we need to go through something else about this?
19:31 <skellat> Just note that we need to review progress next week as well as somebody pinging the bug thread on -devel with an update.
19:32 <knome> #action team to review indicator-sound-GTK2 progress next week and send an update to the mailing list
19:32 * meetingology team to review indicator-sound-GTK2 progress next week and send an update to the mailing list
19:32 <knome> #nick team
19:32 <knome> is there other items that we should go through, or should we schedule the next meeting and then wrap this one?
19:33 <knome> pleia2, you still slept the meeting!
19:33 <knome> #subtopic Schedule next meeting
19:33 <knome> #info Next meeting Dec 12, 19UTC
19:33 <knome> #undo
19:33 <meetingology> Removing item from minutes: <MeetBot.items.Info object at 0x16ca9d0>
19:33 <knome> #info Next meeting Thursday Dec 12, 19UTC
19:33 <knome> #endmeeting