19:01 <Eickmeyer> #startmeeting
19:01 <meetingology> Meeting started Sat Jul 7 19:01:39 2018 UTC. The chair is Eickmeyer. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:01 <meetingology>
19:01 <meetingology> Available commands: action commands idea info link nick
19:01 <Eickmeyer> #chair krytarik eylul captain-tux OvenWerks
19:01 <meetingology> Current chairs: Eickmeyer OvenWerks captain-tux eylul krytarik
19:02 * Eickmeyer hopes he's not forgetting anyone
19:02 <Eickmeyer> Anyhow... I guess we can get started.
19:02 <Eickmeyer> We can continue the conversation we were having just before I hit the button RE: Handbook
19:02 <Eickmeyer> #topic Audio Handbook
19:03 <Eickmeyer> eylul: You said you were working on the pdf and epub, and I mentioned I could get you a larger version of the cover. My reasoning was because the small version wouldn't translate to a full-page cover on a PDF very well.
19:03 <Eickmeyer> I also added "by Peter Reppert and the Ubuntu Studio team" to the bottom-left-corner.
19:04 <Eickmeyer> er, bottom right corner
19:04 * Eickmeyer doesn't know his left from his right today... ask captain-tux.
19:04 <eylul> haha
19:04 <eylul> ok email it to me?
19:04 <Eickmeyer> Yep. Can do.
19:04 <Eickmeyer> Just gotta get Krita to export a PNG, probably just need the library installed.
19:05 <eylul> should I create a PPA for myself and stick the epub in there along with the pdf output?
19:05 <eylul> epub can serve as source code
19:05 <Eickmeyer> Not a bad idea.
19:05 <eylul> until we find a good way to export epub/pdf directly out of wiki that is
19:05 <Eickmeyer> Then we can publish there and link to it. I was just going to do an attachment in the wiki and link it.
19:05 <Eickmeyer> But, I like your idea better.
19:06 <eylul> it should ideally be a PPA in the ubuntustudio assets
19:06 <eylul> but I assume if I can SOMEHOW put it into a dev ppa, you can pull it easily enough from there
19:06 <Eickmeyer> That's easy to do. Just make a local git repo and git push to lp:~eylul/ubuntustudio/+git/handbook or something like that.
19:07 <Eickmeyer> Or, just do it the easy way. :)
19:07 <eylul> which is?
19:07 <Eickmeyer> dput? ¯\_(ツ)_/¯
19:07 <OvenWerks> I am sure we could make it one of the ubuntustudio-core owned subs
19:08 <Eickmeyer> Yeah.
19:08 <OvenWerks> https://launchpad.net/~ubuntustudio-documentation
19:08 <OvenWerks> eylul: you are a member there anyway.
19:09 <Eickmeyer> So, one just needs to create a ppa under that.
19:09 <eylul> yep but you know me and versioning software.
19:09 <OvenWerks> the git can be under that too: https://code.launchpad.net/~ubuntustudio-documentation
19:09 <eylul> ok lets figure this out after the meeting I don't want to hog the time
19:09 * Eickmeyer gives a thumbsup
19:10 <Eickmeyer> OvenWerks: You good with assisting with that?
19:10 <OvenWerks> ok
19:10 <Eickmeyer> #action eylul to create epub & pdf and upload to -documentation team ppa, OvenWerks to assist
19:10 * meetingology eylul to create epub & pdf and upload to -documentation team ppa, OvenWerks to assist
19:11 <Eickmeyer> Reason being is that it seems eylul and versioning software don't get along. :)
19:11 <OvenWerks> I don't know if I will be available right after meeting... but I will work with it.
19:11 <Eickmeyer> Cool
19:11 <eylul> :)
19:11 <Eickmeyer> Cool, then.. moving right along...
19:11 <Eickmeyer> #topic Progress Reports
19:12 <Eickmeyer> #subtopic ubuntustudio-controls
19:12 <OvenWerks> ready to test, ready to release...
19:12 <Eickmeyer> OvenWerks: Is this ready for upload?
19:12 <OvenWerks> I need bug reports to do much else
19:13 <Eickmeyer> Sweet. Let's give cyphermox, tsimonq2, and or Ross the heads-up on this.
19:13 <Eickmeyer> (they will probably see this, but Ross will need an email)
19:14 <OvenWerks> The best test case is to install on a non-ubuntustudio flavour to test rt fix
19:14 <OvenWerks> (worked for me)
19:14 <Eickmeyer> Gotcha. Truth be told, I'm on a Kubuntu install that I converted to Ubuntu Studio at the moment.
19:15 <Eickmeyer> -controls seems to run rather smoothly in my setup, but qjackctl doesn't like it, and other than Catia I have yet to find a good way to monitor Jack with it running from -controls.
19:16 <OvenWerks> carla works too.
19:16 <Eickmeyer> Yeah, but carla doesn't show xruns.
19:16 <OvenWerks> if qjackctl is started after jack is running it works fine
19:16 <eylul> we did have a few new people who offered to help. we could reach out to them too, and ask them to test the daily image? assuming it will be there?
19:16 <Eickmeyer> Yeah, most have said they'd be up for testing.
19:18 <Eickmeyer> Well, should we have them subscribe to the Autobuilds PPA?
19:19 <eylul> we should probably contact them via email first
19:19 <eylul> then surprise. :)
19:19 <OvenWerks> Is there anything else in there that may be a problem?
19:19 <eylul> that's a good question
19:20 <Eickmeyer> I'm subscribed to it and haven't seen any problems.
19:20 <OvenWerks> ya it looks ok.
19:21 <OvenWerks> Eickmeyer: it should be possible to build Catia separate from Cadence.
19:21 <Eickmeyer> OvenWerks: Not in my experience. It depends on carla-data.
19:21 <Eickmeyer> er, cadence-data
19:21 <OvenWerks> Eickmeyer: :)
19:22 <OvenWerks> so maybe write a bug against -controls to show xruns as a start
19:22 <Eickmeyer> When you install catia, it only pulls-in cadence-data, so cadence itself doesn't get pulled-in, though cadence will pull catia in.
19:22 <Eickmeyer> OvenWerks: Okay, I'll do that.
19:22 <Eickmeyer> Okay. OvenWerks, do you want to do the call-for-testing email for -controls?
19:22 <OvenWerks> I could detect cadence is installed and limit what controls can do in that case.
19:23 <Eickmeyer> Oh, not a bad idea! That way I could get rid of the Breaks: line in the debian/control file.
19:23 <OvenWerks> But I don't use cadence because it is quite intrusive
19:23 <OvenWerks> Once cadence is installed, pulse will no longer start without cadence running.
19:24 <Eickmeyer> Right, unless you edit ~/.pulse/client.conf
19:24 <OvenWerks> That may be ok for audio users, but not for graphics only users
19:24 <Eickmeyer> Yeah. I don't think cadence should be installed by default, but it has been requested.
19:24 <OvenWerks> hopefully a good -controls will help that not to be needed
19:25 <OvenWerks> I will write the email. I was hoping for a release first though.
19:25 <Eickmeyer> Yeah. Honestly, the features in Cadence, aside from the pulse bridge, are available in Catia alone.
19:25 <OvenWerks> I will include how to add the autobuilds PPA
19:25 <Eickmeyer> Cool.
19:26 <Eickmeyer> #action OvenWerks to put a call-for-testing out to the -devel ML, instructions to add autobuild PPA.
19:26 * meetingology OvenWerks to put a call-for-testing out to the -devel ML, instructions to add autobuild PPA.
19:26 <Eickmeyer> Shall we move on to the next topic?
19:26 <OvenWerks> I have no more for that
19:26 <Eickmeyer> Cool.
19:26 <Eickmeyer> #subtopic ubuntustudio-plasma
19:27 <Eickmeyer> Any progress?
19:27 <OvenWerks> not really.
19:27 <OvenWerks> I have been working on Ardour for the past few weeks.
19:28 <OvenWerks> I will have a seed up soon, after that I don't know how to go about getting a second ISO built
19:28 <Eickmeyer> Okay. I noticed a cool file in /etc that configures the "About This System" to customize the distro & logo.
19:29 <Eickmeyer> That sould be a matter of contacting the release team.
19:29 <OvenWerks> which file?
19:30 <Eickmeyer> Trying to remember...
19:30 * OvenWerks notes that changing the os-release file may have odd problems
19:31 <Eickmeyer> Nah, it's a simple little config file specifically for the plasma system info app.
19:31 <OvenWerks> Ah, ok
19:32 <Eickmeyer> KInfoCenter
19:33 <Eickmeyer> /etc/xdg/kcm-about-distrorc
19:33 <Eickmeyer> That's it.
19:33 <Eickmeyer> Anyhow, anything else on this topic?
19:33 <OvenWerks> ok, I will be doing the plasma seed as a bzr repo for now. I don't know how they want git repos set
19:34 <Eickmeyer> They might not want seeds as git yet for all I know.
19:34 <Eickmeyer> tsimonq2 would have more info.
19:34 <OvenWerks> I know they wated master with branch per cycle or something like that
19:34 <OvenWerks> bzr has repo per cycle
19:35 <Eickmeyer> Yeah. Branch per cycle makes sense.
19:35 <OvenWerks> (or maybe even tag per cyce)
19:35 <Eickmeyer> Yeah.
19:35 <Eickmeyer> Shall we move on?
19:36 <OvenWerks> ok]
19:36 <Eickmeyer> #subtopic Plymouth Theme
19:36 <Eickmeyer> eylul: Any progress?
19:37 <Eickmeyer> (looks like we may need to come back to this)
19:38 <Eickmeyer> Okay, moving along for now. eylul, if you come back, we'll go back to this topic.
19:38 <Eickmeyer> #subtopic Website theme and backend access)
19:39 <Eickmeyer> Still roadblocked on this one. Honestly, I haven't been working too much on the administrative end on this, the past two weeks have been crazy and I've been learning a lot about packaging.
19:39 <Eickmeyer> So, that's my progress report.
19:39 <Eickmeyer> Anybody have anything to add?
19:40 <eylul> no progress on plymouth theme
19:40 <Eickmeyer> Okay.
19:40 <Eickmeyer> No worries.
19:40 <Eickmeyer> :)
19:40 <eylul> :)
19:40 <Eickmeyer> #subtopic Packaging for Carla
19:40 <OvenWerks> please test?
19:41 <Eickmeyer> So, I've got it packaged in a very dirty way, and it doesn't include the wine bridges, which looks like they have to be packaged separately to keep carla from pulling-in wine.
19:41 <OvenWerks> same as lmms
19:41 <Eickmeyer> I ran into a compilation error on the 32-bit side where it just plain wouldn't compile even though I had the right dependencies and everything.
19:43 <Eickmeyer> So, that's where I'm at. Testing Carla would probably be good, but since it's just a git snapshot with a /debian directory added, any bug reports will have to be reported upstream.
19:44 <Eickmeyer> Any questions?
19:45 <Eickmeyer> Okay, moving along
19:45 <Eickmeyer> #topic Discussion
19:45 <Eickmeyer> #subtopic Replacing lightdm with sddm
19:45 <Eickmeyer> OvenWerks: I believe this was your idea.
19:46 <OvenWerks> ya
19:46 <Eickmeyer> The floor is yours, my friend. :)
19:47 <OvenWerks> It deals with wayland sessions better
19:47 <Eickmeyer> Would this be something we can or should do this cycle?
19:48 <OvenWerks> I noticed that when I added plasma, that it gave two entries in the login page using lightdm. As happens the first one was really for plasma with wayland and so failed.
19:48 <OvenWerks> it failed in such a way that I needed to reboot
19:48 <Eickmeyer> Yikes
19:49 <Eickmeyer> And, from what I saw you write before, sddm doesn't have this problem.
19:49 <OvenWerks> using the sddm at least puts a (wayland) behind anything for that
19:50 <Eickmeyer> Yeah. And from what I've seen, sddm is fairly customizable, so we could even come up with our own theme from that.
19:50 <OvenWerks> Now it is possible to configure both sddm and lightdm to look in a different directory for the desktop files, so that is another solution.
19:50 <OvenWerks> that is another thing.
19:52 <OvenWerks> US-plasma will probably, at first come with sddm
19:52 <OvenWerks> so maybe test it there
19:53 <Eickmeyer> Yeah. So, maybe hold-off on switching xfce to sddm until next cycle?
19:53 <OvenWerks> wayland is coming... so is fusion power
19:53 <OvenWerks> I think we should consider it testing this cycle if we can get us-plasma going
19:54 <Eickmeyer> Okay. So, we'll focus on us-plasma then and having that use sddm. The default breeze theme for sddm in Plasma 5.13 is really pretty.
19:54 <OvenWerks> If people really like it, I think it would not be hard to switch
19:54 <Eickmeyer> We could take that and customize it to use our US background.
19:54 <OvenWerks> yes
19:54 <Eickmeyer> Cool. I like this idea.
19:55 <Eickmeyer> So, we'll test this cycle and implement in Xfce if all goes well.
19:55 <OvenWerks> eylul: as an aside, I have taken the jpg and reloaded it as a png, but it may be better to use a png made from the original.
19:57 <eylul> jpg of...
19:57 <eylul> the background.
19:57 <Eickmeyer> #action sddm to be default display manager in Ubuntu Studio Plasma. If it goes well, look at making it default for Ubuntu Studio Xfce.
19:57 * meetingology sddm to be default display manager in Ubuntu Studio Plasma. If it goes well, look at making it default for Ubuntu Studio Xfce.
19:58 <eylul> The original is a tif and jpg that were edited in photography. It is in my todo list to check what can be done to reduce the file size.
19:58 <eylul> I'll just roll that into it? I just didn't have a lot of time to experiment with tracing etc
19:59 <Eickmeyer> I'd say just convert the tif to png and replace what's already there.
19:59 <OvenWerks> The png is there now so there is no rush
19:59 <eylul> I do have it converted... somewhere
19:59 <eylul> I'll email it
19:59 <OvenWerks> that sounds good.
19:59 <Eickmeyer> Excellent. :)
19:59 <Eickmeyer> BTW, it's my background now. :)
20:00 <eylul> :))))
20:00 <Eickmeyer> Okay, speaking of wallpapers...
20:00 <OvenWerks> Ya, it is in autobuilds
20:00 <eylul> I also was planning to do several color versions. epub/pdf first that next. then I will look into the plymouth theme?
20:00 <Eickmeyer> #subtopic Wallpaper Contest
20:00 <Eickmeyer> eylul: Absolutely.
20:00 <Eickmeyer> So, we had talked about the Ubuntu Studio users coming up with wallpapers of their own.
20:01 <Eickmeyer> Showcasing the best of the US community.
20:01 <Eickmeyer> I think with all the other flavors doing their wallpaper contests, we should start ours.
20:01 <Eickmeyer> Question is, where should we host it?
20:01 <eylul> we have had one...
20:02 <eylul> for 16.04 possibly?
20:02 <Eickmeyer> Yeah, I saw some stuff for 16.04.
20:02 <OvenWerks> That sounds like the last one.
20:02 <Eickmeyer> Should we have people link us their work and post it on the wiki, then vote on the top 10?
20:02 <Eickmeyer> Or, vote to create a top 10?
20:02 <tsimonq2> Eickmeyer: I would argue that all new seeds need to be Git.
20:03 <Eickmeyer> OvenWerks: There's our answer. tsimonq2, I think OvenWerks is going to need some help with that down the road.
20:03 <Eickmeyer> #chair tsimonq2
20:03 <meetingology> Current chairs: Eickmeyer OvenWerks captain-tux eylul krytarik tsimonq2
20:03 <OvenWerks> tsimonq2: ok, so just load it with no cosmic?
20:03 <tsimonq2> OvenWerks: Huh?
20:04 <tsimonq2> Eickmeyer: Sure.
20:04 <OvenWerks> in bzr we have: lp:~ubuntustudio-dev/ubuntu-seeds/ubuntustudio.cosmic
20:04 <Eickmeyer> #action tsimonq2 to assist OvenWerks with ubuntustudio-plasma seed
20:04 * meetingology tsimonq2 to assist OvenWerks with ubuntustudio-plasma seed
20:05 <OvenWerks> for git it would be just ubuntustudio-dev/ubuntu-seeds/ubuntustudio?
20:05 <tsimonq2> Look at how Lubuntu does it :) https://git.launchpad.net/~lubuntu-dev/ubuntu-seeds/+git/lubuntu
20:05 <OvenWerks> ok
20:05 <tsimonq2> So https://git.launchpad.net/~ubuntustudio-dev/ubuntu-seeds/+git/ubuntustudio
20:05 <OvenWerks> tsimonq2: we want a second iso ubuntustudio-plasma, same thing?
20:06 <tsimonq2> OvenWerks: That needs some tweaks in lp:livecd-rootfs, lp:ubuntu-cdimage, and a few other misc places, but essentially, yes.
20:07 <OvenWerks> I expect I don't have access for the rest :)
20:07 <Eickmeyer> So, once we have the seed, is it a matter of contacting the release team?
20:07 <tsimonq2> OvenWerks: Instead of https://git.launchpad.net/~ubuntustudio-dev/ubuntu-seeds/+git/ubuntustudio you would have https://git.launchpad.net/~lubuntu-dev/ubuntu-seeds/+git/ubuntustudio-plasma
20:07 <tsimonq2> Eickmeyer: Yep.
20:07 <tsimonq2> (I don't have access either :) )
20:07 <OvenWerks> Ok, I will do that
20:07 <Eickmeyer> So, then infinity and slangasek are our contacts once we have the seed ready.
20:08 <tsimonq2> It's generally useful to talk to someone who is an Archive Administrator, is on the Release Team, and works for Canonical. I always personally bug infinity and slangasek (<3) but there are other options too, depending on who you're comfortable with.
20:09 <Eickmeyer> slanasek has always been cool with me.
20:09 <tsimonq2> ("Works for Canonical" is not something I usually look for, but in this case, they have SSH access as Canonical employees where I don't.)
20:09 <tsimonq2> Eickmeyer: Then there you go. :)
20:10 <tsimonq2> Once you have a seed for Plasma, you'll need a separate metapackage.
20:10 <tsimonq2> I can help with getting that uploaded.
20:11 <Eickmeyer> Okay, cool. I'm starting to run low on time, so I think we need to get back to the wallpaper contest.
20:11 <tsimonq2> Thanks. :)
20:11 <Eickmeyer> No, thank YOU!
20:12 <Eickmeyer> :)
20:12 <Eickmeyer> So, how should users submit their creation? Email us a link and we post that on the wiki? Then we vote at a later time?
20:13 * OvenWerks needs to go as well, my lovely Laura is calling. :)
20:13 <eylul> :)))
20:14 <Eickmeyer> Okay, we'll table the rest of the topics for next meeting.
20:14 <Eickmeyer> Everybody okay with that?
20:14 <eylul> I can sort out how we could theorically do the uploading, have them email and then put it somewhere in website. the voting part. I'd really look into how we did it last time
20:14 <eylul> because I came in right after it happened.
20:14 <Eickmeyer> Okay. Sounds good.
20:15 <Eickmeyer> #action eylul to look into how the last wallpaper contest was run
20:15 * meetingology eylul to look into how the last wallpaper contest was run
20:15 <eylul> errr
20:15 <eylul> haha actually I was hoping we could ask on email.
20:15 <Eickmeyer> #undo
20:15 <meetingology> Removing item from minutes: ACTION
20:15 <eylul> I think the person who ran it might still be around
20:15 <Eickmeyer> Okay, then we can take the discussion to email. :)
20:15 <eylul> *nods*
20:16 * eylul really doesn't want to take on more work, before clearing the backlog
20:16 <Eickmeyer> Okay, well, the next topic is something that can wait (replacing abandoned patchage with Catia).
20:16 <eylul> *nods*
20:16 <Eickmeyer> Just something to think about.
20:17 <Eickmeyer> And the installability of Cadence is something I can work on with OvenWerks throughout the next two weeks.
20:17 <Eickmeyer> Everybody okay with ending the meeting here?
20:17 <eylul> from a user perspective I love patchage, and if catia has the same tools it would be wonderful to have it. (I use carla, as a sort of replacement, but it doesn't show alsa midi inputs)
20:17 <eylul> (otherwise is wonderful)
20:17 <eylul> yes for me
20:17 <Eickmeyer> Catia shows alsa midi inputs, but it's considered experimental. :/
20:18 <eylul> :)
20:18 <Eickmeyer> Allrighty then...
20:18 <Eickmeyer> #endmeeting