19:00 <ErichEickmeyer> #startmeeting
19:00 <meetingology> Meeting started Sat May 12 19:00:14 2018 UTC. The chair is ErichEickmeyer. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:00 <meetingology>
19:00 <meetingology> Available commands: action commands idea info link nick
19:00 <ErichEickmeyer> #chair ErichEickmeyer
19:00 <meetingology> Current chairs: ErichEickmeyer
19:00 <ErichEickmeyer> #chair eylul
19:00 <meetingology> Current chairs: ErichEickmeyer eylul
19:00 <ErichEickmeyer> #chair krytarik
19:00 <meetingology> Current chairs: ErichEickmeyer eylul krytarik
19:00 <ErichEickmeyer> #chair captain-tux_
19:00 <meetingology> Current chairs: ErichEickmeyer captain-tux_ eylul krytarik
19:00 <ErichEickmeyer> #chair OvenWerks
19:00 <meetingology> Current chairs: ErichEickmeyer OvenWerks captain-tux_ eylul krytarik
19:00 <ErichEickmeyer> #chair sakrecoe1
19:00 <meetingology> Current chairs: ErichEickmeyer OvenWerks captain-tux_ eylul krytarik sakrecoe1
19:01 <ErichEickmeyer> Anybody else here?
19:01 <OvenWerks> WOW, I have never used meeting-whatever before
19:01 <ErichEickmeyer> LOL
19:01 <krytarik> It accepts multiple nicks at once btw.
19:01 <ErichEickmeyer> Good to know.
19:02 <ErichEickmeyer> How is everyone?
19:03 <OvenWerks> yes, very how.
19:03 <ErichEickmeyer> Such what, very how, super where. Wow.
19:04 <SlidingHorn> I'm here - sorry
19:04 <captain-tux_> #aggree
19:04 <SlidingHorn> wasn't paying attention
19:04 <ErichEickmeyer> Okay, not seeing eylul or SlidingHorn just yet, and the first item is involving them, so .... oh, there's SlidingHorn
19:04 <ErichEickmeyer> o
19:04 <ErichEickmeyer> o/
19:04 <SlidingHorn> o/
19:04 <captain-tux_> Oops
19:04 <ErichEickmeyer> Okay, so here comes the first topic:
19:05 <ErichEickmeyer> #topic New Website Theme (Eylul, SlidingHorn)
19:05 <ErichEickmeyer> So, how's the progress on that, SlidingHorn?
19:06 <SlidingHorn> Unfortunately I haven't gotten anywhere on that, my apologies.
19:06 <SlidingHorn> I'm not aware of what exactly needs to be done, however
19:06 <ErichEickmeyer> Well, it's really a matter of migrating the theme on eylul's site to ubuntustudio.com.
19:07 <ErichEickmeyer> And maybe getting some photos on there as well.
19:07 <ErichEickmeyer> As for the rest, she has more info.
19:07 <ErichEickmeyer> We can table that topic for now if you'd like.
19:07 <SlidingHorn> Okay, I'll make a point of contacting eylul within the next 24 hours to get that moving
19:08 <ErichEickmeyer> Okay, cool. I think if we got that theme going, we'd make a very public statement that we're making progress and moving forward.
19:08 <OvenWerks> I don't think eylul has been around... some of what we were saying yesterday should have gotten a comment...
19:09 <ErichEickmeyer> Yeah. I'm sure she'll turn up.
19:09 <ErichEickmeyer> Probably busy. Happens.
19:09 <ErichEickmeyer> Let's move on.
19:09 <ErichEickmeyer> #topic Desktop Environments
19:10 <ErichEickmeyer> OvenWerks: Loved your review of Plasma. Expressed my sentiments very well.
19:11 <OvenWerks> I think we should see if we can add a ubuntustudio-plasma meta to our repo.
19:12 <ErichEickmeyer> Agreed. I honestly think that should be our first addition, and maybe stick with Xfce as the default.
19:12 <OvenWerks> We should probably rename the current one to ubuntustudio-xfce
19:12 <ErichEickmeyer> Yeah. That'd be a good idea.
19:12 <OvenWerks> we could then take the current name and point it at one or the other as default.
19:12 <ErichEickmeyer> A transitional dummy package.
19:13 <OvenWerks> probably not transitional, but as a way to point people at the default who have no idea what xfce or plasma mean
19:13 <eylul> *sneaks in to the room*
19:14 <OvenWerks> o/
19:14 * ErichEickmeyer notices a wild eylul appears
19:14 <ErichEickmeyer> Quick! Get me a pokeball!
19:14 <captain-tux_> (stealth check failed)
19:14 <eylul> :) oh dear.
19:14 <ErichEickmeyer> haha
19:14 <ErichEickmeyer> Welcome!
19:14 <SlidingHorn> *natural 1*
19:14 * eylul quickly catches up to the backlog
19:15 <ErichEickmeyer> ROFL
19:15 <eylul> and please continue the discussion don't let me disrupt the meeting. sorry for being late
19:15 <ErichEickmeyer> No worries.
19:16 <ErichEickmeyer> OvenWerks: Do you think you could take the kubuntu-settings-desktop package and modify it to be more "Studio" like? Simply put, wallpaper and start button.
19:17 <OvenWerks> ErichEickmeyer: I will try...
19:17 <ErichEickmeyer> Okay, cool.
19:17 <OvenWerks> I have both a bzr -controls and a git -controls sitting here and will try converting the LP version to git.
19:18 <ErichEickmeyer> #info OvenWerks to work on forking kubuntu-settings-desktop package and create ubuntustudio-plasma package.
19:18 <ErichEickmeyer> (may have misused that command)
19:18 <OvenWerks> I will try starting the plasma as git.
19:18 <ErichEickmeyer> Perfect. That would get us migrated easier, I think.
19:18 <krytarik> That's #action
19:18 <OvenWerks> I was about to say that...
19:18 <krytarik> #undo
19:18 <meetingology> Removing item from minutes: INFO
19:18 <ErichEickmeyer> #action OvenWerks to work on forking kubuntu-settings-desktop package and create ubuntustudio-plasma package.
19:18 * meetingology OvenWerks to work on forking kubuntu-settings-desktop package and create ubuntustudio-plasma package.
19:19 <ErichEickmeyer> Awesome. So, I think we've established our first alternate environment. Should we stick with Xfce by default for now?
19:20 <OvenWerks> We have time to decide that when we have a working plasma desktop...
19:21 <ErichEickmeyer> Cool. Let's roll forward with ubuntustudio-plasma and decide whether xfce or plasma will be default in 18.10 at a later time.
19:21 <OvenWerks> So yes default stays xfce, unless we vote something else
19:21 <eylul> honestly considering timelines... even if we planned to switch defaults, 6 months really isn't a long time :)
19:21 <ErichEickmeyer> That's true. Maybe we make the Plasma alternate and consider changing default for 19.04?
19:22 <OvenWerks> right, but if we get to beta with either or being able to load... it would be a choice.
19:22 <ErichEickmeyer> Right. That's a choice we can put into the installer via radio button dialog, I think.
19:23 <eylul> *nods*
19:23 <ErichEickmeyer> The ISO will have to have a default, however. I think for size sake, Xfce is a safe default still.
19:23 <eylul> you know....
19:24 <eylul> and I am putting this out here, just as a long term idea because we definitely don't have the packaging-testing power at the moment but...
19:24 <eylul> we could possibly perhaps maybe have ISOs with both? so people can download what they want. *ducks the incoming objects from multiple directions*
19:25 <ErichEickmeyer> If we have the manpower...
19:25 <OvenWerks> eylul: how far do we go with that?
19:25 <ErichEickmeyer> I know Lubuntu did this for a while with LXQt, and they have a similar staffing situation to us.
19:25 <OvenWerks> how many iso should we keep?
19:25 <eylul> this could be a good idea if we had 2 DEs. probably a very bad idea for all 5 of them.
19:26 <OvenWerks> right.
19:26 <eylul> I wouldn't offer this if not for glowing review of plasma from OvenWerks. usually his and my user cases are very different so it makes me hopeful about it
19:26 <ErichEickmeyer> Well, let's look at it like this: The top two default desktops for multimedia creation are Xfce (probably because of Studio) and Plasma (KXStudio, Fedora Jam)
19:26 <OvenWerks> while I would suggest that budgie, cinnamon, cnome are not suited as defaults, there is not reason not to offer them as install time options.
19:27 <ErichEickmeyer> I can agree with that.
19:27 <OvenWerks> MATE, xfce and plasma are doable.
19:28 <ErichEickmeyer> So, then that begs the question about new desktops: Plasma for 18.10 and then add MATE for 19.04?
19:28 <OvenWerks> unless lxqt basically takes over the xfce world in the next few years... I don't know that it would be worth spending time on right now.
19:28 <eylul> I am just hoping maybe having a separate ISO would get people to try it out and test it beyond the regular testing process.
19:29 <eylul> ah
19:29 <ErichEickmeyer> eylul: That's exactly what Lubuntu did with Lubuntu-Next for LXQt, so I don't see why we can't do it.
19:29 <ErichEickmeyer> Especially since I'm working relatively closely with tsimonq2.
19:29 * eylul nods at OvenWerks
19:30 <krytarik> Notice that they never actually *released* the LXQt until now though.
19:30 <eylul> ErichEickmeyer: this might be a good route IF we decide that something other than XFCE is the new default
19:30 <ErichEickmeyer> I didn't mean we'd do UbuntuStudio-Next. I mean we'd do UbuntuStudio-XFCE and UbuntuStudio-Plasma.
19:30 <OvenWerks> It would not be hard to have two iso if 32bit is gone.
19:31 <ErichEickmeyer> That's a good point, too!
19:32 <OvenWerks> the installer bit would have to be part of the desktop meta.
19:32 <OvenWerks> (it would be different for each iso)
19:33 <ErichEickmeyer> As long as we can get the metapackages sorted out, it should fall into place.
19:33 <ErichEickmeyer> BTW, related: until MyPaint gets upgraded, our ISOs are going to continue to fail to build.
19:34 <OvenWerks> I don't see anything upstream for that.
19:34 <ErichEickmeyer> I'll work with the release team on perhaps getting a git snapshot, which was suggested by jbicha.
19:34 * OvenWerks is not watching their dev work closely
19:35 <ErichEickmeyer> Either that, or we'll have to remove MyPaint from default.
19:35 <OvenWerks> our graphics meta fails to load as well
19:35 <ErichEickmeyer> That's because of the GIMP-MyPaint discrepency.
19:35 <OvenWerks> right
19:35 <ErichEickmeyer> Anyhow...
19:36 <eylul> it does look like the code is updated at least. so the work is ongoing
19:36 <eylul> (sorry was checking their forums and github for any progress*
19:36 <ErichEickmeyer> #action Erich to work on GIMP-MyPaint conflict with release team.
19:36 * meetingology Erich to work on GIMP-MyPaint conflict with release team.
19:37 <ErichEickmeyer> So, did we reach the decision on adding Plasma as the first alternate desktop?
19:37 <ErichEickmeyer> I'm in favor.
19:37 <krytarik> +1
19:37 <SlidingHorn> +1
19:37 <eylul> +1
19:37 * OvenWerks seconds
19:37 <SlidingHorn> sd
19:38 <SlidingHorn> (sorry was wiping off my keyboard)
19:38 <OvenWerks> looks like a vote
19:38 <ErichEickmeyer> That looks like a majority if not unity.
19:38 <ErichEickmeyer> #agreed Adding KDE Plasma as first alternate desktop environment in 18.10
19:39 <ErichEickmeyer> Okay, with that, we'll drop the survey idea.
19:39 <ErichEickmeyer> Anyhow, let's move this along.
19:39 <ErichEickmeyer> #topic Wallpapers
19:39 <ErichEickmeyer> #subtopic Targeting PNG format vs JPEG for submissions
19:40 <ErichEickmeyer> OvenWerks: Can you fill us in on this one?
19:40 <OvenWerks> I can try...
19:41 <OvenWerks> because of the hurry at the end of last cycle, we ended up with a backdrop we were going to add that was JPG. and required changing two packages.
19:41 <OvenWerks> we should probably avoid this in the future by settling on a format to use
19:42 <ErichEickmeyer> Agreed. PNG seems like the logical solution.
19:42 <eylul> my main concern at least with this wallpaper was that the png file ended up being huge
19:42 <OvenWerks> it seems to me in the past PNG was specified for contest entries and defaults.
19:43 <eylul> the wallpapers from the contest seemed to be a mix, the defaults are created as vector. I am not against png as default. I am just not sure at which point
19:43 <OvenWerks> My main question is how do the two formats deal quality wise with sizing?
19:43 <eylul> what do you mean OvenWerks?
19:43 <ErichEickmeyer> Isn't PNG basically lossless compression?
19:43 <OvenWerks> everyone has different screen sizes,
19:43 <OvenWerks> resizing affects png too
19:44 <eylul> ErichEickmeyer: not sure it scales up when the original is not a vector art
19:44 <OvenWerks> a hw screen has an exact number of pixels.
19:44 <OvenWerks> So the backdrop is resized on the fly I would guess
19:45 <OvenWerks> this might mean a jpg would actually resize better.
19:45 <ErichEickmeyer> Well, then, what if we had both?
19:46 * OvenWerks doesn't know how closely graphics is to audio in this respect.
19:46 <OvenWerks> the reason we want one to be default is that we only have to change one package to set default not two (or three)
19:46 <eylul> could we modify the script
19:47 <ErichEickmeyer> TBH, svg is the most scalable, but that's not common for wallpapers.
19:47 <eylul> so that we can specify the file type on one package?
19:47 <eylul> Also Erich we would still have to have started with a vector art to use that.
19:47 <OvenWerks> I don't know how plasma deals with this, but xfce needs the file name in a certian place
19:47 <eylul> yes auto-trace got a lot better, but not quite that good :)
19:48 <ErichEickmeyer> Plasma also needs the files in a certain place, but I had great luck with symbolic links for the wallpapers.
19:48 <OvenWerks> we do specify the type in one package... but we keep the image in another.
19:48 * eylul is testing exact file sizes of png output again while talking.
19:48 <ErichEickmeyer> Xfce looks in /usr/share/backgrounds, plasma looks in /usr/share/wallpapers
19:48 <OvenWerks> link would fix that.
19:48 <OvenWerks> and plasma would handle a full path.
19:49 <OvenWerks> (same with xfce)
19:49 <ErichEickmeyer> Yep. All I did was 'ln -s /usr/share/backgrounds/ubuntustudio/* /usr/share/wallpapers/*
19:50 <OvenWerks> now if we could use wildcards image.* that would be fine, but I don't think so.
19:50 <eylul> well.. we now have time to test it out
19:50 <ErichEickmeyer> Yeah. Let's test this and report back next meeting?
19:50 <eylul> also.. speaking of testing we should probably test that the high res image (png or jpeg) is not bogging down a low end system.
19:51 <ErichEickmeyer> How low are you talking?
19:51 <OvenWerks> the path to image has to be in the -desktop-DE meta but the images should be in a package common to both.
19:51 <eylul> how low do we support I honestly have no idea if this would be an issue or not.
19:51 <OvenWerks> eylul: I don't think that is a problem, the image gets resized once on load?
19:52 <eylul> the image is over 5MB for each screen (6-7 for png) not sure if it is a problem or not.
19:52 <eylul> ah
19:52 <ErichEickmeyer> Well, as I've said before, if you're running many of our apps you either have a higher-end system or have unworldly amounts of patience.
19:52 <eylul> :D
19:52 <OvenWerks> ErichEickmeyer: yes but...
19:52 <OvenWerks> screen size is not the same thing
19:52 <ErichEickmeyer> That's true.
19:53 <eylul> also the problem is that we are putting a very large image for even someone who has 1/4th area of the screen.
19:53 <OvenWerks> There are both lower power/memory systems than mine with higher rez screens and more powerful ones with lower rez..
19:53 <ErichEickmeyer> Yeah, and it has to render that every time the desktop is shown. That adds up to problematic quickly.
19:54 <eylul> exactly
19:54 <ErichEickmeyer> So, do we, say, go roughly 720 and scale up, or meet somewhere in the middle at 1080?
19:55 <eylul> Erich for context, I am on a 4K screen.
19:55 <ErichEickmeyer> I'm on a 1080.
19:55 <eylul> that's double of a 1080p on each dimension
19:55 <OvenWerks> 1920x1080?
19:55 <eylul> :D
19:55 <ErichEickmeyer> My former system was 1280x800.
19:55 <OvenWerks> I think that was what we were looking for last time
19:55 <ErichEickmeyer> Before that I had a system at 1366x768.
19:56 <OvenWerks> mine are 1600x900
19:56 <eylul> *nods* a lot of newer laptops are 1920 or HiDPI through. it is a lot more common than it was 2-3 years ago. :)
19:56 <ErichEickmeyer> Then, set 1080 as a target?
19:56 <OvenWerks> gotta compete with apple...
19:56 <OvenWerks> I think that is still valid
19:57 <ErichEickmeyer> But, this still has the question of whether PNG or JPG. Would the two of you be able to test and report back by next meeting?
19:57 <eylul> we can go with png. it is not a problem.
19:58 <eylul> I just need to know how much MB size I can go with before we start bogging down systems badly.
19:58 <eylul> and I am not sure how to check that.
19:58 <eylul> it might be that we don't need to worry and that a few MB sized wallpaper is perfectly fine
19:58 <ErichEickmeyer> Most low-end systems handle PNG fairly gracefully, in my experience.
19:58 <eylul> which size is the question here. ;)
19:59 <ErichEickmeyer> Okay, so we'll go with PNG, and size TBD?
19:59 <eylul> which file size. yes
19:59 <eylul> as in if we have a maximum or not
19:59 <OvenWerks> eylul: in a 20inch screen is there that much noticable difference from 1920x1020 and 4k?
20:00 <eylul> I'll look for background but on browser
20:00 <eylul> I definitely notice stuff that is low rez
20:00 <ErichEickmeyer> On my 42-inch 1080 screen at work, I can definitely see pixelation, but that makes sense.
20:01 <eylul> *nods*
20:01 <OvenWerks> 42 inch is too big for my desk...
20:01 * OvenWerks can't land f18s on it either...
20:01 <ErichEickmeyer> Yeah, but I make videos for a living, so having something native is good.
20:02 <ErichEickmeyer> So, should we table this for more testing?
20:02 <eylul> yeah
20:03 * eylul wishes had space for a 42" screen.
20:03 <OvenWerks> it would be possible to have default and optional.
20:03 <ErichEickmeyer> Okay. eylul and OvenWerks to do testing?
20:03 <OvenWerks> I can do a bit, but my screens are small and low res
20:04 <eylul> *nods* I'll check what things look like on my screen if they are low rez. I think what I need is someone to make sure the current ones I did post are not causing overhead
20:04 <eylul> too badly when used.
20:04 <ErichEickmeyer> OvenWerks can check higher on low, and eylul can check lower on high.
20:04 <ErichEickmeyer> Perfect comparison.
20:04 <eylul> the ones I did link were high resolution. :)
20:04 <OvenWerks> of course 8k is "future proof" for a bit longer :)
20:04 <eylul> so if they don't cause problems then we don't have a problem.
20:05 <eylul> is there 8K screens out there outside of large displays?
20:05 <eylul> ;)
20:05 <ErichEickmeyer> #action eylul and OvenWerks to test various wallpaper resolutions and report back.
20:05 * meetingology eylul and OvenWerks to test various wallpaper resolutions and report back.
20:06 <ErichEickmeyer> #agreed Using PNG as default format for wallpapers
20:06 <ErichEickmeyer> We need to move this along.
20:06 <ErichEickmeyer> #topic Welcome App & Software Boutique
20:06 <ErichEickmeyer> I'm just going to give a brief status update on this one.
20:08 <ErichEickmeyer> I'm working with tsimonq2 on forking ubuntu-mate-welcome since we can collaborate. He's doing it for Lubuntu, I'm doing it for Studio. It's up to Wimpress, but I have the feeling he could give us tips along the way if needed.
20:08 <ErichEickmeyer> So, that's part of the flavor collaboration we've got going on.
20:08 <OvenWerks> budgie uses it too.
20:09 <eylul> \o/
20:09 <ErichEickmeyer> Yep, and bashfulrobot is probably a good resource as well.
20:09 <ErichEickmeyer> So, with that, since this is a project I'm focusing on, I'll take this one on.
20:09 <OvenWerks> I notice it is a snap package and that the mounted patitions remain after the app is closed.
20:10 <ErichEickmeyer> #action ErichEickmeyer to work with tsimonq on ubuntustudio-welcome and ubuntustudio-software-boutique in collaboration with Lubuntu, with Budgie (bashfulrobot) and MATE (Wimpress) as possible additional resources.
20:10 * meetingology ErichEickmeyer to work with tsimonq on ubuntustudio-welcome and ubuntustudio-software-boutique in collaboration with Lubuntu, with Budgie (bashfulrobot) and MATE (Wimpress) as possible additional resources.
20:11 <ErichEickmeyer> OvenWerks: I'll ask Wimpress about that. Chances are he'll see this.
20:11 <eylul> ErichEickmeyer: question, would having 2DEs duplicate your work or one package will be usable for both plasma and XFCE?
20:11 <ErichEickmeyer> One package would be usable for both.
20:11 <eylul> nice :)
20:11 <OvenWerks> no problem, snap may do some of this at boot too for all I know.
20:12 <OvenWerks> Ya, that would work for as many as we ever have.
20:12 <ErichEickmeyer> It's pretty desktop-independent.
20:12 <ErichEickmeyer> Anyhow... we're running a bit overtime, so...
20:12 <ErichEickmeyer> #topic Next Meeting
20:13 <ErichEickmeyer> As you saw from the email, I'm not available next week. We can take the week off or I can write-up an agenda and one of you runs the meeing. Thoughts?
20:13 <OvenWerks> just a general caution. check any package before uploading to make sure it has not changed from bzr to git.
20:14 <OvenWerks> A week off would not hurt. I have stuff to do.
20:14 <ErichEickmeyer> OvenWerks: Absolutely. I think it's more of a base than a fork. :)
20:15 <OvenWerks> I am available on the 26 though
20:16 <SlidingHorn> I would actually be gone next weekend as well, most likely
20:16 <ErichEickmeyer> I should be available on the 26th as well. Memorial day weekend, and my family will be in Idaho.
20:16 <ErichEickmeyer> Okay. eylul, thoughts?
20:16 <eylul> I wouldn't mind a break.
20:16 <ErichEickmeyer> Cool.
20:16 <ErichEickmeyer> #agreed Next meeting will be May 26th
20:16 <ErichEickmeyer> Alright. That's all I've got. Any additional items?
20:17 <eylul> I was going to ask if Slidinghorn or anyone else wants to co-manage the mastodon account.
20:17 <eylul> so that we can be more active there. Just asking because I need to share the account info with you.
20:17 <eylul> if that is the case
20:17 <SlidingHorn> eylul: Sure
20:18 <ErichEickmeyer> That reminds me, I have yet to make the Telegram group.
20:18 <ErichEickmeyer> #topic Additional Items
20:18 <ErichEickmeyer> #action SlidingHorn to help eylul with Mastodon account.
20:18 * meetingology SlidingHorn to help eylul with Mastodon account.
20:19 <ErichEickmeyer> #action ErichEickmeyer will continue to investigate Telegram and Telegram-IRC bridge.
20:19 * meetingology ErichEickmeyer will continue to investigate Telegram and Telegram-IRC bridge.
20:19 <ErichEickmeyer> Anything else?
20:19 <eylul> not from me.
20:19 <captain-tux_> No
20:19 <OvenWerks> -controls has not really moved porting to git today.
20:20 <ErichEickmeyer> That's okay. Still working on that?
20:20 <OvenWerks> I have the fun of getting it on to launchpad.
20:20 <ErichEickmeyer> Joy. /s
20:21 <ErichEickmeyer> Unless you weren't being sarcastic with the "fun"
20:21 <ErichEickmeyer> #action OvenWerks to continue to get ubuntustudio-controls migrated to git.
20:21 * meetingology OvenWerks to continue to get ubuntustudio-controls migrated to git.
20:21 <OvenWerks> it was a one linner to get it to git on my system.
20:21 <ErichEickmeyer> Wow! That's.. incredible!
20:22 <OvenWerks> some of the links in the instructions are bad though :P
20:22 <ErichEickmeyer> Hmmm.... Documentation. :/
20:23 <ErichEickmeyer> Anyhow, shall we adjourn or do we have any other items to discuss?
20:23 <OvenWerks> I guess I can bug it.
20:23 <OvenWerks> was that a move?
20:23 <ErichEickmeyer> I move to adjourn. Second?
20:23 <OvenWerks> o/
20:23 <ErichEickmeyer> Okay. Meeting adjourned.
20:23 <ErichEickmeyer> #endmeeting