14:05 <popey> #startmeeting Ubuntu Trojita port meeting
14:05 <meetingology> Meeting started Fri Mar 21 14:05:11 2014 UTC. The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
14:05 <meetingology>
14:05 <meetingology> Available commands: action commands idea info link nick
14:05 <popey> Good morning mhall119, do you want to run this?
14:05 <mhall119> nope
14:05 <DanChapman> boren hey o/
14:05 <mhall119> :)
14:05 <popey> Hah!
14:05 <mhall119> but I'll give an update
14:05 <popey> Thanks.
14:06 <popey> I asked Andrea Del Sarto - who worked on the design mockups - if he could be here but he's afk right now
14:06 <popey> and sends his apologies
14:06 <DanChapman> :-(
14:06 <popey> He said he's working some more on the email client UI mockups today, and should have something to present later.
14:06 <mhall119> so after a week of back and forth changes, DanChapman and I were able to put together a working CMake config and some place holder QML accepted into upstream trojita
14:07 <mhall119> that means you can now run "cmake -DWITH_UBUNTU=on" against the trojita trunk and get a working Ubuntu build!
14:08 <mhall119> I've updated the wiki with build instructions: https://wiki.ubuntu.com/Touch/CoreApps/EmailClient
14:08 * mzanetti is a bit late, but likes git too
14:08 <mzanetti> :D
14:08 <mhall119> if you're on Saucy or ealier, you'll have to make a small change to the CMakeLists.txt to get it to compile with Qt 5.0.2, that's also on the wiki, just don't commit that change
14:09 <popey> mhall119: once you have built it, how do you run it and use the ubuntu UI?
14:09 <popey> (rather than the desktop UI on a desktop for example)
14:09 <mhall119> I've also documented how to send contributions to upstream, using KDE's reviewboard, which is a bit confusing IMO but worked well enough
14:09 <mhall119> once it's built there wil be a 'trojita' binary in the build directory, just run that
14:09 <popey> i get the desktop UI
14:09 <mhall119> it's built to use the ubuntu UI, so there's nothing more to do when running the binary
14:10 <mhall119> popey: then you built it wrong :)
14:10 <popey> hm
14:10 <popey> pretty sure I copy/pasted from the wiki
14:10 <mhall119> popey: make sure you're up to date and check that cmake says it's building with the Ubuntu UI
14:11 <popey> oh look, I'm not up to date
14:11 <popey> hey delsa !
14:11 <delsa> hi popey :)
14:11 <delsa> hi to all
14:11 <popey> delsa = Andrea..
14:11 <mhall119> so as I said before, the QML there now is just a placeholder, don't feel like you need to build on top of it
14:12 <mhall119> you can use it to see how to use the ImapAccess class and others from Trojita's core to access information
14:12 <mhall119> I'd also like to start with multi-account support like boren did in his branch
14:12 <mhall119> and convergence, again like boren's branch
14:13 <popey> Agreed, multi-account and convergent UI should be baked in from the start IMO
14:13 <delsa> +1
14:13 <popey> Will this be using online accounts?
14:13 <mhall119> but it's open now for QML developers
14:13 <mhall119> popey: ideally, but I'm not sure how to make it do that, and it shouldn't be *just* online accounts
14:14 <DanChapman> mhall119: with borens branch how does it handle multi account i thought trojita didn't have support for that? or does it only open one account at a time?
14:14 <DanChapman> boren ^^
14:14 <mhall119> so for a first draft I think entering a google account is fine
14:14 <boren> I essentially create two imapaccess at the same time
14:14 <mhall119> ^^
14:14 <mhall119> which seemed to work fine
14:15 <mhall119> especially if you're only *using* one at a time
14:15 <mhall119> which I think is fine
14:15 <DanChapman> ahh ok
14:15 <DanChapman> cool
14:15 <popey> Would that support an "All mail" view though?
14:15 <mhall119> I linked to som eof delsa's mockups on the wiki https://wiki.ubuntu.com/Touch/CoreApps/EmailClient
14:15 <popey> as in "show me everything from every mail box sorted by date"?
14:15 <mhall119> delsa: if you create more, please link them there too
14:16 <popey> s/if/when/ ☻
14:16 <mhall119> popey: not easily, no
14:16 <popey> ok
14:16 <popey> Worth knowing.
14:16 <popey> Because it's something I've become used to on iOS
14:16 <mhall119> I think you can use GMail's all mail mailbox
14:16 <popey> No, not the same thing.
14:16 <delsa> yes popey :)
14:16 <popey> I mean "All mail from all mailboxes"
14:17 <popey> as in "show me work and personal mail intertwined"
14:17 <mhall119> oh, merging mail from different accounts?
14:17 <delsa> yes mhall119 ;)
14:17 <popey> Yes.
14:17 <DanChapman> i'd say it's possible
14:17 <mhall119> yeah, that sounds tricky
14:17 <mzanetti> in any case, believe it or not, there's people not using gmail
14:17 <mzanetti> :)
14:17 <DanChapman> +1
14:17 <mhall119> mzanetti: as long as they're using IMAP
14:18 <mhall119> anyway, that's my update, configuration is done and ready for development on the app to start
14:19 <popey> Thanks mhall119
14:19 <mhall119> if you have trouble getting it to build the Ubuntu UI (looking at you popey) please ping me or DanChapman
14:19 <popey> alan@deep-thought:~/phablet/code/coreapps/trojita/build$ ./trojita
14:19 <popey> Segmentation fault (core dumped)
14:19 <popey> just rebuilt it
14:19 <popey> ☻
14:19 * popey cleans things out and will try again in a bit
14:19 <DanChapman> ouch
14:19 <boren> I have built it just now. It looks great.
14:20 <popey> So really the question is what's next on the to-do list.
14:20 <mhall119> popey: on trusty?
14:20 <popey> yes
14:20 <popey> nvm, I'll sort it after
14:20 <mhall119> ok
14:20 <mhall119> next is creating work items based on the designs we have (and work items for delsa for the designs we don't have)
14:20 <popey> As I understand it we can't view mail content or send mail, right?
14:21 <mhall119> correct, the QML is very basic
14:21 <DanChapman> thats correct
14:21 <popey> ok.
14:21 <mhall119> IMO, replacing the current QML is the first thing to do
14:22 <mhall119> so, a way to create accounts, mailboxes listing, message listing
14:22 <mhall119> I really liked the way boren displayed mail messages with expandable quoted sections, if we can re-use that
14:23 <popey> so I'm seeing 5 views...
14:23 <mhall119> delsa: I saw that your mockups used different color icons, was there a function to determine which color to use for which person?
14:23 <popey> * Manage IMAP accounts
14:23 <popey> * Manage SMTP accounts
14:23 <popey> * Folder list selection
14:23 <popey> * Message list view
14:23 <popey> * Message content view
14:23 <popey> right?
14:23 <popey> although we can't send yet, so SMTP is somewhat academic, but required
14:24 <delsa> mhall119 no, or not now, it's random colour, or we can choose colour in base at the initial of the name :)
14:24 <mhall119> popey: trojita can send, just not the QML we have now
14:25 <mzanetti> "The underlying socket is having troubles when processing connection to imap.gmx.net:143: Error during SSL handshake: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol"
14:25 <mzanetti> can't connect. is that known?
14:26 <mhall119> we might end up needing some C++ work on the core components to expose things we need, who's good at C++ who can tackles those as they come?
14:26 <popey> oh. ok
14:26 <mhall119> mzanetti: I haven't had that problem before
14:26 <mzanetti> mhall119: did you use SSL?
14:26 <gcollura> mhall119: will there be a priority list of things that need to be implemented asap with its assignee?
14:26 <mhall119> with Gmail, yes
14:26 <mhall119> gcollura: not yet, I think popey is working on that
14:27 <gcollura> mhall119: I have some experience of exporting things over qml from c++
14:27 <popey> yeah
14:27 <boren> mhall119: I can also help with c++
14:27 <mhall119> gcollura: great!
14:27 <mhall119> boren: great again!
14:28 <mhall119> jkt is the upstream developer, he's in #trojita most of the time, and has been very friendly and helpful so you can always ask him how to do things with the existing classes
14:29 <mzanetti> yeah, well... in case mhall119 didn't know. I'm not really afraid of C++ tasks either
14:29 <mzanetti> in fact I'd like to remind people to not write any logic in qml
14:29 <mzanetti> especially if it could be of use for other platforms too
14:29 <mhall119> mzanetti: I'll let you argue that one with zoltan :)
14:30 <popey> #action popey write up work items on the wiki
14:30 * meetingology popey write up work items on the wiki
14:32 <mzanetti> mhall119: well, I don't think the trojita people would be happy if we extend features and do that in the ubuntu QML ui only
14:33 <boren> So for multiple account support, we first help Trojita make it. And then we port to Ubuntu
14:33 <boren> ?
14:33 <DanChapman> mzanetti: jkt has already mentioned this
14:33 <mzanetti> ah ok. missed that
14:33 <DanChapman> mzanetti: i think it was in #trojita though :-)
14:34 <mhall119> mzanetti: good point, anything not UI related should go into the core
14:34 <popey> boren: yes, i see us as contributing to trojita upstream, not forking it
14:34 <popey> so if we add multi-account support or any other currently-missing logic, we should do it in a way that other consumers of trojita will benefit
14:34 <mhall119> so the way boren made multi-account before was just using multiple instances of ImapAccess, which didn't require any changes tothe core
14:35 <mhall119> I'm not sure how to make that UI independent
14:35 <DanChapman> while we talk about that jkt mentioned this week that anything like server defaults like common imap and smtp addresses should be built into the core and not as say a listmodel in qml
14:36 <mhall119> right, that was something from the QML code I took from joseph mill's branch, he had a page where you can select pre-defined providers (like Gmail) and it would fill in the server and port info for you, jkt wanted something like that build into the core
14:36 <mhall119> but it's also not something we particularly need for a first cut
14:37 <mhall119> so for now I've just removed that all together
14:37 <DanChapman> oh yes i see it's gone now :-)
14:37 <popey> I feel an etherpad coming on...
14:38 <DanChapman> +1 to that
14:38 <mhall119> https://docs.google.com/a/canonical.com/spreadsheet/ccc?key=0AofbdH5hl5CbdE1rRmpyd0lWNE1zYXUwc01SNW4yVHc&usp=drive_web#gid=0 again is our list of known requirements
14:38 <gcollura> pre-defined providers should be automatically set once a user write his email address
14:38 <popey> oh yes, thanks mhall119
14:38 <mhall119> popey: maybe we can sort those into milestones
14:39 <popey> we had another doc?
14:39 * mhall119 has lots of docs
14:39 <popey> https://docs.google.com/a/canonical.com/document/d/1MlGUefZxlYxJzwvIlD0LzhrUA8T4ulVtHA7Fb78RPyY/edit#heading=h.ipr46wz6jck6
14:39 <popey> that one
14:40 <mhall119> I think most of that went into the wiki already
14:40 <mhall119> at least the work items did
14:40 <mhall119> we should decide where we're going to track work items
14:40 <popey> yeah, i just wanted something we can all edit now
14:40 <popey> wiki doesn't do multi-player edit well
14:41 <mhall119> it barely does single-player edit well
14:41 <DanChapman> are we using kde bugzilla for workitems?
14:41 <mhall119> I think that was the plan, yeah
14:41 <DanChapman> cool
14:41 <popey> Ok, so who will work on the backend mail provider selector?
14:42 <mhall119> popey: is that a priority right now?
14:42 <boren> popey
14:42 <boren> popey
14:42 <boren> popey: what is that again?
14:42 <mhall119> I think we can put that off until we have working accounts management and message listing
14:42 <popey> mhall119: you tell me?
14:42 <popey> well thats what i kinda meant by that.
14:43 <popey> the backened for selecting mail accounts
14:43 <popey> is that already 100% done?
14:44 <mhall119> oh, ok, not the "pick Gmail and it'll configure the server and port for you"
14:44 <popey> no, no
14:44 <mhall119> so the UI is 0% done, effectively
14:44 <popey> Just whatever is needed behind the bit where you fill in the IMAP server details
14:44 <mhall119> we can hopefully re-use some of boren's code
14:45 <mhall119> but in the upstream repo, everything there needs to be replaced
14:45 <popey> right, which is a priority?
14:46 * mzanetti is open for any task. just assign me something :)
14:46 * gcollura is available for tasks too
14:46 <mzanetti> but right now I'm struggling to finding something to do myself without stepping on other people's toes
14:46 <mhall119> popey: the ones you listed then are the priority
14:47 <mhall119> mzanetti: want to figure out how to tie Ubuntu Online Accounts into this?
14:47 <mzanetti> ack.
14:47 <boren> Does online account provide password?
14:47 <mhall119> mzanetti: we'll also need help with making sure cross compiling and click packaging works
14:47 <mhall119> boren: no, but it does provide an auth token
14:47 * mzanetti didn't manage to cross compile something yet
14:48 <mzanetti> click bails out in every possible wayevery time I tried so I gave up until the major version number is bumped
14:48 <mzanetti> might give it another try soon. hearing that some people start having success
14:48 <mhall119> mzanetti: I tried with boren's branch, but had a qt gles error that zoltan was going to look into
14:49 <popey> any takers for the UI tasks in the doc?
14:49 <mhall119> delsa: could you work on account management (add, remove, switch) designs for us?
14:49 <delsa> mhall119 for sure :)
14:49 <mhall119> thanks
14:50 <delsa> :)
14:50 <gcollura> mhall119: If I remember correctly trojita saves passwords in plaintext, is this bug going to be fixed upstream?
14:50 <mhall119> gcollura: I don't know, you'd have to ask jkt
14:51 <gcollura> popey: I can do some UI tasks
14:51 <popey> gcollura: great! Feel free to add your name to the doc
14:51 <mhall119> boren: since you've already done the multi-account work once, could you take the work item to implement those UI bits?
14:51 <popey> and I'll paste it back into teh wiki
14:51 <DanChapman> hmmm should the imap smtp ui's wait till a design is done
14:52 <mhall119> DanChapman: we can use a simple form until designs are available
14:52 <boren> mhall119: sure. How would you like it done?
14:52 <mhall119> so we can unblock other work
14:52 <DanChapman> cool
14:52 <mzanetti> mhall119: wait... what exactly wold you think should be connected to online accounts?
14:52 <mhall119> boren: for now just a simple form until delsa has designs for it, just enough to let people start on the mailbox and message list viewa
14:53 <mhall119> mzanetti: ideally if I have my Google account in UOA, I could just tell Trojita to use that to get my gmail
14:53 <popey> Ok, we have only a couple of mins left
14:53 <mzanetti> mhall119: I guess not only for gmail tho. does online accounts support other mail providers yet?
14:53 <popey> Anything else we need to discuss before we wrap?
14:53 <popey> mzanetti: no
14:54 <mhall119> mzanetti: it could, but I don't think it does yet
14:54 <boren> mhall119: what's the problem with the current approach?
14:54 <mzanetti> hmm... then we assigned the gmail task to the only guy not using gmail :D
14:54 <DanChapman> heh
14:54 <mhall119> mzanetti: if somebody were to create a "Generic IMAP Account" provider, that would mean we can use UOA for all of them
14:54 <popey> +1
14:54 <mzanetti> yeah... that's the idea
14:54 <boren> mhall119: I can view mailbox and messagelist now
14:54 <mhall119> boren: current approach to what?
14:55 <mzanetti> so in the end, the whole account setup should be handled in UOA, right?
14:55 <mhall119> boren: in the upstream branch, you can only view for a single account, not multiple
14:55 <mhall119> mzanetti: could be
14:55 <mhall119> mzanetti: like I said if somebody (hint, hint) were to make a generic IMAP account provider, we could do that
14:56 <mzanetti> sure... just trying to understand
14:56 <mzanetti> seing that we have people assigned to implement an account setup ui in trojita itself
14:56 <mzanetti> confused me a bit where it should go in the end
14:56 <DanChapman> that wuld remove the need for trojita to have account setup
14:56 <DanChapman> would*
14:56 <mzanetti> exactly
14:57 <mhall119> boren: delsa has designs already for message list, that can be implemented
14:57 <boren> mhall119: I am confused about accounts, I can implement the message list first.
14:58 <mzanetti> In any case, I'll play around with UOA and see how far we can get with that. hopefully I have some idea by next week so we can define how to go forward
14:58 <popey> I think that would make sense, until we have the online accounte generic IMAP plugin?
14:58 <mzanetti> boren: +1 imo
14:59 <gcollura> ok I have to go to a lecture, tomorrow I'll start with writing some UI bits (I'll update the docs accordingly) or if you have some task to give to me, just contact me :)
14:59 <gcollura> thanks everyone and good weekend
14:59 <popey> thanks gcollura
14:59 <neugierig> you guys rock - big time! Vielen Dank!
15:00 <mhall119> for the message content view, Trojita uses a special URL scheme to provide message content, I think the code up there has an example of how to tell Qt WebView about that scheme
15:00 <mhall119> thanks everyone!
15:00 <popey> awesome.
15:00 <popey> That was productive.
15:01 <popey> Everyone done? Any last comments?
15:01 <delsa> done
15:01 * popey edits the wiki
15:01 <mhall119> just that all of you guys rock, keep up the great work
15:02 <delsa> :)
15:02 <popey> #endmeeting