17:01 <popey> #startmeeting Clock App meeting
17:01 <meetingology> Meeting started Thu Jan 16 17:01:50 2014 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:01 <meetingology> 
17:01 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
17:01 <popey> Clock App links:-
17:01 <popey> Bugs: https://bugs.launchpad.net/ubuntu-clock-app/+bugs
17:01 <popey> Reviews: https://code.launchpad.net/ubuntu-clock-app/+activereviews
17:02 <popey> Blueprint: https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/coreapps-1404-clock-dev
17:02 <popey> General Links:-
17:02 <popey> Milestones: https://launchpad.net/ubuntu-phone-coreapps/+milestones
17:02 <popey> Burndown: http://status.ubuntu.com/coreapps-14.04/
17:02 <popey> Blockers: https://wiki.ubuntu.com/Touch/CoreApps/Blockers
17:02 <popey> I'll take a look at https://code.launchpad.net/~nik90/ubuntu-clock-app/fix-alarm-analogue-format/+merge/201282 after the call.
17:02 <nik90> sure
17:03 <nik90> I also asked zanetti to review it when he has time
17:03 <popey> ah okay
17:03 <popey> i have time after this call.
17:04 <nik90> yeah definitely. I want to hear about your experience using it on the phone.
17:04 <popey> k
17:04 <popey> We spoke to tstrehl
17:04 <popey> about alarms
17:05 <popey> implementing the api seems to have been pushed back a week
17:05 <nik90> david told me yesterday about the planned release to be in week 5
17:05 <popey> ah okay
17:05 <popey> yes, that's what I was going to mention
17:06 <nik90> I think that's fine as long we get a date fixed
17:06 <popey> current work ongoing with the indicator, alarms service to follow after
17:06 <popey> as with all these things it's a big list of things to do this cycle
17:06 <nik90> true
17:06 <popey> the good news is we're at the top of that list
17:06 <nik90> :)
17:06 <popey> so unless some urgent show-stopper comes along we should be fine for the timescales david mentioned
17:07 <popey> do you want to hold off any clock releases to store until then?
17:07 <nik90> #info Indicator-datetime fix planned for week 5
17:07 <nik90> yes
17:07 <popey> ok.
17:07 <nik90> I want to bring in more fixes to it before pushing an update out to the store
17:07 <popey> np
17:08 <nik90> this week I also added a setting ui to switch between 12/24 hour mode. This also uses u1db to store it
17:08 <popey> oh neat
17:09 * popey looks at the blueprint
17:09 <popey> not much to update there.
17:09 <nik90> #action nik90 Talk to zsombi about the Alarms API bug fixes
17:09 * meetingology nik90 Talk to zsombi about the Alarms API bug fixes
17:10 <nik90> I just updated it yesterday I think
17:10 <popey> ah, okay
17:10 <nik90> and the keyboard shortcuts work is also coming nicely
17:10 <nik90> so overall this week was quite productive
17:11 <popey> yeah, I was impressed with how quickly that came together
17:11 <popey> also lots of conversations with the music app guys about u1db
17:11 <nik90> I think I am a bit lucky that the bugs blocking u1db in music app wouldn't affect clock app
17:12 <popey> indeed
17:12 <nik90> so I am slowly planning to transition other parts to u1db when possible
17:13 <popey> Ok.
17:13 <popey> Anything else? Blockers?
17:13 <popey> (other than already discussed)(
17:14 <nik90> Next week however I will be busy with University stuff. So I will try to get things into the trunk by this week.
17:14 <popey> ok.
17:14 <nik90> I would consider cancelling next week's meeting alone since I won't have much to report about due to it.
17:15 <nik90> regarding the performance blocker bug, timp has fixed it. It just need a review and merge to trunk.
17:15 <nik90> Although I am afraid that if I utilise that fix to do performance optimizations, then the clock app might break on the phone
17:16 <nik90> since the SDK package on the phone is nearly 2 months old
17:16 <nik90> due to the Qt 5.2 transition
17:17 <popey> hm
17:17 <popey> i know timo has a ppa with the qt5.2 stuff in already
17:17 <popey> and I expect at some point soon we will start agressively testing apps on 5.2
17:18 <popey> we can of course use the emulator for it
17:18 <popey> balloons: do you know what plans we have for testing apps on 5.2?
17:18 <nik90> true but should I wait until the SDK package on the phone is updated before pushing the performance fixes to trunk?
17:18 <popey> i would, yes
17:19 <balloons> currently looking at why clock is randomly failing on maguro
17:19 <popey> on 5.2? or current?
17:20 <nik90> balloons: yup just had a look at your email
17:20 <balloons> popey, I believe 5.2 is delayed till post 14.04? I am mistaken
17:20 <popey> oh!
17:20 <nik90> balloons: what?
17:20 <balloons> am i mistaken? lol
17:20 <popey> thats news to me!
17:20 * nik90 hopes not :/
17:21 <popey> yeah, i dont think that's the case.
17:22 <popey> ok, checked
17:22 <nik90> popey: can you confirm that later? It is quite important.
17:22 <popey> plan is feb/mar
17:22 <popey> lots of discussions
17:22 <popey> but thats the current plan
17:22 <nik90> okay
17:22 <balloons> yes, I checked as well.. last mailing indicate the push is still on.. So I am mistaken
17:23 <popey> \o/
17:23 <popey> so yes, I'd hold back nik90 until 5.2 at end of feb.
17:23 <balloons> the uitk has been tested against 5.2. there was some breakage.. I should ask leo about it
17:23 <balloons> that's the big piece. I hope that will ease the transition for many apps
17:23 <nik90> popey: okay
17:24 <nik90> popey: in that case, I will focus on my efforts on digital style and u1db transition until then.
17:24 <popey> awesome.
17:24 <nik90> #action nik90 Enquire with michael spencer about his convergence branch
17:24 * meetingology nik90 Enquire with michael spencer about his convergence branch
17:24 <balloons> yes.. I think pure qml apps will escape mostly unscathed
17:25 <nik90> balloons: true, since they are quite dependant primarily on the SDK
17:25 <popey> unless they expose a bug in uitk or u1db or platform...
17:25 <balloons> yep, exactly
17:26 <popey> ok. anything else nik90 ?
17:26 <popey> I'll cancel next weeks meeting
17:26 <nik90> nothing else
17:26 <popey> awesome. Thanks nik90
17:26 <nik90> #action nik90 Get keyboards shortcuts branch in by this week
17:26 * meetingology nik90 Get keyboards shortcuts branch in by this week
17:27 <popey> nik90: lemme know if you need any more branches reviewing or testing
17:27 <nik90> popey: will do
17:27 <popey> thanks.
17:27 <nik90> the big one is the alarms branch atm
17:27 <popey> yeah
17:27 <popey> ok, it's a wrap!
17:27 <popey> #endmeeting