19:32:11 <mhall119> #startmeeting Ubuntu Clock App
19:32:11 <meetingology> Meeting started Fri Apr 5 19:32:11 2013 UTC. The chair is mhall119. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:32:11 <meetingology>
19:32:11 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:32:15 <renato> me
19:32:16 <nik90> will popey be joining as well?
19:32:32 <mhall119> no, popey has the day off to celebrate another trip around the sun
19:32:40 <nik90> hehe
19:33:01 <nik90> alrite, I have some questions prepared for this meeting that I'd like to go through one by one
19:33:10 <mhall119> right, let me bring up the BP
19:33:34 <mhall119> #link https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/initial-clock-development
19:33:54 <mhall119> #topic questions
19:34:00 <mhall119> nik90: go fore it
19:34:09 <nik90> In the blueprints, what do the Base Clock API, Timer API etc mean? Are we expecting external programs to use the ubuntu clock app?
19:34:38 <nik90> I asked other clock developers as well, but they didnt know about it as well
19:34:49 <mhall119> that I'm not real sure about
19:35:16 <mhall119> are they new work items, or have they been there?
19:35:26 <nik90> they have been there right from the start
19:35:53 <renato> Hi guys I can check it with my manager, because this is not clear for me either
19:35:53 <nik90> and I have been editing the blueprints right from the begining, adding stuff etc..but has no idea of who came up with the API stuff
19:36:10 <nik90> renato: that would be grt. tnx
19:36:30 <mhall119> ok, it might have been Kevin Wright, who put together the original functional requirements and work items
19:36:48 <mhall119> renato: who is your manager?
19:37:01 <renato> nik90, I know that, the system settings will export a API with the clock/date format to be displayed and the clock app should use that
19:37:01 <renato> mhall119, bill
19:37:07 <mhall119> ok
19:37:31 <nik90> renato: ok..I remember callum also talking about the setting part
19:37:34 <mhall119> renato: I'm wondering if it has something to do with the datetime indicator, or if it was just an API between parts of the app's code
19:38:02 <mhall119> all this is currently scheduled for the month-4 milestone anyway, so doesn't need an immediate resolution
19:38:15 <renato> I am working on datetime indicator, and we get this information from the datetime service
19:38:23 <nik90> mhall119: actually I pushed that to month 4 since i did not have an idea
19:38:32 <mhall119> where was it before?
19:38:35 <renato> the client side does not export anything
19:38:57 <nik90> all the tasks were in month-1...popey asked me to do a logical division of tasks into diff months
19:39:04 <mhall119> ok
19:39:30 <mhall119> it's entirely possible it's something we can drop from the BP, I'll email Kevin and see if he remembers what it meant
19:40:11 <nik90> mhall119: alrite when you get a reply from kevin, can you remove it from the BP if necessary
19:40:28 <mhall119> #action mhall119 to check with Kevin on what the API work items are for
19:40:28 * meetingology mhall119 to check with Kevin on what the API work items are for
19:40:36 <renato> in my opinion who will export the API will be the datetime service the application only uses that
19:41:07 <nik90> renato: I think even the calendar app could use it
19:41:21 <nik90> in a scenario where a user creates an event...he might want to set an alarm 15 min before the event starts
19:41:37 <renato> nik90, yes all applications that uses datetime information
19:42:32 <mhall119> the calendar app would use something like evolution-data-server to store events
19:42:35 <renato> nik90, I think that a event should be a calendar event which will be stored in the schedule server
19:42:43 <mhall119> honestly, I'm not sure if the clock app would interface with the datetime indicator
19:43:37 <nik90> k
19:43:45 <nik90> my next question was regarding the ubuntu touch daily images. I heard that the clock app is now in the daily images (hurray)..does that mean that any commits to trunk will be an update in the next day's build?
19:44:05 <mhall119> I don't know if it's currently in, but it's going to be added
19:44:31 <mhall119> I also don't know if it's pulling daily packages, or if somebody is manually copying them over
19:44:49 <nik90> https://plus.google.com/102351181217041965310/posts/CexNfV7nTTm
19:44:59 <nik90> it def is in the daily images since today or yesterday
19:45:11 <renato> I know that the clock is in the today image, but we need to check if it was added to jenkins autolanding system
19:46:07 <mhall119> ok, rsalveti says its being pulled from the PPA for every new image
19:46:15 <mhall119> so it should be the latest build from trunk
19:46:30 <nik90> awesome :)
19:46:35 <mhall119> yes it is :)
19:46:42 <mhall119> now I have to phablet-flash again so I get them
19:47:07 <nik90> it is nice to get them user tested as early as possible
19:47:12 <mhall119> yeah
19:47:33 <mhall119> also a big recognition of the work you all have been putting into their development that we can include them already
19:48:07 <nik90> my next question was regarding the whole debian folder...I saw a merge to the core app template which improved the debian rules file in particular
19:48:30 <nik90> would be nice if someone can have a look at our folder structure and then improve the debian rules file
19:48:44 <mhall119> nik90: I'll be doing that for all the core apps
19:49:10 <nik90> mhall119: oh ok..that's nice
19:49:14 <mhall119> osomon gave me a merge proposal to the original template branch, so I'll be rolling that down into each coreapps branch
19:49:50 <nik90> mhall119: ok..I already included some of that in my recent MR which renato is reviewing at the moment
19:50:09 <mhall119> nik90: no problem, I'll take care of any merge conflicts when I do mine
19:50:16 <nik90> ok
19:50:46 <mhall119> I'll also be working on some renaming, s/ubuntu-clock-app/clock-app/
19:51:06 <mhall119> to match the others being developed by canonical (gallery-app, phone-app, etc)
19:51:45 <nik90> when can I expect that? I will try to get my MRs in before that to avoid any conflicts :)
19:52:02 <mhall119> probably early next week
19:52:11 <nik90> ok
19:52:11 <mhall119> unless I get really bored over the weekend
19:52:15 <mhall119> :)
19:52:23 <renato> nik90, I think I can review your MR today
19:52:47 <renato> then we can make sure that is merged before to avoid conflicts
19:53:19 <mhall119> any other questions nik90 ?
19:53:51 <nik90> is it necessary to start writing manual tests from now on since we have a working stopwatch, timer?
19:54:07 <nik90> or should we leave it to a bit later?
19:54:10 <mhall119> we can write autopilot tests now
19:54:18 <mhall119> automated testing > manual testing
19:54:53 <nik90> ok I will remove the manual tests from the BP then
19:55:05 <mhall119> +1
19:55:25 <nik90> callum and christina have updated the timer design and I have almost completed it.
19:55:34 <nik90> Should do a MR maybe tomorrow I guess
19:55:56 <nik90> that's all I have to say
19:56:16 <renato> nik90, I will help you guys with the autopilot initial structure, then you can go ahead and write the autopilot test
19:56:34 <nik90> renato: awesome..
19:56:40 <mhall119> renato: I assume jenkins will be able to run those tests too
19:57:14 <nik90> how does one run autopilot to check if the tests are written properly or not?
19:57:26 <renato> mhall119, we we are waining for jenkings get configured for the core apps, this should be ready soon
19:57:29 <mhall119> testing tests, the age old problem
19:57:49 <mhall119> nik90: proper test writing and coverage is more of an artform
19:57:53 <renato> waiting
19:58:31 <nik90> mhall119: no I meant as in like say I write a test for the timer functionality...how do I run it?
19:59:00 <mhall119> nik90: I've asked a couple people to write up instructions for that
19:59:02 <renato> nik90, I will add a target "autopilot" then you can run make autopilot
19:59:13 <renato> this will run the autopilot tests
19:59:21 <nik90> mhall119: ok
19:59:23 <nik90> renato: thnx
19:59:38 <mhall119> nik90: it's mostly just launching your QML app with an autopilot wrapper of sorts, then that wrapper runs normal autopilot tests
20:00:25 <nik90> ok
20:01:20 <mhall119> ok, before we run out of time, how are things going on the month-0 work items?
20:01:48 <nik90> mhall119: we are almost done (around 85-90%)
20:02:00 <mhall119> nothing blocking you guys
20:02:00 <mhall119> ?
20:02:10 <nik90> no blockers at the moment
20:02:28 <mhall119> awesome
20:02:34 <mhall119> great work you guys
20:02:38 <nik90> we have had weekly meeting with callum and christina to help out with any design related issues..
20:02:51 <mhall119> nik90: are those going well? you find them useful?
20:03:41 <nik90> mhall119: yeah really useful to talk to the designers..
20:03:45 <nik90> its on g+ hangout..so face to face..they also get feedback from us on improving the design etc.
20:03:55 <mhall119> great, glad those are working well
20:03:57 <mhall119> #endmeeting