20:32:34 <popey> #startmeeting Ubuntu Touch Weather App Meeting
20:32:34 <meetingology> Meeting started Thu Apr 4 20:32:34 2013 UTC. The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
20:32:34 <meetingology>
20:32:34 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
20:33:50 <popey> How's the weather?
20:33:59 <m-b-o> well, cloudy
20:34:13 <m-b-o> as it turns out the design gets redone
20:34:33 <gusch> bigger issue for now is, that the package does not work
20:34:44 <gusch> most files are missing
20:34:44 <popey> in what way "not work"
20:35:25 <gusch> the whole debian sub-dir should be reworked (as it's currently done for calendar)
20:35:45 <popey> mhall119: is that something you would have time to look at?
20:36:29 <gusch> I could do it as well tomorrow
20:37:09 <popey> oh i see..
20:37:10 <popey> file:///usr/share/ubuntu-weather-app/weather.qml:3 "components": no such directory
20:37:13 <popey> ^^ that?
20:37:45 <popey> I'm sure we can find someone to fix that, leave that to me
20:37:59 <popey> #action popey find someone to fix weather app packaging
20:37:59 * meetingology popey find someone to fix weather app packaging
20:38:28 <popey> I have someone in mind ☺
20:38:59 <popey> some good news... (once packaging is fixed)
20:39:16 <popey> we're looking to get some of the apps onto the daily device image
20:39:30 <gusch> calendar currently gets a proper fix for tha packaging...
20:39:58 <gusch> what's needed for the daily image, is to pass the license header check
20:40:23 <gusch> weather doesn't have any license header so far (neither .qml nor .js)
20:40:42 <m-b-o> even as it doesn't seems important: at the moment there's no design to work on, since the last one gets further explored and the compnents done till now are more or less needless
20:41:12 <m-b-o> so with no visual design, there's not too much to do
20:41:16 <popey> you've seen http://design.canonical.com/2013/03/app-patterns-applied-weather-key-journeys/ ?
20:41:31 <m-b-o> yes, but I ccan't read too much out of it
20:41:46 <popey> but yes, the visual design for weather is in progress
20:41:47 <popey> i think the easter break ate into some of their time
20:41:50 <gusch> there is a lot to do even without design - the whole "backend" is missing
20:42:07 <m-b-o> what's the backend?
20:42:18 <gusch> the engine to fetch the data
20:43:39 <m-b-o> megred yesterday
20:43:39 <gusch> something got merged, but that's only a start
20:43:39 <gusch> there should be a declarative model to easily access the data as properties
20:45:12 <gusch> and one more feedback: tests are missing
20:45:26 <popey> are there items which need attention that we're not tracking on https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/initial-weather-development ?
20:45:34 <popey> if so, please add them as TODO
20:45:45 <popey> so we can track them and unblock if necessary
20:46:51 <gusch> so shall I add an item for tests?
20:47:15 <popey> sure
20:49:32 <gusch> as said I can provide first tests, so it's easier to "just" add some more
20:51:45 <popey> I'll chase design in the morning and find out when we will have wireframes for the weather app
20:52:31 <popey> #action popey chase weather app wireframes
20:52:31 * meetingology popey chase weather app wireframes
20:52:53 <popey> is there anything else which needs attention?
20:53:09 <mhall119> m-b-o: I did approve one of your branches yesterday
20:53:25 <mhall119> the other was, I think, the renaming, which popey and I are going to be doing for all of the core apps
20:53:32 <m-b-o> mhall119: thanks!
20:53:40 <mhall119> happy to contribute
20:54:38 <mhall119> as for tests, I just found out that autopilot tests can be written against QML apps, balloons gave me a doc on how to do it, and has offered to help write a tutorial or something
20:55:30 <m-b-o> mhall119: there's no package for u1db-qml for now?
20:55:38 <mhall119> sorry, I'm catching up with the meeting, had a repair guy here earlier
20:55:48 <mhall119> m-b-o: yes, in the core apps PPA I believe
20:56:07 <popey> yup
20:56:23 <m-b-o> ah, I see
20:56:47 <gusch> mhall119: ok - so you don't need my help for the autopilot tests?
20:57:20 <mhall119> gusch: I don't know anything about writing autopilot tests, so yes we still need your help :)
20:57:30 <mhall119> I just learned that it's available to QML apps
20:57:58 <nik90> mhall119: sry to interrupt, would you showcasing how to write autopilot test for all the core apps?
20:58:02 <gusch> ok so tomorrow I' provide a first simple autopilto test, and a first simple unit test
20:58:24 <popey> nik90: excellent idea ☺
20:59:45 <nik90> gusch: that would be grt. Where can one follow you regarding the tests? I am asking because it would be better writing test right from the beginning to make life easier.
21:00:40 <gusch> nik90: I'll provide a first and simple test, and then do a merge request
21:00:58 <mhall119> nik90: I'm hoping to get balloons to write up some generic info on that
21:01:07 <gusch> nik90: you can ping me on #ubuntu-touch anytime
21:01:07 <mhall119> since he's the expert on testing on my team
21:01:55 <nik90> gusch: nice..will do so..
21:01:55 <nik90> mhall119: I will also request him :)
21:01:59 <mhall119> gusch: do you have a blog? If you want to write up the process, I'd love to link to it. If you don't have a blog but are still willing to write up a tutorial, I'll publish it on developer.ubuntu.com
21:02:35 <gusch> mhall119: no blog from me
21:03:05 <gusch> mhall119: I can forward you an email from mzanetti describing testing for unity
21:05:37 <gusch> mhall119: sent you the mail
21:06:23 <popey> ok, we're over time.. any last minute things to mention?
21:09:24 <popey> .. ok
21:09:34 <popey> thanks for coming guys..
21:09:37 <popey> #endmeeting