21:37:56 <popey> #startmeeting Ubuntu weather app meeting
21:37:56 <meetingology> Meeting started Thu Mar 21 21:37:56 2013 UTC. The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
21:37:56 <meetingology>
21:37:56 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
21:38:04 <popey> hows it going m-b-o ?
21:38:28 <m-b-o> well, started finally with the API
21:40:20 * popey checks previous meeting log
21:41:40 <popey> no actions from past meeting
21:41:55 <m-b-o> no
21:42:12 <m-b-o> I would add an item: "Storage"
21:42:47 <popey> ah yes, a perpetual thing that comes up with all the apps
21:43:01 <m-b-o> can LocaleStorage be used?
21:43:08 <popey> sqlite?
21:43:14 <popey> yes, others have used that
21:43:27 <popey> calendar app guys had some issues with performance, but recently worked those out
21:43:33 <popey> with large numbers of events
21:43:46 <popey> I'd imaging the weather app isn't likely to have a huge amount of data to retain though?
21:44:09 <m-b-o> hmm, in the weather app there should not be that much requests against the storage
21:44:13 <m-b-o> yes
21:44:22 <popey> I would expect most people would have between 1 and 10 locations (more likely 1 or 2 - home & work) and only some days/hours of forecast data
21:44:40 <mhall119> so just a heads up, the's a U1DB plugin being written, that will store your data in an sqlite database, but also make it sync over U1 with any other device running the same code
21:45:00 <popey> who's doing the plugin mhall119 ?
21:45:03 <mhall119> kevin wright
21:45:11 <m-b-o> okay. Sync mandatory or optional?
21:45:18 <popey> optional, but desired
21:45:25 <mhall119> it needs to be packaged and put in out PPA, I have a TODO to get that done
21:45:30 <m-b-o> okay
21:45:58 <mhall119> so, don't block on it if you can avoid it, but be aware that it'll be available sometime soon to take advantage of
21:46:21 <mhall119> weather is one of the apps where syncing makes sense
21:46:23 <m-b-o> ok. It can be possible, I'll make a temporary solution unitl the plugin is available
21:46:31 <mhall119> m-b-o: sounds good
21:47:26 <m-b-o> Another question: how will the periodic updates in the background be managed?
21:47:41 <m-b-o> let's say: "update the weather every hour"
21:47:47 <popey> another question I get a lot
21:47:52 <popey> this is currently unknown
21:48:02 <popey> for now we'll have to update on demand until we figure that out
21:48:06 <mhall119> I think QML has the ability to do that, but obviously only while the app is running
21:48:31 <popey> at the moment on the phone, backgrounded apps are suspended
21:48:34 <m-b-o> yes. the weather api stuff is written in JS
21:48:57 <mhall119> popey: ah, I see the problem now
21:50:12 <popey> I think we use SIGSTOP and SIGCONT
21:50:15 <popey> really basic and brutal
21:50:23 <mhall119> ouch
21:50:27 <popey> but sufficient to give a demo at MWC :D
21:50:42 <melnaquib> :D
21:50:51 <popey> hey melnaquib
21:50:54 <m-b-o> hi melnaquib
21:51:15 <popey> mhall119: do we have a meeting with kevin where we discuss system service like this?
21:51:24 <melnaquib> hi everybody, is this ubuntu mob? cuz i thought i saw a SIGSTOP and SIGCONT there
21:51:27 <mhall119> popey: no, but we can and probably should
21:51:39 <mhall119> popey: give me an action to get one scheduled
21:52:10 <popey> #action mhall119 sheduled checkpoint meeting with kevwright to discuss system level stuff (background apps, scheduling etc)
21:52:10 * meetingology mhall119 sheduled checkpoint meeting with kevwright to discuss system level stuff (background apps, scheduling etc)
21:52:11 <melnaquib> can we use webworker wrappers?
21:52:29 <popey> wait a moment while I google what that is ..
21:52:30 <popey> ㋛
21:52:51 <mhall119> from the "web" part of it, I would guess not
21:52:53 <melnaquib> javascript "threads" more or less
21:53:07 <mhall119> melnaquib: probably Qt/QML has their own way of doing it
21:53:16 <popey> i think we want to have a system level common api for this
21:53:19 <mhall119> that uses Qt's threading
21:53:37 <melnaquib> may be under the hood
21:53:37 <mhall119> yeah, there needs to be some way of scheduling wake-ups
21:53:47 <melnaquib> but for javascript, they are the same
21:54:38 <melnaquib> http://harmattan-dev.nokia.com/docs/library/html/qt4/qml-timer.html
21:54:52 <m-b-o> http://qt-project.org/doc/qt-5.0/qtqml/qml-qtquick2-workerscript.html
21:55:26 <mhall119> right, but if we suspend the process when it's not visible, that won't run either
21:56:01 <melnaquib> ah
21:56:12 <popey> hence "brutal" ☺
21:56:23 <mhall119> so we need either an API to tell it not to suspend the process, or a way to schedule a wakeup of the process
21:56:30 <melnaquib> but you can pass the whole webworker to another "app" resopnsoble to run in the background
21:56:36 <popey> or that, yes
21:56:44 <popey> a system level scheduler for running tasks
21:56:49 <popey> a.k.a. cron
21:56:55 <popey> but not cron
21:56:56 <mhall119> yeah, whatever it is, it needs to be created
21:57:14 <popey> I briefly discussed this with kevin earlier this week
21:57:17 <mhall119> ok, we're almost outof time
21:57:20 <popey> we'll discuss further
21:57:24 <popey> yup
21:57:29 <mhall119> is there anything blocking you guys, or that you need us to get you information about?
21:57:55 <m-b-o> what about this jenkins "commit message needed" thing?
21:58:05 <mhall119> oh, that just needs to be added to LP
21:58:19 <mhall119> https://code.launchpad.net/~jakub-a/ubuntu-weather-app/ubuntu-weather-app/+merge/153474 has a "Set Commit Message" link
21:58:30 <mhall119> Jenkins needs that to use when it commits to trunk
21:58:51 <m-b-o> okay, when a review was approved, jenkins will megre it?
21:58:55 <popey> yup
21:58:59 <m-b-o> ah, okay
21:59:00 <mhall119> yep
21:59:21 <mhall119> most of the time the commit message is essentially the change description
22:00:18 <popey> ok, lets call it a wrap
22:00:31 <popey> thanks for coming guys, will update you with any progress via the mailing list
22:00:33 <mhall119> thanks for your work guys, the weather app is looking nice
22:00:39 <melnaquib> @popey, I may need a brief session with you, can I?
22:00:39 <meetingology> melnaquib: Error: "popey," is not a valid command.
22:00:41 <mhall119> can't wait to play with it when it has real data
22:00:49 <popey> sure
22:00:51 <melnaquib> popey, I may need a brief session with you, can I?
22:00:53 <popey> #endmeeting