18:01:06 <popey> #startmeeting Ubuntu Calculator Core App meeting
18:01:06 <meetingology> Meeting started Thu Mar 14 18:01:06 2013 UTC. The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:01:06 <meetingology>
18:01:06 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:01:11 <popey> Who's here for the meeting?
18:01:12 <popey> o/
18:01:19 <daliusd> me
18:01:26 <daliusd> rferrazz, must be here as well
18:02:11 <rferrazz> i'm here!
18:02:15 <rferrazz> just in time
18:02:15 <popey> great!
18:02:18 <popey> ☺
18:02:32 <popey> #topic Review work items and ensure everyone is happy with them and there are no blockers
18:02:46 <popey> I saw some updates to the work items this afternoon..
18:03:05 <popey> https://blueprints.launchpad.net/ubuntu-calculator-app/+spec/initial-calculator-development
18:03:21 <popey> and some updates to the code which I just checked out..
18:03:24 <popey> looking great!
18:03:31 <daliusd> I guess rferrazz even implemented more than it is marked
18:03:41 <daliusd> e.g. Implement "C" is done as well
18:03:58 <rferrazz> don't know what it means
18:04:11 <popey> lets make sure we keep the "DONE" items in the list, so people can see the stuff that's been done. I saw some items removed earlier..
18:04:24 <daliusd> my idea is that "C" button should work
18:04:26 <daliusd> that's it
18:04:32 <daliusd> it was not working before :)
18:04:48 <rferrazz> ah! ok, so we can mark it as DONE
18:05:28 <popey> excellent
18:05:39 <popey> are you guys blocked on anything at the moment?
18:05:48 <daliusd> no we are not
18:05:56 <daliusd> we just need to discuss some little details
18:05:57 <daliusd> Start new calculation (I think "C" should be used for that)
18:06:00 <popey> ok
18:06:01 <daliusd> this one is either DONE
18:06:03 <daliusd> or not
18:06:09 <daliusd> design team proposed
18:06:13 <daliusd> to use swipe up
18:06:21 <daliusd> or maybe swipe up and release
18:06:26 <daliusd> whatever
18:06:27 <popey> as the tear-off?
18:06:37 <daliusd> no
18:06:41 <daliusd> maybe like refresh
18:06:44 <daliusd> in some apps
18:06:57 <daliusd> when you swipe down and release to refresh
18:06:59 <popey> oh as a general purpose gesture?
18:07:23 <daliusd> in any case they are inventing new gesture
18:07:27 <popey> not sure what there is to "refresh" in a calculator?
18:07:38 <daliusd> exactly
18:07:40 <rferrazz> i've tried to acheive that but it's not easy
18:07:40 <daliusd> that's one problem
18:07:44 <popey> perhaps we should raise that with the design team on the call with them tomorrow?
18:07:53 <daliusd> yes we can do that
18:07:56 <daliusd> while C
18:08:09 <daliusd> already does what's necessary
18:08:11 <daliusd> is intuitive
18:08:14 <daliusd> and expected
18:08:16 <popey> yeah
18:08:21 <popey> people know "C"
18:08:28 <popey> gestures are cool though ;)
18:08:34 <daliusd> but let's give design team a chance
18:08:39 <popey> So, i found a couple of bugs...
18:08:48 <popey> http://popey.com/~alan/calc1.png
18:08:53 <popey> don't think it should let me do that
18:09:18 <daliusd> file bug and let us fix it :)
18:09:33 <popey> yeah, will do, only just found it before the meeting started
18:10:03 <daliusd> nice :)
18:10:15 <popey> another interesting one is what happens if you do this sequence... 1 + 2 + + = =
18:10:49 <popey> equals in my mind should always "undo" whatever operator you just pressed
18:11:00 <popey> and just provide the result of the latest calculation
18:11:15 <popey> (my internet connection is a bit wobbly, if I disappear mid sentence, that's why)
18:11:36 <popey> but I'll file a bug about both
18:11:43 <daliusd> most probably that's one bug
18:11:53 <daliusd> but file for both
18:11:55 <rferrazz> popey, do you have the lastest sources? i can't press operators more than one time
18:12:01 <popey> yes
18:12:10 <daliusd> rferrazz, play around with +/- button
18:12:13 <popey> i did a bzr pull at about 5 mins before the meeting
18:12:43 <daliusd> I can reproduce this as well
18:12:50 <popey> 1 + 2 / = =
18:12:51 <daliusd> the trick is to get several + in line
18:12:58 <daliusd> when you can press anything
18:13:00 <rferrazz> ok, i've reproduced the bug!
18:13:04 <popey> \o/
18:13:04 <daliusd> *then you can press anything
18:14:16 <popey> Are we still using localstorage to save frequently? is it still a performance issue?
18:14:29 <rferrazz> we use it on shutdown
18:14:37 <popey> ok.
18:15:18 <popey> What's intended to go on the help/about page?
18:15:28 <daliusd> We have no idea yet :)
18:15:39 <popey> I only discovered it by accident, swiped sideways when i should have clicked
18:15:50 <daliusd> most probably it shouldn't even be tab
18:16:04 <daliusd> most probably page called using toolbar
18:16:06 <popey> I dont think I've eve read the help for a calculator app
18:16:22 <popey> maybe I did when windows 3.0 came out because I had nothing else to run ☺
18:16:29 <daliusd> :D
18:17:10 <rferrazz> we could get rid of tabs too?
18:17:16 <popey> the tabs?
18:17:21 <daliusd> Yes
18:17:25 <daliusd> why not
18:17:30 <daliusd> notepad-qml is not using tabs
18:18:03 <popey> well if there's only one tab..
18:18:28 <popey> I guess traditionally we'd have somewhere to put the copyright message, author names etc
18:18:44 <popey> but that sounds like one for design too ..
18:18:54 <popey> the tab is a bit of a waste of space
18:19:04 <rferrazz> agree!
18:19:16 <daliusd> we can create help button in toolbar
18:19:21 <popey> it's not like you don't know you're in a calculator
18:19:45 <daliusd> or "about"
18:20:02 <ravirdv> hmm I don't think we need about tab
18:20:33 <daliusd> Updated blueprint a little bit
18:20:35 <popey> http://design.canonical.com/2013/03/app-patterns-applied-calculator-key-journeys/
18:20:40 <popey> first one doesn't have a tab
18:21:37 <popey> ok, lets go with no tab and confirm with design for tomorro?
18:21:39 <popey> +w
18:21:47 <daliusd> ok
18:21:53 <rferrazz> ok
18:21:56 <popey> great.
18:21:59 <popey> anything else?
18:22:23 <daliusd> at the moment no
18:22:46 <daliusd> I have at least one idea but don't remember it now :)
18:22:57 <popey> you need a notepad app ;)
18:23:11 <daliusd> it's about location
18:23:27 <ravirdv> interesting..
18:23:32 <daliusd> design contains idea to add location where we have date only now
18:23:34 <popey> getting the location from the device? for tagging calculations?
18:23:43 <daliusd> like @costco
18:23:47 <daliusd> Yes
18:23:53 <daliusd> Design has that :)
18:23:55 <rferrazz> good idea!
18:24:25 <popey> you want to know how we can get the location of the device?
18:24:26 <ravirdv> I haven't seen it on other platforms
18:24:28 <daliusd> question is if device can give us something inteligent
18:24:54 <popey> I'll speak to the SDK guys about it, I have thinking about this myself for other apps
18:25:02 <daliusd> OK
18:25:07 <popey> #action popey speak to SDK about location aware apps
18:25:07 * meetingology popey speak to SDK about location aware apps
18:25:11 <daliusd> that's not the most important thing :)
18:25:15 <ravirdv> popey: any idea when SDK will have official OSX support?
18:25:19 <daliusd> plus it is security issue
18:25:36 <daliusd> e.g. user might not want to have gps turned on for some reasons
18:25:38 <popey> sure, there's a lot of other things to raise around location awareness, I agree.
18:25:51 <popey> but "is it possible to get the location of the device" is a good starter
18:26:22 <daliusd> BTW funny thing that I have something better than notepad :)
18:26:40 <daliusd> I have written TODO service with app for smartphones I have
18:26:49 <popey> nice!
18:26:50 <daliusd> but usually I forget to use it :D
18:26:54 <popey> haha
18:27:20 <popey> the notepad app with the sdk really is a basic demo though..
18:27:31 <popey> ok, we're nearly out of time, anything before I end the meeting?
18:27:44 <daliusd> nothing from me :)
18:27:51 <popey> #action popey speak to SDK team about OSX support
18:27:51 * meetingology popey speak to SDK team about OSX support
18:28:26 <rferrazz> me neither
18:28:31 <popey> (I wouldnt get my hopes up, I'd be surprised if any of our poor impoverished SDK developers could affort shiny Apple hardware ;)
18:28:35 <popey> great!
18:28:42 <popey> thanks guys! awesome work as always!
18:28:44 <popey> #endmeeting