19:03 <mwhudson> #startmeeting Technical Board
19:03 <meetingology> Meeting started at 19:03:38 UTC.  The chair is mwhudson.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:03 <meetingology> Available commands: action, commands, idea, info, link, nick
19:03 <mwhudson> teward: are you here?
19:04 <teward> *beep*
19:04 <teward> yep just was getting my coffee :)
19:04 <mwhudson> we don't have all that much on the agenda but it has been an age since our last meeting so i'm sure there are other things to talk about
19:04 <mwhudson> i guess we get through the agenda first
19:05 <mwhudson> #topic action review
19:05 <mwhudson> #item review revised snapd SRU exception proposal https://github.com/ubuntu/ubuntu-project-docs/pull/542
19:06 <mwhudson> it looks like this is still waiting on a response to Nick's review in _april_
19:06 <mwhudson> i guess i can apply some internal prodding to see if we can get an update
19:06 <seb128> ack and thanks!
19:07 <rbasak> Maybe we could agree to close the PR if it doesn't receive a response?
19:07 <mwhudson> #action michael to prod ernest internally to reply to Nick's comments
19:07 * meetingology michael to prod ernest internally to reply to Nick's comments
19:07 <rbasak> It could always be reopened.
19:08 <mwhudson> rbasak: seems reasonable if no updates by the next time we meet yes
19:09 <mwhudson> #topic Scan the mailing list archive for anything we missed (standing item)
19:10 <mwhudson> there are two mails that i see "Approving the support of Ubuntu suites by the extrepo maintainer", "Key Ubuntu teams should have an open process for new members"
19:11 <mwhudson> i did read the first one but don't really understand it
19:11 <rbasak> I've been working on a reply to the latter. On behalf of myself as one TB/SRU team member, not on behalf of any whole team.
19:12 <rbasak> I don't think the first one is something where it's the place for Ubuntu to agree or disagree to, particularly.
19:12 <mwhudson> yeah but i guess we should reply to say that?
19:13 <rbasak> We also have add-apt-repository which overlaps with extrepo
19:13 <mwhudson> i have also only skimmed the latter i admit. i trust rbasak to have sensible opinions but maybe that's just me ducking my responsibilities
19:14 <rbasak> I'm also not sure about the sibling package that I assume contains trust roots. We get them by default by autosyncing from Debian, but I don't really want to start taking SRUs for them (similar to my opinion in ubuntu-devel@ about some other trust root).
19:15 <mwhudson> i don't think i remember that ubuntu-devel@ thread?
19:15 <rbasak> Oh, and Ubuntu favours snaps of course.
19:15 <mwhudson> but the presence of trust roots in the archive is an interesting topic in general i guess
19:16 <mwhudson> oh this is all about the discussion that lead to https://ubuntu.com/project/docs/tech-board/3rd-party-software-sources/ i guess
19:16 <rbasak> Yes that document is relevant too
19:17 <rbasak> https://lists.ubuntu.com/archives/ubuntu-devel/2024-September/043147.html "Enhancing cross-distro collaboration via foreign archive keyring availability"
19:17 <rbasak> tl;dr: if we're going to SRU trust root updates, I think we need a good way to validate that the new trust roots being proposed for sponsorship/upload are correct.
19:18 <rbasak> And I'm not sure I see the value anyway, since TLS trust roots via ca-certificates should be good enough to bootstrap trust from an external data source which is the one we'd be trusting anyway
19:18 <rbasak> ca-certificates having a well established governence model so we can trust its updates.
19:18 <mwhudson> oh that one, i do remember that
19:20 <mwhudson> all that said i'm not sure i care very much what the extrepo maintainer does
19:20 <mwhudson> maybe i should try to come up with a reply that we can discuss at the next meeting?
19:20 <rbasak> I agree, provided that there are no expectations from the Ubuntu side either (eg. I'm not keen on SRUs for this).
19:20 <rbasak> Please do!
19:21 <mwhudson> yeah i was just looking in debian, it seems that stable updates to extrepo don't really happen there much so i would not expect SRUs
19:21 <mwhudson> #action michael to draft a reply to the mail about extrepo for discussion
19:21 * meetingology michael to draft a reply to the mail about extrepo for discussion
19:21 <mwhudson> #topic Check up on community bugs and techboard bugs (standing item)
19:22 <mwhudson> i don't think there have been any changes to any of these bugs since our last meeting
19:23 <mwhudson> #Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:23 <mwhudson> i think it's rbasak's turn next. teward as backup?
19:24 <seb128> yes
19:24 <rbasak> ack
19:26 <mwhudson> assuming silence is assent from teward...
19:26 <mwhudson> #topic AOB
19:26 <rbasak> Nothing from me. Thanks!
19:26 <mwhudson> nothing from me either
19:27 <seb128> nor from me
19:30 <mwhudson> ok then
19:30 <mwhudson> #endmeeting