19:07 <mwhudson> #startmeeting technical board
19:07 <meetingology> Meeting started at 19:07:07 UTC.  The chair is mwhudson.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:07 <meetingology> Available commands: action, commands, idea, info, link, nick
19:07 <mwhudson> #topic Review snapd SRU exception PR
19:08 <rbasak> I think this is blocked on my question in the MP
19:08 <mwhudson> yeah i am getting pinged by Ernest to ask if we have discussed this yet but he hasn't replied to your question
19:09 <mwhudson> i am behind on TB topics sadly, i haven't read the change properly yet
19:09 <mwhudson> (apart from noting that the existing text is pretty out of date)
19:10 <mwhudson> so yeah. no action required here. i will try to read the MP properly but we are waiting on replies
19:10 <seb128> I think we need the snapd team to reply there. If Ernest pinged you maybe point that out to him
19:10 <mwhudson> i did about 10 minutes
19:10 <mwhudson> ago
19:10 <mwhudson> #topic Review SRU Exception for HWE
19:11 <mwhudson> same kind of thing here? Robie replied on the list
19:11 <rbasak> I replied to the ML
19:11 <rbasak> RIght
19:11 <rbasak> I have written my opinion
19:11 <rbasak> It's up to other TB members now I think to provide theirs
19:11 <mwhudson> ack
19:12 <mwhudson> #action seb, thomas, michael to provide feedback in "RFC: SRU Exception for transitional hardware enablements (tHWE)" thread
19:12 * meetingology seb, thomas, michael to provide feedback in "RFC: SRU Exception for transitional hardware enablements (tHWE)" thread
19:12 <seb128> I expect that to be discussed by some of us in person at the upcoming sprints
19:12 <mwhudson> yes indeed
19:12 <mwhudson> #topic Review PGP key recommentations for Ubuntu Developers
19:12 <mwhudson> we did this i think?
19:12 <seb128> yes, we got quorum and it was merged
19:12 <rbasak> I think that's handled now and the MP landed?
19:13 <seb128> so can be closed
19:13 <mwhudson> woo
19:13 <seb128> :-)
19:13 <mwhudson> #topic Review Ubuntu Flavors proposed specification
19:13 <rbasak> I haven't seen any movement on this following my doc feedback
19:14 <mwhudson> again, i am behind here. but there has been feedback from a variety of people which has not really been acted on in any meaningful way
19:14 <seb128> same for me, I didn't have time to read that one
19:14 <seb128> I see teward also had feedback on the spec
19:15 <mwhudson> so i guess seb and i should catch up but there is not really anything for the TB to have an official opinion on yet
19:15 <rbasak> I have a proposal
19:15 <mwhudson> ok
19:15 <rbasak> Sorry just arranging copy and paste
19:15 <teward> *appears finally*
19:16 <teward> sorry i was in a dead zone in the office, no data and no wifi
19:16 <mwhudson> teward: wb, i don't think we've said anything very controversial so far but is there anything you want to have an opinion on?
19:16 <rbasak> I suggest this (or at least the gist, maybe with some copyediting) as a response from the TB:
19:16 <rbasak> We appreciate efforts to get clarity on expectations on flavours by documenting it, and encourage the relevant teams to continue working on this together.
19:16 <rbasak> One major point of contention seems to be on a requirement to use a particular installer. We haven't seen any justification to require this without the flavours' consent, so we cannot accept or ratify the document as-is.
19:16 <rbasak> Until and unless this is resolved, we consider the status quo to remain in terms of flavour expectations.
19:16 <rbasak> Unless some other justification to require a specific installer is provided, we don't think TB involvement or intervention is appropriate here. Any change to the status quo still requires consent from the flavours.
19:17 <teward> so, it's my understanding that Canonical is waiting for us to review and CC to review (CC already happened) and then hand it back saying "we need these things addressed"
19:17 <teward> i do agree with rbasak here
19:17 <rbasak> Maybe s/any justification/sufficient justification/ because there is one in the doc; I just don't think it's relevant.
19:17 <teward> and i want to remind the TB that this has been an issue for > 1yr since the "standardized installer" question came up in end of 2024, and was raised as a CC level issue (when it wasn't really)
19:17 <rbasak> I don't see this as an "issue" FWIW. It's a change request.
19:18 <rbasak> The flavours said no, AIUI, and while nobody has formally escalated it to the TB, I think it would help with progress to provide the above response.
19:18 <seb128> I though we got an agreement during the previous discussion and everyone was happy with the outcome?
19:19 <mwhudson> it is my understanding that (non-subiquity) installer issues were a pain for the release team again this cycle but i feel like this is a behaviour issue rather than a choice of technology issue. but i do need to read the spec
19:19 <seb128> I'm fine with the suggested reply rbasak just shared
19:19 <mwhudson> i suspect i'll be fine with it once i've actually read the document :-)
19:20 <mwhudson> rbasak: are you ok to wait for me for say 48 hours before replying with that content?
19:20 <seb128> I think it's fine for flavors to have their own installer, what is not fine is for them to not have resources/maintainers to deal with their installer and create release issues
19:21 <mwhudson> seb128: right that's my general feeling too
19:21 <teward> which will bring me to another issue i want us to consider in a later item
19:21 <teward> but i agree, the problem isn't needing a unified installer, it's needing resources/maintainers
19:21 <rbasak> If the release team are facing pain, then they need to address that with the relevant Ubuntu developers and figure out how to fix it. If they can't, and objective and specific concerns are raised to the TB, then we can best decide how tackle that. Without those specifics, deciding that the solution is for the flavours to change installer is inappropriately jumping to conclusions (if that argument
19:21 <rbasak> is even being made).
19:21 <mwhudson> i guess we should come up with some #action here
19:21 <teward> rbasak: it's my understanding this is coming from Canonical not the Release Team.
19:22 <seb128> is there anyone left in RT who isn't Canonical?
19:22 <rbasak> mwhudson: 48 hours> yes, sure. Since we have +3, how about we agree that I'll post that as the official TB response unless you reply to us (privately if you need) with any concerns, so we can reconsider?
19:22 <teward> well i mean, it came **originally** as an action item from one of Canonical's internal teams, not with the Release Team hats on
19:22 <mwhudson> rbasak: sure
19:23 <rbasak> teward: I don't think it matters where it's coming from. I'm considering the request objectively without regard to that.
19:23 <teward> ack
19:23 <teward> *sips coffee*
19:23 <mwhudson> #action rbasak to reply to Mauro in 48 hours unless mwhudson objects
19:23 * meetingology rbasak to reply to Mauro in 48 hours unless mwhudson objects
19:23 <mwhudson> anything else on this for now?
19:23 <rbasak> _after_ 48 hours, please :)
19:23 <mwhudson> heh ok
19:24 <mwhudson> #undo
19:24 <meetingology> Removing item from minutes: ACTION
19:24 <mwhudson> #action rbasak to reply to Mauro after 48 hours unless mwhudson objects
19:24 * meetingology rbasak to reply to Mauro after 48 hours unless mwhudson objects
19:24 <mwhudson> #topic Action review
19:25 <mwhudson> #subtopic teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (carried over)
19:25 <mwhudson> teward: any news here?
19:25 <teward> still nothing there
19:25 <teward> unfortunately
19:25 <mwhudson> #action teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (carried over)
19:25 * meetingology teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (carried over)
19:25 <mwhudson> #topic Scan the mailing list archive for anything we missed (standing item)
19:26 <mwhudson> the only one i see that we haven't covered already is the one about unity
19:26 <seb128> right
19:26 <rbasak> I don't think it's a matter for the TB
19:26 <mwhudson> i think we are going to hear something from the release team soon on this topic, i don't know that this is something for us to talk about
19:27 <rbasak> We're not in a position to provide resources to get things done.
19:27 <rbasak> The only thing we might do is disqualify a flavour for failing to meet some expectations, but that's not the request
19:27 <rbasak> We can provide encouragement of course, but nothing along those lines is proposed
19:28 <rbasak> All of this was already covered effectively in Discourse, but perhaps we should reply with TB authority since the TB was asked
19:28 <mwhudson> i don't know that we need to reply to this specific mail. if someone else wants to, i'm not going to object
19:29 <rbasak> I don't think it's a good look to leave it unanswered
19:29 <mwhudson> ok.
19:29 <rbasak> Sounds like I volunteered :-/
19:30 <mwhudson> who is it then? :) do we play paper scissors rock
19:30 <mwhudson> i can write something to take the load off robie as board comms person
19:30 <rbasak> I don't mind
19:31 <rbasak> If everyone is happy for me to speak for the TB as I describe above without further review?
19:32 <mwhudson> rbasak: i am happy with that
19:32 <seb128> I'm happy with it but I share mwhudson's opinion that we should try to not let you do most of the communication
19:33 <seb128> I mean load balancing between members would be nicer
19:34 <mwhudson> i guess thats +3, enough for something of this importanc
19:34 <mwhudson> #action rbasak to reply to mail about unity flavour on mailing list
19:34 * meetingology rbasak to reply to mail about unity flavour on mailing list
19:34 <mwhudson> #topic Check up on community bugs and techboard bugs (standing item)
19:34 <mwhudson> i don't see any recent activity
19:36 <mwhudson> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:37 <mwhudson> so it looks like there will not be a meeting on the 4th as Seb and I are at a canonical event
19:37 <mwhudson> i propose teward as chair for the meeting on the 18th with ... robie as backup?
19:38 <seb128> +1
19:38 <teward> +1
19:38 <rbasak> +1
19:38 <mwhudson> #action teward to chair meeting on 2025-11-18 with rbasak as backup
19:38 * meetingology teward to chair meeting on 2025-11-18 with rbasak as backup
19:39 <mwhudson> the meeting times should be fine for me for the next while
19:39 <mwhudson> #topic AOB
19:39 <mwhudson> i don't think i have anything
19:40 <mwhudson> teward, seb128, rbasak: anything from you?
19:41 <rbasak> Nothing from me thanks
19:41 <teward> nope
19:41 <seb128> not from me
19:42 <mwhudson> ok we are done then
19:42 <mwhudson> #endmeeting