#ubuntu-meeting: Technical Board meeting

Meeting started by teward at 19:01:47 UTC (full logs)

Meeting summary

  1. Action review (teward, 19:02)
    1. mwhudson to catch up on the previous riscv64 "official status" discussion and then drive it forward as needed (teward, 19:02)
      1. https://paste.ubuntu.com/p/Jc4WgqRCNM/ (mwhudson, 19:03)
      2. summary: 1. the flag is cosmetic only 2. it's up to us to decide what it means 3. the release team is in favour of setting it for riscv (teward, 19:05)
      3. 4. the only reason not to set it is that security updates in some situations might be delayed (teward, 19:05)
      4. 5. mdeslaur (security team) is ok with it being set despite that (teward, 19:05)
      5. VOTE: Define 'official' arch flag as: "The release team considers the quality of support to meet both user and developer expectations, in agreement with the Security team." (Carried) (teward, 19:10)
      6. VOTE: Actual vote: Define 'official' arch flag as: "The release team considers the quality of support to meet both user and developer expectations, in agreement with the Security team." (Carried) (teward, 19:11)
      7. ACTION: rbasak to follow up on ML thread regarding riscv64 'official' status / TB definition of what the 'official' designation/flag means. (teward, 19:14)
      8. AGREED: The "Official" flag for riscv64 applies for Questing release and forward (teward, 19:18)
      9. ACTION: rbasak to follow up in ML thread on "official" flag and riscv64 official status (teward, 19:19)
      10. ACTION: mwhudson to handle RT ticket to IS to set riscv64 status as official for Questing onward (teward, 19:21)
      11. teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (teward, 19:22)
      12. ACTION: teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (carried over) (teward, 19:22)
      13. teward to write up a proposal for how the move away from the wiki will work (teward, 19:22)
      14. ACTION: teward to write up a proposal for how the move away from the wiki will work (carried over) (teward, 19:22)
      15. seb128 to contact release team about official status of riscv64 (teward, 19:23)
      16. seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations (teward, 19:23)
      17. ACTION: seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations (teward, 19:23)

  2. utkarsh2102 - FFe for new packages (mwhudson) (teward, 19:23)
    1. https://wiki.ubuntu.com/FreezeExceptionProcess#FeatureFreeze_for_new_packages (utkarsh2102, 19:25)
    2. AGREED: TB agrees that the Release Team has the purview to adjust the definition of Feature Freeze and any such FF Exception rules accordingly, and TB does not need to define a policy or intervene unless directly escalated to. (teward, 19:34)

  3. Scan the mailing list archive for anything we missed (standing item) (teward, 19:34)

  4. Check up on community bugs and techboard bugs (standing item) (teward, 19:36)

  5. Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members) (teward, 19:38)

  6. AOB (teward, 19:41)

  7. what are the rules about what can go into multiverse (mwhudson) (teward, 19:42)
    1. https://git.launchpad.net/ubuntu/+source/ubuntu-policy/tree/policy.sgml#n607 is the original policy and status quo, I think (rbasak, 19:42)

  8. "what is a flavour" and installers (mwhudson) (teward, 19:49)
    1. https://wiki.ubuntu.com/RecognizedFlavors (rbasak, 19:51)
    2. https://wiki.ubuntu.com/RecognizedFlavors/AddingNew (rbasak, 19:51)
    3. https://wiki.ubuntu.com/RecognizedFlavors/NewFlavorProcess (rbasak, 19:51)

  9. AOB (again) (teward, 19:55)


Meeting ended at 19:57:34 UTC (full logs)

Action items

  1. rbasak to follow up on ML thread regarding riscv64 'official' status / TB definition of what the 'official' designation/flag means.
  2. rbasak to follow up in ML thread on "official" flag and riscv64 official status
  3. mwhudson to handle RT ticket to IS to set riscv64 status as official for Questing onward
  4. teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (carried over)
  5. teward to write up a proposal for how the move away from the wiki will work (carried over)
  6. seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations


Action items, by person

  1. mwhudson
    1. mwhudson to handle RT ticket to IS to set riscv64 status as official for Questing onward
  2. rbasak
    1. rbasak to follow up on ML thread regarding riscv64 'official' status / TB definition of what the 'official' designation/flag means.
    2. rbasak to follow up in ML thread on "official" flag and riscv64 official status
  3. teward
    1. teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (carried over)
    2. teward to write up a proposal for how the move away from the wiki will work (carried over)
  4. UNASSIGNED
    1. seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations


People present (lines said)

  1. teward (150)
  2. mwhudson (67)
  3. rbasak (59)
  4. utkarsh2102 (25)
  5. meetingology (23)


Generated by MeetBot 0.4.0