19:06 <rbasak> #startmeeting Technical Board
19:06 <meetingology> Meeting started at 19:06:48 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:06 <meetingology> Available commands: action, commands, idea, info, link, nick
19:07 <rbasak> #topic Action review
19:07 * rbasak seb128 to contact release team about official status of riscv64
19:07 <rbasak> I guess we carry that over
19:07 <rbasak> #action seb128 to contact release team about official status of riscv64
19:07 * meetingology seb128 to contact release team about official status of riscv64
19:07 * rbasak rbasak to draft a response to merlijn's email thread about the OSAID for review
19:07 <rbasak> This is done
19:07 * rbasak rbasak to reply to the release team and clarify the LTS flavor delegation process
19:07 <rbasak> Done, though the release team hasn't yet replied on my process/documentation question
19:07 * rbasak seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
19:07 <rbasak> Carry over I guess?
19:07 <rbasak> #action seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
19:07 * meetingology seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
19:08 * rbasak teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC
19:08 <rbasak> teward: any progress on this, please?
19:08 * rbasak teward to write up a proposal for how the move away from the wiki will work
19:08 <rbasak> teward: ^ also this
19:08 * rbasak rbasak to proposed https://paste.ubuntu.com/p/ZrTXdHhM3P/ or a lightly edited version as the policy on DMB staffing
19:08 <rbasak> This is done and documented
19:08 <teward> Carry over both.
19:08 <rbasak> #action teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC
19:08 * meetingology teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC
19:08 <rbasak> #action teward to write up a proposal for how the move away from the wiki will work
19:08 * meetingology teward to write up a proposal for how the move away from the wiki will work
19:09 <rbasak> #topic Scan the mailing list archive for anything we missed (standing item)
19:09 <mwhudson> i don't think there is anything
19:09 <teward> My larger task at the MOMENT has been the meetingology replacement.  The chaos from Earlier(TM) has left us without the matrix meetingology that someone I will not mention had created.
19:09 <rbasak> I don't see anything either
19:09 <teward> Oh i have an FYI for us btw
19:09 <rbasak> #info No recent ML activity that requires follow-up
19:10 <rbasak> #topic Check up on community bugs and techboard bugs (standing item)
19:10 <rbasak> #info No open community bugs
19:10 <mwhudson> i think we are actually progressing on https://bugs.launchpad.net/techboard/+bug/2015921 in some ways?
19:11 <rbasak> #info No new techboard bugs
19:11 <rbasak> I'm not sure we have a good answer yet, but it isn't a problem currently.
19:11 <mwhudson> agreed
19:11 <rbasak> We appointed new DMB members and have a process for that now
19:11 <teward> Agreed
19:11 <rbasak> That bug is more about what to do when there are absentee DMB members.
19:12 <rbasak> Some of the bugs could do with catching up with current status and recent discussion, if someone would like to do that?
19:13 <rbasak> But apart from documentation in the bugs I don't think there's any action needed from the TB righ tnow
19:13 <rbasak> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:13 <teward> 100% me
19:13 <mwhudson> there is also the 'Consider marking riscv64 architecture "official"' topic that we ran out of time discussing at some point, i don't know if we wnat to talk about it now
19:13 <teward> For next
19:13 <mwhudson> i can be back up
19:14 <rbasak> #info The next chair will be teward with mwhudson as back up
19:14 <rbasak> Thanks!
19:15 <mwhudson> i have a couple of topics, more for information than discussion (he says optimistically)
19:15 <teward> mwhudson: given the issues with builders slowness and such, etc. And the massive massive backlog of builds, I dont think we can move forward on that effectively at the moment? (RE: riscv official status)
19:15 <rbasak> IIRC the last time we discussed riscv64, we agreed that the release team should set a quality bar but then leave it to them to make a recommendation, or something like that? I'm not sure if I have the details right.
19:15 <rbasak> #topic AOB
19:16 <teward> rbasak: i seem to remember thats where we left off
19:16 <mwhudson> maybe i should try to summarize where we were and raise this properly in the next meeting
19:17 <mwhudson> i don't want to just rehash things
19:17 <rbasak> Sounds good - thanks!
19:17 <teward> mwhudson: i think that would work. Make that a specific action item
19:17 <rbasak> #action mwhudson to catch up on the previous riscv64 "official status" discussion and then drive it forward as needed
19:17 * meetingology mwhudson to catch up on the previous riscv64 "official status" discussion and then drive it forward as needed
19:18 <rbasak> mwhudson: you said you had a couple of other AOB items?
19:18 <rbasak> teward: you too?
19:18 <mwhudson> for this meeting, topic 1: there has been some discussion about hardware specific kernels only being in specific LTS releases and such. one of the relevant teams at canonical has made a document to try to explore this topic and maybe propose a way forward
19:19 <mwhudson> i only got the document a few hours ago though and i've been asleep for 90% of that time so nothing really to talk about, just that there is some stuff going on
19:19 <rbasak> Good to know they're driving this - thanks! I'll wait to see the document then I guess?
19:19 <mwhudson> the other topic is about the ubuntu project documentation and moving the techboard documentation into that
19:20 <mwhudson> the plan is to limit change to the techboard docs via CODEOWNERS (as was doing for AA documentation)
19:20 <mwhudson> e.g. https://github.com/ubuntu/ubuntu-project-docs/blob/main/.github/CODEOWNERS
19:20 <rbasak> I'd like to see some kind of agreed sign-off system
19:20 <rbasak> Maybe signed tags or something?
19:21 <rbasak> Since otherwise _who_ signed off on a change will become lost to time (or the next migration to somewhere else)
19:22 <mwhudson> i think robert should email the list about this. i'll send that comment back to him for now
19:22 <rbasak> Thanks!
19:22 <teward> just an fyi about things, there are known issues with the email systems and ubuntu email aliases - things are being looked at but the hiccup seems to be at Canonical. They know about it but its been several weeks without a fix.  Just so everyone knows if they use their ubuntu aliases and arent getting messages.
19:22 <teward> Thats just a general notice for awareness.  Nothing actionable by TB
19:23 <teward> But its having massive impact on bug notices, lists, etc. Going to people
19:23 <rbasak> OK thanks
19:23 <rbasak> Anything further to discuss?
19:24 <teward> I dont have anythjng, nope.
19:24 <teward> anything*
19:24 <mwhudson> nothing from me
19:24 <rbasak> #endmeeting