15:33 <lvoytek> #startmeeting Developer Membership Board
15:33 <meetingology> Meeting started at 15:33:24 UTC.  The chair is lvoytek.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:33 <meetingology> Available commands: action, commands, idea, info, link, nick
15:34 <lvoytek> Welcome RikMills!
15:34 <RikMills> Hi :)
15:35 <lvoytek> #topic Ubuntu Core Developer application for Rik Mills
15:35 <lvoytek> #link https://wiki.ubuntu.com/RikMills/CoreDevApplication
15:36 <RikMills> If the wiki decides not to work for people it is also here in a couple of formats https://people.ubuntu.com/~rikmills/coredevapp/
15:38 <cpaelzer> Tanks, sorry for the relog
15:38 <cpaelzer> I can ask one, simple tech question to start
15:38 <cpaelzer> Let me ask about one of the mechanisms that you seem to know,
15:38 <cpaelzer> can you explain how your upload https://launchpad.net/ubuntu/+source/lto-disabled-list/61 works.
15:38 <cpaelzer> Changing from delta to lto-disables is clear, but please tell me what LTO has to do with the symbols files?
15:39 <cpaelzer> up to you, my copy and paste is done :-)
15:41 <RikMills> I will admit that my technical in depth knowlege is perhap a little lacking there. It is something on a long list of things to dig in to when time allows
15:41 <RikMills> I do know very clear from experience that is some cases visibiliy of symbols is affected by LTO
15:42 <cpaelzer> well, sad but at least you are honest and aware about shortcomings. I thought this would have been a great starting case as you uploaded it, didn#t want to set you up. Next question?
15:43 <cpaelzer> You recently did a merge of fontconfig in https://launchpad.net/ubuntu/+source/fontconfig/2.15.0-2.3ubuntu1
15:43 <cpaelzer> Did you coordinate that with anyone else, should you?
15:43 <cpaelzer> I'm aware that this is more a social question, but I'm curious how you think about it.
15:43 <cpaelzer> there is no right or wrong here, but a lot of insight in how you work
15:43 <cpaelzer> that is the question - up to you
15:44 <RikMills> I talked to graham first, saying that at the very least we need to do a NRC, and would he like me to do the merge at the same time
15:44 <RikMills> NCR
15:44 <RikMills> he was collating: https://wiki.debian.org/ToolChain/IEEELongDouble
15:45 <cpaelzer> ok, toolchain option kind-of-but-not-transition it is - sufficient for me
15:45 <cpaelzer> thanks
15:46 <cpaelzer> I'll go for the next while the others re-word their questions
15:46 <cpaelzer> No doubt you are Kubuntu and due to that demonstrated multiple times deep insightin uploads and e.g. the release process as well as in interactions with the AA team.I'm not challenging the ability to do of that for sure,due to that I was mostly looking into the motivation, your self-reflection andwhat you plan to do with it.
15:46 <cpaelzer> But sadly application sections "Things I could do better", "Plans for the future","General" and "What I like least in Ubuntu" in the applcation were empty :-/So not much on self reflection or plans to pick up from there.
15:46 <cpaelzer> All I got was from the intro at the top "I'd like to eliminate delays in gettingmy work sponsored." and "I'd like to reduce the burden on my sponsors."
15:46 <cpaelzer> But with almost all of the "uploads to be proud" being "K*" and that beingcovered by MOTU already I wondered what else you'd expect to go for.Data only gave me very few
15:46 <cpaelzer> #link https://udd.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=&sponsor_search=name&sponsoree=*Rik+Mills*&sponsoree_search=name
15:47 <cpaelzer> - All the sponsoring until you got MOTU in 2019
15:47 <cpaelzer> - A huge block updating qt in jammy via SRUs
15:47 <cpaelzer> - And recently a few sponsorships for lto, flac, snapd-glib and fontconfig
15:47 <cpaelzer> So I need to ask here:
15:47 <cpaelzer> "What is it that you expect to use these powers for?"
15:47 <cpaelzer> "In that case when would you use the core-dev powers and when would you still ask for a reviewer or sponsor?"
15:47 <utkarsh2102> just fyi, i'm here but will be fully here in 13
15:47 <cpaelzer> enough text, up to you RikMills
15:47 <cpaelzer> (it might be obvious by now that I prepared for this)
15:48 <RikMills> I hadn't guessed :P
15:49 <RikMills> I certainly want to contribute more on the Ubuntu side in general
15:50 <RikMills> core dev would allow me to do that
15:50 <cpaelzer> anything in particular due to your interest?
15:50 <cpaelzer> or any area you'd not want to touch because $reason?
15:51 <RikMills> I have quite frequently run up against permissions in cases such as triggering tests
15:51 <lvoytek> Are there any packages in main that you would like to work on?
15:52 <RikMills> snapd-glib is obviously important to us
15:52 <cpaelzer> yep, we've seen these in the recent sponsoring
15:53 <RikMills> I would actually like to get more involved in actual Ubunru desktop
15:54 <RikMills> also there is simply the fundamental issue that having a very active flavour dev as core dev helps all us flavours
15:54 <juliank> how would you go about an apt bug?
15:54 <RikMills> we all depend on the core base after all
15:54 <RikMills> juliank: probably talk to you in the first case :)
15:55 <cpaelzer> passed :-P
15:55 <cpaelzer> yeah, I feel we would go in circles - next q please
15:55 <cpaelzer> (not in a bad way)
15:55 <athos> In your latest commit to the hints-ubuntu repository, there is a massive list of packages being hinted for the Qt 6.8.3 transition.
15:55 <athos> How do you come up with that list? What those hints accomplish during your transition?
15:57 <RikMills> athos: the list of packages are all the ones require to migrate together to allow the transition to complete
15:58 <RikMills> e.g. such as those for the 6.9.1 transition in preparation
15:58 <RikMills> https://ubuntu-archive-team.ubuntu.com/transitions/html/qt6-abi-6.9.1.html#!good,bad,partial,unknown,!notintesting
15:58 <athos> so, you use ben's output to come up with the list?
16:00 <RikMills> athos: initially at least, though it would need to be modified to list current versions in proposed
16:00 <RikMills> and updated if those change for some reason
16:01 <RikMills> plus I would of course look at the britney outpus to see if anything else needed adding
16:01 <RikMills> *output
16:02 <RikMills> transitions get entangled etc
16:02 <bdrung> RikMills, do you plan to do sponsoring?
16:02 <athos> Thanks, RikMills!
16:03 <RikMills> bdrung: eventually I would. I would ease myself into that very gently with a great deal of caution
16:03 <bdrung> RikMills, what kind of caution would you apply to main packages compared to universe packages?
16:06 <RikMills> bdrung: main will usually have some team or person with responsibility for that package, so I would also be checking with them whether something looks sane fit with any plans that might exist
16:06 <RikMills> *and fits with
16:08 <bdrung> thanks
16:09 <bdrung> RikMills, would you do a NCR for packages in main without asking first?
16:10 <RikMills> certainly not at first!
16:11 <RikMills> I would be mindful that even a NCR can have some consequences
16:12 <bdrung> okay. Probably most core-devs would just do NCR upload (unless they except those upload to cause huge amount of autopkgtest runs)
16:12 <RikMills> people may be holding back as not to entagnle two transitions for example
16:12 <bdrung> RikMills, can you give an example what those consequences could be?
16:12 <RikMills> I just did
16:13 <bdrung> race condition between question and answer. :D
16:14 <lvoytek> Any other questions for RikMills?
16:14 <bdrung> RikMills, what is the worst thing an upload to main can cause?
16:14 <RikMills> bdrung: on the the issue of most core devs would JFDI, then maybe I may come to that point. but I would certainly be cautious for some time
16:15 <RikMills> bdrung: in my mind it would be breakage/harm to users that somehow goes under the radar and sneaks into a release
16:16 <bdrung> RikMills, what can we do to prevent such an scenario?
16:17 <RikMills> bdrung: work together. talk to each other. be aware of what others are doing and how what you do may have an impact
16:18 <RikMills> if in any doubt ask someone with more knowledge or a wider perspective
16:18 <bdrung> communication is key.
16:19 <RikMills> indeed
16:19 <bdrung> Did you answer reflect past experience?
16:20 <bdrung> I.e. do you have an example that demonstrates your point?
16:21 <RikMills> well, someone did land last minute untested changes to calamares settings literall a few days before plucky release
16:22 <RikMills> *literally
16:22 <cpaelzer> I remember ...
16:22 <RikMills> that deviatig for the norm of proposing changes, getting testing etc caused a great deal of stress
16:23 <bdrung> thanks.
16:24 <bdrung> That answered my questions.
16:24 <lvoytek> Everyone ready to vote?
16:24 <cpaelzer> utkarsh2102: maybe around and having a question too by now?
16:24 <bdrung> To catch breakage before hitting the users, we could add tests and autopkgtests
16:25 <RikMills> indeed
16:25 <bdrung> (more tests are better, but we will never cover 100%)
16:25 <bdrung> (the more tests we have the higher the confidence when uploading a change)
16:27 * juliank is reading
16:27 <cpaelzer> I've re-read the content that happened since I was distracted - I'd be ready to vote
16:27 <juliank> but you may proceed with the vote
16:27 <RikMills> the test gating in Ubuntu certainly gives me some confidence that I lack with some other distro
16:28 <lvoytek> #vote Grant RikMills Core Dev rights
16:28 <meetingology> Please vote on: Grant RikMills Core Dev rights
16:28 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:28 <RikMills> though not complacency
16:28 <juliank> +1
16:28 <meetingology> +1 received from juliank
16:28 <lvoytek> +1 I see a lot of great packaging work in the past, and forsee even more great packaging work in the future
16:28 <meetingology> +1 I see a lot of great packaging work in the past, and forsee even more great packaging work in the future received from lvoytek
16:29 <cpaelzer> +1 but please keep continue to be aware of the areas you do not know (and grow to learn about them)
16:29 <meetingology> +1 but please keep continue to be aware of the areas you do not know (and grow to learn about them) received from cpaelzer
16:29 <bdrung> +1 You have a long history of contribution
16:29 <meetingology> +1 You have a long history of contribution received from bdrung
16:30 <athos> +1; I was indeed surprised when I realized RikMills was not a core-dev yet. For the records, since people do refer to these logs later, the application wiki page could contain more links to your work to make it easier for us to check all the great work you have been doing
16:30 <meetingology> +1; I was indeed surprised when I realized RikMills was not a core-dev yet. For the records, since people do refer to these logs later, the application wiki page could contain more links to your work to make it easier for us to check all the great work you have been doing received from athos
16:32 <utkarsh2102> +1
16:32 <meetingology> +1 received from utkarsh2102
16:32 <lvoytek> #endvote
16:32 <meetingology> Voting ended on: Grant RikMills Core Dev rights
16:32 <meetingology> Votes for: 6, Votes against: 0, Abstentions: 0
16:32 <meetingology> Motion carried
16:32 <lvoytek> Congrats!
16:32 <juliank> congratulations RikMills
16:32 <utkarsh2102> \o/
16:32 <utkarsh2102> finally!!!
16:32 <RikMills> Thank you all. I have always treated the powers I got with MOTU with respect. I will make sure I raise that standard higher if I can with core-dev
16:32 <bdrung> congrats RikMills!
16:32 <lvoytek> #action juliank to announce RikMills' successful application
16:32 * meetingology juliank to announce RikMills' successful application
16:33 <athos> congrats!
16:33 <lvoytek> #action juliank to make ACL changes for RikMills
16:33 * meetingology juliank to make ACL changes for RikMills
16:33 <lvoytek> #topic AOB
16:33 <lvoytek> AOB?
16:33 <lvoytek> None afaik
16:36 <lvoytek> That should be all lol. Congrats again RikMills
16:36 <lvoytek> #endmeeting