19:03 <tsimonq2> #startmeeting Developer Membership Board
19:03 <meetingology> Meeting started at 19:03:11 UTC.  The chair is tsimonq2.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:03 <meetingology> Available commands: action, commands, idea, info, link, nick
19:03 <tsimonq2> #topic Review of previous action items
19:03 <tsimonq2> #action teward to resolve the wiki / Discourse process ambiguity (carried over)
19:03 * meetingology teward to resolve the wiki / Discourse process ambiguity (carried over)
19:04 <tsimonq2> #topic Application Review
19:04 <tsimonq2> #subtopic Ubuntu MOTU Application by Pushkar Kulkarni
19:04 <pushkarnk> Hey, this is my MOTU application https://wiki.ubuntu.com/pushkarnk/MOTUApplication
19:05 <pushkarnk> I am Pushkar Kulkarni. I am with the Foundation team in Canonical, since June 2023. I have been making contributions to Ubuntu since July 2023.
19:05 <pushkarnk> Foundations*
19:05 <rbasak> Hello!
19:06 <rbasak> pushkarnk: are you active on IRC at all, or Matrix now? Searching back on IRC logs, I can barely see any communication from you, going back all the way to April last year.
19:06 <tsimonq2> pushkarnk: What are some examples of a package you have uploaded to source NEW, or otherwise overhauled, besides OpenJDK packaging?
19:07 <tsimonq2> s/you have uploaded/you have had sponsored/
19:07 <pushkarnk> rbasak: I used to be on IRC during my +1 shifts. With the movement to Matrix, I have found it easier to follow conversations.
19:08 <rbasak> pushkarnk: you're a Canonical employee, right? It's a requirement within Canonical that you are available on IRC during your entire working day.
19:08 <pushkarnk> tsimonq2: Besides openjdk-crac the third other NEW package is crac-criu. This was based on criu, but has a different upstream.
19:08 <rbasak> (or now Matrix, of course)
19:08 <rbasak> pushkarnk: but it doesn't look like you participate in realtime Ubuntu development discussions at all, really?
19:09 <pushkarnk> rbasak: Yes, I do log in. But yes, I am not active in discussions as yet.
19:10 <rbasak> pushkarnk: any other discussions elsewhere that I'm missing? I see a couple of +1 maintenance reports only.
19:11 <pushkarnk> Yes, my discussions on ubuntu-devel (mailing list) have been in the context of my +1 shifts and reports.
19:11 <pushkarnk> On Ubuntu Discourse too, but in the context of +1 only.
19:11 <tsimonq2> pushkarnk: For MOTU, we're expecting a wide range of experience with packages in Universe and providing substantive fixes, yet many of the uploads I'm seeing on the UDD report for you seem to be minor; environment variable additions, segfault fixes, and of course the OpenJDK work (I'll get to that). Do you have any strong examples, besides crac-criu, that you're proud of WRT a fix? I may not have
19:11 <tsimonq2> looked closely enough and would like to give you the benefit of the doubt.
19:12 <pushkarnk> tsimonq2: https://launchpad.net/bugs/2072516 is one
19:13 <pushkarnk> valgrind is another https://launchpad.net/bugs/2078264
19:14 <pushkarnk> I'd say https://launchpad.net/bugs/2071358 is a third
19:15 <rbasak> pushkarnk: your endorsement from Athos says: "Pushkar helped with the ruby 3.3 transition while I was on a patch pilot shift. He was able to identify two specific, recurrent issue with backward compatibility and fixed most (if not all) affected packages" -> where did this collaboration happen? Was it in public?
19:15 <pushkarnk> In OpenJDK, something I proud of was fixed in Debian: https://salsa.debian.org/openjdk-team/openjdk/-/merge_requests/115 tsimonq2
19:16 <pushkarnk> rbasak: This happened during a +1 shift in the oracular cycle, through LP
19:16 <tsimonq2> pushkarnk: While fixing FTBFS issues and working around test failures is part of what a MOTU does, I'm looking for something a bit deeper than that (although that last link is solid.) Anyway, let's move onto the next question I have, I don't want to dwell on that for too long.
19:16 <tsimonq2> pushkarnk: Is there a particular reason you didn't go for OpenJDK PPU first, given your work there?
19:17 <pushkarnk> tsimonq2: most of the OpenJDK work (apart from openjdk-lts) happens in Debian. We try to not maintain any Ubuntu delta.
19:18 <tsimonq2> pushkarnk: Okay, that makes sense. Thanks.
19:19 <rbasak> pushkarnk: how do you understand how Ubuntu package maintenance works wrt. teams?
19:19 <rbasak> pushkarnk: for example at https://git.launchpad.net/ubuntu/+source/crac-criu/tree/debian/control#n4 you've listed yourself as the sole maintainer
19:19 <rbasak> How do you see that working in practice?
19:20 <pushkarnk> rbasak: crac-criu is a unique situation. Let me explain.
19:20 <tsimonq2> pushkarnk: In your endorsement from Lukas, he mentions: "Furthermore, he should be mindful about tiny oversights that might slip into uploads, like slightly wrong version strings or typos in debian/changelog. The aforementioned tools can help with that!" - could you please give an example of an upload that needed work, and how you improved on subsequent uploads? Alternatively, everyone makes
19:20 <tsimonq2> mistakes, including me and Robie, occasionally. Is there a mistake you find yourself making more than others, or a topic that's particularly difficult to grasp, more than othersa?
19:22 <pushkarnk> rbasak: The openjdk crac projects maintains a large delta on top of an old release of criu. My first proposal was to vendor it into the openjdk-17/-21 crac packages. But due to reluctance of maintainers, which is justified, we had to create our own upstream. The openjdk upstream hasn't been under maintenance for over a year now.
19:24 <rbasak> (not really a question for Pushkar) How did https://launchpad.net/ubuntu/+source/gdb/16.2-1ubuntu1 get uploaded by Pushkar without a sponsor showing? Did someone sponsor this?
19:24 <pushkarnk> tsimonq2: about mistakes, I have mostly done mistakes related to typos in the early days - which can be serious enough, of course! I do some self-reviews before pushing code now
19:24 <tsimonq2> Copied from ubuntu plucky in test-ppa by Pushkar Kulkarni (sponsored by Matthias Klose)
19:24 <rbasak> Ah thanks
19:25 <pushkarnk> rbasak: right, that was uploaded by Matthias
19:25 <rbasak> Is there any review feedback visible?
19:25 <rbasak> pushkarnk: what was the process you used to prepare that merge prior to upload to the PPA, please?
19:25 <bdrung> \o I am here physically, but do not feel well. So I will leave most of the questioning to the other DMB members.
19:25 <tsimonq2> rbasak: Not on the LP end, unless there's a bug attached (d_oko just used copy-package -b here)
19:25 <rbasak> And a gdb is a significant piece of work. Why isn't there any comment from doko on your application?
19:27 <pushkarnk> rbasak: I use the git ubuntu process to do the merge, and of course manually resolve conflicts. Is there anything more to your question here?
19:27 <rbasak> I didn't mean to imply that you're doing anything wrong necessarily there.
19:28 <rbasak> But to judge your application, I'd like to see review feedback given, and relevant endorsements. Otherwise I don't really have information that will help form an opinion
19:28 <pushkarnk> rbasak: I really can't comment on that :)
19:28 <pushkarnk> I understand.
19:29 <rbasak> For example, looking at all the merges you point out on your application page, you have no comments or endorsements from anyone who sponsored those uploads.
19:29 <tsimonq2> Additionally, while the *quantity* of endorsements is what you're looking for, the quality is somewhat troubling to me.
19:29 <rbasak> That might mean that your merges are perfect everytime. That might mean that your merges need significant work every time, and you're not ready. Without relevant endorsements, I can't tell the difference.
19:29 <pushkarnk> I did reach out and followed up once. But I wouldn't want to chase people for endorsements.
19:30 <rbasak> Similarly you have an example of one SRU upload only.
19:30 <pushkarnk> Yes.
19:31 <rbasak> In bug 2069384 I think your regression analysis is lacking.
19:31 <rbasak> And that sponsor hasn't endorsed your application either.
19:31 <rbasak> In Ubuntu, all packages are team maintained. So it isn't really correct for you to list yourself as the sole maintainer of packages that exist in Ubuntu only.
19:31 <pushkarnk> rbasak: Yes, I did misunderstand the meaning of the "Where problems could occur" field
19:32 <rbasak> And as above, I've not seen evidence of you being active in Ubuntu development in public either.
19:33 <rbasak> Your +1 maintainence looks excellent btw
19:33 <pushkarnk> ack, thanks
19:34 <pushkarnk> I'll address the crac-criu feedback.
19:34 <rbasak> I haven't quizzed you on some other aspects I usually ask about.
19:34 <rbasak> I'm not sure it would make a difference to my opinion though, so I don't want to waste your time on that.
19:34 <tsimonq2> pushkarnk: To provide feedback from more of a sponsorship perspective, there are some uploads which have been okay, but the majority so far have either required several rounds of iteration, or have been rejected in favor of a sync altogether. I don't mean to be harsh, I want to see things improve and I'd like to be able to accept more of your MPs, but it's not meeting the standards I would expect
19:34 <tsimonq2> from a MOTU right now.
19:34 <rbasak> Please see https://wiki.ubuntu.com/RobieBasak/DMB/CoreDev - for MOTU I expect largely the same, except for things not relevant to main, such as component mismatches, MIRs and (somewhat) seeds.
19:35 <teward> tsimonq2: oyi check your msgs (related)
19:35 <teward> (and yes i'm passively attending the meeting every few minutes)
19:35 <pushkarnk> rbasak: tsimonq2: OK, I accept that feedback.
19:36 <tsimonq2> pushkarnk: From a DMB perspective, it's more or less the same, and this is my formal vote: -1 I have concerns with granting you upload rights this early in your Ubuntu Developer journey. It seems that you have good intentions, but the vast majority of your uploads are rather small, and seem to only fix an environment variable or autopkgtest. Additionally, I have unfortunately had to reject a
19:36 <tsimonq2> handful of sponsorship requests from you, even recently, due to simple mistakes that I would expect a MOTU to not make. I would encourage you to re-apply when you're ready, and if we can do anything to help please let us know.
19:36 <rbasak> pushkarnk: for me, the main issue is the lack of evidence and endorsements that demonstrate that you are doing excellent work. You might well be, but I can't really tell the difference.
19:36 <tsimonq2> pushkarnk: Again, I want to see you succeed long-term, and you're well on your way there, but I agree with Robie's concerns and I've had some of my own. Thanks for what you do.
19:36 <rbasak> It sounds like tsimonq2 has direct experience of reviews of your work that I do not.
19:37 <rbasak> So to give something concrete:
19:37 <pushkarnk> Thanks for the feedback!
19:37 <rbasak> 1) I'm starting to push harder on seeing active communication from Canonical employees. You could ask questions here, or on mailing lists, or on Discourse, and also help others. That would help give confidence that you know what you're doing.
19:38 <rbasak> (you are present on IRC though, AFAICT, which is a good start, and a hard requirement for Canonical employee Ubuntu developers)
19:38 <rbasak> 2) Merge activity is good, but then you should have endorsements from the people who are reviewing your work there.
19:39 <rbasak> 3) Not much activity on SRUs. It'd be nice to see more of those, and endorsements from the people who are reviewing that work.
19:39 <rbasak> I haven't asked about the release cycle, milestones and exceptions, autopkgtest and proposed migration, handling transitions. I'd expect to do that in a future application.
19:40 <rbasak> I don't require detailed direct experience in all of these, but I do expect to see direct and deep experience of at least some of them and a general understanding of most of them.
19:40 <rbasak> I hope that's actionable feedback.
19:40 <pushkarnk> rbasak: very much, I ack that. Thanks again!
19:40 <rbasak> And I hope that I'm applying the same bar that I hold to everyone else. I try!
19:41 <rbasak> IRC -> Matrix from 1 March, of course.
19:41 <bdrung> I see the feedback from tsimonq2 and rbasak and agree with them.
19:41 <tsimonq2> Do we want to hold a formal vote? bdrung or teward do you happen to have a vote, if not?
19:42 <tsimonq2> ah one second too late on my end :)
19:42 <rbasak> As chair it's up to you, but it doesn't seem like a motion to approve this application would succeed.
19:42 <teward> i have a vote but no feedback - rbasak and tsimonq2 basically stole my thunder with regarda to feedback
19:42 <teward> rbasak: but for formality the vote should still be held
19:42 <tsimonq2> *shrug* why not
19:43 <teward> just so we can say we abide by our own policies :P
19:43 <tsimonq2> #vote Grant pushkarnk membership to Ubuntu MOTU
19:43 <meetingology> Please vote on: Grant pushkarnk membership to Ubuntu MOTU
19:43 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:43 <rbasak> -1 feedback given above
19:43 <meetingology> -1 feedback given above received from rbasak
19:43 <tsimonq2> #voters rbasak teward tsimonq2 utkarsh2102 bdrung
19:43 <meetingology> Current voters: bdrung, rbasak, teward, tsimonq2, utkarsh2102
19:43 <teward> -1
19:43 <meetingology> -1 received from teward
19:43 <bdrung> -1
19:43 <meetingology> -1 received from bdrung
19:43 <tsimonq2> -1 feedback stated abovew
19:43 <meetingology> -1 feedback stated abovew received from tsimonq2
19:43 <tsimonq2> *above
19:43 <tsimonq2> 10...
19:43 <tsimonq2> 5...
19:44 <teward> thats a quorate negative vote against the app currently
19:44 <tsimonq2> #endvote
19:44 <meetingology> Voting ended on: Grant pushkarnk membership to Ubuntu MOTU
19:44 <meetingology> Votes for: 0, Votes against: 4, Abstentions: 0
19:44 <meetingology> Motion denied
19:44 <bdrung> I propose to vote for pushkarnk to become Ubuntu Contributing Developer
19:44 <rbasak> Sure
19:44 <tsimonq2> pushkarnk: Apologies. I hope our feedback was useful for you, and we hope to see you come back soon!
19:44 <tsimonq2> bdrung: I'd be +1 to that
19:44 <pushkarnk> tsimonq2: Yes, feedback is always useful!
19:45 <rbasak> I think contributions are good and pass the bar for that. +1
19:45 <tsimonq2> teward: What's your vote on voting for Contributing Developer?
19:45 <tsimonq2> :P
19:45 <bdrung> tsimonq2, great. then we should make a formal vote there as well.
19:46 <tsimonq2> #vote Grant pushkarnk membership to Ubuntu Contributing Developers
19:46 <meetingology> Please vote on: Grant pushkarnk membership to Ubuntu Contributing Developers
19:46 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:46 <tsimonq2> #voters rbasak teward tsimonq2 utkarsh2102 bdrung
19:46 <meetingology> Current voters: bdrung, rbasak, teward, tsimonq2, utkarsh2102
19:46 <bdrung> +1
19:46 <meetingology> +1 received from bdrung
19:46 <rbasak> And thank you for the suggestion bdrung - I do appreciate pushkarnk's contributions and I regret not being pro-active with that suggestion myself. I think it's a good idea to recognise applicants in this way when they pass the bar for contributing developer but not the original application.
19:46 <rbasak> +1
19:46 <meetingology> +1 received from rbasak
19:46 <tsimonq2> +1
19:46 <meetingology> +1 received from tsimonq2
19:46 <tsimonq2> rbasak: I completely agree.
19:47 <teward> +1
19:47 <meetingology> +1 received from teward
19:47 <tsimonq2> #endvote
19:47 <meetingology> Voting ended on: Grant pushkarnk membership to Ubuntu Contributing Developers
19:47 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
19:47 <meetingology> Motion carried
19:47 <tsimonq2> pushkarnk: Congratulations, you are now an Ubuntu Contributing Developer!
19:47 <rbasak> I can take the actions to announce and make the ACL change if you like.
19:47 <pushkarnk> Thank you, all!
19:47 <bdrung> pushkarnk is on the right track to become a MOTU etc and Ubuntu Contributing Developer is the right appreciation.
19:48 <tsimonq2> rbasak: ACL change done immediately, I'll take the wiki if you take the email :)
19:49 <tsimonq2> #topic AOB/outstanding mailing list items
19:49 <rbasak> tsimonq2: ack
19:49 <tsimonq2> rbasak: Thanks!
19:50 <tsimonq2> The agenda page was changed a bit: https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda - I think it looks good, any thoughts?
19:50 <teward> I am gonna go back to the car show with my dad ans get a beer unless y'all need me still
19:50 <rbasak> tsimonq2: ah
19:50 <rbasak> tsimonq2: I'm going to struggle a bit for technical reasons. I don't have the devel-permissions@ application email from pushkarnk to reply to.
19:51 <rbasak> (to do with my email for @ubuntu.com being turned upside down in the past few weeks)
19:51 <rbasak> Would you mind doing the email please?
19:51 <rbasak> Or else I can do it, but won't have access to the correct archive for a few days
19:51 <bdrung> the new layout of the agenda page looks good to me.
19:51 <tsimonq2> rbasak: Sure, I can take care of it :)
19:51 <rbasak> Thanks!
19:51 <rbasak> Normal @ubuntu.com service is already back to normal for emails received after about 7 Feb :)
19:52 <tsimonq2> \o/
19:52 <rbasak> It's just that there's a gap :-/
19:53 <tsimonq2> I do want to respect everyone's time, but I haven't had enough coffee today to re-dig into some of the recentish mailing list items proposed - rbasak etc if you have questions you'd like to bring up, go for it, but in terms of the Agenda wiki page I'd like to update it further to add some useful clarifying bits as specified on the ML.
19:53 <tsimonq2> Otherwise I'll leave it open to the end of the hour.
19:54 <rbasak> I don't think I have anything to add to the ML thread, unless I've missed something (not unlikely because of my email disruption)
19:55 <tsimonq2> Yeah, I just had a few somewhat pedantic suggestions on documentation and process improvements. :P
19:56 <rbasak> I appreciate you (and others) working to improve things!
19:56 <rbasak> I don't want to get in the way of that.
19:57 <tsimonq2> No worries, the current holdup is my coffee supply and Feature Freeze. ;)
19:57 <rbasak> IMHO, people who are prepared to do the work should get to choose how they go about it, and the opinions people who aren't volunteering should carry far less weight :)
19:58 <tsimonq2> I somewhat agree, although seniority does play a factor IMO :)
19:59 <rbasak> Sure - I'm happy to share my opinion in the hope that it'll be helpful, but I don't want it to be used to force any kind of outcome :)
19:59 <tsimonq2> Sounds good. :)
20:00 <tsimonq2> rbasak: I am glad you're still around helping with things - I'm sure it lends a new perspective!
20:00 <tsimonq2> #endmeeting