16:02 <rbasak> #startmeeting Developer Membership Board
16:02 <meetingology> Meeting started at 16:02:23 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:02 <meetingology> Available commands: action, commands, idea, info, link, nick
16:02 <rbasak> #topic Review of previous action items
16:02 * rbasak teward to resolve the wiki / Discourse process ambiguity (carried over)
16:03 <rbasak> #action teward to resolve the wiki / Discourse process ambiguity (carried over)
16:03 * meetingology teward to resolve the wiki / Discourse process ambiguity (carried over)
16:03 <rbasak> #topic Applicaiton review
16:03 <rbasak> #subtopic sosreport PPU Application by Arif Ali
16:05 <teward> i'm late sorry
16:05 <schopin> I doubt bdrung will make it, I think he's still traveling from FOSDEM.
16:06 <rbasak> I know that arif-ali has been using mentors.debian.net for sosreport package updates in Debian
16:06 <rbasak> I wonder if there's a way to see the code reviews that took place previously? I can't find one.
16:07 <arif-ali> There were no code reviews, mentors stuff gets wiped after the upload
16:07 <arif-ali> However, the initial reviews would have been on the debian-mentors mailing list
16:07 <arif-ali> The links should be in my application
16:08 <schopin> I see you've just become a DM, presumably for that very package.
16:09 <rbasak> Aha - thanks!
16:09 <arif-ali> That's still on the final RT ticket to process my GPG key
16:10 <schopin> #link https://wiki.ubuntu.com/arif-ali/sosreportPerPackageUploadApplication
16:10 <utkarsh2102> thanks for the link
16:10 <rbasak> "Arrange the Depends and Recommends as a list, so that it is a one-line change the next time"
16:11 <rbasak> You might want to look at the wrap-and-sort tool if you didn't know about it already
16:11 <rbasak> I should probably declare that I've worked with arif-ali extensively since he started looking at the sosreport package.
16:11 <arif-ali> rbasak: that was my plan, and already on my todo for next upload
16:12 <rbasak> However, it was all about Salsa workflow, and giving him push access to the Salsa project. I've never actually reviewed any uploads since he was already using the mentors.d.n process successfully for that.
16:12 <rbasak> (and gbp workflow)
16:12 <rbasak> Let me start with a question for arif-ali then. When is feature freeze for Plucky, and where would you find that information?
16:14 <arif-ali> rbasak: I would normally find that on discourse and currently that sits at Feb 20
16:15 <rbasak> arif-ali: great. Let's say that it's Feb 21. Currently Plucky has 4.8.2-2. Someone asks you to upload a new sosreport 4.8.3 to Plucky. Would that be acceptable? Or if you need more information to decide, what information would you need?
16:18 <arif-ali> It's not something I've had to deal with yet. But I would ask the question on #ubuntu-devel and see it would be acceptable. Questions would potentially be asked if how this can seriously change anything and could cause any regressions. If things look good, we could potentially have an exception (My thoughts, not with any experience on this)
16:19 <rbasak> OK. Are there any cirumstances under which you wouldn't need a regression and it would be OK to upload without consulting anyone?
16:19 <rbasak> Uh
16:19 <rbasak> OK. Are there any cirumstances under which you wouldn't need an *exception* and it would be OK to upload without consulting anyone?
16:22 <arif-ali> as I have not dealt or read anything on this; If the autopkgtest are good, and it doesn't affect core aspects of the respective build, then I guess it would be good to go.
16:22 <arif-ali> I still need some aspects of learning on this
16:24 <rbasak> I'll move on but continuing that scenario...
16:25 <rbasak> Plucky has 4.8.2-2, it's Feb 21, and you have (after consulting others) concluded that it is acceptable to update Plucky to 4.8.3.
16:25 <rbasak> What would your next steps be?
16:28 <arif-ali> I will create a LP bug as usual for the update, I will grab the latest package details from git ubuntu, bring in the new release as well as any relevant changes. Then the version would be 4.8.3-0ubuntu1 which would be uploaded. I will alert #ubuntu-release that the package was agreed to be accepted.
16:28 <rbasak> What about Debian?
16:28 <arif-ali> I will, (based on my experience), create a PPA before-hand and do autopkgtests, to ensure that all is good before upload
16:29 <utkarsh2102> question: "I will alert #ubuntu-release that the package was agreed to be accepted" -> accepting from where?
16:29 <utkarsh2102> and alerting who? :)
16:30 <arif-ali> I would typically, do debian first, and allow to autosync, and that would be my preferred way. However, if we had to do ubuntu first and have the ubuntu change first, then I would also do Debian with the latest changes
16:30 <arif-ali> From the unapproved queue, and would alert ubuntu-sru
16:33 <rbasak> I wonder if it would be worth you taking a couple of minutes to re-read this conversation and see if there's anything you'd like to add, remove or correct.
16:37 <utkarsh2102> apologies but i'm ready to vote. :)
16:37 <arif-ali> In an ideal scenario, I would prepare Debian package, upload to Debian, which after their autopkgtest and migration would end in testing, this would then go into plucky-proposed and run autopkgtest
16:38 <arif-ali> In this case a LP ticket wouldn't necessarily be needed
16:39 <rbasak> OK, so let's say you do that. You upload 4.8.3-1 to Debian. Plucky stays on 4.8.2-2, even after a few days. There's no sign of 4.8.3-1 appearing in Ubuntu at all whatsoever. Why?
16:39 <arif-ali> ah, the autosync would have been disable due to feature freeze
16:40 <rbasak> Good - and what's the action you would need to take to pull 4.8.3-1 into plucky-proposed?
16:40 <arif-ali> There is a command to request a sync, which automatically creates an LP, for then someone to action, and manually do the autosync
16:40 <rbasak> OK
16:40 <rbasak> So the package syncs, but then the package stays in plucky-proposed and doesn't seem to make it in the release pocket. What do you do next?
16:42 <arif-ali> If all the tests are green, then I would go into ubuntu-release to request it to be migrated to -updates
16:42 <utkarsh2102> to -updates?
16:43 <arif-ali> to be released/migrated, sorry no -updates in this scenario
16:45 <rbasak> Does anyone else have any questions for Arif?
16:47 <utkarsh2102> no, i'm ready to vote
16:47 <rbasak> #vote Grant arif-ali PPU for sosreport
16:47 <meetingology> Please vote on: Grant arif-ali PPU for sosreport
16:47 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:49 <rbasak> -1 Thank you for maintaining sosreport! I'm not sure you have a firm grasp on teh various Ubuntu processes yet - including what team is reponsible for what. I appreciate that you're very willing to ask questions when needed, and that's a good sign that you might be ready to upload directly. But given some of your answers, I think that might actually hinder more than help. I think you'd be better
16:49 <meetingology> -1 Thank you for maintaining sosreport! I'm not sure you have a firm grasp on teh various Ubuntu processes yet - including what team is reponsible for what. I appreciate that you're very willing to ask questions when needed, and that's a good sign that you might be ready to upload directly. But given some of your answers, I think that might actually hinder more than help. I think you'd be better received from rbasak
16:49 <rbasak> served having some more guidance from sponsors before you are ready to work on the package unsupervised. This relates only to Ubuntu process matters though - I've seen nothing to suggest that there's any issue with your actual packaging skills!
16:49 <rbasak> Sorry I wasn't able to vote in favour this time. But I hope to see you apply again soon, once you have a better overview of Ubuntu teams and processes!
16:50 <rbasak> See https://wiki.ubuntu.com/ProposedMigration for further study on my proposed migration question.
16:51 <rbasak> On my question about whether 4.8.3 would qualify for upload after feature freeze, I'd like you to understand that the answer depends on the actual changes being uploaded - whether those are to be considered feature changes, changes in behaviour from a user perspective, or bugfixes (and of course that's subjective).
16:51 <schopin> Apologies, I went away for a bit, let me catch up on the backlog.
16:52 <rbasak> Note that there's a very big distinction between the ~ubuntu-sru and ~ubuntu-release teams.
16:52 <ahasenack> and you may have just pinged both :)
16:53 <schopin> their fault for misconfiguring their HLs, we're not on the proper channel ;)
16:53 <arif-ali> cool, thanks, and I'll keep that in my mind
16:53 <rbasak> For the development release, nobody is "in control" of proposed migration - migration happens when the appropriate conditions are met, and their privileged hats can't really help with that.
16:53 <rbasak> (during most of the cycle, anyway - final freeze may be an exception to that - the excuses page will make it clear)
16:54 <utkarsh2102> -1; thank you for your work! exactly what Robie said. I am afraid that by your answers it's not clear if you have a clear distinction/knowledge of the Ubuntu processes and the workflows, the teams involved, and so on. I'd love for you to re-apply soon but that'd need some work around polishing those rough edges.
16:54 <meetingology> -1; thank you for your work! exactly what Robie said. I am afraid that by your answers it's not clear if you have a clear distinction/knowledge of the Ubuntu processes and the workflows, the teams involved, and so on. I'd love for you to re-apply soon but that'd need some work around polishing those rough edges. received from utkarsh2102
16:54 <rbasak> ahasenack: when training / explaining, I have no choice. It'd be confusing not to use their names.
16:54 <rbasak> Sorry!
16:55 <schopin> -1 understanding of what one can and should (or shouldn't) do during the release process is lacking. I'm sure you'll get there very soon, though :)
16:55 <meetingology> -1 understanding of what one can and should (or shouldn't) do during the release process is lacking. I'm sure you'll get there very soon, though :) received from schopin
16:57 <rbasak> FWIW, I do think that our documentation in these areas are poor. We've always relied heavily on training provided by mentors. We need to be moving to written documentation. So this is not your fault, and shouldn't reflect badly on you.
16:57 <rbasak> Progress on written documentation is slow, but is happening at least :-/
16:58 <schopin> teward: are you still around? On the hunt for coffee perhaps?
16:58 * genii twitches
16:59 <arif-ali> rbasak: thanks, I'll keep reading, and keep asking questions. Need to keep working on the Ubuntu processes
17:02 <rbasak> We're out of time.
17:02 <rbasak> #endvote
17:02 <meetingology> Voting ended on: Grant arif-ali PPU for sosreport
17:02 <meetingology> Votes for: 0, Votes against: 3, Abstentions: 0
17:02 <meetingology> Motion denied
17:03 <rbasak> #topic Outstanding mailing list requests to assign
17:03 <rbasak> #info No recent mailing list requests
17:03 <rbasak> #topic Open TB bugs
17:03 <rbasak> #info No open TB bugs
17:04 <rbasak> #topic AOB
17:04 <rbasak> AOB?
17:04 <rbasak> #endmeeting