20:01 <seb128> #startmeeting Ubuntu Technical Board
20:01 <meetingology> Meeting started at 20:01:52 UTC.  The chair is seb128.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
20:01 <meetingology> Available commands: action, commands, idea, info, link, nick
20:02 <seb128> #topic Apologies
20:02 <seb128> I didn't see any sign from Lukasz since he left Canonical but I'm going to assume he's not going to join us tonight
20:02 <seb128> #topic Action review
20:03 * seb128 amurray to look into scripting for packages in flavor-specific overlays
20:03 <amurray> carry-over please
20:04 <seb128> #action amurray to look into scripting for packages in flavor-specific overlays
20:04 * meetingology amurray to look into scripting for packages in flavor-specific overlays
20:04 * seb128 seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:04 <seb128> I'm carrying that over still but I've seen some action from teams on documentation so I will try to pick that up again
20:05 <seb128> #action seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:05 * meetingology seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:05 * seb128 sil2100 to follow up on the Cinnamon 24.04 LTS Qualification to ensure the listed contacts can action the flavor
20:05 <seb128> it was decided in the previous meeting to carry that over until we have a new board I think
20:06 <seb128> so doing that
20:06 <seb128> #action sil2100 to follow up on the Cinnamon 24.04 LTS Qualification to ensure the listed contacts can action the flavor
20:06 * meetingology sil2100 to follow up on the Cinnamon 24.04 LTS Qualification to ensure the listed contacts can action the flavor
20:06 * seb128 amurray and seb128 to engage with IS re Canonical leavers and ubuntu LP team memberships
20:06 <seb128> I've opened a RT for Canonical IS which got some activity and is triaged
20:07 <seb128> rbasak wrote a script that could be used to ensure teams under community governance aren't modifier by the Canonical exit process, which seems to be a good step
20:08 <rbasak> I haven't taken that script any further FWIW. I've been occupied with some personal matters.
20:08 <seb128> rbasak, did you want to continue on that topic and own to propose that solution to IS?
20:08 <amurray> would it be useful to get the CC to review the script/the output of the script and then if we are happy with it then propose it to IS?
20:09 <rbasak> seb128: I think that's difficult as I've leaving Canonical on Friday.
20:09 <rbasak> Would it be easier for those at Canonical to take this on? I'm happy to help from the scripting/community end, but I'm not sure I'll be able to drive it effectively with Canonical IS any more.
20:09 <seb128> right, I'm happy to continue the IS side of the discussion
20:09 <rbasak> Thanks!
20:10 <seb128> I don't really have an opinion on getting review from CC or not, I think it's probably straightforward enough that it is not needed
20:10 <seb128> but at the same time it doesn't hurt either
20:10 <seb128> rbasak, opinion?
20:10 <rbasak> I don't think it's necessary to get review
20:10 <rbasak> (except IS will review it of course)
20:11 <amurray> no worries - yeah I wasn't sure if we thought it needed some other eyes on it but am happy for us to just proceed as we see fit
20:11 <seb128> amurray, did you feel strongly about the CC review?
20:11 <amurray> no, am happy to go ahead without it
20:11 <seb128> ok, well I will review and if I'm happy I will follow up with IS
20:11 <rbasak> An opportunity to enhance the script might be to also identify whether or not a team has an ultimate owner who is a member of ~canonical. If not, it's probably a not-Canonical not-Ubuntu team and membership of it shouldn't be touched.
20:12 <rbasak> But I don't think I'll have time for that in the next couple of weeks.
20:12 <rbasak> So probably better to go with what's there so far.
20:12 <seb128> #action seb128 to continue the discussion with IS and propose the script from rbasak or its output to be integrated in their process
20:12 * meetingology seb128 to continue the discussion with IS and propose the script from rbasak or its output to be integrated in their process
20:13 <seb128> ack, we can always iterate later/improve
20:13 <seb128> #topic Scan the mailing list archive for anything we missed (standing item)
20:15 <seb128> I'm going to mention that I pinged the CC again (because I didn't see the summary of the governance sync posted on discourse), the TB election is still waiting for review from Mark from what I understand
20:15 <seb128> they will extend the current board meanwhile
20:15 <seb128> .
20:15 <seb128> other topic I emailed the list about to discuss here
20:15 <seb128> https://lists.ubuntu.com/archives/technical-board/2025-January/002969.html
20:16 <seb128> the ubuntu.com TB description states
20:16 <seb128> ```
20:16 <seb128> Nominations for the Technical Board will be considered for each release
20:16 <seb128> (every six months). Mark Shuttleworth, as project sponsor, is
20:16 <seb128> responsible for nominating candidates, and a poll of Ubuntu developers
20:16 <seb128> will be conducted to select, or veto, the final membership. Appointments
20:16 <seb128> are made for a period of two years.
20:16 <seb128> ```
20:16 <seb128> which seems inaccurate/not to match what is happening
20:16 <rbasak> Sounds like we need someone to fix the text to be accurate again.
20:16 <rbasak> I'm happy for that to be delegated to one TB member and trust them to do a good job :)
20:17 <seb128> right, I was unsure if that was a change that was decided
20:17 <amurray> I can take that on - can draft something and circulate to you both if you like before getting it updated
20:17 <seb128> or if practice drifted from what should happen
20:17 <seb128> amurray, thanks
20:17 <rbasak> AIUI, the current process has been happening since before I got involved in 2011.
20:17 <rbasak> I'm not sure there are many people around any more who would know if the change was intentional.
20:18 <rbasak> I can think of one person we could ping if curious. I don't want to bother them that much though if we don't need to know.
20:18 <seb128> #action amurray to draft an updated description for the TB nominations process on ubuntu.com
20:18 * meetingology amurray to draft an updated description for the TB nominations process on ubuntu.com
20:18 <rbasak> I'm happy to describe the current process and leave the old one behind.
20:18 <seb128> +1
20:19 * rbasak has an AOB topic
20:19 <seb128> well, there is still one list thing
20:19 <seb128> rbasak, can you provide context on https://lists.ubuntu.com/archives/technical-board/2025-January/002967.html and https://lists.ubuntu.com/archives/technical-board/2025-January/002968.html ?
20:20 <seb128> did you move from an owner team that included the TB to direct set the TB as owner?
20:20 <rbasak> Sure. It's a minor thing that I don't think matters, but I moderated through the emails as I didn't want to hide anything.
20:21 <rbasak> I "wrapped" ~git-ubuntu-import into ~git-ubuntu-owners. Ultimate TB ownership didn't change.
20:21 <rbasak> This is important because ~git-ubuntu-import is a "Code admin" under launchpad.net/ubuntu, to manage the "official" git repositories for the project
20:21 <rbasak> So the TB should be the ultimate owner
20:22 <seb128> ack, makes sense, thanks for the context!
20:22 <rbasak> But for admin purposes, we need some people to be able to write to the repos if required, even if right now (pending the staging branches spec) they should be read-only.
20:23 <rbasak> So while addressing the bus factor, I did the wrapping so that the owners can add and remove themselves from the actual git-ubuntu-import team, so that they don't have to have write access all the time. As a type of "safety".
20:23 <rbasak> .
20:23 <seb128> thanks
20:24 <seb128> I've to admit I still don't really understand who has access to git-ubuntu changes but I will study that
20:24 <rbasak> ahasenack, me and bryce.
20:24 <seb128> despite being coredev and TB member I don't have acces to change the status of merge requests for example
20:24 <rbasak> Yes that's annoying.
20:25 <seb128> I guess owners don't have special rights in that sense?
20:25 <rbasak> The staging spec was supposed to fix that but it's pending implementation at the Launchpad end.
20:25 <rbasak> Currently changing MP status requires write access to the target repo, but it's important that Ubuntu developers do not write to the git-ubuntu repos except through uploads.
20:26 <seb128> well I though that by being owner the TB would have access though
20:26 <rbasak> One way around it might be to write a bot that changes MP status based on instructions in comments, or something like that
20:26 <rbasak> I don't think ownership is treated as team membership
20:26 <seb128> I see
20:26 <rbasak> It's just someone who can act as a team admin without necessarily being an owner
20:26 <rbasak> Which actually works quite well in general, IMHO.
20:27 <seb128> right
20:27 <rbasak> Since it's a good way to specify ultimate ownership but delegating all powers
20:28 <seb128> thanks again, and let's move on, that's getting out of topic in context of the TB that was more curiosity from my side now
20:28 <seb128> #topic Check up on community bugs and techboard bugs
20:28 <seb128> #link https://bugs.launchpad.net/ubuntu-community/+bugs?field.assignee=techboard
20:28 <seb128> #info No new community bugs
20:28 <seb128> #link https://bugs.launchpad.net/techboard
20:28 <seb128> #info No new techboard bugs
20:29 <seb128> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
20:29 <seb128> #info The next chair will be amurray with rbasak as backup
20:29 <rbasak> ack
20:29 <seb128> #topic AOB
20:29 <amurray> ack
20:29 <seb128> rbasak, you have one
20:29 <rbasak> Sorry I didn't raise this in the agenda properly. I've been occupied with some personal matters for the past week or so that couldn't wait.
20:29 <rbasak> You'll have seen my thread on moving from IRC to Matrix. I said I'd ask the TB, but it seems we have consensus on the ML anyway, so maybe that isn't really necessary at all.
20:29 <rbasak> I'm planning to announce a move to Matrix for #ubuntu-devel and #ubuntu-release on 1 March, to give people time to set up accounts, etc. The old channels wouldn't shut down or presence banned or anything, but privileged team presence should move to Matrix instead, and we should try to hold conversations on Matrix as much as possible to avoid fragmentation.
20:29 <rbasak> Is the TB OK with that, and to leave the details to me?
20:29 <rbasak> I'm abandoning my proposal to merge -release and -devel since many people weren't sure about that.
20:30 <seb128> +1 from me, and thank you for pushing that forward, it's about time we move to a more modern platform
20:30 <amurray> +1 from me - thanks for driving this basak, it is long overdue
20:31 <rbasak> Great. Thanks! Nothing else from me.
20:31 <amurray> now to move this channel as well ;)
20:31 <seb128> :)
20:31 <seb128> amurray, any AOB?
20:31 <rbasak> This channel is a little more complicated
20:31 <rbasak> There's no replacement for meetingology AIUI
20:31 <amurray> true
20:31 <rbasak> So I think it's open as to whether we should move or wait.
20:31 <rbasak> But I don't want to hold up the main move on that point.
20:32 <rbasak> Perhaps we can set a deadline and move anyway, say in six months.
20:32 <rbasak> Or earlier if someone ports meetingology earlier.
20:32 <rbasak> Depends on how important people thing it is.
20:32 <amurray> I would also prefer we go to something more high bandwidth like google meet and we record those etc but yes then it would need someone to actually take notes during the meeting without meetingology
20:33 <rbasak> I like it - it helps with logs, which is very useful for TB / DMB business IMHO.
20:33 <seb128> let's talk about that with the new board when we have one I would say
20:33 <rbasak> But I can ask on the ML to see what others think.
20:33 <amurray> yep lets leave it to the next TB
20:33 <seb128> maybe once better staffed we will have someone wanting to spend some time working on a solution
20:34 <seb128> it's probably not going to me, the workload problem isn't likely to get better any time soon I think
20:34 <seb128> to be me*
20:35 <seb128> anyway
20:35 <seb128> anything else?
20:35 <amurray> nothing from me
20:35 <seb128> that's a wrap then, thanks amurray and rbasak!
20:35 <seb128> #endmeeting