19:09 <rbasak> #startmeeting Developer Membership Board
19:09 <meetingology> Meeting started at 19:09:00 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:09 <meetingology> Available commands: action, commands, idea, info, link, nick
19:09 <rbasak> #topic Review of previous action items
19:09 <rbasak> teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:09 <rbasak> teward isn't here so we'll carry over
19:09 <rbasak> #action teward to follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:09 * meetingology teward to follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:09 <rbasak> rbasak to start a ML thread to find consensus on whether to allow PPU applications for "core" packages (done)
19:10 <rbasak> This is done and is awaiting input from others
19:10 <rbasak> #topic SRU Developer Applications
19:10 <rbasak> #subtopic     SRU Developer application by Matthew Ruffell at DMB meeting 2024-09-30 (due to APAC NZST timezone).
19:10 <rbasak> mruffell: o/
19:10 <mruffell> hello everyone
19:10 <teward> rbasak: bug me when we get to AOB
19:11 <teward> (my availability is only as long as my Verizon connection doesn't dip out, looks like they're having cellular issues and i'm travelling today)
19:12 <rbasak> Questions for mruffell?
19:12 <teward> rbasak: link to their appliclation since wiki and agenda are slow as sin today?
19:12 <teward> application*
19:12 <mruffell> https://wiki.ubuntu.com/mruffell/SRUDeveloperApplication
19:12 <rbasak> Thanks
19:12 <rbasak> #link https://wiki.ubuntu.com/mruffell/SRUDeveloperApplication
19:15 * teward staring at the application wondering what APAC is, and then realizes he's just undercaffeinated and that this is representation for the Asia/Pacific region
19:18 <rbasak> mruffell: do you have / remember any recent examples of turning someone else's contribution into an SRU ready to upload? This isn't a hard requirement but would be nice to see if you do.
19:19 <rbasak> Meanwhile, bug 2059197 is a nice example of dealing with a regression - thank you!
19:20 <mruffell> I believe I have tidied up someones patches for SRU, but it is at most once or twice.... I'm trying to figure out what one it was...
19:20 <mruffell> but I normally delete superseeded patches from the LP bug to tidy it up to not confuse my sponsors, so finding them is hard
19:20 <rbasak> OK don't worry
19:21 <mruffell> and yeah, I do try my best to talk to community users and correct any regressions as fast as possible
19:21 <rbasak> We don't get many SRU developer applications. I don't have a set of standard questions ready to ask!
19:22 <bdrung> to avoid needing to clean-up the bug report, you could name the patches $name_v1.patch, $name_v2.patch and so on. then it's clear what is the latest one.
19:22 <rbasak> From your application and endorsements I agree with ddstreet that you have been ready for a while, and you're well past the line in terms of volume and quality of work.
19:22 <mruffell> but sometimes v1 is fine for focal, but jammy gets superseeded with a security upload, so jammy has a v2... but then they ask, where's focal v2?
19:23 <mruffell> So I just try keep everything in lockstep to not be confusing
19:23 <rbasak> I can't see anything in your recent SRU history that I might want to expand upon by asking questions, so I think I have no questions to ask.
19:23 <rbasak> Does anyone else have questions or should we move on to vote?
19:23 <bdrung> it's hard to come up with questions since your work would answer a lot of them (like regression handling, etc)
19:24 <rbasak> I'm not sure a vote can be quorate today but we can make some progress towards that at least.
19:24 <rbasak> mruffell: not really for your application, but I'd appreciate feedback on the new docs and how you've found them!
19:24 <mruffell> I have read them! https://canonical-sru-docs.readthedocs-hosted.com/en/latest/
19:24 <rbasak> If there are no objections I'll start voting now then.
19:25 <rbasak> #vote Grant mruffell SRU Developer membership
19:25 <meetingology> Please vote on: Grant mruffell SRU Developer membership
19:25 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:25 <rbasak> +1 comments as above. Thank you for your excellent work!
19:25 <meetingology> +1 comments as above. Thank you for your excellent work! received from rbasak
19:25 <bdrung> +1
19:25 <meetingology> +1 received from bdrung
19:25 <teward> +1
19:25 <meetingology> +1 received from teward
19:26 <rbasak> bdmurray: around?
19:26 <rbasak> (since I saw you enquiring earlier)
19:26 <rbasak> Anyone else?
19:27 <rbasak> #endvote
19:27 <meetingology> Voting ended on: Grant mruffell SRU Developer membership
19:27 <meetingology> Votes for: 3, Votes against: 0, Abstentions: 0
19:27 <meetingology> Motion carried
19:27 <rbasak> Sorry we need at least another vote
19:27 <rbasak> I'll ask on the ML
19:27 <mruffell> great, thanks
19:28 <rbasak> Please also schedule another meeting date, in case we need it to chase for a final vote. There are reduced quorum rules for a second meeting if it becomes necessary
19:28 <bdrung> rbasak, one comment on https://canonical-sru-docs.readthedocs-hosted.com/en/latest/ - it would be nice to have a one-page version of it (to make searching in it easier)
19:29 <rbasak> bdrung: is https://canonical-sru-docs.readthedocs-hosted.com/_/downloads/en/latest/pdf/ enough?
19:30 <bdrung> that'll do it as well
19:30 <rbasak> #topic Ubuntu Core Developer Applications
19:30 <rbasak> #subtopic Ubuntu Core Developer application by Chris Peterson at DMB meeting 2024-11-25 (I will also join the 2024-09-30 meeting in case there is extra time, pending confirmation if this is ok.)
19:30 <cpete> Hey there o/
19:30 <rbasak> cpete: we can see how far we get in the next half hour
19:31 <rbasak> cpete: but as above a vote today won't be quorate, so you may have to reschedule anyway. Do you want to continue regardless?
19:31 <cpete> Yeah let's do it please
19:32 <rbasak> #link https://wiki.ubuntu.com/cpete/CoreDev
19:33 <rbasak> Questions for cpete?
19:34 <cpete> I suppose I'll introduce myself too. Hi, name is Chris Peterson and I work for Canonical on the Foundations team. I primarily work on Subiquity and other installer related areas. Although as part of my Founations responsibilities I may work in other areas as well.
19:34 <utkarsh2102> (also, hi!!!)
19:35 <rbasak> Sorry I was preoccupied reading your application. I hadn't realised there was a second one until just earlier. Hello :)
19:38 <rbasak> cpete: OK I'll start then I guess. If you were considering uploading a new upstream version of a package today, for Oracular, what would you need to check before upload?
19:41 <cpete> There are various freezes to be aware of, such as featurefreeze, betafreeze etc. For Oracular, you can find the effective dates here: https://discourse.ubuntu.com/t/oracular-oriole-release-schedule/36460
19:41 <utkarsh2102> cpete: did you get my question?
19:41 <cpete> Currently, we are past FeatureFreeze so I wouldn't be considering a new upstream release unless it only contained critical bug fixes necessary for the final release.
19:41 <rbasak> OK. How does feature freeze apply if the new upstream version is a "microrelease" (eg. 1.2.3 -> 1.2.4)?
19:41 <utkarsh2102> sorry, my client disconnected
19:42 <cpete> utkarsh2102 no sorry
19:42 <utkarsh2102> q: what if you have package version 1.2.3 in ALL the current stable releases and the current DEVEL release. you're exactly where you are in the cycle as of today. you have notified of a grave bug and you have a patch ready. what versions will you upload and what should you take care before uploading?
19:42 <utkarsh2102> tell me the versions and the precautions for ALL the stable releases and the devel release
19:42 <utkarsh2102> answer once you've answered the current question
19:43 <cpete> rbasak: version strings aren't the most reliable way to tell what's changed. It's a good indicator, but you'd have to look at the real source changes to be sure if it's a bug fix or not.
19:43 <rbasak> cpete: OK, thanks.
19:44 <utkarsh2102> rbasak: is it possible for you to paste the scrollback for today's meeting, please?
19:44 <utkarsh2102> https://irclogs.ubuntu.com/2024/09/30/%23ubuntu-meeting.html will take time to sync
19:45 <rbasak> utkarsh2102: https://pastebin.ubuntu.com/p/7pttVVttM5/
19:47 <utkarsh2102> thank you!
19:47 <utkarsh2102> cpete: ??
19:47 <cpete> utkarsh2102:  The new version would be 1.2.3-0ubuntu1. I would be first uploading to devel, and I would need to then prepare SRUs for applying the patch to previous versions. SRU version strings can be hard, I'd need a second to double check the guidance on that. I imagine in this case 1.2.3-0ubuntu1 would be fine, but all of my SRUs have already had the version numbers handy :)
19:48 <cpete> utkarsh2102:  taking "grave" to mean critical but maybe not a security bug
19:48 <utkarsh2102> yes, a regular bug
19:49 <utkarsh2102> cpete: will you directly upload to devel? no precautions?
19:49 <utkarsh2102> cpete: so 1.2.3-0ubuntu1 will work for what all releases, please name them?
19:50 <cpete> utkarsh2102: ah certainly not. I would first build and test the new version locally and make sure autopkgtests pass. (I have done this so far with the majority of my uploads with PPA builds to demonstrate this to my sponsors)
19:53 <cpete> utkarsh2102: Well it will certainly work for devel. The SRU version string is important that's greater than any version in any of that releases pockets e.g. jammy jammy-updates, jammy-security. Since you say that's the version in all releases that should be fine as well. But we'd have to check each release
19:54 <cpete> jammy-release jammy-updats jammy-security
19:55 <utkarsh2102> cpete: I had added "you're exactly where you are in the cycle as of today." - which applies to devel. what do you think you should do more, if anything?
19:55 <utkarsh2102> cpete: 1.2.3 is the highest version in noble, jammy, focal
19:55 <utkarsh2102> i don't think you really have to go through each pocket of the release to check :)
19:56 <rbasak> We're nearly out of time
19:56 <cpete> Ah well I would probably contact a release team member and make them aware of the bug.
19:56 <utkarsh2102> cpete: "The SRU version string is important that's greater than any version in any of that releases pockets" why?
19:57 <utkarsh2102> rbasak: I can vote on mruffell's application now and make it quorate, right?
19:57 <rbasak> utkarsh2102: yes
19:57 <rbasak> (if you vote +1)
19:57 <rbasak> A -1 wouldn't be quorate
19:57 <utkarsh2102> ok, +1 for mruffell!!!
19:57 <rbasak> Congrats mruffell :)
19:57 <utkarsh2102> yay!
19:57 <mruffell> Thanks! I'm very happy
19:57 <bdrung> congrats!
19:58 <rbasak> I had further questions too, so I think we'll need to postpone. Sorry cpete
19:58 <mruffell> I can finally retry autopkgtests now without bothering m-f-o or h-a-l-v-e-s =p
19:58 <cpete> utkarsh2102: so they get the new version of the package when updating it
19:58 <cpete> rbasak: no worries, thanks for the time everyone
19:58 <utkarsh2102> right, so what about f -> j upgrades?
19:58 <rbasak> If anybody would like to continue, feel free and I'll check the logs later
19:58 <utkarsh2102> and j - n ?
19:58 <rbasak> I think that might be utkarsh2102 volunteering :)
19:58 <rbasak> #chair utkarsh2102
19:59 <meetingology> Current chairs: rbasak, utkarsh2102
19:59 <utkarsh2102> rbasak: i don't think we should half half applications
19:59 <utkarsh2102> that is so sub-optimal
19:59 <utkarsh2102> #chair bdrung
19:59 <rbasak> utkarsh2102: fair. Do you want to continue with this line of questions then?
19:59 <utkarsh2102> also
19:59 <meetingology> Current chairs: bdrung, rbasak, utkarsh2102
19:59 <utkarsh2102> rbasak: yes, I can. bdrung, are you around for a bit more?
20:00 <bdrung> yes
20:00 <utkarsh2102> are you okay to continue then?
20:00 <bdrung> yes
20:00 <utkarsh2102> perf!
20:00 <rbasak> utkarsh2102: afterwards, please switch to an AOB topic and assign the two necessary actions for mruffell's application, to keep the automatic minutes straight
20:00 <rbasak> o/
20:00 <mfo> congrats, mruffell! o/ (3-min delayed)
20:00 <utkarsh2102> rbasak: will do, thanks! o/
20:01 <utkarsh2102> cpete: waiting on you to answer my question currently
20:01 <teward> *waves*
20:01 * bdrung grabs some snacks to be able to continue
20:01 <teward> i'm still here but my internet's fuzzy because Verizon is having some internet problems right now on cell service
20:01 <utkarsh2102> great, thanks teward
20:01 <teward> #chair teward
20:01 <meetingology> Current chairs: bdrung, rbasak, teward, utkarsh2102
20:01 <cpete> utkarsh2102: Ah right, we don't want users to upgrade and regress. This is why it's important to SRU to each release, and each version string is usually release specific
20:02 <teward> *knows too much about meetingology*
20:02 <utkarsh2102> lmao
20:02 <utkarsh2102> cpete: okay, soooo?
20:02 <utkarsh2102> wdym by "upgrade and regress"?
20:04 <cpete> utkarsh2102: So if 1.2.3 is the highest version in each release, then 1.2.3-0ubuntu1 is probably fine for each version you would just need to SRU it back to each. By "upgrade and regress" we don't want users to upgrade to a newer version of ubuntu and reintroduce bugs. This is why we make sure to land patches in devel before SRUing them.
20:04 <utkarsh2102> got it
20:05 <mruffell> cpete: have you done an SRU before?
20:05 <utkarsh2102> last question around this: when you update to 1.2.3-0ubuntu1 to focal, jammy, and noble. does this cause any problem?
20:05 <cpete> mruffell: I have done 3 yes. Here is one example for livecd-rootfs https://bugs.launchpad.net/subiquity/+bug/1974483
20:07 <cpete> utkarsh2102: I'm not sure I understand the question
20:08 <utkarsh2102> cpete: per your last answer above - you said "1.2.3-0ubuntu1 is probably fine for each version [...]"
20:08 <utkarsh2102> so when you've done that
20:09 <utkarsh2102> and let's say focal, jammy, noble is at "1.2.3-0ubuntu1" - does  everything work fine? and can we call the bug closed? or is there something we should still do? or?
20:11 <cpete> utkarsh2102: we could only close the bug after SRU verification. It will then phase from -proposed to -updates and as long as no errors are reported it will fully phase and we could call it done. If that's what you're getting at.
20:12 <utkarsh2102> ok, i'll move on, thank you :)
20:12 <utkarsh2102> cpete: I was trying to get at the upgrade story from focal -> jammy; jammy -> noble.
20:13 <utkarsh2102> cpete: q: what happens when you upload a package to the devel release. where does it go? is there any other step you need to take care as an uploader?
20:15 <cpete> utkarsh2102: It will land in -proposed and await migration until the package's and its rev-dpes autopkgtests pass. The uploader is responsible for seeing the package migrate into -release. This is setting aside times from freezes, say beta freeze, where the upload may require additional approval in the queue before landing into -proposed.
20:16 <utkarsh2102> mruffell: hey, btw, i've added you to the right ACL and announced your application already!!! o/
20:16 <utkarsh2102> cpete: thanks, what if all autopkgtests pass and yet the package doesn't migrate?
20:16 <mruffell> utkarsh2102: thanks, I got the ACL email and the announcement =)
20:17 <bdrung> cpete, Imagine a user detects a bug in droopy in jammy and provides a patch. You want to sponsor the fix. What would you upload (version numbers and releases)?
20:18 <cpete> utkarsh2102: there may be other reasons for the package not migrating. update_excuses output is helpful here
20:18 <utkarsh2102> cpete: suppose there's nothing in update_excuses, all autopkgtests pass, yet the package doesn't migrate
20:18 <utkarsh2102> what next?
20:21 <cpete> utkarsh2102: hmmm reasons for this scenario don't immediately come to mind. (is there a block-proposed tag for devel series?) I would probably head over to ubuntu-devel or ubuntu-release and ask
20:21 <utkarsh2102> no tags, that'd show up in update_excuses
20:22 <cpete> utkarsh2102: and if it were waiting for another package to migrate it would show up there too. So I don't know here
20:22 <utkarsh2102> got it, thanks o/
20:23 <utkarsh2102> i was trying to get at uninstallability issues :)
20:23 <cpete> Ah, I feeel like I usually see those in autopkgtest before they dissapear from update_excuses
20:24 <utkarsh2102> update_output tells you about them! :)
20:24 <utkarsh2102> update_output.txt
20:24 <utkarsh2102> cpete: i'll let you answer bdrung's question next
20:24 <cpete> Ahh. Another useful tool of the ubuntu archive toolbox
20:24 <bdrung> cpete, Imagine a user detects a bug in droopy in jammy and provides a patch. You want to sponsor the fix. What would you upload (version numbers and releases) in case you are a core-dev?
20:27 <cpete> bdrung: sorry for the delay. Looking at droopy. I see that for Jammy, Noble, and Oracular are all the same version. I would first upload their patch to oracular-devel as 0.20160830-5ubuntu1
20:27 <bdrung> good and then?
20:29 <cpete> Considering all is well and they have SRU templates for Noble and Jammy, I would upload 0.20160830-5ubuntu1 to Jammy and Noble. Although my intuition is telling me to make it ...-5ubuntu1.0, but again I need to look up the versioning string guidance.
20:30 <utkarsh2102> uh, what?
20:30 <bdrung> cpete, could you upload 0.20160830-5ubuntu1 to jammy and noble or what would happen?
20:30 <utkarsh2102> -5ubuntu1.0 to SRU and -5ubuntu1 to devel is already contradicting what you said earlier
20:32 <cpete> bdrung:  thinking. utkarsh2102: that was more of an incomplete thought thinking about the right versioning scheme, not to say that would be right process there
20:32 <bdrung> cpete, what constraints do the version numbers need to follow?
20:33 <cpete> bdrung: The version number in noble-updates needs to be higher than the version in noble-release.
20:34 <cpete> since there's no -security upload there
20:34 <bdrung> cpete, are there more contraints for the noble upload?
20:36 <cpete> I suppose it would need to be less than the version in oracular.
20:36 <bdrung> yes
20:37 <utkarsh2102> ok, I am serverely over time, it's 2 AM here and I'll need to conclude soon
20:37 <utkarsh2102> bdrung: are you ready to vote?
20:37 <utkarsh2102> teward: ^?
20:37 <teward> i have no questions, ready to vote
20:38 <utkarsh2102> perf
20:38 <bdrung> okay, ready
20:38 <utkarsh2102> perf
20:38 <utkarsh2102> #ubuntu-devel Chris to get core-dev rights
20:38 <utkarsh2102> ooof
20:38 <utkarsh2102> libera
20:39 <utkarsh2102> #vote Chris to get core-dev rights
20:39 <meetingology> Please vote on: Chris to get core-dev rights
20:39 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
20:39 <utkarsh2102> #voters bdrung teward utkarsh2102 rbasak bdmurray tsimonq2 schopin
20:39 <meetingology> Warning: 'schopin' not in channel
20:39 <meetingology> Current voters: bdmurray, bdrung, rbasak, schopin, teward, tsimonq2, utkarsh2102
20:39 <utkarsh2102> ok, go
20:42 <bdrung> +1 the application is still on the thin side and some more areas to dive in (like versioning of SRUs) but I have worked with cpete and are confident that he will follow his statement "I certainly still expect to ask for review and thoroughly test changes before committing something I'm not 100% certain about."
20:42 <meetingology> +1 the application is still on the thin side and some more areas to dive in (like versioning of SRUs) but I have worked with cpete and are confident that he will follow his statement "I certainly still expect to ask for review and thoroughly test changes before committing something I'm not 100% certain about." received from bdrung
20:43 <utkarsh2102> -1; apologies, I think Chris is great & I really appreciate his work and whilst he's got strong endorsements, they didn't answer the last three questions quite correctly. versioning is quite an important subject and I think that is where I go from +1 to -1. :(
20:43 <meetingology> -1; apologies, I think Chris is great & I really appreciate his work and whilst he's got strong endorsements, they didn't answer the last three questions quite correctly. versioning is quite an important subject and I think that is where I go from +1 to -1. :( received from utkarsh2102
20:45 <utkarsh2102> teward: ?
20:45 <teward> sorry my connection is slow
20:46 <teward> -1 I believe that you have more to learn and prove knowledge of before we can give you core dev levels of access. Versioning is critical in Ubuntu and not understanding that in and of itself is a necessary skill that you don't currently have, therefore I must provide a -1 vote.
20:46 <meetingology> -1 I believe that you have more to learn and prove knowledge of before we can give you core dev levels of access. Versioning is critical in Ubuntu and not understanding that in and of itself is a necessary skill that you don't currently have, therefore I must provide a -1 vote. received from teward
20:47 <utkarsh2102> #endvote
20:47 <meetingology> Voting ended on: Chris to get core-dev rights
20:47 <meetingology> Votes for: 1, Votes against: 2, Abstentions: 0
20:47 <meetingology> Motion denied
20:48 <utkarsh2102> i'll carry it to the ML
20:48 <cpete> Ack. Thanks for your time all. I'll brush up so I can give better answers for the next go around.
20:48 <utkarsh2102> cpete: apologies we can't complete the voting yet.
20:49 <utkarsh2102> cpete: whilst you have a phenomenal set of people (foundations!!!) to help you through, please feel free to reach out if you need help at any point!
20:50 <cpete> utkarsh2102: I certainly will! Thanks :)
20:50 <utkarsh2102> cpete: i hope you get your rights sooner but one quick thing I'd like to see is cross-team interaction. All your endorsers are Foundations
20:50 <bdrung> regarding quorum: Vote is between -5 and 3, outcome unknown as quorum was not reached
20:50 <utkarsh2102> I'd like to see you get more involved with others
20:51 <bdrung> +1 on more cross-team interactions
20:51 <utkarsh2102> bdrung: oh wait, even if it's 3, it's still quorum not reached, right?
20:52 <utkarsh2102> that's a.....denied?
20:52 <utkarsh2102> we're 7, quorum is 4
20:53 <bdrung> utkarsh2102, we are currently at -1, but the votes of the other can move it to -5 (denied) or 3 (accepted)
20:53 <utkarsh2102> but that's what I am saying
20:53 <utkarsh2102> 3 is not accepted
20:53 <utkarsh2102> 4 is accepted, isn't it?
20:53 <utkarsh2102> or have I gotten it wrong? I should sleep soon, oof
20:53 <utkarsh2102> anyway, I'll take it to the ML and conclude here for now
20:53 <utkarsh2102> #topic AOB
20:54 <utkarsh2102> utkarsh2102 already added mruffell to the right teams and announced the application
20:54 <utkarsh2102> #action utkarsh2102 to take cpete's application to ML
20:54 * meetingology utkarsh2102 to take cpete's application to ML
20:54 <utkarsh2102> teward: AOB from your side?
20:54 <bdrung> utkarsh2102, four +1 are enough because the remaining members can only decrease it to 1 (by voting 3x -1).
20:55 <bdrung> the sum of the votes only need to be positive
20:55 <teward> utkarsh2102: not enough connection strength to state it and get a reply too
20:55 <utkarsh2102> gotcha
20:55 <teward> so i'll just send to the ML for that
20:55 <utkarsh2102> teward: okeydoke, yes, thank you!
20:55 <utkarsh2102> #endmeeting