16:07 <utkarsh2102> #startmeeting Developer Membership Board
16:07 <meetingology> Meeting started at 16:07:21 UTC.  The chair is utkarsh2102.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:07 <meetingology> Available commands: action, commands, idea, info, link, nick
16:07 <utkarsh2102> #agenda
16:07 <utkarsh2102> #link https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda
16:07 <utkarsh2102> #topic PPU Applications
16:08 <utkarsh2102> #subtopic Mitchell Dzurick
16:08 <utkarsh2102> #link https://wiki.ubuntu.com/mitchdz/ServerUploaderDeveloperApplication
16:08 <utkarsh2102> mitchdz: hey! could you please introduce yourself? :)
16:09 <mitchdz> Of course!
16:09 <mitchdz> Hi everyone, I'm Mitch, you might know me already as I'm working at Canonical on the CPC team, mainly working on AWS related packages and tasks.
16:10 <mitchdz> I'm looking to attain server package upload rights, to help contribute to the Ubuntu community :)
16:11 <rbasak> o/
16:12 <rbasak> Is Bryce around?
16:12 <rbasak> His endorsement sounds like it was for PPU rather than server packageset. I wondered what the wiki said at the time he wrote the endorsement and it doesn't look like he edited the wiki himself?
16:13 <rbasak> It's probably fine but he should probably confirm what it is he endorsed you for exactly.
16:15 <rbasak> I pinged him privately
16:16 <rbasak> Shall we ask questions in the meantime? I have a few unless someone else wants to drive first?
16:16 <cpaelzer> he is around
16:16 <bryceh> hi, sorry, was in another meeting.
16:16 <cpaelzer> but he'd had to let me down for you :-P
16:17 <rbasak> bryceh: thanks for joining! Your endorsement at https://wiki.ubuntu.com/mitchdz/ServerUploaderDeveloperApplication#Bryce_Harrington - is that for PPU or the server packageset please?
16:17 <rbasak> Meanwhile I guess I'll start with questions
16:17 <bryceh> server packageset was what I had in mind, was he applying for PPU?
16:18 <rbasak> That's fine - your endorsement says PPU
16:18 <bryceh> ah, sorry, then I was wrong
16:18 <rbasak> No worries. The wiki history didn't leave me any wiser. Thank you for confirming!
16:19 <rbasak> mitchdz: OK so first question. At what point in the release cycle must you stop uploading feature changes, where can you find that information, how do you decide what constitutes a feature change, what do you do if you want an exception?
16:19 <mitchdz> Thanks bryce!
16:21 <mitchdz> Thanks Robie, For oracular, as an example, you can find those dates at https://discourse.ubuntu.com/t/oracular-oriole-release-schedule/36460 where August 15th is Feature Freeze. Feature freeze is any changes that adds a feature which is pretty much most things that are not strictly bug fixes or cosmetic changes such as branding.
16:22 <mitchdz> You will file an FFE to make any feature changes
16:22 <rbasak> Great. Where's the process for filing an FFe documented please?
16:22 <mitchdz> https://wiki.ubuntu.com/FreezeExceptionProcess
16:23 <rbasak> Excellent. Next, let's say that you upload an Ubuntu delta to a server package. What happens next wrt. that delta? What the process to ensure that we continue to keep up with changes upstream?
16:25 <mitchdz> First I like to see if the change is relevant for upstream, and if not, then I look to include the changes in Debian so we do not diverge. If it does not apply to either (for example, it's a change for systemd and Debian wants sysvinit) I'll make a delta with sufficient comments explaining why we are holding those changes, and what to look out for when doing the next merge or fixing bugs.
16:25 <rbasak> when doing the next merge> how do you ensure that this happens and doesn't get forgotten about?
16:27 <mitchdz> There's a few ways, 2 that I like - first I like to have a descriptive summary in the git commit message stating to carry it over, look into it more, or potentially drop. Second option if it might require a discussion is to bring it up on the merge bug in LP.
16:27 <rbasak> Where does the LP merge bug come from?
16:28 <mitchdz> For the server packages Bryce usually makes them
16:28 <rbasak> OK :)
16:28 <rbasak> I suppose what I was looking for is that you understand that the process is that the server team tracks these things :)
16:28 <utkarsh2102> I'd also like to add information in patches, if they are, as PEP-3 guidelines :)
16:29 <utkarsh2102> DEP* :)
16:29 <rbasak> Next, let's say you do an upload to add a delta. What do you need to ensure next, and how do you do that?
16:29 <mitchdz> Definitely Utkarsh, those help too :)
16:30 <mitchdz> rbasak: Is this a general question of what should be done after a package is uploaded?
16:31 <rbasak> mitchdz: socially, you have some responsibilities in the days after you upload a package. What are those?
16:32 <mitchdz> Ah understood
16:33 <mitchdz> The package would then enter the unapproved queue and if it gets neglected, it would be nice to ping in IRC so it doesn't get lost. If the packages have any issues, it would be nice to guide along the issues especially if the committer is new to the process. Once the package is in the -proposed pocket then monitoring the package for any regressions is also necessary.
16:34 <mitchdz> s/commiter/individual making the changes/g
16:34 <bdmurray> What kind of "issues" could occru?
16:35 <bdmurray> s/occru/occur/
16:35 <mitchdz> Perhaps something wasn't caught such as a change that seems harmless, but upon further review could have side effects that are not intended
16:36 <rbasak> Are you thinking of an SRU specifically? I was thinking about an upload to the development release.
16:36 <mitchdz> Ah yes I'm in the SRU mindset mostly
16:36 <mitchdz> but a decent chunk of the process still applies to devel
16:36 <rbasak> I think your answer makes sense when speaking of an SRU, but please could you also answer the question for a development release upload?
16:37 <mitchdz> For development release it's common to add a lot of changes/features so it would be good to keep an eye out for new bugs coming out that pertain to changes you made, especially because you will probably be most informed about the changes so could address them easily.
16:37 <rbasak> OK, so let's say that you do that upload and the package is built in oracular-proposed. What happens next?
16:38 <bdmurray> How would you learn about regressions for a package version in -proposed?
16:38 <mitchdz> You would look for your package in https://ubuntu-archive-team.ubuntu.com/proposed-migration/update_excuses.html
16:39 <mitchdz> I usually just ctrl+f the package name I'm working on to see if anything is sad now
16:40 <rbasak> Do you know where the documentation is with guides for working on that page?
16:40 <mitchdz> Would that be this page? https://github.com/canonical/ubuntu-maintainers-handbook/blob/main/ProposedMigration.md
16:41 <rbasak> Sure, that'll do :)
16:41 <rbasak> Thanks! I have no more questions.
16:41 <mitchdz> Thanks Robie :)
16:44 <utkarsh2102> ok, no questions from me either.
16:44 <bdmurray> I have no further questions.
16:44 <utkarsh2102> sil2100?
16:44 <sil2100> No question
16:45 <sil2100> ...s
16:45 <utkarsh2102> coolio, I'll proceed to vote then
16:45 <utkarsh2102> #vote Mitchell Dzurick to get PPU rights for Server related packages
16:45 <meetingology> Please vote on: Mitchell Dzurick to get PPU rights for Server related packages
16:45 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:45 <rbasak> +1
16:45 <meetingology> +1 received from rbasak
16:46 <bdmurray> +1
16:46 <meetingology> +1 received from bdmurray
16:46 <sil2100> +1
16:46 <meetingology> +1 received from sil2100
16:46 <rbasak> FWIW, it's not PPU. It's server packageset.
16:46 <utkarsh2102> +1; I've known and seen Mitch's work for quite a while now and I convinced that he'll be a good addition. Please don't forget to ask for help and go into rabbit holes unnecessarily. ;)
16:46 <meetingology> +1; I've known and seen Mitch's work for quite a while now and I convinced that he'll be a good addition. Please don't forget to ask for help and go into rabbit holes unnecessarily. ;) received from utkarsh2102
16:46 <utkarsh2102> rbasak: ah yes
16:46 <utkarsh2102> #endvote
16:46 <meetingology> Voting ended on: Mitchell Dzurick to get PPU rights for Server related packages
16:46 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
16:46 <meetingology> Motion carried
16:46 <rbasak> PPU would imply a separate ACL entry, which this isn't. Server packageset just needs ~ubuntu-server-dev team membership
16:46 <rbasak> (+ ~ubuntu-dev etc)
16:46 <utkarsh2102> yes, I am aware
16:47 <utkarsh2102> thanks!
16:47 <utkarsh2102> mitchdz: congratulations, I'll add your acl shortly
16:47 <mitchdz> \o/
16:47 <rbasak> Contratulations Mitch!
16:47 <rbasak> Contra? Congra.
16:47 <mitchdz> Thank you!
16:47 <utkarsh2102> #ubuntu-devel utkarsh2102 to add mitchdz to the server packageset and announce the same
16:47 <utkarsh2102> ughhhh, autocorrect
16:47 <rbasak> Although I like contragulations. For when you don't really mean it. But I did mean it, so congratulations :-P
16:48 <utkarsh2102> #action utkarsh2102 to add mitchdz to the server packageset and announce the same
16:48 * meetingology utkarsh2102 to add mitchdz to the server packageset and announce the same
16:48 <utkarsh2102> ok, anything else?
16:48 <mitchdz> Speaking of PPU, I sent an email just before this that I would also be interested in a PPU for `ec2-hibinit-agent` if we want to squeeze that in :) No worries if not
16:48 <rbasak> We still have that outstanding unassigned ML item I think?
16:48 <utkarsh2102> mitchdz: I think that's doable - rbasak, bdmurray, sil2100?
16:49 <rbasak> Looking
16:50 <mitchdz> I'd be glad to give a quick explanation of the package and why I'm looking to attain uploader rights
16:50 <utkarsh2102> I am happy to vote directly, though
16:50 <utkarsh2102> mitchdz: a "why" would be helpful for others to get context
16:50 <utkarsh2102> so please do that
16:50 <mitchdz> Sure, shortly - `ec2-hibinit-agent
16:51 <mitchdz> is one of the cloud agents to support hibernation. It mainly sets up SWAP on the system and talks to the AWS backend to get information.
16:51 <mitchdz> It's one of those packages that often needs a change "all the way back" usually to Focal for pretty simple changes
16:52 <mitchdz> So I would like to get uploader rights to help alleviate the burden of finding a sponsor for these types of packages
16:52 <rbasak> So the first couple of sponsored uploads I looked into seem to have significant review feedback.
16:52 <rbasak> https://bugs.launchpad.net/ubuntu/+source/ec2-hibinit-agent/+bug/2031345/comments/4 is one
16:53 <mitchdz> Heh yeah, those were some of my first changes so I was learning a bit back then :)
16:53 <rbasak> https://bugs.launchpad.net/ubuntu/+source/ec2-hibinit-agent/+bug/2023924/comments/10 is another
16:54 <rbasak> That may be so but those are (nearly) your most recent ec2-hibinit-agent uploads
16:56 <rbasak> It feels like this is a tricky, messy package (by its nature - not a problem with the packaging itself)
16:57 <rbasak> IMHO, it needs careful review, and the still fairly recent track record seems to suggest that this is a good thing and should continue for now, IMHO.
16:57 <rbasak> It's subjective though and others' views may vary!
16:57 <rbasak> I don't think it's anything you've done or not done, but my conclusion for now is that it's inappropriate for a new uploader to have PPU for this.
16:58 <mitchdz> That's fair enough, I can definitely come again when more changes are done. I get requests for a lot of changes and have pushed back on a few since they don't apply to Ubuntu
16:59 <utkarsh2102> just to be clear - mitchdz, you'll apply again in the upcoming weeks and not now, right?
16:59 <rbasak> What I'd like to see is a track record of sponsored uploads where you've successfully anticipated key points of review feedback. It's fine if you've antipicated by asking questions though!
17:00 <rbasak> I'd want those examples to be of similar complexity to the previous uploads.
17:01 <mitchdz> Yeah if we decide not to do the PPU for ec2-hibinit-agent, that will be a later date
17:01 <mitchdz> or perhaps I'll work towards the new ubuntu-cloud :)
17:01 <utkarsh2102> got it, alright, thanks
17:01 <utkarsh2102> we're already at the top of the hour
17:01 <bryceh> or core-dev...?  ;=)
17:02 <rbasak> I remain concerned that sgmoore's ML request still has not had an answer.
17:02 <rbasak> Can someone take that please?
17:02 <utkarsh2102> yes, I plan to do it this week
17:02 <rbasak> We can't keep skipping the standing agenda items :-(
17:02 <utkarsh2102> I have a rough draft ready, just need to polish it, and send it out
17:02 <rbasak> Thanks! Maybe give yourself an action?
17:03 <utkarsh2102> #action utkarsh2102 to reply to Scarlett's mail on the ML
17:03 * meetingology utkarsh2102 to reply to Scarlett's mail on the ML
17:03 <rbasak> Thank you!
17:03 <utkarsh2102> #topic AOB
17:03 <utkarsh2102> anything else?
17:03 <rbasak> Nothing else from me thanks!
17:03 <utkarsh2102> 5..
17:03 <utkarsh2102> 4..
17:03 <utkarsh2102> 3..
17:04 <utkarsh2102> 2..
17:04 <utkarsh2102> 1..
17:04 <utkarsh2102> #endmeeting