19:01 <utkarsh2102> #startmeeting Developer Membership Board
19:01 <meetingology> Meeting started at 19:01:43 UTC.  The chair is utkarsh2102.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:01 <meetingology> Available commands: action, commands, idea, info, link, nick
19:01 <utkarsh2102> hello, everyone! o/
19:02 <utkarsh2102> we have some things to discuss
19:02 <utkarsh2102> but per usual, I'll start with today's application
19:02 <rbasak> I suggest looking at sudip's application first, but please note that there's an outstanding request from sgmoore that hasn't received attention.
19:02 <utkarsh2102> looks like we have applicants for the next 4 meeting, yay
19:02 <rbasak> It'd be good to have someone take an action to address that please, if we don't have time to do anything else.
19:02 <utkarsh2102> rbasak: I intend to reply to that but I wanted to talk about it here first
19:02 <utkarsh2102> anyway..
19:03 <utkarsh2102> #topic MOTU Application
19:03 <utkarsh2102> #subtopic  Sudip Mukherjee
19:03 <utkarsh2102> #link https://wiki.ubuntu.com/sudipmuk/MotuApplication
19:03 <utkarsh2102> sudip: hellu, could you please introduce yourself? :)
19:04 <sudip> Hi All, I believe my application has the full intro. But for a summary, I have been an Ubuntu user for a long time but started contributing since last year (from Ubuntu Summit). I am not part of any Canonical team, just a community volunteer and like to look at bugs in my spare time.
19:04 <utkarsh2102> And you're also a DD since 2020. Nice.
19:04 <sudip> yes :)
19:04 <utkarsh2102> \o/
19:05 <utkarsh2102> thanks, sudip
19:05 <utkarsh2102> with that, I am going to open the floor for questions
19:05 <utkarsh2102> *ta dum*
19:05 <rbasak> Disclosure: sudip is local to me, I see him regularly, and I introduced him to various Ubuntu-specific bits at the Ubuntu Summit in Riga last year. I don't think that there's sufficient conflict of interest to recuse myself though (or else we'd never get anywhere with promising applicants that we get to know well!)
19:06 <rbasak> ...and thanks to utkarsh2102 for introducing us :-)
19:06 <utkarsh2102> hehe
19:06 <sudip> yes, thanks to utkarsh2102
19:06 <utkarsh2102> which means, I know Sudip as well. :)
19:06 <sudip> lol, yes, you do
19:07 <utkarsh2102> but there's no conflict of interest, I haven't directly worked with Sudip but have interacted a bunch - he's a <3 person.
19:07 <rbasak> So let me start with a question on transitions. sudip: how would you identify if you're about to trigger a transition when you're ready to upload?
19:08 <sudip> I will first check Debian bug report if there was transition request or not. If there is one, then it will definitely trigger a transition in Ubuntu. But if its not a Debian package and it bumps soname or changes API/ABI then I will check rdep.
19:09 <rbasak> OK. In the common case, how would you identify if the upload bumps soname?
19:09 * sil2100 has a question when there's a moment
19:09 * utkarsh2102 joins the queue
19:09 <sudip> the package version should change, like libfoo0 will become libfoo1
19:10 <rbasak> Thanks! I have further questions but let's go to sil2100 first I guess?
19:10 <sil2100> o/
19:10 <sudip> but again, there was a recent Debian bug where the package version was not changed with SONAME bump
19:11 <sil2100> sudip: let's say you want to bring a completely new piece of software into Ubuntu. How would you do that? What are the possible options and processes for that?
19:12 <sudip> I will prefer to do it in Debian first. But if I have to do it in Ubuntu, then iirc, it needs to be reviewed by two core-dev first
19:13 <sil2100> sudip: can you elaborate on the two core-devs?
19:14 <sudip> well, https://wiki.ubuntu.com/UbuntuDevelopment/NewPackages says "MOTUs can upload new packages directly to the archive. However they are greatly encouraged to have a new package reviewed prior to uploading"
19:15 <sudip> and I was wrong about 2 core-dev, that is an old requirement which has been dropped now
19:15 <sil2100> Is uploading the package the only thing that's needed? And when will the package be made available in Ubuntu?
19:17 <sudip> new packages will go through a review process and final review by the archieve admins
19:17 <sil2100> Where will the review progress be tracked? Is there any 'paperwork' related to requesting new packages to Ubuntu?
19:18 <sudip> there needs to be a bug open for that for packaging it
19:19 <sil2100> Fair enough! Ok, thank you :)
19:19 <sudip> I missed saying with the tag "needs-packaging."
19:19 <sil2100> I open the floor to others
19:22 * sudip waits for questions from utkarsh2102 and rbasak 
19:22 <rbasak> sudip: where can you find the dates of the relevant freezes in the current Ubuntu development cycle? For feature freeze in particular, what would you need to consider if for example feature freeze were active for Oracular and you were looking at uploading version 2.3.2 of package foo while 2.3.1 were in the Oracular release pocket?
19:23 <sudip> Oracular FF is at https://discourse.ubuntu.com/t/oracular-oriole-release-schedule/36460
19:24 <sudip> depends on 2.3.2 diff
19:24 <sudip> if its a leaf package then I will be comfortable with it
19:25 <sudip> but if its a library, then I will check the diff to confirm there is no ABI/API change
19:25 <rbasak> Could you give me an example of a change that, if it were in the diff, should block it from being uploaded during feature freeze without an exception?
19:25 <rbasak> Oh I suppose you already answered that, sorry :)
19:25 <sudip> :)
19:25 <rbasak> What's the process of getting an exception if you thought one were appropriate?
19:26 <sudip> I need to file a bug and attach the debdiff to it and subscribe the release team
19:27 <rbasak> OK, thanks! Moving on, after you've uploaded a delta to Ubuntu, what happens next?
19:27 <sudip> when a package is uploaded it will first go to -proposed where it will be built for all the arch its supposed to go to, autopkgtests will be run, if there are autopkgtest of the rdeps then those will also be run. And, if tests are ok, then it will migrate to the release suite.
19:28 <rbasak> OK. And if something holds up migration, then who needs to take care of that and where can they find more information about it?
19:29 <sudip> update_excuses will have the details and usually its the responsibility of the uploader to check and take care of that
19:29 <rbasak> Thanks. Long term, what happens to the Ubuntu delta with respect to further packaging/upstream updates in Debian?
19:30 <sudip> Usually I also open a Debian bug if the bug is reproduced in  unstable, and the delta is added to Debian then it needs a sync or else with the new Debian package we have to do a merge
19:31 <rbasak> Do you know how to find packages that require a merge?
19:31 <sudip> I check at https://merges.ubuntu.com/
19:31 <sudip> mostly - https://merges.ubuntu.com/universe.html?showProposed=true&showMergeNeeded=true&showLongBinaries=true
19:31 <rbasak> Great. Thanks!
19:32 <rbasak> utkarsh2102: did you have a question?
19:32 <utkarsh2102> yes
19:32 <utkarsh2102> what if update_excuses doesn't say anything but your package is still stuck in -proposed, what will you do? where will you look?
19:33 <utkarsh2102> I mean, what if update_excuses has everything green and passing but still your upload hasn't migrated.
19:34 <sudip> https://wiki.ubuntu.com/ProposedMigration says to check the  update_output.txt bt thats quite cryptic
19:34 <utkarsh2102> what will you do then?
19:34 <utkarsh2102> heh, correct!
19:34 <utkarsh2102> I am glad that you know where to look up at least ;)
19:34 <sudip> I have a long list of bookmarks :)
19:35 <utkarsh2102> sudip: re: cryptic - https://wiki.ubuntu.com/ProposedMigration#The_update_output.txt_file_is_completely_unreadable.21
19:35 <utkarsh2102> :)
19:35 <utkarsh2102> anyway, I might have more questions but I'll wait and see if anybody else wants to ask first?
19:36 <sil2100> No questions from me
19:36 <utkarsh2102> rbasak, sil2100, bdmurray?
19:36 <utkarsh2102> thanks o/
19:36 <bdmurray> I have no questions
19:36 <rbasak> I have no more questions thanks
19:37 <utkarsh2102> ok, I have none either
19:37 <utkarsh2102> let's proceed to vote
19:38 <utkarsh2102> #vote Sudip Mukherjee to get MOTU rights
19:38 <meetingology> Please vote on: Sudip Mukherjee to get MOTU rights
19:38 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:38 <utkarsh2102> seb128: o/
19:39 <seb128> hey, sorry I had some personal conflict, still joining in case there is a need for a quorum or something
19:39 <rbasak> +1 I have personally observed sudip's significant contributions flowing through the sponsorship and SRU queues over the past months. He has fixed many high impact bugs in universe that had been unattended for months or years. He's clearly a skilled engineer especially being a Debian Developer. I'm confident that he understands Ubuntu-specific process. I think his immediate addition to the MOTU team
19:39 <meetingology> +1 I have personally observed sudip's significant contributions flowing through the sponsorship and SRU queues over the past months. He has fixed many high impact bugs in universe that had been unattended for months or years. He's clearly a skilled engineer especially being a Debian Developer. I'm confident that he understands Ubuntu-specific process. I think his immediate addition to the MOTU team received from rbasak
19:39 <sil2100> +1
19:39 <meetingology> +1 received from sil2100
19:39 <rbasak> will be valuable to Ubuntu. And his various endorsements concur with my direct observations.
19:39 <rbasak> Thank you for your continued contributions!
19:39 <rbasak> FWIW, I think your recent SRU work has been exemplary and I wish some existing uploaders could produce work of the same quality!
19:40 <utkarsh2102> +1; great endorsements, good answers - I am glad that you have your links ready and know where to look. I will still ask that you consult a fellow MOTU/core-dev whenever in doubt or you're unsure about something. I appreciate your good work and I'm happy you've finally applied to be a MOTU. Hope to see you get core-dev soon! ;)
19:40 <meetingology> +1; great endorsements, good answers - I am glad that you have your links ready and know where to look. I will still ask that you consult a fellow MOTU/core-dev whenever in doubt or you're unsure about something. I appreciate your good work and I'm happy you've finally applied to be a MOTU. Hope to see you get core-dev soon! ;) received from utkarsh2102
19:41 <seb128> +1 from me, sorry I had to miss most of the meeting but the wiki application is solid enough to convince me
19:41 <meetingology> +1 from me, sorry I had to miss most of the meeting but the wiki application is solid enough to convince me received from seb128
19:41 <utkarsh2102> bdmurray: hey? o/
19:42 <bdmurray> +1
19:42 <meetingology> +1 received from bdmurray
19:42 <bdmurray> sorry still in a meeting
19:42 <utkarsh2102> #endvote
19:42 <meetingology> Voting ended on: Sudip Mukherjee to get MOTU rights
19:42 <meetingology> Votes for: 5, Votes against: 0, Abstentions: 0
19:42 <meetingology> Motion carried
19:42 <utkarsh2102> congratulations, sudip :D
19:42 <seb128> sudip, congrats!
19:42 <sudip> thanks all \o/
19:43 <utkarsh2102> #action Utkarsh to announce successful application and add sudip to the right team.
19:43 * meetingology Utkarsh to announce successful application and add sudip to the right team.
19:43 <utkarsh2102> #topic AOB
19:43 <utkarsh2102> rbasak: I find the request from Scarelett unreasonable
19:43 <bdmurray> I briefly looked and don't know how to create a diff of the packages
19:44 <utkarsh2102> I would be a -1 to such a request which asks us to go through a seed with hundreds of packages and ask us to add them to the packageset
19:44 <utkarsh2102> nope, not happening like that
19:44 <utkarsh2102> I'll reply to the thread asking this to be a bit more systematically - that is, give us a diff and explanation for packages that aren't obvious
19:44 <utkarsh2102> do you think that makes sense?
19:45 <bdmurray> Well if any of us know how to do it given how long its been I think we should
19:45 <rbasak> We used to have a script that worked all this out automatically. So it's a reasonable request IMHO - because we should just be able to run the script and call it good - except that the script has gone unmaintained.
19:46 <rbasak> Volunteers to fix the automated packageset management welcome! But I've been saying that for years unfortunately with nobody volunteering.
19:46 <rbasak> In the meantime, I guess we can add a specific list of packages to the packageset or otherwise tweak it as needed to fix the holdup, but the details of that need to be worked out with sgmoore on the ML I guess.
19:47 <rbasak> So that's basically the same as utkarsh2102's suggestion then I suppose?
19:47 <utkarsh2102> right, hehe
19:47 <seb128> agreed, ideally the script would work but it doesn't but at least the DMB is usually responsive to reasonable requests to add packages to a set
19:47 <rbasak> For anyone else reading: it doesn't necessarily need a member of the DMB to fix the management script!
19:48 <rbasak> We're supposed to have a regular meeting agenda item to check for outstanding ML requests.
19:48 <utkarsh2102> #action Utkarsh to reply to Scarlett's mail at some point this week.
19:48 * meetingology Utkarsh to reply to Scarlett's mail at some point this week.
19:48 <rbasak> I guess this is a reminder to not forget to do that :-/
19:48 <rbasak> Thanks utkarsh2102!
19:48 <utkarsh2102> o/
19:49 <utkarsh2102> rbasak: I do a email scrub for DMB from time to time
19:49 <utkarsh2102> Scarlett's mail hadn't been forgotten
19:49 <utkarsh2102> it's one of those big thing to action on without any script or documentation, so..
19:49 <utkarsh2102> anyway
19:49 <utkarsh2102> anything else?
19:49 <rbasak> One more AOB item
19:50 <utkarsh2102> yes, please
19:50 <rbasak> Nominations to stand for the DMB close end of day (UTC) tomorrow.
19:50 <rbasak> Please consider standing if you haven't already, and get those nominations in!
19:50 <utkarsh2102> thanks!
19:50 <sil2100> o/
19:50 <sil2100> Sure
19:50 <rbasak> As it stands there are three nomineees, and seven seats.
19:50 <utkarsh2102> anything else, anybody?
19:50 <sil2100> Thanks!
19:51 <utkarsh2102> dw, it'll fill up fast
19:51 <rbasak> (though there might be a flurry tomorrow; I hope there will be, anyway!)
19:51 <rbasak> Nothing else from me. Thank you for chairing utkarsh2102!
19:51 <rbasak> And congrats to sudip
19:51 <utkarsh2102> of course! :D
19:52 <utkarsh2102> ending the meeting in 5
19:52 <sudip> thanks rbasak :)
19:52 <utkarsh2102> 4
19:52 <utkarsh2102> 3
19:52 <utkarsh2102> 2
19:52 <utkarsh2102> 1
19:52 <utkarsh2102> #endmeeting