20:05 <amurray> #startmeeting Ubuntu Technical Board
20:05 <meetingology> Meeting started at 20:05:16 UTC.  The chair is amurray.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
20:05 <meetingology> Available commands: action, commands, idea, info, link, nick
20:05 <amurray> #topic Apologies
20:05 <amurray> none but seems sil2100 is unavailable
20:05 <amurray> #topic Action review
20:06 * amurray seb128/amurray/sil2100 to help drafting the snap-store Ubuntu-specific tracks usage
20:06 <amurray> no update on this from my side
20:06 <seb128> neither from mine, sorry
20:06 <amurray> no worries - will carry over
20:06 <seb128> and I didn't schedule the meeting
20:06 <amurray> #action seb128/amurray/sil2100 to help drafting the snap-store Ubuntu-specific tracks usage
20:06 * meetingology seb128/amurray/sil2100 to help drafting the snap-store Ubuntu-specific tracks usage
20:07 * amurray seb128 to organize a meeting to unblock the draft of the tracks usage section
20:07 <amurray> carry over?
20:08 <seb128> yes
20:08 <amurray> #action seb128 to organize a meeting to unblock the draft of the tracks usage section
20:08 * meetingology seb128 to organize a meeting to unblock the draft of the tracks usage section
20:08 * amurray rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
20:08 <rbasak> Carry over please
20:08 <amurray> #action rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
20:08 * meetingology rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
20:08 * amurray rbasak to follow up on finding consensus on question of test plans for third party apps
20:09 <rbasak> Carry over, but this one I'd like to talk about if we have time today please
20:09 <amurray> ok do you want to do that during AOB?
20:09 <rbasak> Yes let's do it at the end
20:10 <amurray> #action rbasak to follow up on finding consensus on question of test plans for third party apps
20:10 * meetingology rbasak to follow up on finding consensus on question of test plans for third party apps
20:10 * amurray rbasak to open wider discussion on third-party repo policy
20:10 <rbasak> It's low priority so whatever else comes first can have the time first
20:10 <rbasak> This is blocked on the previous
20:10 <amurray> ack
20:10 <amurray> #action rbasak to open wider discussion on third-party repo policy
20:10 * meetingology rbasak to open wider discussion on third-party repo policy
20:10 * amurray seb128 to continue working with SRU, AA, Release, Backporters and Security teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:10 <seb128> carry over please
20:10 <amurray> #action seb128 to continue working with SRU, AA, Release, Backporters and Security teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:10 * meetingology seb128 to continue working with SRU, AA, Release, Backporters and Security teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:10 * amurray vorlon to write up draft guidelines for packages in the archive that download from the Internet
20:11 <vorlon> I suggest we drop this from here and that I track it elsewhere, since I'm the one who was arguing for it
20:11 <vorlon> and haven't had time to follow through
20:12 <amurray> would it be worth filing at https://bugs.launchpad.net/techboard to track this?
20:12 <vorlon> only if you think the TB wants to keep track of it IMHO
20:12 <vorlon> since it was my proposal, it's more useful for me to track the TODO elsewhere
20:13 <amurray> I don't think the TB needs to track it
20:14 <amurray> I'll drop it from the agenda then
20:14 * amurray seb128 to follow-up with ubuntu cinnamon on 24.04 request
20:14 <seb128> I did, and they replied so I need to process the details and follow up
20:14 <seb128> let's carry over
20:15 <amurray> #action seb128 to follow-up with ubuntu cinnamon on 24.04 request
20:15 * meetingology seb128 to follow-up with ubuntu cinnamon on 24.04 request
20:15 * amurray seb128 to follow-up with ubuntu budgie on 24.04 request
20:15 <seb128> done
20:15 <amurray> ack - https://lists.ubuntu.com/archives/technical-board/2024-January/002874.html
20:15 <seb128> that one should have been deleted from the actions in favor of the one 3 items down
20:15 <seb128> which is also done
20:16 <amurray> ah ok  - I'll keep plowing through the agenda to make sure we don't miss anything
20:16 * amurray amurray to send confirmation of successful LTS status for UbuntuKylin 24.04
20:16 <amurray> done - https://lists.ubuntu.com/archives/technical-board/2024-January/002870.html
20:17 * amurray sil2100 to review the lubuntu LTS participation request and follow up as appropriate (question or call for vote)
20:17 <amurray> I'll put that as carry over too then
20:18 <amurray> oh actually I forgot we already voted via email
20:18 <amurray> so it just needs someone to send the confirmation email from what I can tell
20:19 <amurray> I can do that then
20:19 <seb128> I guess since Lukasz was doing the review he should do the emailing?
20:19 <seb128> or that :)
20:19 <amurray> I'm fine either way
20:19 <tsimonq2> Didn't vorlon follow up giving an official ack? :)
20:19 <vorlon> I think I did?
20:19 <vorlon> yes
20:20 <seb128> oh yes, I went over that email but the conclusion is several screen down and I didn't scroll all the way :p
20:20 <amurray> ah right - sorry I wasn't looking at the right one either - https://lists.ubuntu.com/archives/technical-board/2024-February/002877.html
20:20 <vorlon> https://lists.ubuntu.com/archives/technical-board/2024-February/002877.html
20:20 <amurray> thanks vorlon
20:20 <vorlon> yah
20:20 <tsimonq2> <3
20:20 * amurray seb128 to send confirmation of successful LTS status for Ubuntu Budgie 24.04
20:20 <seb128> that's done
20:20 <amurray> as seb noted above this is done already
20:21 * amurray vorlon to confirm TB agreement to launchpad-buildd-admins ownership change
20:21 <vorlon> done
20:21 <amurray> this was done in https://lists.ubuntu.com/archives/technical-board/2024-February/002876.html
20:21 * amurray amurray to follow up with Kubuntu on 24.04 LTS request
20:21 <amurray> this is still ongoing
20:21 <tsimonq2> o/ I'm a stand-in for Kubuntu today, and just wanted to provide some context (nothing actionable.) Scarlett Gately Moore has been working for the Kubuntu Council now, officially, on a contract basis. I have been tasked with guiding her through so she re-learns the ropes. There has been enough progress and energy in the Kubuntu Team where I am confident in saying we should be re-qualified. I'm
20:21 <tsimonq2> happy to answer any specific questions if there are any today, because I have been deeply involved in this effort.
20:22 <tsimonq2> Rik is still around and involved, providing guidance on the precedent he has set over the past few years, to be clear.
20:23 <amurray> hey tsimonq2 - at this stage I don't have any specific questions, I'll probably just continue to follow up via email - I did notice scarlett said they would intend to support the entire kubuntu packageset (which is great!) but I worry about whether they have the resources for this?
20:23 <vorlon> that all seems reasonable, and Kubuntu is established enough that I'm personally not worried about a change of lead impacting the LTS qual
20:24 <vorlon> amurray: could you elaborate as to what's in the kubuntu packageset that's not KDE?
20:24 <vorlon> we do a poor job of gardening packagesets
20:24 <vorlon> there's probably a bunch of stuff listed that doesn't even exist in the archive anymore
20:25 <tsimonq2> vorlon: I understand this isn't necessarily what we want to do going forward, but yes, that list has quite grown over time.
20:25 <vorlon> doesn't have to be done here and now, anyway; this could be a mail followup
20:25 <vorlon> but I'd like to get into the nitty-gritty of the capacity concerns
20:26 <tsimonq2> Not a problem :)
20:26 <amurray> ok (fyi the packageset is quite long https://pastebin.ubuntu.com/p/jbYsvvfVgq/ so I assume the kubuntu folks might want to scope their statement of support a bit)
20:26 <rbasak> I think a flavour packageset is a poor list to use outside of DMB managed ACLs because they are (were) automatically produced
20:26 <vorlon> https://ubuntu-archive-team.ubuntu.com/packagesets/noble/kubuntu btw
20:27 <rbasak> ...and they might change arbitrarily for the same sort of reason in the future
20:27 <tsimonq2> I'll follow up on our end to see if Rik had a particular rhyme or reason.
20:27 <amurray> ok, we'll continue this via email then
20:27 <vorlon> rbasak: unfortunately it's the best proxy we have for "things in this flavor that aren't also in a base seed" without additional coding that we've never bothered doing.  But I agree
20:27 <vorlon> tsimonq2: I look forward to you elaborating on your support plan for cvs
20:28 <rbasak> The task of fixing the scripts is years old and not taken now. The DMB currently just adjusts them manually on request.
20:28 <tsimonq2> vorlon: lol :)
20:28 <rbasak> So there's no longer really any assurance that packages in there aren't in a different seed. Nobody is checking for that.
20:28 <vorlon> uh you can give me an action to look whether we have any ubuntu-archive / ubuntu-release bits that would let me say "this bit is the flavor-specific overlay"
20:29 <vorlon> because what we want to see is set(kubuntu-seeds) - set(platform-seeds)
20:29 <amurray> #action vorlon to look into scripting for packages in flavor-specific overlays
20:29 * meetingology vorlon to look into scripting for packages in flavor-specific overlays
20:30 * amurray vorlon to confirm ratification of Lubuntu LTS
20:30 <amurray> as noted above, this was already done
20:30 <vorlon> well. set(kubuntu-seeds) - set(platform-seeds) - set(ubuntu-seeds)
20:31 <amurray> #topic Scan the mailing list archive for anything we missed (standing item)
20:31 <rbasak> xnox asked for a change in LP
20:31 <vorlon> yes
20:32 <vorlon> which he pointed out that my previous request for apt maintainer sign-off was unfortunately on a superseded mp and thus "lost" to the stream
20:32 <vorlon> with my AA hat on I have 0 concerns about dropping this if apt itself doesn't use it
20:32 <rbasak> I wanted to know who would be taking responsibility for the change, dealing with any fallout, etc, and I don't think I got a clear answer to that.
20:32 <amurray> yep - I'm not sure how to proceed here - there is clearly some perceived risk in this change but its not clear to me who owns it
20:33 <vorlon> I will as an AA
20:33 <vorlon> give this to me as an action please
20:33 <rbasak> Great - thanks!
20:33 <amurray> thanks vorlon
20:33 <vorlon> (TBH I think despite the acl being owned by the TB this could have just been handled directly with the AA members of the TB rather than involving the TB as a whole)
20:33 <amurray> #action vorlon to follow up on xnox's request to set noble.publish_i18n_index to False
20:33 * meetingology vorlon to follow up on xnox's request to set noble.publish_i18n_index to False
20:34 <amurray> I don't see anything else on the mailing list for today
20:34 <amurray> #topic Check up on community bugs and techboard bugs
20:34 <amurray> #link https://bugs.launchpad.net/ubuntu-community/+bugs?field.assignee=techboard
20:34 <amurray> #link https://bugs.launchpad.net/techboard
20:35 <amurray> nothing here either
20:35 <amurray> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
20:35 <amurray> looks like its me and rbasak as backup
20:35 <rbasak> ack
20:35 <amurray> #agreed next meeting chair: amurray, backup: rbasak
20:35 <meetingology> AGREED: next meeting chair: amurray, backup: rbasak
20:36 <amurray> #topic AOB
20:36 <rbasak> o/
20:36 <vorlon> the covention is that it be sil2100 with rbasak as backup, but ok :)
20:36 <vorlon> +n
20:36 <amurray> oh cool
20:36 <amurray> #agreed next meeting chair: sil2100, backup: rbasak
20:36 <meetingology> AGREED: next meeting chair: sil2100, backup: rbasak
20:36 <vorlon> (i.e. missing your chair spot doesn't get you off the hook for chairing :)
20:37 <amurray> does anyone else have AOB? otherwise rbasak the floor is yours
20:37 <rbasak> This relates to "snap-MIRs" here: https://docs.google.com/document/d/1apUKR4gtOrfPGCWmtoebaQUhoy-fG8Cyo3VKJyhnpD0/edit#heading=h.whx7oqqnxsv0
20:37 <rbasak> Our previous discussions are summarised and linked from there. This is the only thing that might be holding up the main body text. To make progress I'd like to: 1) decide if it really needs to be general, because if we can agree that it's snap-specific then we can progress on the main body at least; 2) meet in a higher bandwidth medium (Google Meet?) with amurray and maybe seb128, sil2100, whoever
20:37 <rbasak> else wants to be involved to actually get something drafted that works for us.
20:37 <rbasak> This might be homework for you for next time to remind yourself of the previous conversation, but maybe it's worth mentioning here in public that I'd like to resolve this out-of-band and come back with a result to present in public in order to get something into the draft that's workable for everyone. I'd still expect a final vote / ratification here in public regardless so I don't think there need
20:37 <rbasak> be any concerns about not being public enough with the work on this.
20:38 <amurray> sounds reasonable to me
20:38 <vorlon> +1
20:39 <rbasak> Thanks. I'll set up a meeting then. Anybody else who'd like to be involved, please contact me.
20:40 <amurray> we already have an action item on the agenda around this so I won't add any additional one
20:40 <seb128> rbasak, I had that action item but I'm happy for it to grab it if you have time to move that forward
20:41 <rbasak> seb128: I think that was on a different point - snap tracks?
20:41 <amurray> yeah we have 2 similar items on the agenda - one is about track usage and the other is about test plans for third-party apps - this is about the second one
20:42 <rbasak> We could try and combine them to make scheduling easier
20:42 <rbasak> Approximately the same set of people need to discuss them anyway
20:42 <amurray> sure
20:42 <rbasak> So you can leave it with me to schedule something
20:42 <amurray> thanks rbasak
20:42 <seb128> ah, right, sorry ... but yeah, might be more efficient to cover both topics in one meeting
20:42 <seb128> rbasak, thanks!
20:43 <amurray> anything else for today...?
20:43 <vorlon> nothing here
20:43 <rbasak> Nothing else from me. Thanks!
20:44 <seb128> not from me
20:44 <tsimonq2> Thank you all for
20:44 <tsimonq2> ...what you do :)
20:44 <amurray> thanks folks
20:44 <amurray> #endmeeting