20:00 <sil2100> #startmeeting Ubuntu Technical Board
20:00 <meetingology> Meeting started at 20:00:33 UTC.  The chair is sil2100.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
20:00 <meetingology> Available commands: action, commands, idea, info, link, nick
20:00 <sil2100> #topic Apologies
20:00 <sil2100> I guess seb is out, right?
20:01 <amurray> he doesn't appear to be online from what I can see
20:01 <sil2100> I can't remember if he sent anything, but I think he's still out-of-office
20:01 <sil2100> #topic Action review
20:01 * sil2100 seb128/amurray/sil200 to help drafting the snap-store Ubuntu-specific tracks usage
20:02 <sil2100> Not sure about seb or amurray, but I didn't work on this yet
20:02 <rbasak-mobile> My actions all need carrying over please.
20:02 <amurray> I recall seeing some update to the doc but I need to look at it again - carry over please
20:02 <sil2100> Hopefully I can contribute more in the nearest month
20:02 <sil2100> ACK
20:03 <vorlon> (confirmed that Seb is OoO)
20:03 <sil2100> #action seb128/amurray/sil2100 to help drafting the snap-store Ubuntu-specific tracks usage
20:03 * meetingology seb128/amurray/sil2100 to help drafting the snap-store Ubuntu-specific tracks usage
20:03 <vorlon> my action is also carry-over
20:03 <sil2100> Now some actions from rbasak-mobile, carrying-over as requested
20:03 <sil2100> #action rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
20:03 * meetingology rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
20:03 <sil2100> #action rbasak to follow up on finding consensus on question of test plans for third party apps
20:03 * meetingology rbasak to follow up on finding consensus on question of test plans for third party apps
20:04 <sil2100> #action rbasak to open wider discussion on third-party repo policy
20:04 * meetingology rbasak to open wider discussion on third-party repo policy
20:04 <sil2100> Next is:
20:04 <sil2100> CTION: seb128 to continue working with SRU, AA, Release, Backporters and Security teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:04 <sil2100> I guess best would be if we had seb here
20:05 <sil2100> I am certainly still responsible for the Release team documentation. As the release team knows, I have a short draft that I need to make public somewhere
20:05 <sil2100> I'll discuss with the release team on the best placement for that
20:05 <sil2100> Anything to add before I carry it over?
20:05 <vorlon> no; I think it's clearly carry-over
20:05 <sil2100> #action seb128 to continue working with SRU, AA, Release, Backporters and Security teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:05 * meetingology seb128 to continue working with SRU, AA, Release, Backporters and Security teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:06 <rbasak-mobile> I think the SRU side is done on the ML and just meeds transferring to formal docs
20:06 <sil2100> Some carry overs:
20:06 <sil2100> #action vorlon to write up draft guidelines for packages in the archive that download from the Internet
20:06 * meetingology vorlon to write up draft guidelines for packages in the archive that download from the Internet
20:06 <sil2100> #action seb128 to follow-up with ubuntu cinnamon on 24.04 request
20:06 * meetingology seb128 to follow-up with ubuntu cinnamon on 24.04 request
20:06 <sil2100> Now an action for me, but I think it's actually done:
20:06 * sil2100 sil2100 to follow-up with ubuntu studio on 24.04 request
20:07 <sil2100> In my latest reply to the LTS qualification, I signed off it with my TB hat
20:07 <sil2100> So I consider this one done
20:08 <sil2100> (no carry over)
20:08 <tsimonq2> I have Lubuntu's draft LTS qualification on my desk and ready for a final ack today. Expect that soon.
20:08 * sil2100 amurray to follow-up with edubuntu on 24.04 request
20:08 <sil2100> amurray: how's your item looking? ^
20:08 <sil2100> tsimonq2: excellent
20:09 <amurray> I was waiting on them posting the support policy in some public location but I don't think they have anything (are apparently waiting on IS for their web hosting iirc)
20:09 <Eickmeyer> amurray: Hi! As far as I was aware, that wasn't a hard requirement.
20:09 <vorlon> sil2100: you're signing off as an individual TB member?  I think it's better governance-wise to have TB votes on these, as in the example of ubuntu-unity
20:10 <sil2100> vorlon: oh, I was not aware that was the process
20:10 <vorlon> well the wiki page says "TB" not "a member of the TB"
20:10 <sil2100> vorlon: I thought in the past I saw it being single people signing off
20:10 <sil2100> Then we can vote for that for sure
20:11 <sil2100> #vote Signing off on Ubuntu Studio on 24.04 LTS request
20:11 <meetingology> Please vote on: Signing off on Ubuntu Studio on 24.04 LTS request
20:11 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
20:11 <sil2100> +1
20:11 <meetingology> +1 received from sil2100
20:11 <vorlon> +1
20:11 <meetingology> +1 received from vorlon
20:11 <amurray> +1
20:11 <meetingology> +1 received from amurray
20:12 <rbasak-mobile> +1 see ML thread - I'm merely choosing to follow sil2100 and vorlon here.
20:12 <meetingology> +1 see ML thread - I'm merely choosing to follow sil2100 and vorlon here. received from rbasak-mobile
20:12 <vorlon> addendum: we ought to make sure we have some central place collecting the state of LTS sign-off for all the flavors
20:12 <sil2100> #endvote
20:12 <meetingology> Voting ended on: Signing off on Ubuntu Studio on 24.04 LTS request
20:12 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
20:12 <meetingology> Motion carried
20:12 <sil2100> vorlon: +1 on that too!
20:12 <sil2100> For now I'll follow up on the thread, let me add an action for that
20:13 <sil2100> #action sil2100 to send confirmation of successful LTS status for Ubuntu Studio 24.04
20:13 * meetingology sil2100 to send confirmation of successful LTS status for Ubuntu Studio 24.04
20:13 <sil2100> Back to the previous action item
20:13 <vorlon> do we want it in the 24.04 release notes in the discourse, or do we want it in a wiki page?
20:14 <tsimonq2> addendum> There is an existing Discourse thread tracking information about 24.04 participation that also includes these details. I would suggest to the TB that they should manage a Discourse post with the official list.
20:14 <sil2100> amurray: do you consider this a hard requirement for the policy to be made available right now, or would you be happy for this happening later?
20:14 <tsimonq2> #link https://discourse.ubuntu.com/t/responses-needed-flavor-participation-for-24-04-lts/40075
20:14 <amurray> no I don't consider it a hard policy but I think we would definitely want it before the release goes live
20:14 <amurray> s/policy/requirement/
20:15 <sil2100> amurray: +1 indeed
20:15 <sil2100> amurray: if you're fine with the request otherwise, do you want to vote for it now?
20:15 <vorlon> as long as the flavor commits to having it up by release time, regardless of domain hosting status
20:16 <sil2100> Eickmeyer: ^ is that something you can commit to?
20:16 <Eickmeyer> That puts Edubuntu in a rough situation with our current hosting situation. We simply do *not* have a place to put it.
20:16 <rbasak-mobile> It seems weird to be waiting just because of an issue with publication in a particular place. I suggest just using Discourse in the meantime and so whether it is blocking or not shouldn't even need to be a question.
20:16 <Eickmeyer> We're working with Aaron Prisk to get IS to work on this, but they don't have it as a priority item.
20:17 <sil2100> So maybe like this: if by around release time the hosting situation is still not solved, would it be possible for you to publish a discourse post with all the details instead?
20:17 <Eickmeyer> sil2100: It will be in the release notes for sure if the hosting situation isn't resolved. Our release notes have been published to Discourse in the meantime.
20:17 <vorlon> NB hosting of per-flavor websites is not listed on https://wiki.ubuntu.com/RecognizedFlavors as part of what Canonical commits to
20:18 <sil2100> Eickmeyer: that sounds like a good plan B to me
20:18 <sil2100> amurray WDYT?
20:18 <amurray> works for me
20:18 <sil2100> Let's vote
20:18 <Eickmeyer> vorlon: Edubuntu used to be hosted by Canonical, and Ubuntu Studio currently is, along with Kubuntu, so there's precident.
20:19 <sil2100> #vote Signing off on Edubuntu 24.04 LTS request
20:19 <meetingology> Please vote on: Signing off on Edubuntu 24.04 LTS request
20:19 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
20:19 <rbasak-mobile> No precedent for an SLA though. I didn't think hosting at all or not was in question?
20:19 <sil2100> +1 (with the compromise as we discussed above)
20:19 <meetingology> +1 (with the compromise as we discussed above) received from sil2100
20:19 <amurray> +1
20:19 <meetingology> +1 received from amurray
20:20 <vorlon> the point is that from a governance perspective, the flavors are responsible for meeting the LTS requirements, and this isn't a buck that can be passed to Canonical IS
20:21 <arraybolt3> There's already a workaround in place, there's no buck being passed that I can see.
20:21 <sil2100> (vorlon, rbasak-mobile ^)
20:22 <vorlon> +1
20:22 <meetingology> +1 received from vorlon
20:22 <rbasak-mobile> +1 see ML thread - I'm merely choosing to follow sil2100 and vorlon here.
20:22 <meetingology> +1 see ML thread - I'm merely choosing to follow sil2100 and vorlon here. received from rbasak-mobile
20:22 <sil2100> #endvote
20:22 <meetingology> Voting ended on: Signing off on Edubuntu 24.04 LTS request
20:22 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
20:22 <meetingology> Motion carried
20:23 <sil2100> amurray: can you follow up with the final decision on the thread? Thank you!
20:23 <amurray> yep
20:23 <sil2100> #action amurray to send confirmation of successful LTS status for Edubuntu 24.04
20:23 * meetingology amurray to send confirmation of successful LTS status for Edubuntu 24.04
20:23 <sil2100> Carrying over seb's item
20:23 <sil2100> #action seb128 to follow-up with ubuntu budgie on 24.04 request
20:23 * meetingology seb128 to follow-up with ubuntu budgie on 24.04 request
20:23 * sil2100 amurray to follow-up with ubuntu kylin on 24.04 request
20:24 <sil2100> amurray: ^ any luck with Kylin? I might have missed any ML threads regarding this
20:24 <amurray> I proposed voting via email yesterday
20:24 <tsimonq2> rbasak-mobile: There is existing precedence for flavors to ask Canonical to host infrastructure, however, to my knowledge it's been a courtesy rather than a requirement. For example, our domain is hosted by Canonical, and if that goes down, that would certainly reflect poorly on our qualification efforts.
20:25 <vorlon> since the UbuntuKylin vote has already been called on the mailing list I propose we continue it there rather than voting in the meeting
20:25 <sil2100> amurray: do you want to vote here instead?
20:25 <amurray> I think email is fine
20:26 <sil2100> ACK o/
20:26 <sil2100> I'll carry it over then
20:26 <rbasak-mobile> I agree but again this shouldn't be relevant or seen as blocking. We can be pragmatic and just publish somewhere else eg. Discourse. Not need for this to formally block anything.
20:26 <sil2100> #action amurray to follow-up with ubuntu kylin on 24.04 request
20:26 * meetingology amurray to follow-up with ubuntu kylin on 24.04 request
20:26 <sil2100> Okay, let's move on
20:26 <sil2100> #topic Scan the mailing list archive for anything we missed
20:26 <vorlon> note that there is also CFV on the mailing list for Ubuntu Unity
20:27 <vorlon> which wasn't assigned to me in the TB meeting when they were being assigned because I wasn't able to attend, instead I just picked up the ones that hadn't been assigned
20:27 <sil2100> I'll try to follow up on those with votes then
20:27 <sil2100> I think there are no actionable items on the ML that do not have actions already, from what I know?
20:28 <sil2100> Since we have the participation e-mails, the process thread, and all those have action items assigned
20:28 <rbasak-mobile> I think it's worth following up on a multitude of issues raised by the mutter regression but I'll follow up on the list first, hopefully this week.
20:28 <sil2100> rbasak-mobile: thanks
20:28 <sil2100> #topic Check up on community bugs and techboard bugs'
20:29 <sil2100> Nothing new there
20:29 <sil2100> #topic Select a chair for the next meeting
20:29 <sil2100> That would be amurray, with rbasak-mobile as backup
20:29 <sil2100> If that'
20:29 <vorlon> I'm very confused by that
20:29 <sil2100> If that's fine
20:30 <sil2100> Well, amurray is next after me, right?
20:30 <vorlon> the wiki page said it was supposed to be seb128 with me as backup
20:30 <vorlon> are we just jumping the pointer?
20:30 <sil2100> I have volunteered today as I have not chaired for quite a long time
20:30 <vorlon> I don't mind, it's just not historical practice :)
20:31 <sil2100> #topic AOB
20:31 <amurray> fwiw I think I am on leave during the next scheduled TB meeting so not sure if I will be able to make it at this time
20:31 <sil2100> Ah, so maybe back to the scheduled chairs then? seb and vorlon as backup?
20:32 <sil2100> If there are no objections, I'd propose that then
20:32 <sil2100> Any other business?
20:33 <vorlon> nothing else from me
20:33 <amurray> nor from me
20:34 <rbasak-mobile> Please don't wait on everyone to say no :-)
20:35 <sil2100> ;)
20:35 <sil2100> #endmeeting