19:02 <utkarsh2102> #startmeeting Developer Membership Board
19:02 <meetingology> Meeting started at 19:02:35 UTC.  The chair is utkarsh2102.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:02 <meetingology> Available commands: action, commands, idea, info, link, nick
19:02 <rbasak> Personally I follow the policy that I'll provide a +1 if needed for quorum and everyone else is unanimously +1, but of course you can do as you wish :)
19:02 <utkarsh2102> rbasak: that's my plan, yes!
19:03 <utkarsh2102> anyway, hello everyone! \o
19:03 <utkarsh2102> today's agenda can be found on https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda
19:03 <utkarsh2102> #link https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda
19:03 <utkarsh2102> I'll start with the PPU (+UbuntuContributingDeveloper) application straight away
19:03 <utkarsh2102> #topic PPU Applications
19:04 <utkarsh2102> #subtopic Phil Roche
19:04 <utkarsh2102> #link https://wiki.ubuntu.com/philroche/ContributingDeveloperAndPerPackageUploadApplication
19:04 * rbasak has a long question ready to paste when you're ready
19:04 <utkarsh2102> hi philroche o/
19:04 <philroche> \o
19:04 <utkarsh2102> could you please introduce yourself? :)
19:04 <philroche> My name is Phil Roche and I've been an Ubuntu user for at least 18 years. I have worked on the Canonical Public Cloud team for seven years. As part of that role I have been involved in all parts of cloud image development including being involved with the release team on release days. A huge part of my job is debugging, building and modifying cloud images. To do that I use livecd-rootfs and live-build. Today I am applying
19:04 <philroche> for upload rights and commit rights to livecd-rootfs to make that part of my job easier and so I can help my other Public Cloud team members with their work in sponsoring their proposed changes. It will hopefully also lessen the burden on other core developers who have been sponsoring changes to livecd-rootfs.
19:05 <utkarsh2102> hah, you were ready :)
19:05 <utkarsh2102> super!
19:05 <utkarsh2102> okay, thank you, Phil!
19:05 <utkarsh2102> I hereby open the floor for questions
19:05 <rbasak> OK. Long paste:
19:05 <rbasak> Thank you for your work in Ubuntu and your application for PPU for livecd-rootfs!
19:05 <rbasak> Subject to your readiness which we'll confirm now, I think this is fine in principle, but I'd like to raise something worth discussing.
19:05 <rbasak> livecd-rootfs is one of the packages in Ubuntu that is deeply involved in our infrastructure in a number of extremely complicated ways. Historically this sort of thing has been the realm of core devs only, but the DMB generally also takes the position that core dev applicants have broader knowledge and experience than a focus on one particular package.
19:06 <rbasak> Arguably, gaining that broader knowledge and experience is also relevant for keeping livecd-rootfs in good shape.
19:06 <rbasak> On the other hand, I don't want to block your progress in making livecd-rootfs better, so not permitting PPU for livecd-rootfs at all on this basis would also seem counter-productive.
19:06 <rbasak> I wonder if you have any plans for peer review on uploads to this package? For example, on the Server team we have a peer review policy for all uploads. Does CPC have anything similar? More generally, is there any way we can ensure that review happens on complex changes to this package, to look out for unintended side effects?
19:06 <rbasak> .
19:07 <bdmurray> I seem to recal rcj having upload rights for livecd-rootfs
19:07 <utkarsh2102> I hope I didn't miss anything - rbasak's question and then bdmurray's reply about rcj. Anything in b/w?
19:07 <philroche> 1. RE only core devs. There is precedent for others having upload rights to livecd-rootfs too. Former CPC RobJ and DanW were two such engineers.
19:07 <rbasak> Indeed he does - he's the only one currently.
19:09 <philroche> 2. RE Peer review. Yes CPC has a strict two approvals before any merge in most of our repos (only docs and backports are exceptions). I plan to enforce that on myself for any livecd-rootfs changes. So at least one other livecd-rootfs maintainer + a CPC engineer if required. I very much understand how critical livecd-rootfs is and can not see a scenario in which I would upload without review
19:10 <rbasak> So sorry, I stand corrected. But the concern still holds, I think?
19:11 <philroche> It does rbasak: yes
19:12 <rbasak> Thanks. That sounds fine to me. Although I'd like to register my preference that one of the peers be a core dev, I also think that you should be free to use your own judgement (eg. absolutely not needed for trivial/obvious fixes)
19:13 <philroche> ack.
19:13 <rbasak> Moving on, I'd like to ask the "usual" questions, unless others have anything else in particular?
19:13 <bdmurray> I do
19:14 <bdmurray> philroche: You mention "I do not want it [upload rights for livecd-rootfs] to separate us from foundations". How would you go about ensuring that?
19:14 <teward> (sorry DMB I'm absent - CC priority items with Canonical - unintended coincidence on scheduling, but CC stuff takes priority)
19:14 <teward> (rbasak you know what i'm referring to)
19:15 <philroche> bdmurray: I can't think of a formal way but my intention would be to try ensure that CPC so not start developing on the ubuntu-cpc project livecd-rootfs code paths without oversight or input form foundations and or other core-devs.
19:16 <philroche> * do not start
19:16 <bdmurray> philroche: okay, thanks
19:17 <philroche> Also another way would be for myself and other CPC engineers to be more involved in reviewing non ubuntu-cpc project changes to livecd-rootfs
19:17 <philroche> CPC have a dashboard for pending MP reviews and I have work in progress for a dedicated livecd-rootfs area to make it easier to surface those MPs
19:19 <bdmurray> rbasak: did you have some questions?
19:19 <seb128> I've one as well
19:20 <rbasak> philroche: at what point in the development cycle are you no longer permitted to make feature changes, where is the schedule published, and what's the process for requesting an exception?
19:22 <philroche> Using Mantic as an example - the schedule is @ https://discourse.ubuntu.com/t/mantic-minotaur-release-schedule/34989 . I am no longer permitted to make changes to livecd-rootfs after October 5th (Final Freeze) and require a Feature Freeze Exception for any changes after that
19:23 <philroche> Thep process for applying for FFE is @ https://wiki.ubuntu.com/FreezeExceptionProcess
19:23 <rbasak> OK. Is there any special consideration you need for beta freeze?
19:24 <philroche> yes - if the change proposed affects the images (server, cloud desktop etc.) then an FFE may be required
19:25 <rbasak> OK. What about feature freeze - that was 17 August for Mantic from the schedule. How does livecd-rootfs interact with feature freeze?
19:26 <utkarsh2102> philroche: you mention that you're no longer permitted to make changes after Final Freeze but question from rbasak was when are you no long permitted to make feature changes. I suppose you misread?
19:26 * utkarsh2102 just trying to clarify
19:27 <philroche> For mantic at least I have only seen bug fixes being merged since feature freeze and from https://wiki.ubuntu.com/FeatureFreeze I see bug fixes are allowed after feature freeze
19:28 <philroche> I did misread yes. Feature changes only before feature freeze unless exception is sought
19:28 <rbasak> s/sought/granted/ but OK :-)
19:28 <philroche> yes sorry. of course
19:29 <rbasak> Next question: how do you find out if livecd-rootfs is stuck in proposed in the development release, and what do you need to do to fix it?
19:30 * utkarsh2102 needs to find the bridging status for Matrix <---> Libera
19:30 <philroche> First I would look at the autopkg tests @ https://autopkgtest.ubuntu.com/packages/l/livecd-rootfs/mantic/amd64 and https://ubuntu-archive-team.ubuntu.com/proposed-migration/update_excuses.html . To fix it I need to inspect any failures
19:31 <rbasak> OK. And sorry, I just noticed something about beta freeze that is quite important. Apart from feature changes requiring an FFe, what else must you do before uploading livecd-rootfs during beta freeze?
19:31 <philroche> So far I have been using https://wiki.ubuntu.com/ProposedMigration#Migrating_packages_from_-proposed_to_release as my guide when inspecting any issues with migration
19:32 <philroche> rbasak: I need to seek approval from release team/release manager
19:32 <rbasak> Great answers. Thanks! Over to seb128 then.
19:33 <seb128> philroche, hey, my question was about testing ... how do you usual test livecd-rootfs changes?
19:35 <philroche> seb128: Aside from autopkgtests I use https://github.com/ubuntu-bartenders/ubuntu-old-fashioned/ to build cloud images with the proposed changes which I can then test manually or test with the internal cloud image test suite.
19:35 <philroche> ubuntu-old-fashioned allows you to either build from livecd-rootfs in a PPA or from a local checkout on your machine
19:35 <seb128> philroche, thanks
19:36 <seb128> no other question from me
19:37 <utkarsh2102> bdmurray, rbasak, seb128, kanashiro: any questions?
19:37 <utkarsh2102> s/any/any more/g
19:37 <utkarsh2102> :)
19:38 <kanashiro> I am good with the answers so far
19:38 <rbasak> No more from me thanks
19:38 <seb128> not really, but I've sort of a dilemnia on how to vote now :/
19:39 <utkarsh2102> I have a quick question meanwhile. philroche: what happens when you fundamentally disagree with one of the core-dev's changes for livecd-rootfs? what will you do?
19:39 <philroche> seb128: Happy to help address any remaining concerns you have
19:40 <seb128> the replies around the different archive freezes and process were a bit inaccurate/confused but I'm unsure how much we should ask to master those topics for a ppu
19:42 <utkarsh2102> seb128: I take freezes as an important thing for any upload rights, personally. I'm not sure how others look at it. rbasak, bdmurray, kanashiro?
19:42 <philroche> seb128: apologies. This isn't a topic I have had to deal with much without PPU as those sponsoring the changes were aware of the process required. I will study more and given my heavy involvement on many release days and weeks leading up to release, I am very aware of the need for such process
19:42 <utkarsh2102> \o/
19:42 <rbasak> I agree about the inaccuracy/confusion, but FWIW, in my very subjective judgement, and having worked with philroche before, I concluded that he does actually understand it and the mistakes only came from trying to get it down here. But that is of course a very subjective opinion. Trying to judge others' understanding is hard :-(
19:43 <utkarsh2102>19:43 <seb128> well, there are things like 'if the change proposed affects the images (server, cloud desktop etc.) then an FFE may be required'
19:43 <bdmurray> I think phil's explanation for not being intimately familiar with the freezes is reasonable and I'd trust him to check carefully going forward.
19:43 <utkarsh2102> philroche: I had a question above, if you missed^
19:44 <philroche> utkarsh2102: RE. If I fundamentally disagree with a core-devs changes to livecd-rootfs. I would treat it as any other MP review. I would seek solid reasoning, and even better supporting data, on why such a change is being made.
19:44 <philroche> If that is provided then I have no argument and it is then only down to personal preference
19:45 <bdmurray> philroche: Would you use your upload rights, if they are granted, in the next two weeks?
19:45 <utkarsh2102> philroche: what if they still are not convinced? what if you strongly disagree with the proposed changes, who will you go to?
19:46 <philroche> bdmurray: I would if required yes and if I had the required approvals/exceptions grants etc.. Given it is coming up to release I would seek guidance and +1s for the steps involved for my first uploads from another maintainer
19:49 <philroche> utkarsh2102: RE. strongly disagree even after reasoning and supporting data. Unless I have data to counter then I no longer pursue any debate. I would also seek guidance from other maintainers to review
19:49 * utkarsh84 has no idea why libera keeps kicking him out :)
19:50 <rbasak> philroche: I think what he's asking is: what's the escalation path, if, despite all efforts escalation turns out to be required?
19:50 <rbasak> (since I'm not sure if he saw your reply or nto)
19:51 <utkarsh2102_real> yeah, I didn't
19:51 <philroche> utkarsh2102_real: RE. strongly disagree even after reasoning and supporting data. Unless I have data to counter then I no longer pursue any debate. I would also seek guidance from other maintainers to review
19:51 <utkarsh2102_real> ok, we're running out of time
19:51 <philroche> rbasak: utkarsh2102: I ask other maintainers to review
19:52 <utkarsh2102_real> but in reality, when all of this fails and there's still a disagreement, you go to technical board to work things out.
19:52 <philroche> understood
19:52 <utkarsh2102_real> hope things never go there but that's the path you'd have to take
19:53 <utkarsh2102> okeydoke, I am going to start the vote unless someone has any other question
19:53 * utkarsh2102 reminds everyone that he's not going to vote unless it's unanimous ;)
19:53 <seb128> do we do one vote since that's a contrib dev + ppu application and vote might different for each question?
19:53 <utkarsh2102> seb128: they could be different, yes
19:53 <utkarsh2102> I'll start with PPU
19:54 <utkarsh2102> if we don't reach a +1 there
19:54 <utkarsh2102> then I'll start the vote for contributing dev
19:54 <utkarsh2102> #vote Phil Roche to get PPU rights for livecd-rootfs
19:54 <meetingology> Please vote on: Phil Roche to get PPU rights for livecd-rootfs
19:54 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:54 <rbasak> +1
19:54 <meetingology> +1 received from rbasak
19:54 <rbasak> I understand the concern about the detail in some of your answers. If this were a core dev application, I would agree. But this is not a core dev application, so I don't think I set the bar that high. IMHO, generally referring to others to find answers is fine for a per-package uploader, and I'm confident that you broadly understand the landscape.
19:54 <rbasak> As an aside, my own interactions with philroche have been excellent, and he stands out to me as someone I really enjoy working with especially when in person. Thank you!
19:55 <bdmurray> +1
19:55 <meetingology> +1 received from bdmurray
19:55 <kanashiro> +1
19:55 <meetingology> +1 received from kanashiro
19:56 <seb128> +0, it's an important package and we are speaking about upload right, I would prefer to see a more solide understanding of the different freeze (FF is not the only freeze we have)
19:56 <meetingology> +0, it's an important package and we are speaking about upload right, I would prefer to see a more solide understanding of the different freeze (FF is not the only freeze we have) received from seb128
19:56 <utkarsh2102> I wouldn't call it unanimous so I'll skip but the results are clear anyway
19:56 <utkarsh2102> #endvote
19:56 <meetingology> Voting ended on: Phil Roche to get PPU rights for livecd-rootfs
19:56 <seb128> or said different I think you clearly have the technical understanding of the codebase and project to be an upstream maintainer
19:56 <meetingology> Votes for: 3, Votes against: 0, Abstentions: 1
19:56 <meetingology> Motion carried
19:57 <utkarsh2102> congratulations, philroche :)
19:57 <rbasak> We need r +1s
19:57 <rbasak> 4
19:57 <rbasak> We only have three
19:57 <utkarsh2102> oh wait, really?
19:57 <utkarsh2102> ah, yes
19:57 <utkarsh2102> there are 7 of us :)
19:57 <rbasak> So either Utkarsh needs to vote, or we need the other two.
19:57 <utkarsh2102> you put me in situations where I don't want to be in :)
19:58 <seb128> sorry :(
19:58 <rbasak> I'm not asking you to vote, to be clear.
19:58 <utkarsh2102> ok, given seb128 isn't a -1, I'll be +1 here. If someone objects, I'm happy to retract it and we can take it to mailing list.
19:58 <utkarsh2102> does that seem fair to everyone?
19:58 <rbasak> You're entitled to vote or not vote as you feel appropriate.
19:59 <seb128> I've no problem with that
19:59 <utkarsh2102> I'll add a note that whilst there might have been confusion/misunderstanding, I know that Phil is an excellent engineer and won't proceed with uploads, et al, without a peer review.
19:59 <rbasak> IIRC, something similar happened with a colleague of mine as they were at the time, and I didn't vote, and it had to go to the ML.
20:00 <utkarsh2102> furthermore, I am happy to work with Phil further to help him get more clarity on those freezes. Well, only if he wishes to ;)
20:00 <seb128> I would be +1 if that was a commitment from you and him
20:00 <utkarsh2102> philroche: wdyt? :)
20:01 <teward> rbasak: +1 on my end
20:01 <philroche> seb128: Definite commitment
20:01 <teward> if you need the vote.
20:01 <teward> (my meeting with Canonical people is over and I just finished catching up)
20:01 <rbasak> We do, and thank you :)
20:01 <seb128> ack, let me change to a +1 then
20:01 <utkarsh2102> philroche: super, we're super good then! :)
20:01 <utkarsh2102> OKAYYYYYYYYYY
20:01 <utkarsh2102> #vote (again)
20:01 <meetingology> Please vote on: (again)
20:01 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
20:01 <rbasak> +1
20:01 <meetingology> +1 received from rbasak
20:01 <teward> +1
20:01 <meetingology> +1 received from teward
20:02 <seb128> +1
20:02 <meetingology> +1 received from seb128
20:02 <rbasak> I mean if you insist. I don't consider meetingology authoritative. They're only a bot :)
20:02 <rbasak> and I trust that we can all count :-P
20:02 <kanashiro> +1
20:02 <meetingology> +1 received from kanashiro
20:02 <utkarsh2102> sure, I just want it to get it on record and do it right ;)
20:02 <bdmurray> +1
20:02 <meetingology> +1 received from bdmurray
20:02 <utkarsh2102> super!
20:03 <utkarsh2102> unanimous
20:03 <utkarsh2102> +1
20:03 <meetingology> +1 received from utkarsh2102
20:03 <utkarsh2102> #endvote
20:03 <meetingology> Voting ended on: (again)
20:03 <meetingology> Votes for: 6, Votes against: 0, Abstentions: 0
20:03 <rbasak> Sure, you're the chair :-)
20:03 <meetingology> Motion carried
20:03 <seb128> :)
20:03 <utkarsh2102> congratulations, philroche :)
20:03 <seb128> philroche, congrats!
20:03 <philroche> I can see this was a tricky one and apologies for making it even trickier. Thank you all for your time.
20:03 <utkarsh2102> #action Utkarsh to announce the application and adjust the ACLs
20:03 * meetingology Utkarsh to announce the application and adjust the ACLs
20:03 <teward> (again i extend my apologies for being *late as heck* to this meeting, higher priority Community Council level stuff needed attention with meetings and stuff to.)
20:03 <utkarsh2102> I mean, it'll be TB but I'll prod
20:03 <utkarsh2102> teward: no problem but thanks for being there
20:04 <utkarsh2102> anyway, there's nothing else on the agenda
20:04 <utkarsh2102> and we're over time
20:04 <utkarsh2102> soooooo
20:04 <utkarsh2102> thank you, everyone! \o
20:04 <teward> yep, still apologizing for not being here sononer :P
20:04 <teward> sooner*
20:04 <utkarsh2102> see you in two weeks!
20:04 <teward> heck i need to learn to type
20:04 <teward> o/
20:04 <utkarsh2102> #endmeeting