15:05 <ddstreet> #startmeeting Ubuntu Backporters Team
15:05 <meetingology> Meeting started at 15:05:49 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:05 <meetingology> Available commands: action, commands, idea, info, link, nick
15:06 <ddstreet> probably should go through all the agenda items, though i've been busy with other work and summertime vacations so unfortunately i dont think i've done much of anything
15:06 <ddstreet> #topic previous action items
15:07 <mapreri> same, plus I've been traveling for 1+ month...
15:07 <ddstreet> #subtopic ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:07 <ddstreet> #action ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:07 * meetingology ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:07 <ddstreet> #subtopic ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:07 <ddstreet> #action ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:07 * meetingology ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:07 <ddstreet> #subtopic ddstreet send follow up email on no-bug-required ML thread mentioning cockpit
15:08 <ddstreet> i did this one! :) and i think it's been resolved?
15:08 <mapreri> nope
15:08 <ddstreet> i have not caught up on my email, just got back today
15:08 <mapreri> I mean, you did the followup, but we haven't follow up again on the topic
15:08 <ddstreet> ah ok
15:08 <mapreri> oh wait
15:08 <mapreri> this is specific to cockpit
15:08 <ddstreet> oh this is the no-bug-required one
15:08 <mapreri> wait
15:08 * mapreri spawns up mails
15:09 <ddstreet> the cockpit self-approvals issue is separate i think
15:09 * ddstreet been gone too long, brain needs to catch up
15:09 <teward> (and handled)
15:09 <mapreri> so, the pitti issues has finally been handled, though I do have some questions after reading his answer.
15:09 <ddstreet> lemme go read that also
15:10 <teward> so did I.  It took the TB poking pitti to get attention, I don't accept their reasoning of simply sinkholing everything going to their ubuntu.com address but i cant validate any of that on their end
15:11 <teward> and yes i did escalate it to the TB for intervention / poking
15:11 <mapreri> well, let's just say that his "I'm not reading this email because it's only spam" is bullshit in my mind, so I want to dig deeper in there, since AFAIK we did try to reach him on multiple addresses.  And our thing has been announced in ubuntu-devel-announce (IIRC), so one reason less for him not knowing, so…   but yes, I believe it's handled enough for now.
15:11 <teward> i brought those concerns up with the TB in a reply myself but it got eaten by my email so i have to resend it
15:11 <mapreri> teward: you mean the points I raised?
15:12 <teward> but yeah theres concerns at play, but at least Martin seems willing to work in the new processes
15:12 <teward> mapreri: and others I am not at liberty of bringing up publicly or I'd have to eat my many hats
15:12 <mapreri> heh
15:12 <mapreri> then ok, I think I'll leave everything to you, thank you
15:13 <teward> yep, the key was to poke Martin and get it handled such that he stops self approving.  And I rejected his reasons as well for not replying prior.
15:13 <mapreri> ddstreet: the actual "no-bug-required" topic is further down, btw, this seems to be specific to cockpit/pitti.
15:13 <ddstreet> i'll read the full escalation TB thread later, it seems like for now his response seems fine and i think he did recently upload a new version to backports and did not self-approve
15:13 <teward> and he has agreed to abide by our processes so.
15:14 <ddstreet> yep, let's drop this action item as it seems done
15:14 <mapreri> yes
15:14 <ddstreet> #subtopic ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html
15:14 <ddstreet> i guess we should keep this on the ML, unless either of you want to discuss it now?
15:15 <mapreri> not now
15:15 <ddstreet> ack
15:15 <ddstreet> #action ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html
15:15 * meetingology ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html
15:15 <ddstreet> #subtopic ddstreet send follow up email for clarification on specific wording for no-bug-required backport exceptions
15:15 <ddstreet> i think this can be dropped as we have the ML thread already
15:16 <ddstreet> #subtopic mapreri upload (more of) all the tools (carried over, in progress)
15:16 <mapreri> as long as we don't forget (fwiw, I have a wording in my mind, but it will have to wait until I get to this)
15:16 <mapreri> carry over pls
15:16 <ddstreet> #action mapreri upload (more of) all the tools (carried over, in progress)
15:16 * meetingology mapreri upload (more of) all the tools (carried over, in progress)
15:16 <ddstreet> #subtopic mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:16 <mapreri> carry over
15:16 <ddstreet> #action mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:16 * meetingology mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:17 <ddstreet> #subtopic mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
15:17 <ddstreet> also i assume?
15:17 <mapreri> yes
15:17 <ddstreet> #action mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
15:17 * meetingology mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
15:17 <ddstreet> #subtopic mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
15:17 <ddstreet> #action mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
15:17 * meetingology mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
15:17 <mapreri> aye, sorry
15:17 <ddstreet> #subtopic mapreri follow up in https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/2012676
15:17 <ddstreet> carry?
15:17 <mapreri> no, this was done and over
15:18 <ddstreet> awesome!
15:18 <ddstreet> #subtopic mapreri reply to TB charter email thread
15:18 <ddstreet> i think this is done too?
15:18 <mapreri> yes
15:18 <mapreri> hold on a sec pls
15:18 <ddstreet> ack
15:19 <mapreri> I was reading that bug about nfs-utils, I missed the last answer from the OP.  But I believe it's fine as it is (i.e., rejected)
15:20 <ddstreet> yep i agree
15:20 <ddstreet> ok moving on
15:20 <ddstreet> #subtopic teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over)
15:21 <ddstreet> i think you looked at this at least somewhat?
15:22 <teward> i havent poked everything but there were some issues
15:22 <teward> so keep it for now
15:22 <ddstreet> #action teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over)
15:22 * meetingology teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over)
15:23 <teward> (had bigger fish to fry since that was put on so)
15:23 <ddstreet> ack, no worried
15:23 <ddstreet> #subtopic (unassigned) consider documenting an SLA for reviewing uploaded backport packages
15:23 <ddstreet> should we carry this or move to ML? or discuss now?
15:23 <mapreri> keep it here
15:23 <ddstreet> #action (unassigned) consider documenting an SLA for reviewing uploaded backport packages
15:23 * meetingology (unassigned) consider documenting an SLA for reviewing uploaded backport packages
15:24 <ddstreet> works for me :)
15:24 <ddstreet> #subtopic (unassigned) check if backports pocket uploads and/or approvals go to a ML
15:24 <ddstreet> probably should assign this to someone to look into ?
15:24 <ddstreet> teward you have any extra time to look into this?
15:24 <mapreri> imho better keep it in the backburner until we catch up with the rest, unless either of you want to take it on.
15:24 <teward> nope no spare cycles
15:25 <teward> FT job eats all my cycles atm
15:25 <ddstreet> ack, yeah let's keep it here then
15:25 <ddstreet> me as well, yeah
15:25 <ddstreet> #action (unassigned) check if backports pocket uploads and/or approvals go to a ML (carried over)
15:25 * meetingology (unassigned) check if backports pocket uploads and/or approvals go to a ML (carried over)
15:25 <ddstreet> #subtopic (unassigned) if no ML for backports uploads/approvals, check on how to create one
15:25 <ddstreet> follow on to last item so carrying this one too
15:25 <ddstreet> #action (unassigned) if no ML for backports uploads/approvals, check on how to create one (carried over)
15:25 * meetingology (unassigned) if no ML for backports uploads/approvals, check on how to create one (carried over)
15:26 <ddstreet> that's all the previous action items; moving on to ML threads unless anyone has any other previous items to discuss
15:26 <teward> nope but i have a time crunch so can i bring a different item up ahead of ml threads
15:26 <ddstreet> sure
15:27 <ddstreet> #topic AOB
15:27 <teward> i will need one of you two to poke distro-info later today
15:27 <teward> i am reuploading after a self reject due to version strinfs
15:27 <teward> strings*
15:27 <mapreri> is it fine to accept it?
15:27 <teward> this is the pings from cpaelzer_ in devel yesterdat
15:27 <teward> mapreri: cpaelzer_ said yeah but i made a screwup with version strings so gonna fix and reup
15:27 <mapreri> I mean, I have no cycles today or tomorrow to actually confidently look at things.  for me it would be better if I did it next week.
15:28 <mapreri> (and I believe it can wait)
15:28 <teward> ack just putting it on the list
15:28 <ddstreet> if it's not complicated, i can take a look today or tomorrow
15:28 <ddstreet> i'll keep it in mind to try to get to this week
15:29 <ddstreet> otherwise mapreri can tackle it next week :)
15:29 <mapreri> ^^
15:29 <teward> yep this or next week is fine but wanted it on the list
15:30 <ddstreet> since we're in AOB, anything else to discuss before going back to regular agenda?
15:30 <mapreri> so, right now we have one open bug (which is a reject, launchpad will expire it in 10 days)
15:30 <mapreri> and in the queue there is only cockpit from pitti
15:30 <teward> i'm being pulled into a meeting @ work so i need to nip out but will read back after.
15:30 <mapreri> are we going to ask him for bug or shall we just look at it as it is?
15:30 <teward> *whooshes out*
15:30 <mapreri> teward: o/
15:32 <ddstreet> i can take a look at the cockpit backports, if they are the typical 'no-change' backports that we usually don't require bugs for, i think it's ok to just approve without a bug
15:32 <ddstreet> unless you think we should ask for a bug at least for the first cockpit we approve
15:32 <mapreri> that was pretty much my question
15:33 <ddstreet> how about if i see *anything* that i have a question about i'll ask for a bug, otherwise if the backports look fine and i have no q's i'll approve them without a bug
15:33 <mapreri> the wording for the no-bug-required thing I was thinking of was indeed to require the bug for the first upload to series, and then not require a new it if it's only no-change with no real risk to it (and instead just keep referring the old bug in the changelog also for the new updates).
15:34 <mapreri> that would work for me.
15:34 <mapreri> It would be unfair to ask for a bug for a process that has not been defined (the no-bug-required thing) when we are silently accepting simple no-change updates.
15:35 <ddstreet> yep, once we have the policy in place it should be easier
15:35 <ddstreet> i'll action that at least
15:35 <ddstreet> #action ddstreet review cockpit backport uploads
15:35 * meetingology ddstreet review cockpit backport uploads
15:35 <mapreri> ty
15:36 <mapreri> no further AOB from me today
15:36 <ddstreet> #subtopic ML threads
15:36 <ddstreet> #undo
15:36 <meetingology> Removing item from minutes: SUBTOPIC
15:36 <ddstreet> #topic ML threads
15:36 <ddstreet> #subtopic clarification on specific wording for no-bug-required backport exceptions
15:36 <ddstreet> i think this is the only ML thread? at least, in the agenda
15:36 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2022-February/022680.html
15:36 <ddstreet> no movement for a while on it
15:37 <ddstreet> i'll send another ping to try to keep it alive :)
15:37 <mapreri> ty
15:37 <ddstreet> #action ddstreet ping email to keep thread alive: clarification on specific wording for no-bug-required backport exceptions
15:37 * meetingology ddstreet ping email to keep thread alive: clarification on specific wording for no-bug-required backport exceptions
15:37 <ddstreet> i think that's everything, besides picking a next mtg date?
15:38 <mapreri> yes
15:38 <ddstreet> #subtopic next mtg date
15:38 <mapreri> according to my calendar, regular schedule would say Oct 18th?
15:38 <mapreri> ah, no, sorry  wrong ubuntu team
15:38 <ddstreet> 4 weeks as 'usual' would be Oct 25
15:38 <mapreri> not in my recurring calendar?
15:39 <ddstreet> yeah we've been just doing one-off mtgs so far, though we could switch to recurring
15:39 <mapreri> oh, was it you sending gcal invite?
15:39 <ddstreet> yep
15:39 <ddstreet> after each mtg
15:39 <mapreri> see, it has been too long since the last meeting i forgot!
15:39 <ddstreet> lol
15:39 <ddstreet> maybe we should just commit to monthly mtgs?
15:39 <mapreri> I'm fine with oct 25
15:39 <mapreri> would normally wfm
15:40 <ddstreet> sounds good, i'll set up the next for oct 25 and set it as recurring every 4 weeks, and we can cancel/resched as needed
15:40 <mapreri> hold on
15:40 <mapreri> the 25th is right before the DST change
15:40 <mapreri> what about after?
15:41 <mapreri> I'm keen on keeping this at 5pm Europe/Rome time :>
15:41 <ddstreet> in the past, we were sticking with DST
15:41 <ddstreet> US DST change is first sunday in Nov, so i think it would be the same time
15:42 <mapreri> let's just schedule next 25th that's before the change, and let's growl at DST next week ^^
15:42 <mapreri> s/week$/meeting/
15:42 <ddstreet> sounds good
15:42 <ddstreet> #action ddstreet sched next mtg oct 25
15:42 * meetingology ddstreet sched next mtg oct 25
15:42 <ddstreet> isn't the EU getting rid of DST?
15:42 <mapreri> ahahahaha
15:43 <mapreri> that will happen after whatever next "crisis" pass
15:43 <mapreri> but then postponed to the after the next-next crisis, I'm sure
15:43 <ddstreet> lol yeah i dont see the US dropping it anytime soon either
15:44 <ddstreet> ok i think we're wrapped
15:44 <ddstreet> any final items?
15:44 <mapreri> none from me
15:44 <ddstreet> #endmeeting