14:31 <cpaelzer_> #startmeeting Weekly Main Inclusion Requests status
14:31 <meetingology> Meeting started at 14:31:24 UTC.  The chair is cpaelzer_.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
14:31 <meetingology> Available commands: action, commands, idea, info, link, nick
14:31 <cpaelzer_> Ping for MIR meeting - didrocks joalif slyon sarnold cpaelzer jamespage ( eslerm dviererbe )
14:31 <cpaelzer> #topic current component mismatches
14:31 <cpaelzer> Mission: Identify required actions and spread the load among the teams
14:31 <dviererbe> o/
14:31 <cpaelzer> #link https://people.canonical.com/~ubuntu-archive/component-mismatches-proposed.svg
14:31 <cpaelzer> #link https://people.canonical.com/~ubuntu-archive/component-mismatches.svg
14:31 <slyon> uh oh! What happened to our -perl tree?
14:32 <luis220413> s_lyon: thanks
14:32 <cpaelzer> we removed the dependency
14:32 <cpaelzer> back to a suggest
14:32 <cpaelzer> as it won't be in time for 23.10
14:32 <cpaelzer> I can't force sarnold to review 50 in 2 weeks
14:32 <sarnold> \o/
14:32 <dviererbe> :D
14:32 <cpaelzer> interestingly independent to that there is one left in the svg
14:32 <cpaelzer> dkim-perl->cryptx
14:33 <cpaelzer> that is a mismatch even with that reduced to a suggest
14:33 <slyon> but that's desktop's perl tree, not server's
14:33 <cpaelzer> that is true
14:34 <cpaelzer> and, other than the old
14:34 <cpaelzer> it is only in -proposed
14:34 <cpaelzer> and therefore fine
14:34 <luis220413> What binaries from src:rustc are depending on binaries from src:fonts-nanum, src:fonts-open-sans and src:highlight.js?
14:34 <cpaelzer> the whole former stack already did migrate because it was only recommends
14:34 <cpaelzer> which surprising to me, recommends conflicts only - do not block proposed
14:34 <slyon> luis220413: that's rust-doc
14:34 <cpaelzer> -doc usually should go to excludes
14:35 <cpaelzer> it is auto-included, but quite often it is ok to just exclude the -doc
14:35 <luis220413> What is excludes?
14:35 <slyon> luis220413: Extra-Excludes is part of the seeds: https://wiki.ubuntu.com/SeedManagement/
14:35 <luis220413> OK
14:35 <cpaelzer> thank you for answering quicker slyon :-)
14:35 <slyon> to deny-list certain binary packages
14:36 <cpaelzer> luis220413: you'll see plenty of similar cases in the git history
14:36 <cpaelzer> https://git.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/+git/ubuntu
14:36 <cpaelzer> now, let us look at the mismatches once more
14:36 <cpaelzer> jaraco - openstack is aware
14:36 <cpaelzer> rust -> fonts we just discussed
14:37 <cpaelzer> libmail-dkim-perl and others - would need Desktop activity if urgent
14:37 <slyon> wrt rustc component-mismatch. We got the security +1 \o/ So we need didrocks to check the latest comments and let us know if he's fine with that to unblock the MIR
14:37 <cpaelzer> seb128: ^^ is that important to you?
14:37 <eslerm> o/
14:37 <slyon> (well.. cargo MIR, that is. Which is combined with src:rustc)
14:37 <cpaelzer> he mentioned that he will be unavailable now, but will re-read the log
14:37 <seb128> which one?
14:37 <cpaelzer> seb128: https://ubuntu-archive-team.ubuntu.com/component-mismatches-proposed.svg
14:38 <cpaelzer> seb128: libmail-dkim-perl is on desktop in http://reqorts.qa.ubuntu.com/reports/m-r-package-team-mapping.html
14:38 <cpaelzer> 2/3 dependencies are already approved from being in main in the past
14:38 <seb128> I will investigate, I'm not familiar with it
14:39 <cpaelzer> that is enough for now, thanks seb128
14:39 <seb128> I (wrongly) assumed that was part of the perl stack being discussed in previous meeting
14:39 <seb128> sorry about that
14:39 <cpaelzer> it was maybe hidden in there
14:39 <cpaelzer> but we had to opt out of this for 23.10 as no one can do so many reviews in time
14:40 <cpaelzer> so that is what is left visible for the time being
14:40 <cpaelzer> probably by a sync from debian
14:40 <cpaelzer> I'd go on with the agenda then
14:40 <cpaelzer> #topic New MIRs
14:40 <cpaelzer> Mission: ensure to assign all incoming reviews for fast processing
14:40 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-date_last_updated&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&assignee_option=none&field.assignee=&field.subscriber=ubuntu-mir
14:40 <cpaelzer> https://bugs.launchpad.net/ubuntu/+source/vpnc-scripts/+bug/1987571
14:40 <cpaelzer> https://bugs.launchpad.net/ubuntu/+source/stoken/+bug/1987448
14:41 <slyon> (I cannot take any MIR reviews today, as I'll be out for an extended leave soon, with no "distro day" left)
14:41 <cpaelzer> yeah
14:41 <cpaelzer> and I'm crushed by "until end of cycle" high level duties
14:41 <eslerm> does stoken actually have an owning team?
14:41 <luis220413> slyon: Until when?
14:41 <luis220413> eslerm: No
14:41 <slyon> I'll be back for release week, early October
14:41 <eslerm> Luis is back from suspension
14:42 <cpaelzer> eslerm: and he suggested Desktop
14:42 <luis220413> Nor vpnc-scripts
14:42 <sarnold> (welcome back :)
14:43 <cpaelzer> I think we need seb128 or anyone else to officially say "yes we'd take it" on stoken + vpnc-scripts
14:43 <cpaelzer> otherwise there might be a lot of review efforts for Desktop saying "that wasn't our plan"
14:43 <eslerm> jbicha has closed other related MIRs which were recently reopened
14:44 <luis220413> Specifically bug 1986592 and bug 1987446
14:44 <seb128> cpaelzer, I'm also not familiar with those, I will review/consider but I doubt we are interested by those or wanting to commit to maintain them
14:44 <luis220413> Bug 1986592 is the main one, with the rationale for promoting this set of packages
14:44 <seb128> it's not for this cycle for sure
14:45 <luis220413> Then for 24.04?
14:45 <jbicha> luis220413: comment 2 on 1986592 is significant
14:45 <cpaelzer> I think we can leave "having a look and discussion" to you both
14:46 <seb128> yes
14:46 <cpaelzer> and go on here
14:47 <cpaelzer> I've assigned them to you and left a comment why
14:47 <cpaelzer> #topic Incomplete bugs / questions
14:47 <cpaelzer> Mission: Identify required actions and spread the load among the teams
14:47 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-date_last_updated&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.subscriber=ubuntu-mir
14:47 <cpaelzer> there  is the whole openconnect topic we just handled
14:48 <cpaelzer> including https://bugs.launchpad.net/ubuntu/+source/network-manager-openconnect/+bug/1986592 which jbicha referred to
14:48 <cpaelzer> nothing to act on those for the MIR team
14:48 <cpaelzer> then https://bugs.launchpad.net/ubuntu/+source/python-reportlab/+bug/2028054
14:48 <cpaelzer> has found an unexpected solution, will be revisited if it causes issues
14:49 <cpaelzer> then https://bugs.launchpad.net/ubuntu/+source/dotnet6/+bug/2023531
14:49 <cpaelzer> with some back and forther around the discontinue support in LTS
14:49 <slyon> +1 and thanks for that (wrt python-reportlab)
14:49 <cpaelzer> notinth to act for us either
14:49 <dviererbe> I had an SRU exception for a few minutes :/
14:49 <cpaelzer> hehe
14:49 <cpaelzer> then https://bugs.launchpad.net/ubuntu/+source/cargo/+bug/1993819
14:49 <cpaelzer> which we handled above, waiting for didrocks to confirm if all is completed
14:49 <slyon> this is for didrocks to look into ^ (as was said earlier)
14:49 <cpaelzer> then https://bugs.launchpad.net/ubuntu/+source/pappl-retrofit/+bug/2031814
14:50 <cpaelzer> got a MIR review
14:50 <slyon> I NACKed this today...
14:50 <cpaelzer> back to Till to rethink
14:50 <slyon> It's not needed for this cycle, though.
14:50 <cpaelzer> ok and last but not least
14:50 <cpaelzer> https://bugs.launchpad.net/ubuntu/+source/aom/+bug/2004442
14:50 <cpaelzer> has todo's left open
14:50 <cpaelzer> ok
14:50 <slyon> just a tracking update, showing some progress from our (foundations) side
14:50 <cpaelzer> that was a lot of "incompletes with updates"
14:51 <cpaelzer> but all fine in regard to "not waiting to be unblocked by us"
14:51 <cpaelzer> #topic Process/Documentation improvements
14:51 <cpaelzer> Mission: Review pending process/documentation pull-requests or issues
14:51 <cpaelzer> #link https://github.com/canonical/ubuntu-mir/pulls
14:51 <cpaelzer> #link https://github.com/canonical/ubuntu-mir/issues
14:51 <cpaelzer> FYI I landed the one that was agreed last week and you pinged me on
14:51 <luis220413> https://github.com/canonical/ubuntu-mir/issues/39
14:51 <cpaelzer> I'm not sure we made recent progress to base-sets
14:52 <cpaelzer> three worth to mention
14:52 <luis220413> I opened this due to comment 12 to #1986592
14:52 <luis220413> cpaelzer: Base-sets?
14:52 <slyon> no. base-sets will be discussed at the next engineering sprint
14:52 <slyon> (hopefully)
14:52 <cpaelzer> ok
14:52 <cpaelzer> so the first to discuss is the one luis220413 linked
14:52 <cpaelzer> Hmm, ok
14:53 <cpaelzer> thanks for the report
14:53 <cpaelzer> this is one of the cases that is clear if you already know it
14:53 <cpaelzer> The answer is: it is a requirement to have an owning team
14:53 <cpaelzer> But we need to fix this in the repository
14:53 <cpaelzer> I can easily write this a bit better and propose a change
14:54 <cpaelzer> since that will be quick, that should be fine soon
14:54 <luis220413> cpaelzer: It is a requirement for which stage(s) of the MIR process?
14:54 <cpaelzer> I'm trying
14:55 <cpaelzer> luis220413: it is not a requirement to have "the onwing team subscribed" to start the MIR and get the ACK. Oly to get the promotion to main done. But OTOH it is an absolute requitement to "have commitment of a team that will own it" to even enter the process
14:55 <slyon> luis220413: I guess there are 2 stages: A MIR needs an owning team to be processed AND that team must be subscribed before being promoted by an AA.
14:56 <slyon> yeah... cpaelzer is probably a bit more detailed
14:56 <cpaelzer> with time in mind, going on
14:56 <cpaelzer> https://github.com/canonical/ubuntu-mir/issues/38
14:56 <cpaelzer> dviererbe: I have no idea
14:56 <dviererbe> I am not sure what to do here; just wanted to let you know that this is weird
14:57 <cpaelzer> I think that it might not be an external party, but a GH feature we do not know?
14:57 <cpaelzer> thanks for the report
14:57 <cpaelzer> question
14:57 <dviererbe> np
14:57 <cpaelzer> was https://github.com/canonical/ubuntu-mir/pull/36 ready to merge?
14:57 <cpaelzer> looks that way
14:57 <cpaelzer> any last need to stop me?
14:57 <slyon> do it
14:57 <cpaelzer> done
14:57 <cpaelzer> and now, time for security
14:58 <cpaelzer> #topic MIR related Security Review Queue
14:58 <cpaelzer> Mission: Check on progress, do deadlines seem doable?
14:58 <cpaelzer> Some clients can only work with one, some with the other escaping - the URLs point to the same place.
14:58 <cpaelzer> #link https://bugs.launchpad.net/~ubuntu-security/+bugs?field.searchtext=%5BMIR%5D&assignee_option=choose&field.assignee=ubuntu-security&field.bug_reporter=&field.bug_commenter=&field.subscriber=ubuntu-mir
14:58 <cpaelzer> #link https://bugs.launchpad.net/~ubuntu-security/+bugs?field.searchtext=[MIR]&assignee_option=choose&field.assignee=ubuntu-security&field.bug_reporter=&field.bug_commenter=&field.subscriber=ubuntu-mir
14:58 <cpaelzer> Internal link
14:58 <cpaelzer> - ensure your teams items are prioritized among each other as you'd expect
14:58 <cpaelzer> - ensure community requests do not get stomped by teams calling for favors too much
14:58 <cpaelzer> #link https://warthogs.atlassian.net/jira/software/c/projects/SEC/boards/594
14:58 <cpaelzer> things keep looking good
14:58 <cpaelzer> anything of concern sarnold / eslerm that you want to bring up?
14:58 <sarnold> (especially without a perl tree to tend to :)
14:58 <cpaelzer> well, we have the first few of the perl tree
14:58 <cpaelzer> and the rest will come later
14:58 <cpaelzer> but yes, only root-work now
14:59 <eslerm> nothing to bring up, I'll push for s390-tools assignment this week
14:59 <cpaelzer> great
14:59 <cpaelzer> jfh will be happy to hear that
14:59 <cpaelzer> in that case
14:59 <cpaelzer> let me go on
14:59 <cpaelzer> #topic Any other business?
14:59 <luis220413> Yes
14:59 <cpaelzer> nothing from me
14:59 <sarnold> none here
14:59 <joalif> none
14:59 <eslerm> none
14:59 <cpaelzer> yes = another topic luis220413?
15:00 <luis220413> cpaelzer: Exactly
15:00 <slyon> kudos for the security to finish libei review quickly, to unblock the desktop team!
15:00 <cpaelzer> indeed
15:00 <eslerm> thanks amurray \o/
15:00 <luis220413> I would like to have libwpe and wpebackend-fdo promoted to main in Focal to be able to have WebKitGTK 2.40.5 in the official archive
15:01 <luis220413> I have successfully built it (despite upstream's lack of support) and Yelp works well with it
15:01 <luis220413> *lack of support for Focal
15:01 <luis220413> The bugs are bug #1973031 and bug #1973033 (I have not changed them)
15:01 <jbicha> luis220413: I don't think the *wpe* issue is a blocker for webkitgtk 2.40 reaching Focal
15:02 <luis220413> Thanks, but I said this because, from 1973031 it appeared that *wpe* would become mandatory for WebKitGTK starting from 2.40
15:02 <jbicha> however, the Ubuntu Security team currently doesn't plan to release webkitgtk 2.40 to Focal
15:03 <jbicha> I'm saying there are other issues & webkitgtk support for Focal has reached Security End of Life
15:03 <jbicha> we can discuss more after this meeting if needed since I don't think this is a MIR team issue now
15:04 <luis220413> OK
15:04 <cpaelzer> ok
15:04 <cpaelzer> in that case
15:04 <cpaelzer> closing
15:04 <cpaelzer> thank you all!
15:05 <sarnold> thanks cpaelzer, all :)
15:05 <slyon> thanks all! o/
15:05 <cpaelzer> #endmeeting
15:05 <eslerm> thanks all o/
15:05 <dviererbe> thanyk you all! o/
15:05 <luis220413> Thank you all! o/
15:05 <joalif> thanks all
15:06 <jbicha> luis220413: if you want to discuss webkitgtk/focal more, I suggest asking in #ubuntu-security
15:13 <didrocks> cpaelzer: ok, it seems in the end that there is no action outside of cargo for me or anything else I can take?
15:15 <cpaelzer> no, just cargo AFAIR
19:00 <rbasak> o/
19:00 <seb128> o/
19:01 <seb128> amurray, vorlon, sil2100, around?
19:01 <sil2100> o/
19:01 <seb128> great
19:01 <seb128> let's get started!
19:01 <amurray> o/
19:02 <rbasak> FWIW, I have no progress on my action items to report this week, sorry.
19:02 <amurray> hey seb128
19:02 <seb128> same here :-(
19:02 <seb128> #topic Action Items
19:02 * vorlon waves
19:03 * seb128 seb128/amurray/sil200 to help drafting the snap-store Ubuntu-specific tracks usage
19:03 <seb128> I didn't have time to help progressing this so let's carry over
19:03 <sil2100> +1
19:04 <seb128> #action seb128/amurray/sil200 to help drafting the snap-store Ubuntu-specific tracks usage
19:04 * meetingology seb128/amurray/sil200 to help drafting the snap-store Ubuntu-specific tracks usage
19:04 * seb128 rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:05 <seb128> rbasak said he didn't progress his items so carrying over
19:05 <seb128> #action rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:05 * meetingology rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:05 * seb128 rbasak to follow up on finding consensus on question of test plans for third party apps
19:05 <seb128> same
19:05 <seb128> #action rbasak to follow up on finding consensus on question of test plans for third party apps
19:05 * meetingology rbasak to follow up on finding consensus on question of test plans for third party apps
19:05 * seb128 rbasak to open wider discussion on third-party repo policy
19:05 <seb128> same
19:05 <seb128> #action rbasak to open wider discussion on third-party repo policy
19:05 * meetingology rbasak to open wider discussion on third-party repo policy
19:05 * seb128 seb128 to follow up with SRU, AA, Release, Backporters and Security teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
19:05 <seb128> I didn't manage to work on that either
19:06 <seb128> #action seb128 to follow up with SRU, AA, Release, Backporters and Security teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
19:06 * meetingology seb128 to follow up with SRU, AA, Release, Backporters and Security teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
19:06 * seb128 vorlon to write up draft guidelines for packages in the archive that download from the Internet
19:06 <seb128> vorlon, ?
19:06 <vorlon> nothing to report yet, carry over
19:06 <seb128> #action vorlon to write up draft guidelines for packages in the archive that download from the Internet
19:06 * meetingology vorlon to write up draft guidelines for packages in the archive that download from the Internet
19:07 <seb128> #topic Scan the mailing list archive for anything we missed (standing item)
19:07 <seb128> #info No recent ML posts
19:07 <seb128> #topic Check up on community bugs and techboard bugs
19:07 <seb128> https://bugs.launchpad.net/ubuntu-community/+bugs?field.assignee=techboard is empty
19:08 <seb128> https://bugs.launchpad.net/techboard doesn't have anything other that the previously listed action items
19:08 <seb128> #info No new bugs; existing bugs are all being handled through existing action items
19:08 <seb128> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:09 <seb128> #info Next chair will be vorlon with sil2100 as backup
19:09 <vorlon> ahhh Seb speed-running the TB meeting ;)
19:09 <sil2100> +1
19:09 <vorlon> +1
19:09 <seb128> #topic AOB
19:09 <seb128> :p
19:09 <seb128> any other topic?
19:09 <vorlon> I can put this on the mailing list if desired, but I'd like to request another variance of the schedule
19:09 <vorlon> to push the next meeting out to 3 weeks from today instead of 1
19:09 <vorlon> instead of 2
19:09 <sil2100> I might have something for next meeting, since I'd like to first have a chat with the toolchain squad
19:10 <seb128> I'm fine doing 2->3 weeks
19:10 <amurray> same
19:10 <seb128> I think we have enough people to decide here/now
19:10 <sil2100> I don't mind
19:10 <seb128> rbasak, ?
19:12 <seb128> well I guess we have quorum even without him, I will update the wikipage to reflect that
19:12 <rbasak> Sorry, reading
19:12 <seb128> any other topic?
19:12 <rbasak> And checking my calendar
19:13 <rbasak> 3 weeks is OK for me.
19:13 <seb128> great
19:13 <rbasak> Nothing else from me thanks
19:14 <seb128> alright, 30s for other topics if anyone has one!
19:14 <seb128> seems not
19:14 <seb128> thanks everyone!
19:14 <seb128> #endmeeting
19:15 <amurray> thanks seb128
19:15 <seb128> (and I just noticed that I got a /msg from the bot telling me 'Error: Can't start another meeting, one is in progress')
19:15 <seb128> well, we still have the irclogs
19:15 <vorlon> thanks for the very efficient meeting!
19:16 <seb128> np! :)
19:19 <rbasak> vorlon: I had permission to change the shared calendar entry so I JFDI
19:19 <rbasak> (FYI)
19:19 <vorlon> hurray!
19:21 <seb128> rbasak, thanks for updating the calendar! :)
15:01 <bdrung> \o
15:01 <dviererbe> o/
15:01 <ginggs> o/
15:01 <juliank> #endmeeting
15:02 <zhsj> o/
15:02 <liushuyu> o/
15:02 <mclemenceau> o/
15:02 <juliank> We have some meeting starting trouble
15:02 <xypron> \o
15:02 <ogayot> o/
15:03 <xypron> #endmeeting
15:03 <juliank> cpaelzer: Can you #endmeeting, I think it is stuck on your old meeting?
15:04 <juliank> cpaelzer: Oh I guess you need to endmeeting with cpaelzer_
15:04 <juliank> cpaelzer: It never accepted your endmeeting
15:05 <cpaelzer_> #endmeeting