19:04 <utkarsh2102> #startmeeting Developer Membership Board
19:04 <meetingology> Meeting started at 19:04:39 UTC.  The chair is utkarsh2102.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:04 <seb128> anyone wanting to chair?
19:04 <meetingology> Available commands: action, commands, idea, info, link, nick
19:04 <seb128> utkarsh2102, thanks
19:04 <rbasak> seb128: we used to do that, but then got equally stuck when the nominated chair was absent.
19:05 <seb128> that's why we have a fallback chair in TB meetings
19:05 <utkarsh2102> hey, so I'll get straight to the application and then I'll bring up seb128's comment as AOB later
19:05 <rbasak> That didn't work either. Usually the fallback chair was also absent.
19:05 <seb128> if the fallback is also missing then you get an issue...
19:05 <seb128> utkarsh2102, ack
19:05 <rbasak> Anyway, DMB attendance is better now
19:05 <utkarsh2102> we have 1 core-dev application today
19:05 <utkarsh2102> #topic Core Dev Applications
19:05 <rbasak> I'm happy for us to try that again if people want
19:05 * sil2100 will brb in 2 minutes, just grabbing coffee
19:06 <utkarsh2102> #subtopic Nick Rosbrook
19:06 <utkarsh2102> #link https://wiki.ubuntu.com/enr0n/CoreDeveloperApplication
19:06 <utkarsh2102> enr0n: hey, welcome back again! super excited for you to be here! \o
19:06 <enr0n> utkarsh2102: thanks!
19:06 <utkarsh2102> could you please take a quick second to re-introduce yourself, please?
19:07 <enr0n> Sure. My name is Nick Rosbrook, aka enr0n, and I work on the Ubuntu Foundations team at Canonical. I am based in the Eastern US in the state of Vermont
19:07 <utkarsh2102> enr0n: also, I intentionally didn't sponsor your MP last week! I am hoping you'd do that yourself!!!!!!!!!! :)
19:07 <enr0n> utkarsh2102: ah well that would be nice!
19:08 <utkarsh2102> I hereby open the floor for questions
19:08 <utkarsh2102> I'll go first
19:08 <rbasak> FYI, enr0n's previous application can be found here: https://irclogs.ubuntu.com/2023/02/06/%23ubuntu-meeting.html#t16:07
19:08 <utkarsh2102> enr0n: since the last application, what has changed? can you give a quick TL;DR?
19:09 * sil2100 is back
19:09 <enr0n> utkarsh2102: Yeah. Since the last meeting I made the effort to work on a wider variety of packages in main, I took on more merges than I had previously, and I made a stronger effort to reach out to a wider group of sponsors
19:11 <utkarsh2102> sweet!
19:11 <utkarsh2102> thanks!
19:12 <enr0n> Of course
19:12 <rbasak> enr0n: have you manage to work on any transitions yet?
19:12 <rbasak> managed
19:12 <utkarsh2102> anyone else?
19:13 <sil2100> enr0n: when working on +1 maintenance, how do you usually identify what to work on next?
19:13 <sil2100> (great +1 maintenance reports btw.)
19:14 <enr0n> rbasak: no, that is something I have not had the need/opportunity to work on yet. However I have tried to make myself aware of the process in the event that I do, and also so that I am aware of what's going on in the archive during transitions
19:14 <utkarsh2102> seconded, good +1 reports, good stuff.
19:14 <rbasak> enr0n: how would you verify that an upload that you're about to perform (eg. say you were uploading a new upstream version as a -0ubuntu1) won't trigger a transition?
19:15 <enr0n> sil2100: typically I take the approach of starting at the bottom of the update excuse page and working my way up. I also read previous reports and update-excuse bugs to see if there is anything I can help finish
19:17 <sil2100> enr0n: thanks o/
19:18 <enr0n> rbasak: I am not aware if there is a true test for that, I guess. But the main indicators to me would be a new versioned binary package for a library, or anything indicating a ABI change like a soname bump
19:18 <utkarsh2102> enr0n: as a side note, I'd rather have people not work from the bottom because those things are generally not super needed, things have been rotting for a while, et al. And not from the top because those are too new and the uploaders might be looking out for their uploads already. So the sweet spot is from 2/5th to 4/5th of the page. ;)
19:18 <seb128> it's a tricky balance indeed
19:18 <rbasak> enr0n: OK, thanks.
19:18 <enr0n> utkarsh2102: yeah true, the bottom does tend to be bugs that have an update-excuse bug that is not actionable. But sometimes its worthing making sure old bugs do at least have an update-excuse bug with some context
19:19 <utkarsh2102> yep
19:19 <utkarsh2102> any more questions?
19:19 <rbasak> enr0n: if somebody's upload gets stuck in proposed, who's expected to handle it?
19:20 <enr0n> rbasak: the uploader
19:21 <rbasak> enr0n: thanks. And is there a time when you cannot upload feature changes to the development release? If so, where can you find the schedule, and how would you determine if an upload you're about to perform contains a feature change?
19:23 <enr0n> rbasak: yes, feature freeze is the time where such uploads are not allowed without a feature freeze exception. The release schedule is at https://wiki.ubuntu.com/ManticMinotaur/ReleaseSchedule (or whatever the devel release name is). I would need to look at the diff of the upload to determine if it contains a feature change
19:24 <rbasak> enr0n: OK. And who do you need approval from if you need an exception?
19:24 <enr0n> rbasak: the ubuntu release team
19:25 <rbasak> Thanks. Setting aside exceptions, if you disagree with the technical content of an upload someone else has performed, how should you proceed?
19:27 <enr0n> I suppose if were serious enough (rather than nitpicking) I would reach out to the person to try and discuss the change and see if we can improve it, or open a bug report if needed
19:27 <rbasak> OK, and what would you do if that's not successful and you think an escalation is appropriate?
19:28 <enr0n> I would reach out to a more senior member of my team, or maybe ask in #ubuntu-release for advice
19:28 <rbasak> OK, thanks. I have no more questions.
19:29 <utkarsh2102> sweet, no questions from me either
19:30 <utkarsh2102> seb128, sil2100, bdmurray?
19:30 <sil2100> No questions here
19:30 <seb128> neither from me
19:30 <bdmurray> none here
19:31 <utkarsh2102> sil2100: ?
19:32 <rbasak> <sil2100> No questions here
19:32 <utkarsh2102> oh crap, missed it
19:32 <utkarsh2102> let's proceed to vote
19:33 <utkarsh2102> #vote Nick to get core-dev rights
19:33 <meetingology> Please vote on: Nick to get core-dev rights
19:33 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:33 <sil2100> +1
19:33 <meetingology> +1 received from sil2100
19:33 <rbasak> +1 concerns raised at your previous application meeting have mostly been addressed, and you have generally good and to-the-point answers to our usual questions. While having some experience in driving transitions would be nice, I don't think it's a hard requirement to have experience of absolutely everything and your general understanding seems to be good across the board with examples of your work
19:33 <meetingology> +1 concerns raised at your previous application meeting have mostly been addressed, and you have generally good and to-the-point answers to our usual questions. While having some experience in driving transitions would be nice, I don't think it's a hard requirement to have experience of absolutely everything and your general understanding seems to be good across the board with examples of your work received from rbasak
19:33 <seb128> +1
19:33 <meetingology> +1 received from seb128
19:33 <rbasak> consistent with that. Thank you for all your work on Ubuntu!
19:33 <bdmurray> +1 as I trust Nick, his judgement and decision making skills. I believe he will continue to look for guidance when uploading packages.
19:33 <meetingology> +1 as I trust Nick, his judgement and decision making skills. I believe he will continue to look for guidance when uploading packages. received from bdmurray
19:33 <utkarsh2102> +1; solid endorsements, lovely work, had the pleasure of meeting him in person, he's really kind. I've also seen quite a lot of his work, sponsored a couple of things, all neat and clean. Would be a net win for Ubuntu if he gets to core-dev.
19:33 <meetingology> +1; solid endorsements, lovely work, had the pleasure of meeting him in person, he's really kind. I've also seen quite a lot of his work, sponsored a couple of things, all neat and clean. Would be a net win for Ubuntu if he gets to core-dev. received from utkarsh2102
19:34 <utkarsh2102> #endvote
19:34 <meetingology> Voting ended on: Nick to get core-dev rights
19:34 <meetingology> Votes for: 5, Votes against: 0, Abstentions: 0
19:34 <meetingology> Motion carried
19:34 <utkarsh2102> congratulations, enr0n! :D
19:34 <dbungert> 🎉
19:34 <enr0n> \o/
19:35 <utkarsh2102> #action I'll take up the announements
19:35 * meetingology I'll take up the announements
19:35 <utkarsh2102> I mean, Utkarsh will, oof
19:35 <utkarsh2102> anyway
19:35 <enr0n> Thank you everyone!
19:35 <utkarsh2102> moving to AOB
19:35 <utkarsh2102> #topic AOB
19:35 <utkarsh2102> <seb128>: sorry, those meetings feel chaotic, we need to pre-define a chair imho
19:36 <utkarsh2102> let's talk about that
19:36 <utkarsh2102> seb128:^
19:36 <seb128> yes please
19:36 <sil2100> I think we tried pre-defining the chair in the past, but that didn't quite work as the DMB had trouble getting quorum
19:36 <seb128> the define a chair/backuo for the next meeting works fine for the TB imho
19:36 <sil2100> But I think doing it now shouldn't be such a problem, I think it will be rather rare for both the chair and the backup to be absent
19:37 <seb128> if there is no quorum there is no meeting
19:37 <seb128> should we optimize for the non working cases?
19:37 <sil2100> And in case both are missing, which hopefully will be only infrequent, we can resolve tihngs as we do now, by volunteers
19:37 <seb128> if they are absent then we just are in the same situation than today...
19:37 <seb128> there isn't much to loose imho
19:38 <sil2100> Exactly
19:38 <sil2100> So I'd be +1 on that
19:38 <seb128> should we vote?
19:39 <rbasak> +1
19:40 <seb128> +1
19:40 <sil2100> I
19:40 <utkarsh2102> +1
19:40 <sil2100> I'm +1 of course too
19:41 <bdmurray> To be cleare we are voting on having a chair and a backup chair for meetings going forward?
19:41 <utkarsh2102> so are we going to define the chair for the subsequent meeting everytime?
19:41 <seb128> bdmurray, yes
19:41 <bdmurray> Okay, I'm a +1 on that
19:41 <seb128> utkarsh2102, that's the suggestion, TB just do it in alphabetic order from the launchpad team
19:42 <bdmurray> Choosing the next chair at the current meeting makes sense to me
19:42 <utkarsh2102> hah!
19:42 <utkarsh2102> right
19:42 <bdmurray> As we should know our holiday schedule
19:42 <utkarsh2102> to start things off, I can chair the next meeting, too :)
19:42 <seb128> great :)
19:43 <seb128> should we consider that as validated and go with the alphabetic order rule the TB using?
19:43 <rbasak> Yes
19:43 <seb128> great!
19:43 <utkarsh2102> si
19:43 <rbasak> I'm sure we'll all slip up and forget about planned absences. But that'll probably be fine usually. We'll deal with it.
19:44 <seb128> I've another topic which is probably not fit to discuss now but I don't know what's the proper way to bring the subject
19:44 <sil2100> utkarsh2102: who will be backup?
19:44 <utkarsh2102> is that for me to decide?
19:44 <utkarsh2102> I'll pick sil2100, hahaha
19:44 <sil2100> I guess alphabetically that woul be me!
19:44 <seb128> sil2100, let's go alphabetic from https://launchpad.net/~developer-membership-board/+members so you
19:44 <seb128> :p
19:44 <sil2100> ;)
19:46 <seb128> should we move on to the next topic(s)?
19:47 <utkarsh2102> sure
19:47 <utkarsh2102> is there any?
19:47 <seb128> I've one which I'm unsure where to discuss
19:47 <bdmurray> I believe so
19:47 <utkarsh2102> #topic mythbuntu-dev
19:47 <utkarsh2102> [bdmurray] Why is mythbuntu-dev still a delegated team when it isn't a flavor?
19:47 <utkarsh2102> go go go
19:47 <bdmurray> https://launchpad.net/~mythbuntu-dev/+members#active the only members are ubuntu-core-dev
19:49 <bdmurray> I found the team listed under delegated teams at https://wiki.ubuntu.com/DeveloperMembershipBoard
19:49 <rbasak> I guess someone needs to wind everything up there?
19:49 <bdmurray> rbasak: Do have an idea of what "wind everything up" means?
19:51 <rbasak> I don't, sorry.
19:51 <rbasak> Anything outstanding like the delegation you spotted I guess?
19:52 <rbasak> Should we contact the last known contacts first?
19:52 <rbasak> Might be polite.
19:52 <rbasak> (at least to try)
19:52 <bdmurray> Sure, I can do that.
19:53 <rbasak> But also, maybe a low priority since it isn't causing much harm right now?
19:54 <utkarsh2102> si
19:54 <bdmurray> Okay
19:56 <utkarsh2102> let's move on?
19:56 <seb128> yes!
19:57 <seb128> so I had a topic which we aren't going to be able to discuss now but I would like to bring up for discussion
19:58 <rbasak> seb128: could you add it to the agenda?
19:58 <seb128> maybe the mailing list is better and I will post there
19:58 <rbasak> Or sure, mailing list
19:58 <seb128> just getting input
19:58 <seb128> I think the current DMB line (from the past meetings record) discourage coredev applications
19:59 <seb128> the 'you didn't work outside of you usual package set, you are not ready for coredev' line is damaging
19:59 <seb128> you can have very skilled people that just work in a set
19:59 <seb128> why would we deny them trust?
20:00 <utkarsh2102> yep
20:00 <seb128> it just feel them considered negatively which I think is helping nobody
20:00 <utkarsh2102> okay, we have two AOB now
20:00 <utkarsh2102> one from Brian and one from Seb
20:00 <seb128> I will email the list
20:00 <utkarsh2102> let's do it next time
20:00 <sil2100> I think we should be more welcoming indeed, we should encourage applicants to work outside of their sets but not require it - if, of course, they demonstrate during the interview process that they know how to handle packages outside of their comfort zone
20:01 <utkarsh2102> since we're at the top of the hour now
20:01 <seb128> ack
20:01 <bdmurray> +1 sil2100
20:01 <seb128> I think think we are a velocity issue btw
20:01 <seb128> we don't cover much in an hour, there is more gaps than active times in those meetings
20:01 <seb128> which might be a 3rd AOB
20:01 <seb128> utkarsh2102, thanks for chairing!
20:01 <utkarsh2102> and also next meeting has only 1 contirbuting dev so we'll have more time to do these talks
20:02 <utkarsh2102> sweet, np. Any last words before I shut this off? :)
20:02 <utkarsh2102> this = meeting
20:02 <utkarsh2102> not the topic, hehe
20:02 <seb128> I'm not going to be there for the next one btw, summer holidays
20:02 <utkarsh2102> uh oh
20:02 <utkarsh2102> have fun, seb128 \o
20:02 <utkarsh2102> #endmeeting