16:12 <sil2100> #startmeeting Developer Membership Board
16:12 <meetingology> Meeting started at 16:12:23 UTC.  The chair is sil2100.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:12 <meetingology> Available commands: action, commands, idea, info, link, nick
16:12 <sil2100> #topic Ubuntu Contributing Developers Applications
16:13 <sil2100> #subtopic Heather Ellsworth
16:13 <sil2100> #link https://wiki.ubuntu.com/hellsworth/ContributingDeveloperApplication
16:13 <sil2100> hmmm
16:13 <teward> *burp* sorry i'm late
16:13 <sil2100> Do we have Heather here?
16:13 <sil2100> ...I don't see her online
16:14 <sil2100> Let's skip her in that case, she might need to re-appy
16:14 <sil2100> *apply
16:14 <sil2100> #subtopic Nikhil Kshirsagar
16:14 <sil2100> #link https://wiki.ubuntu.com/nkshirsagar/UbuntuPerPackageUploaderApplication
16:14 <sil2100> Argh
16:14 <sil2100> #topic Package Set/Per Package Uploader Applications
16:15 <sil2100> (sorry for the confusion, doing 2 meetings at once is a bit confusing)
16:15 <sil2100> #subtopic Nikhil Kshirsagar
16:15 <sil2100> #link https://wiki.ubuntu.com/nkshirsagar/UbuntuPerPackageUploaderApplication
16:15 <sil2100> Now it's better
16:15 <sil2100> nkshirsa: o/
16:15 <nkshirsa> Hello o/
16:16 <sil2100> So nkshirsa already introduced themselves via e-mail and I asked them some questions already, but feel free to reintroduce yourself again briefly
16:16 <sil2100> #link https://udd.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=&sponsor_search=name&sponsoree=Nikhil+Kshirsagar&sponsoree_search=name
16:17 <sil2100> Otherwise, I guess we're open to questions
16:17 <nkshirsa> Sure. I'm Nikhil Kshirsagar, I've been with Canonical about 2 years working in the SEG team on escalated cases related to cloud and platform storage. I live in Pune, India. I've been using open source for about 10 years now, my main driver OS is Ubuntu of course, but have used red hat and centos/fedora in the past too..
16:18 <teward> sil2100: link to the email?  since i have 20k unread in my inbox :P
16:19 <nkshirsa> teward, https://lists.ubuntu.com/archives/devel-permissions/2023-June/002288.html
16:21 <kanashiro[m]> nkshirsa: what would you do if a sosreport upload gets stuck in -proposed because of a regression?
16:22 <nkshirsa> kanashiro[m], this was what I ran into for the previous release, 4.5.3 .. we discovered a bug in the upstream package that was hit while testing in a juju environment (something that the test cases did not cover)
16:22 <nkshirsa> But that was a bug discovered upstream. If you mean an autopkgtest regression, I'd look at the update_excuses page for a start..
16:23 <nkshirsa> and try to identify the cause of the problem from there. If it all looks good, I'd also consider installability issues and take a look at the update_output page to see if its blocked due to some dependency issues or conflicts
16:23 <kanashiro[m]> yeah, I meant autopkgtest :)
16:23 <nkshirsa> :-)
16:24 <teward> nkshirsa: From what I can tell the vast majority of your sosreport work is in sru updates, do you have contributions to devel release or upstream sosreport?  And if not, then why not?
16:24 <nkshirsa> teward, I do have contributions to upstream sos, I redesigned the ceph plugin in upstream sos , let me dig out the link
16:25 <teward> s/vast majority/majority if not all/
16:25 <kanashiro[m]> There are upstream contributions in the application
16:26 <sil2100> nkshirsa: I'll have a follow up question to your e-mail answers that you gave to my questions
16:26 <utkarsh2102> nkshirsa: I’m confused with the version of sosreport in Ubuntu. What’s the reason? For example, Lunar has 4.5-1ubuntu0. Which looks odd. And then there’s 4.5.3ubuntu0.23.04.1.
16:26 <nkshirsa> the majority of the work is SRU updates, that is correct, that's because I am resposible for building/testing the packages each time there's a new upstream release ..
16:27 <nkshirsa> sil2100, ack
16:27 <utkarsh2102> nkshirsa: there’s no upstream downstream version separation. That’s weird. Why so?
16:28 <sil2100> nkshirsa: so I have a follow up question to question 2), so the question about MRE. Your response was good, but I want some additional clarification: in limitations you mentioned that 'or any drastic changes' are not allowed - what would you consider a drastic change?
16:28 <nkshirsa> utkarsh2102, yeah that was because earlier sos used to be only major release, so 4.2, 4.3, 4.4 etc. for 4.5 they shifted to monthly cadence, and that time we had discussed having just one ubuntu release for the 4.5 series .. so I called it 4.5, and yes the -1 was a mistake .. for the 4.5.3 release we had decided to release more than just 1 major release of 4.5, so that changed the numbering to including the .3 .. it was messy, I plan to take
16:28 <nkshirsa> care of this carefully going forward..
16:29 <utkarsh2102> But there’s no separation of the downstream version from the upstream version.
16:29 <nkshirsa> sil2100, new features, or some new build dependency. Generally MRE's could be considered for bugfix releases upstream
16:30 <nkshirsa> utkarsh2102, so, 4.5.3 only went into devel. we did not release it for stable since we discoverd the bug during testing proposed.
16:30 <utkarsh2102> nkshirsa: but do you understand the problem with the version string you’ve chosen?
16:33 <sil2100> nkshirsa: ok, that's fair, since the important thing is to not change existing behavior of users, which your answer basically incorporates
16:33 <nkshirsa> yes, there are issues .. firstly, I need the -0 at the end of the upstream release to indicate there's no debian revision. It's optional but only if the package is built for debian purely. If there's no debian package (like for sos), then I need it to be -0. That's one. Secondly I realize that I need ubuntu1 instead of ubuntu0 , but thats something I chose based on what ceph does.. the 23.04.1 implies its the first update ..
16:33 <nkshirsa> ^^ utkarsh2102 to answer your question in as much detail as I can :-)
16:34 <sil2100> nkshirsa: it's indeed interesting that sosreport is a native package now starting with lunar?
16:34 <teward> nkshirsa: As slashd mentioned in your endorsements, you don't seem to have much devel release work on the radar with regards to sosreport - from the sponsorship miner, its primarily SRUs and backports of the versions via SRU.  Is there a primary reason for this?  Its generally unusual to see no devel work
16:34 <utkarsh2102> nkshirsa: fair, and thanks. Please try to fix the version in the next upload.
16:35 <teward> also apologies for slow msgs on my end, here via phone today
16:35 <nkshirsa> utkarsh2102, yes this has been discussed in detail and will be taken care of going forward
16:35 <sil2100> Ah, it's not a native package, just the versioning indeed needs fixing
16:35 <utkarsh2102> sil2100: hehe, yeah. I got super confused, too
16:36 <nkshirsa> yes sil2100 , I need to fix the versioning. I need to have -0 for "no debian package of this version" and also ubuntu1 for "first revision". I chose ubuntu0 based on the way ceph does it.. but its clearer to do it with ubuntu1.. as I mentioned, I will fix the versioning properly for the next release
16:36 <sil2100> nkshirsa: thanks ;)
16:36 <sil2100> All good if that's on your radar!
16:36 <nkshirsa> teward, whatever work I've done upstream in sos, it's been architecture/redesign
16:36 <nkshirsa> sil2100, yes it is :-)
16:37 <nkshirsa> teward, also the odd review, bugfixes, and constant discussions with the upstream sos team about stuff that breaks ubuntu specific things..
16:37 <teward> nkshirsa: i didnt ask about upstream.  i asked about the ubuntu devel release.
16:37 <teward> not upstream sosreport
16:39 <sil2100> teward: I do seem new devel release uploads of sosreport there though?
16:39 <nkshirsa> teward, I make the devel release too, but eric (slashd) pushes it to the upload queue
16:40 <teward> sil2100: i see three out of a handful of sponsored items
16:40 <teward> and only one not tied to sru related
16:41 <teward> hence my question about why theres not as much devel work.  but whatever.
16:42 <sil2100> teward: well, to be fair, nkshirsa's upload history has selected devel uploads + SRU uploads. It seems sosreport follows a work-process of submitting the new version to all series at once, devel+stable. Only the first SRUs don't have the devel version prepared by nkshirsa
16:42 <utkarsh2102> fwiw, I’m ready to vote :)
16:42 <nkshirsa> yes, that is correct.. the first SRU i remember 4.3 , slashd did the devel himself because I was new to the process then
16:42 <kanashiro[m]> Ready to vote too
16:43 <sil2100> Any other questions?
16:43 <teward> sil2100: makes me wonder if this needs a mre then just thinking out loud :P
16:43 <nkshirsa> 4.4 onwards I've done the devel too.. so basically last 3 releases.. we release a new sosreport typically every 3 months now.. which is why I'm trying to ease taking up b/w from sponsors and work on the uploads myself to speed up things
16:43 <teward> i am ready to vote
16:43 <sil2100> teward: it has one! ;)
16:44 <sil2100> https://wiki.ubuntu.com/StableReleaseUpdates#sosreport
16:44 <sil2100> Ok, let's vote then!
16:44 <teward> blah this is what happens when my inbox is flooddd xD
16:44 <nkshirsa> yes it does its not for MRE but for stable release exception.. :-)
16:44 <teward> flooded*
16:44 <sil2100> #vote Grant PPU to nkshirsa for sosreport
16:44 <meetingology> Please vote on: Grant PPU to nkshirsa for sosreport
16:44 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:45 <utkarsh2102> +1; I feel Nikhil is ready for the upload rights. They demonstrate the experience needed and I’m sure they’ll be an asset to Ubuntu. Keep up the good work but please keep asking questions when in doubt. Ping me or any core-dev for reviews, et al. Best of luck!
16:45 <meetingology> +1; I feel Nikhil is ready for the upload rights. They demonstrate the experience needed and I’m sure they’ll be an asset to Ubuntu. Keep up the good work but please keep asking questions when in doubt. Ping me or any core-dev for reviews, et al. Best of luck! received from utkarsh2102
16:46 <sil2100> +1 - I see a bit of a learning curve with nkshirsa's uploads, but I think the applicant is ready enough to be able to own the work themselves. Please be sure to put emphasis on versioning, proper changelog formatting and not to miss any d/control dependencies!
16:46 <meetingology> +1 - I see a bit of a learning curve with nkshirsa's uploads, but I think the applicant is ready enough to be able to own the work themselves. Please be sure to put emphasis on versioning, proper changelog formatting and not to miss any d/control dependencies! received from sil2100
16:47 <bdmurray> +1
16:47 <meetingology> +1 received from bdmurray
16:47 <seb128> +1 I think the work on the package is solid and I trust nkshirsa to improve the few things discussed today
16:47 <meetingology> +1 I think the work on the package is solid and I trust nkshirsa to improve the few things discussed today received from seb128
16:47 <kanashiro[m]> +1 I have seen some of nkshirsa's work while triaging bugs, and I think his work on sosreport is great.
16:47 <meetingology> +1 I have seen some of nkshirsa's work while triaging bugs, and I think his work on sosreport is great. received from kanashiro[m]
16:48 <teward> +1
16:48 <meetingology> +1 received from teward
16:48 <sil2100> #endvote
16:48 <meetingology> Voting ended on: Grant PPU to nkshirsa for sosreport
16:48 <meetingology> Votes for: 6, Votes against: 0, Abstentions: 0
16:48 <meetingology> Motion carried
16:48 <teward> (send coffee please)
16:48 <sil2100> nkshirsa: congrats! o/
16:48 <utkarsh2102> Woot! Congratulations!
16:48 <utkarsh2102> sil2100: I’ll take care of the announcement, et al
16:48 <seb128> congrats nkshirsa!
16:48 <sil2100> Who wants to take the action item of adding nkshirsa PPU?
16:48 <sil2100> Excellent
16:48 <nkshirsa> Thank you! :-)
16:49 <sil2100> #action utkarsh2102 to handle announcement and PPU adjustments for nkshirsa
16:49 * meetingology utkarsh2102 to handle announcement and PPU adjustments for nkshirsa
16:49 <nkshirsa> thank you also for the feedback and suggestions :-)
16:49 <utkarsh2102> I ought to run unless there’s anything else that’s pressing?
16:49 <sil2100> Okay, let's move on. I think there's nothing else to address
16:49 <sil2100> #topic AOB
16:50 <sil2100> I guess no AOB?
16:50 <teward> one
16:50 <utkarsh2102> Sweet! I’ll ask Heather to reschedule
16:50 <sil2100> ah, there's one from bdmurray
16:50 <sil2100> [bdmurray] Why is mythbuntu-dev still a delegated team when it isn't a flavor?
16:50 <sil2100> bdmurray: do you want to take this one?
16:50 <utkarsh2102> Also, I’m working on the documentation. I’ll need sometime for it. Will share when I have an update.
16:51 <sil2100> I will have to AFK in a moment as well
16:51 <teward> only an fyi from me for AOB: i will be absent the next two DMB meetings - prior FT job mandatory things conflicting with DMB meetings.
16:51 <sil2100> teward: ACK o/
16:52 <sil2100> bdmurray: let's maybe postpone your AOB to next meeting if you don't mind
16:52 <sil2100> I'll close off the meeting now
16:52 <utkarsh2102> teward: ack, take care, and try not to put things on fire :)
16:52 <sil2100> #endmeeting