15:05 <ddstreet> #startmeeting Ubuntu Backporters Team
15:05 <meetingology> Meeting started at 15:05:18 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:05 <meetingology> Available commands: action, commands, idea, info, link, nick
15:05 <ddstreet> so mapreri I haven't got to any of my action items...i suggest we skip me listing them all if that's ok with you?
15:06 <mapreri> let me read them through in the agenda
15:06 <ddstreet> yep and for reference if anyone is following
15:06 <ddstreet> #link https://wiki.ubuntu.com/UbuntuBackports/Agenda
15:07 <mapreri> right so, I haven't also done my actions either
15:07 <ddstreet> let's just leave the list as is then and move to ML threads and bugs
15:07 <mapreri> ack
15:07 <ddstreet> #action open ml threads
15:07 * meetingology open ml threads
15:08 <ddstreet> #subtopic clarification on specific wording for no-bug-required backport exceptions
15:08 <ddstreet> no action on this one...i'll send a follow up to try to continue it
15:08 <mapreri> k
15:08 <ddstreet> ah dang i used #action instead of #topic above...i need more coffee
15:08 <ddstreet> anyway
15:08 <mapreri> you can #undo twice if you so like ^^
15:09 <ddstreet> #undo
15:09 <meetingology> Removing item from minutes: SUBTOPIC
15:09 <ddstreet> #undo
15:09 <meetingology> Removing item from minutes: ACTION
15:09 <ddstreet> ah nice!
15:09 <ddstreet> didn't know it stacked
15:09 <ddstreet> thanks!
15:09 <mapreri> ^^
15:09 <ddstreet> #topic open ml threads
15:09 <ddstreet> #subtopic clarification on specific wording for no-bug-required backport exceptions
15:09 <ddstreet> #action ddstreet send follow up email for clarification on specific wording for no-bug-required backport exceptions
15:09 * meetingology ddstreet send follow up email for clarification on specific wording for no-bug-required backport exceptions
15:10 <ddstreet> #subtopic New proposal for Ubuntu Backporters Team Charter
15:10 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2023-May/023070.html
15:10 <ddstreet> well looks like we took too long, and the approved it, so nothing for us to do there i suppose...
15:10 <ddstreet> we could follow up with 'thanks!' i guess
15:11 <mapreri> not quite
15:11 <mapreri> they said they will approve it next week, so if we have something big to oppose... but do we, in the end?
15:12 <ddstreet> i guess it looks fine to me
15:12 <ddstreet> you have any objections?
15:12 <mapreri> I don't, either.  I'm for giving them the go ahead
15:12 <ddstreet> sounds good - you want to reply or should i?
15:12 <mapreri> I will :)
15:12 <ddstreet> thanks!
15:13 <ddstreet> #action mapreri reply to TB charter email thread
15:13 * meetingology mapreri reply to TB charter email thread
15:13 <ddstreet> #subtopic self-approval of uploads to -backports pocket
15:13 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2023-May/023075.html
15:13 <ddstreet> i think teward is handling this one
15:13 <mapreri> yes
15:14 <ddstreet> that's all the ml threads i see
15:14 <ddstreet> #topic open bugs
15:14 <ddstreet> #subtopic nfs-utils/1:2.6.1-2ubuntu4 from kinetic
15:14 <ddstreet> #link https://bugs.launchpad.net/ubuntu/focal/+source/nfs-utils/+bug/2012676
15:14 <mapreri> so, I had an action about following up, but I clearly failed and I actually forgot what we decided on 2 months ago? :(
15:15 <mapreri> I fixed the bug matadata, however.  meta is important.
15:15 <ddstreet> lemme check the old mtg minutes...
15:15 * mapreri too
15:15 <teward> i'm late sorry
15:16 <teward> ddstreet: i need to address this sooner than later.  did you get any reply to the last inquiry?
15:16 <teward> on the self approval of uploads thing
15:16 <ddstreet> nope i did not get any reply
15:16 <ddstreet> well lemme just recheck my inbox to be sure
15:16 <mapreri> ddstreet: seems: 1) asking who would provide the update 2) involve the server team 3) having the mentioned bug handled via SRU
15:17 <ddstreet> nope definitely no reply in my inbix
15:17 <teward> mapreri: assuming theres no reply are you OK with me going to the TB and asking the TB to reach out and remind martin about the new process and that it needs to be adhered to?
15:17 <mapreri> I'd add 4) have a better test defined
15:17 <teward> ah there is no relly som
15:17 <teward> reply*   so*   ffs i cant type
15:18 <mapreri> teward: I'm fine, as long as you frame it like "asking the TB to reach out to Martin and check with him whether he received our mails about the new process, and to please contact us about his bpo uploads"
15:19 <mapreri> teward: i.e., lose the final "it needs to be adhered to", for a first TB contact they shouldn't be saying that so straightforwardly
15:19 <mapreri> :3
15:19 <ddstreet> mapreri re: nfs-utils, sounds good, and you already have an action item for it
15:19 * mapreri can be a PITA, I have been bit by too strong wording way too many times
15:20 <teward> mapreri: how i word things for email / official requests is less heavy handed than my statements here in cha lt :)
15:20 <ddstreet> teward we skipped over previous action items earlier, were there any of yours (other than the TB/self-approval one) you made progress on and wanted to review?
15:21 <teward> no its been a chaotic month
15:21 <ddstreet> yeah for me as well
15:21 <ddstreet> ok that's all the bugs i see the team subscribed to
15:21 <ddstreet> #topic AOB
15:21 <ddstreet> any other business to discuss?
15:22 <mapreri> another nfs thing:
15:22 <mapreri> shouldn't it come from jammy, not from kinetic?
15:22 <mapreri> doing kinetic → focal will break update paths
15:22 * mapreri goes to re-read the policy he himself wrote u.u
15:23 <ddstreet> i think we do allow non-LTS backport to LTS, but if they are doing kinetic->focal it must also go into jammy
15:23 <mapreri> right
15:23 <mapreri> I'll mention that too
15:23 <teward> ddstreet: we do allow origin:nonLTS
15:23 <teward> but destination:nonLTS is a no-no.  and yes we need to also get the backport into jammy in that case
15:24 <mapreri> but we did write " For backported packages, the policy is that users must be able to upgrade from LTS to LTS", so in case of origin:kinetic it *also* needs an extra dest:jammy
15:24 <teward> yep
15:24 <mapreri> or just start from jammy, the kinetic update doesn't look interesting to me
15:25 <teward> mapreri: could ask for clarification as to why source:kinetic is required and whether source:jammy works
15:25 <mapreri> aye, doing
15:25 <ddstreet> and also the backport to bionic has a really short window before the bionic repo closes, i think it's end of june right?
15:26 <ddstreet> or maybe july
15:26 <ddstreet> ok moving on, any other business? if not, let's sched the next meeting
15:26 <mapreri> yeah well... they won't make it, but whatever at this point…
15:26 <mapreri> no aob from me :)
15:27 <ddstreet> 4 weeks would put us at july 5
15:27 <teward> no other business here
15:27 <ddstreet> that's very close to USA holiday (july 4), should we bump it to following week (july 12)?
15:28 <mapreri> jul 5 is good to me, but indeed 12 would work slightly better as well
15:28 <teward> either works for me
15:28 <ddstreet> jul 12 would be better for me too
15:28 <ddstreet> ok let's do jul 12, at same time
15:28 <teward> 12th it is then
15:28 <mapreri> yay
15:29 <ddstreet> final business from me is to say i'm going to try to get *some* of my action items done before next meeting :)
15:29 <ddstreet> let's all try to get to at least one ;-)
15:29 <ddstreet> ok any final item before we wrap?
15:30 <mapreri> I'm doing the mails right at this moment
15:30 <ddstreet> awesome!!!
15:30 <ddstreet> thanks
15:30 <mapreri> that should make sure to have them done :3
15:30 <ddstreet> see you covered your action already! xD
15:30 <ddstreet> ok let's wrap then
15:30 <ddstreet> #endmeeting