19:07 <seb128> #startmeeting Developer Membership Board
19:07 <meetingology> Meeting started at 19:07:07 UTC.  The chair is seb128.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:07 <meetingology> Available commands: action, commands, idea, info, link, nick
19:07 <seb128> #link https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda
19:07 <seb128> #topic PPU Applications
19:07 <seb128> #subtopic  James Falcon  https://wiki.ubuntu.com/JamesFalcon/DeveloperPerPackageUploadApplication
19:07 <seb128> falcojr, hey
19:07 <falcojr> hi!
19:08 <seb128> falcojr, do you want to start by introducing yourself?
19:09 <falcojr> Sure! My name is James Falcon and I've been working on cloud-init (as a Canonical employee) for the past 3 years, and looking for PPU. I've been using Ubuntu off and on for a decade longer and have been a Python programmer throughout my career.
19:10 <falcojr> not sure how much you're looking for, so let me know if you want more detail
19:10 <falcojr> the application you linked contains more of the specific details for what I've done on cloud-init
19:10 <seb128> thanks
19:11 <seb128> falcojr, so let me start with one question
19:12 <seb128> falcojr, reading you wikipage you mention your upstream contribution to cloud-init, but what about the ubuntu package? did you work on it?
19:14 <falcojr> Yes, I mention many of our upstream releases but then we SRU that back into the Ubuntu releases. We'll do both at the same time with the same person driving it. The only part I don't do is the dput
19:14 <seb128> sorry I focussed on the things you listed in 'Examples of my work' but I saw now that you listed more in the next section
19:15 <bdmurray> Who is currently uploading cloud-init?
19:16 <falcojr> Chad Smith
19:16 <rbasak> Looking at the sponsorship miner, I see one addition of a Recommends in packaging, and dropping of some quilt patches that were adopted upstream. The rest of your sponsosred uploads are new upstream releases or snapshots and their corresponding SRUs.
19:16 <rbasak> This is all good work!
19:17 <rbasak> But I'm reminded of a recent applicant who had similar experience and we suggested granting upload rights but with a limitation that a public core dev review would be required for anything that required packaging work, as opposed to new upstrema releases - and that wouldn't be enforced except by trust.
19:17 <rbasak> Maybe doing something similar here would be appropriate?
19:19 <rbasak> Just on the principle that we don't want to block progress, but at the same time setting the expectation that you are responsible to sponsor anything for cloud-init packaging including in areas that you don't have prior experience in seems inappropriate.
19:19 <rbasak> This seems to be a common theme nowadays but perhaps expected as we grow and people specialise.
19:19 <falcojr> what does that review process look like? Seems reasonable to me
19:20 <rbasak> I wouldn't want to specify, deliberately so it doesn't tie your hands. What I suggested with the previous applicant was: """
19:20 <rbasak> You must not upload packaging changes or SRUs without a public code                 review from a core dev first. Once you have a public +1 from a core dev,
19:20 <rbasak> you may then sign and upload yourself.
19:20 <rbasak> """
19:21 <rbasak> In your case you clearly have SRU experience so that part wouldn't apply
19:22 <falcojr> and part of it is just that cloud-init's packaging (outside of changelog and patches) rarely changes, so that makes sense
19:23 <rbasak> Right - and if that changes then you'd get some sponsored experience for those types of changes and that would be a good basis to ask the DMB to remove that limitation.
19:23 <rbasak> I don't know if this is a good path to go down generally or what the rest of the DMB think.
19:24 <kanashiro[m]> I agree with rbasak 's proposal
19:24 <seb128> +1
19:24 <rbasak> In part this is to relieve pressure on you - because I know that once you can sponsor uploads to a package, you might get some crazy requests and suddenly it's on you :-/
19:26 <falcojr> yeah, it makes sense to me
19:26 <seb128> alright
19:27 <seb128> any other question from the DMB members?
19:27 <rbasak> So technically falcojr is a colleague on the server team at Canonical so I would abstain.
19:27 <rbasak> But in this case I think my vote is needed
19:27 <kanashiro[m]> no question from me
19:28 <rbasak> Also I don't actually work closely with falcojr - our areas of work are separate so we don't interact that much. I'll +1 if everyone else is unanimous
19:28 <seb128> rbasak, is it? kanashiro[m] utkarsh2102 bdmurray and me are around, so we have 4/7
19:28 <seb128> but I'm fine with you voting
19:28 <rbasak> kanashiro[m] is in an equivalent situation to me, but of course what he does is up to him.
19:28 <rbasak> (he's on the same team as us)
19:28 <seb128> right
19:28 <seb128> k, so if we don't have more questions let's vote
19:29 <rbasak> Anyway, I thought I'd at least declare the situation to minimise any concerns others might have of conflict.
19:29 <seb128> #vote James Falcon to get ppu upload rights for the cloud-init package
19:29 <meetingology> Please vote on: James Falcon to get ppu upload rights for the cloud-init package
19:29 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:30 <rbasak> To be clear, this vote includes the limitation I proposed above?
19:30 <seb128> yes
19:30 <kanashiro[m]> yeah, we are on the same team but TBH I've not seen any work from falcojr , so I'd be fine voting
19:30 <utkarsh2102> I’m ready to vote, I have no questions
19:31 <utkarsh2102> +1; I’ve seen James’ work and I can vouch for his good work. Having met him a couple of times, he’s even a wonderful person. I trust that James will do the right thing and will seek help whenever needed.
19:31 <meetingology> +1; I’ve seen James’ work and I can vouch for his good work. Having met him a couple of times, he’s even a wonderful person. I trust that James will do the right thing and will seek help whenever needed. received from utkarsh2102
19:31 <seb128> +1, I think the sponsors upload record and the upstream involvement and solid and I trust he will ask for a coredev review when packaging changes are needed
19:31 <meetingology> +1, I think the sponsors upload record and the upstream involvement and solid and I trust he will ask for a coredev review when packaging changes are needed received from seb128
19:32 <seb128> 'are solid...'
19:32 <bdmurray> +1
19:32 <meetingology> +1 received from bdmurray
19:32 <rbasak> +1
19:32 <meetingology> +1 received from rbasak
19:32 <kanashiro[m]> +1
19:32 <meetingology> +1 received from kanashiro[m]
19:33 <seb128> I think that's everyone who is there today right?
19:33 <seb128> #endvote
19:33 <meetingology> Voting ended on: James Falcon to get ppu upload rights for the cloud-init package
19:33 <meetingology> Votes for: 5, Votes against: 0, Abstentions: 0
19:33 <meetingology> Motion carried
19:33 <rbasak> falcojr: did you announce your application on devel-permissions@
19:33 <utkarsh2102> Woot! Congratulations!
19:33 <seb128> falcojr, congratulations!
19:33 <kanashiro[m]> congrats falcojr :)
19:33 <falcojr> Thanks!
19:34 <rbasak> falcojr: I don't see your application announced on the ML, which we need in order to reply to it :)
19:34 <falcojr> rbasak: No, I wasn't aware of that step. Can I do that now?
19:34 * rbasak can take the announcement and ACL actions - TB member needed
19:34 <seb128> falcojr, yes, thanks
19:34 <seb128> rbasak, thanks
19:34 <rbasak> falcojr: yes please. It's just so that we have a record on the ML archive which is very useful for figuring things out later.
19:35 <seb128> #action rbasak to do the announcement and ACL actions for falcojr's approved ppu application
19:35 * meetingology rbasak to do the announcement and ACL actions for falcojr's approved ppu application
19:36 <seb128> #topic Review of previous action items
19:37 <seb128> rbasak, any update on documenting the decision on Keeping IRC meetings moving?
19:39 <seb128> I guess not, let's keep moving :p
19:39 <seb128> #topic Outstanding mailing list requests to assign
19:39 <seb128> #link https://lists.ubuntu.com/archives/devel-permissions/2023-April/002250.html
19:40 <rbasak> Sorry, I got distracted - multitasking with childcare this evening. How ironic.
19:40 <seb128> :p
19:40 <seb128> so Till is requesting to have libppd added to the packaging set
19:42 <bdmurray> To which package set?
19:42 <rbasak> I think it's a PPU addition request rather than a packageset
19:42 <seb128> yes, sorry, there is an existing printing set that Till has access to
19:42 <seb128> and he's requesting to have that one source package added to the printing set
19:43 <rbasak> "So libppd can also be considered as a split-off of code which I had already         PPU rights for, via the cups and cups-filters packages.
19:43 <seb128> which seems reasonable to me
19:43 <kanashiro[m]> based on the explanation in the email it seems reasonable to me
19:43 <rbasak> So it's just src:libppd he's requesting, right?
19:43 <seb128> yes
19:44 <seb128> one of the reason Steve asked him to ask the DMB I think is because libppd existed before but was another project
19:44 <seb128> due to an unfortunate naming conflict, we ended up having libppd becoming a new project in Lunar (replacing the 10+ old unmaintained libppd by the new code split from cups stack)
19:44 <rbasak> Ah, right. https://launchpad.net/ubuntu/+source/libppd/2:2.0~b2-0ubuntu4 has some background.
19:46 <rbasak> I think this is all fine and there's no issue with granting PPU. I also don't think a formal vote is needed as it's just a rearrangement to the same effect of what he had before AIUI.
19:46 <seb128> ack
19:46 <rbasak> I appreciate his emailing with the details though, and it being brought up in this meeting so as to make progress.
19:46 <rbasak> If there's no objection I'll JFDI.
19:46 <rbasak> Or we can have a vote if others would like.
19:46 <seb128> unless someone raise an objection I will go ahead after the meeting and add it
19:47 <kanashiro[m]> +1
19:47 <seb128> great, so let's keep moving
19:47 <seb128> there is no other pending topic on the mailing list
19:47 <seb128> #topic Open TB bugs
19:47 <seb128> no bug there
19:48 <seb128> #topic AOB
19:48 <seb128> anything else to discuss today?
19:49 <seb128> seems not, that's a wrap then, thanks everyone!
19:49 <seb128> #endmeeting