#ubuntu-meeting: Ubuntu backporters team meeting

Meeting started by ddstreet at 15:15:24 UTC (full logs)

Meeting summary

  1. previous action items (ddstreet, 15:15)
    1. ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over) (ddstreet, 15:16)
      1. ACTION: ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over) (ddstreet, 15:16)
      2. ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over) (ddstreet, 15:16)
      3. ACTION: ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over) (ddstreet, 15:16)
      4. ddstreet reply to no-bug-required backport exception ML thread to keep thread alive (ddstreet, 15:16)
      5. ddstreet sponsor lp: #1998834 (ddstreet, 15:17)
      6. mapreri upload (more of) all the tools (carried over, in progress) (ddstreet, 15:17)
      7. ACTION: mapreri upload (more of) all the tools (carried over, in progress) (ddstreet, 15:17)
      8. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over) (ddstreet, 15:18)
      9. ACTION: mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over) (ddstreet, 15:18)
      10. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over) (ddstreet, 15:18)
      11. ACTION: mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over) (ddstreet, 15:18)
      12. mapreri start thread on ML about how to use bug status to define meaing in process (carried over) (ddstreet, 15:18)
      13. ACTION: mapreri start thread on ML about how to use bug status to define meaing in process (carried over) (ddstreet, 15:19)
      14. mapreri to look into backporting dh-python (see unit193 and yt-dlp) (carried over) (ddstreet, 15:19)
      15. teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (ddstreet, 15:20)
      16. ACTION: teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over) (ddstreet, 15:21)
      17. (unassigned) consider documenting an SLA for reviewing uploaded backport packages (ddstreet, 15:22)
      18. ACTION: (unassigned) consider documenting an SLA for reviewing uploaded backport packages (ddstreet, 15:23)

  2. open mailing list threads (ddstreet, 15:23)
    1. clarification on specific wording for no-bug-required backport exceptions (ddstreet, 15:24)
      1. https://lists.ubuntu.com/archives/ubuntu-backports/2022-February/022680.html (ddstreet, 15:26)
      2. https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023048.html (ddstreet, 15:27)
      3. ACTION: (unassigned) check if backports pocket uploads and/or approvals go to a ML (ddstreet, 15:34)
      4. ACTION: (unassigned) if no ML for backports uploads/approvals, check on how to create one (ddstreet, 15:34)
      5. ACTION: ddstreet send follow up email on no-bug-required ML thread mentioning cockpit (ddstreet, 15:42)
      6. https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html (ddstreet, 15:43)
      7. https://wiki.ubuntu.com/UbuntuBackports#Future_Maintenance_of_the_Backport mentions that "The backporter is responsible for […] additional updates that should be backported" - which indeed is not quite clear on what those "additioanl updates" are, but to me it means that any further update done on the base suite should also be backported? (mapreri, 15:47)
      8. ACTION: ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html (ddstreet, 15:50)
      9. open bugs (ddstreet, 15:52)

  3. open bugs (ddstreet, 15:52)
    1. https://bugs.launchpad.net/ubuntu/jammy/+source/memtest86+/+bug/1998834 (ddstreet, 15:52)
    2. https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/2012676 (ddstreet, 15:53)
      1. ACTION: mapreri follow up in https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/2012676 (ddstreet, 15:59)

  4. aob (ddstreet, 15:59)
    1. next mtg date (ddstreet, 16:00)
      1. ACTION: ddstreet schedule mtg may 17 same time (ddstreet, 16:02)


Meeting ended at 16:02:50 UTC (full logs)

Action items

  1. ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
  2. ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
  3. mapreri upload (more of) all the tools (carried over, in progress)
  4. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
  5. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
  6. mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
  7. teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over)
  8. (unassigned) consider documenting an SLA for reviewing uploaded backport packages
  9. (unassigned) check if backports pocket uploads and/or approvals go to a ML
  10. (unassigned) if no ML for backports uploads/approvals, check on how to create one
  11. ddstreet send follow up email on no-bug-required ML thread mentioning cockpit
  12. ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html
  13. mapreri follow up in https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/2012676
  14. ddstreet schedule mtg may 17 same time


Action items, by person

  1. ddstreet
    1. ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
    2. ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
    3. ddstreet send follow up email on no-bug-required ML thread mentioning cockpit
    4. ddstreet send short policy wording proposal to ML regarding https://lists.ubuntu.com/archives/ubuntu-backports/2023-March/023030.html
    5. ddstreet schedule mtg may 17 same time
  2. mapreri
    1. mapreri upload (more of) all the tools (carried over, in progress)
    2. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
    3. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
    4. mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
    5. mapreri follow up in https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/2012676
  3. teward
    1. teward make sure there are no bugs in requestbackport and backportpackage tools (in lunar) (carried over)
  4. UNASSIGNED
    1. (unassigned) consider documenting an SLA for reviewing uploaded backport packages
    2. (unassigned) check if backports pocket uploads and/or approvals go to a ML
    3. (unassigned) if no ML for backports uploads/approvals, check on how to create one


People present (lines said)

  1. ddstreet (124)
  2. mapreri (60)
  3. teward (23)
  4. meetingology (20)


Generated by MeetBot 0.4.0