19:02 <amurray> #startmeeting Ubuntu Technical Board
19:02 <meetingology> Meeting started at 19:02:21 UTC.  The chair is amurray.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:02 <meetingology> Available commands: action, commands, idea, info, link, nick
19:02 <amurray> #topic Apologies
19:02 <seb128> vorlon, might be around, he was active on #ubuntu-release
19:03 <amurray> vorlon and sil2100 both sent their apologies via the mailing list earlier
19:03 <seb128> oh right, just saw that
19:03 <amurray> #topic Action review
19:04 * amurray amurray to propose amended Ubuntu Backporters Team Charter
19:04 <seb128> I've a feeling that's going to be a quick one.. :-/
19:04 <seb128> (not that item but the meeting)
19:04 <amurray> I am not sure how to progress this - I think we need some input from other TB members
19:05 <seb128> reading the past discussion that item is just confusing to me
19:05 <amurray> #link https://lists.ubuntu.com/archives/technical-board/2023-March/002723.html
19:05 <seb128> it feels like that should be a simple 'the TB delegate the backport team power to handle backports'?
19:06 <seb128> why do we need drafts or suggestions there?
19:06 <seb128> rbasak, I think you have the history/context and opinions on that one
19:07 <rbasak> ...
19:08 <rbasak> My original draft tried to cover what I think caused the previous failure that took a very long discussion over multiple attempts over multiple years (?) to try to resolve.
19:08 <rbasak> The specific points I suggested in the draft directly spoke to what I perceived to have been previous sticking points.
19:09 <rbasak> I'd also note that *everybody involved* at the time of the discussion in ubuntu-devel@ agreed with my draft, so it's really weird to me to get so much push back against it.
19:09 <seb128> I feel like we should just do a reset and suggest the trivial version unless someone here feels like it's problematic or controversial
19:10 <seb128> rbasak, do you perceive pushback here about your version?
19:10 <rbasak> The trivial version seems like a no-op to me. It doesn't address the previous issues.
19:10 <seb128> if so it's probably misunderstanding, I would be personnally fine with what you proposed
19:10 <rbasak> The pushback is from the backporters team. And of course we need them on board for any progress to be useful.
19:12 <amurray> I also liked your draft rbasak but I think we need to be pragmatic since I would rather have something which both the TB and backporters team can agree on than nothing (although I do also agree the current draft is a bit if a no-op and hence may not even be needed)
19:13 <rbasak> Sorry I don't mean to imply any blocking of the current draft. This is just my opinion of it.
19:14 <amurray> so we have 3 options here from what I can see - 1. push back to the backporters team with something more rigorous again, 2. go with the more trivial version or 3. drop the whole thing and leave it as is
19:14 <rbasak> Maybe we should just accept Mattia's draft and call it done. Hopefully there will be no further issues. If there are, then I fear that they will drag on again as they did last time, but that'll be how it
19:14 <seb128> do you have a pointer to Mattia's draft?
19:14 <rbasak> how it'll have to be I guess.
19:15 <rbasak> Message-ID: <Y/9tpRmwCMlZ0sN3@mapreri.org>
19:15 <rbasak> Date: Wed, 1 Mar 2023 16:22:13 +0100
19:15 <seb128> thanks
19:15 <amurray> (it is also at the bottom of the link I posted earlier assuming I quoted it correctly in my reply)
19:16 <rbasak> FWIW, I think that the third point partially crosses over into terrority I don't think it's up to the TB to dictate either. Specifically to define a set of rules to handle its internal structures and members' responsiblities.
19:17 <seb128> I would be fine giving a  +1 to those 3 bullet points
19:17 <rbasak> However, requiring them to have a policy on team membership is important, because anybody should be able to join their team if they are appropriately qualified.
19:17 <rbasak> But, to make progress, I don't think that's important enough to block either.
19:17 <seb128> it's basically 'the backport team is in charge or handling the backport pocket and free to define they processes and membership rules'
19:17 <seb128> which seems fair to me
19:18 <seb128> I would trust them to accept qualified contributors
19:18 <amurray> my preference is to go with this since this issue has dragged on for too long at this point
19:18 <rbasak> Indeed - but the precise problem with the previous team was that they did not (through their absence) and that was a blocking issue.
19:19 <rbasak> amurray: +1
19:19 <amurray> let's presume good-faith with the new team and hope there won't be similar issues this time around
19:20 <rbasak> Oh to be clear I am also absolutely assuming good faith.
19:20 <seb128> no policy is going to fix a lack-of-people issue
19:20 <rbasak> I was just looking for a clearer path to a reset should difficulties arise again in the future - but hopefully they won't.
19:20 <seb128> I'm +1 as well to go with ^
19:21 <amurray> ok, so should I perhaps respond to that email thread and ask the backporters team to more formally acknowledge Mattia's draft?
19:21 <rbasak> We're quorate here I believe.
19:21 <seb128> +1
19:21 <amurray> #action amurray to follow up with backporters team on Mattia's draft charter proposal
19:21 * meetingology amurray to follow up with backporters team on Mattia's draft charter proposal
19:21 <rbasak> So how about we agree that if the backporters team agree, then Mattia's draft becomes final?
19:22 <amurray> sounds good to me
19:23 * amurray seb128 to help draft an exception to the "must build on all architectures" requirement for snaps
19:23 <seb128> I didn't have time for any of my item with Lunar release get closing
19:23 <amurray> will carry it over
19:23 <seb128> but it's getting better so I hope to have updates by the next meeting
19:23 <seb128> thanks
19:23 <amurray> #action seb128 to help draft an exception to the "must build on all architectures" requirement for snaps
19:23 * meetingology seb128 to help draft an exception to the "must build on all architectures" requirement for snaps
19:23 <seb128> carry over...
19:23 * amurray seb128/amurray/sil200 to help drafting the snap-store Ubuntu-specific tracks usage
19:24 <seb128> also I guess
19:24 <amurray> I took a quick stab at this yesterday
19:25 <amurray> out of interest, is this document already public?
19:25 <rbasak> Thanks!
19:25 <rbasak> Yes - it's public.
19:25 <rbasak> I'd like to clean it up some more, then post it to ubuntu-devel@ for wider consultation.
19:26 <amurray> ok so perhaps if you could take a quick look at what I wrote their rbasak and let me know your thoughts
19:26 <amurray> s/their/there/
19:26 <rbasak> ack
19:27 <rbasak> It'd be good to get a review from those who know what actually happens.
19:27 <amurray> I'll leave this on the agenda as it was from last time though since I think it would be useful to get seb128 and sil2100 to provide feedback as well if they have time
19:27 <rbasak> Please, thanks
19:27 <amurray> #action seb128/amurray/sil200 to help drafting the snap-store Ubuntu-specific tracks usage
19:27 * meetingology seb128/amurray/sil200 to help drafting the snap-store Ubuntu-specific tracks usage
19:27 <seb128> yes, I will block time before the next meeting
19:27 * amurray rbasak to raise any on-going blockers with third-party seeded snap security policy
19:27 <rbasak> (I just mean that I definitely *don't* know exactly what happens :-)
19:27 <rbasak> I'm not aware of any.
19:28 <rbasak> (except for these two action items we have already, and pending my cleanup)
19:28 <amurray> ok, I'll drop it from the agenda then for next time and we can revisit it if we have to
19:28 * amurray sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
19:28 <amurray> carry over as sil2100 is unavailable today
19:28 <amurray> #action sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
19:28 * meetingology sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
19:29 * amurray rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:29 * vorlon waves
19:29 <rbasak> Carry over again please
19:29 <amurray> #action rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:29 * meetingology rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:29 <vorlon> sorry I couldn't be here from the start
19:29 <rbasak> Welcome!
19:29 <amurray> hey vorlon :)
19:29 * amurray rbasak to create initial bugs against the LP techboard project to track third party repo and DMB expiration policies
19:30 <rbasak> Done! https://bugs.launchpad.net/techboard
19:30 <amurray> awesome - thanks rbasak :)
19:30 <rbasak> Perhaps long standing action items should move to the bug tracker instead
19:30 <rbasak> And perhaps we could use Triaged status or a tag to track them or something.
19:31 <rbasak> Now that we're using the bug tracker.
19:31 <rbasak> Anyway, just thoughts. No action needed right now I guess.
19:31 <amurray> yes I think that was the intent - the only thing that would meet this criteria at this point is the backporters charter but I hope this will progress this week so hopefully won't be needed to be added to the bug tracker
19:32 * amurray sil2100 to follow up on the Ubuntu Cinnamon flavor addition thread and announce their official status
19:32 <amurray> this was done https://lists.ubuntu.com/archives/technical-board/2023-March/002725.html
19:33 <amurray> #topic Mailing list review
19:34 <amurray> I don't see anything here other than your announcement of the git-ubuntu-import annoucement rbasak
19:34 <amurray> #topic Bug review
19:35 <amurray> nothing new here either :) (but thanks again for creating the techboard bugs rbasak)
19:37 <amurray> next meeting will be during the product roadmap sprint - and you would be chair rbasak as per the rotation
19:37 <seb128> I think we should skip that one in advance
19:37 <seb128> realistically most of us will decline
19:37 <rbasak> Yes it seem unlikely many of us will be able to make that
19:38 <amurray> fair enough - next meeting will be on the 9th May with rbasak as chair and seb128 as back-up
19:38 <seb128> +1
19:38 <amurray> #topic AOB
19:39 <seb128> nothing from me
19:39 <amurray> nothing from me either
19:41 <amurray> ok I think we are done then :)
19:41 <seb128> \o/ :)
19:41 <rbasak> Thank you for chairing amurray!
19:41 <amurray> #endmeeting