16:06 <rbasak> #startmeeting Ubuntu Developer Membership Board
16:06 <meetingology> Meeting started at 16:06:06 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:06 <meetingology> Available commands: action, commands, idea, info, link, nick
16:06 <rbasak> Let's go straight to applications
16:06 <rbasak> #topic Package Set/Per Package Uploader Applications
16:06 <rbasak> #subtopic Paolo Pisati (2023-04-03)
16:06 <rbasak> ppisati: welcome! Would you like to introduce yourself?
16:06 <rbasak> #link https://wiki.ubuntu.com/PaoloPisati/DKMSUploadApplication
16:06 <ppisati> yep
16:07 <ppisati> Hi there, my name is Paolo and I've been a member of the Ubuntu kernel team since 2011
16:07 <ppisati> my main focus is devel kernel / kernel packaging, and i mantain the kernel dev series
16:08 <ppisati> I'm applying for dkms upload rights so i can (hopefully) speedup release of new kernels
16:08 <ppisati> since often new kernels are blocked on DKMS FTBFS or various other DKMS failures
16:09 <rbasak> Does anyone have questions for ppisati?
16:09 <rbasak> I can start :)
16:09 <rbasak> ppisati: do you know what the SRU team's opinion is of "Regression Potential: None" or similar?
16:10 <ppisati> rbasak: yes, they don't like it! :)
16:10 <ppisati> i think you picked that from one of my previous DKMS upload
16:10 <rbasak> I looked for recent SRUs, and see bug 2002527 and bug 2002329 :)
16:11 <ppisati> that is actually part of the SRU template and should show where the update you are working on 'could go wrong'
16:11 <rbasak> Bug 2002636 too.
16:11 <rbasak> Those are your most recent SRUs I think?
16:12 <ppisati> rbasak: yep, somehow that list doesn't show all the SRUs i did in the past
16:12 <rbasak> I'm looking at https://udd.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=&sponsor_search=name&sponsoree=Paolo+Pisati&sponsoree_search=name - is that more representative?
16:12 <rbasak> https://launchpad.net/~p-pisati/+uploaded-packages only shows each package once I think.
16:13 <rbasak> Maybe per package or per release or something like that. Anyway I find the sponsorship miner to be more comprehensive. Or do you think there are more yet that are missing?
16:13 <ppisati> rbasak: yes, that looks more complete
16:13 <ppisati> rbasak: the last url you posted looks good (please dont' ask me what i did in 2011...)
16:14 <rbasak> Looking at your past few SRUs (most recent) from there, I feel that you're missing something in your communications with the SRU team. They keep needing to clarify things, and I don't think they generally include much of a regression analysis at all.
16:15 <ppisati> rbasak: yes, i should improve that
16:15 <rbasak> eg. https://bugs.launchpad.net/ubuntu/+source/evdi/+bug/2002320/comments/2 and https://bugs.launchpad.net/ubuntu/+source/openafs/+bug/2002527/comments/3
16:15 <rbasak> OK, let's move on
16:16 <rbasak> ppisati: are there times when it might be inappropriate to upload DKMS fixes to the development release?
16:16 <ppisati> rbasak: when we are in beta freeze or finale freeze, for example
16:17 <ppisati> rbasak: but even feature freeze, upload should slow down, and only hot fixes for specific bugs are admitted
16:17 <rbasak> Great.
16:17 <rbasak> ppisati: what freeze applies to Lunar at the moment, and where can you find that information?
16:18 <ppisati> rbasak: ATM we just left beta freeze and we are back to feature freeze, final freeze should be...
16:18 <ppisati> https://discourse.ubuntu.com/t/lunar-lobster-release-schedule/27284
16:18 <ppisati> April 13 ^
16:18 <rbasak> Great, thanks!
16:19 <ppisati> the release schedule tells you the state of the archive wrt uploads
16:19 <rbasak> ppisati: to fix packages in the stable release, where is the process and policy documentation?
16:20 <ppisati> rbasak: it's the SRU process -> https://wiki.ubuntu.com/StableReleaseUpdates
16:22 <rbasak> Thanks! I have no more questions.
16:22 <rbasak> Does anyone else have any questions for ppisati?
16:24 <kanashiro[m]> ppisati: what could block your upload in proposed? What would you do to investigate that?
16:25 <ppisati> kanashiro[m]: autopkgtests, i useually check the excuse page and then take it from there
16:25 <ppisati> e.g. https://ubuntu-archive-team.ubuntu.com/proposed-migration/update_excuses.html
16:26 <kanashiro[m]> is autopkgtest the only reason to get a package blocked?
16:27 <ppisati> kanashiro[m]: uhm, no, it could depend on another package that is not installable
16:28 <ppisati> it could be that the archive is frozen
16:28 <ppisati> or the package violates one of the SRU rules
16:29 <kanashiro[m]> ppisati: thanks for the answer! It could also be a installability issue in the package itself or a FTBFS
16:30 <ppisati> kanashiro[m]: sure
16:31 <kanashiro[m]> no more questions from me
16:31 <rbasak> Anyone else?
16:31 <rbasak> (thanks kanashiro[m]!)
16:33 <rbasak> OK, let's vote.
16:33 <rbasak> #vote Grant ppisati membership of the kernel-dkms packageset uploading team
16:33 <meetingology> Please vote on: Grant ppisati membership of the kernel-dkms packageset uploading team
16:33 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:33 <rbasak> +1 you have an extensive track record of fixes to DKMS packages, sufficient Ubuntu development knowledge (likely a lot more!) and endorsements from relevant developers. I'd like to see more comprehensive regression analysis and test plans for your SRUs, but on balance I think Ubuntu would benefit more if you could upload these directly today.
16:33 <meetingology> +1 you have an extensive track record of fixes to DKMS packages, sufficient Ubuntu development knowledge (likely a lot more!) and endorsements from relevant developers. I'd like to see more comprehensive regression analysis and test plans for your SRUs, but on balance I think Ubuntu would benefit more if you could upload these directly today. received from rbasak
16:33 <rbasak> But please consider what you could do to reduce questions review iterations on your SRU uploads. I welcome conversations with the SRU team about that - especially discussions around anything you think we should change.
16:34 <seb128> +1 seems a solid application for the requested packages, I would also like to see improvements on the SRU front as mentioned by Robie
16:34 <meetingology> +1 seems a solid application for the requested packages, I would also like to see improvements on the SRU front as mentioned by Robie received from seb128
16:35 <teward> +1 I would like to see improvements on the SRU front as Robie mentioned, but otherwise a solid application for the packages requested.
16:35 <meetingology> +1 I would like to see improvements on the SRU front as Robie mentioned, but otherwise a solid application for the packages requested. received from teward
16:35 <teward> *sips coffee*
16:36 <kanashiro[m]> +1. I see all the amount of work done during those several years and I do believe more people taking care of DKMS packages would benefit the project. I'd say you still need to improve your SRUs to avoid more work on the overloaded SRU team. Thanks for all your work and keep it up!
16:36 <meetingology> +1. I see all the amount of work done during those several years and I do believe more people taking care of DKMS packages would benefit the project. I'd say you still need to improve your SRUs to avoid more work on the overloaded SRU team. Thanks for all your work and keep it up! received from kanashiro[m]
16:36 <rbasak> #endvote
16:36 <meetingology> Voting ended on: Grant ppisati membership of the kernel-dkms packageset uploading team
16:36 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
16:36 <meetingology> Motion carried
16:36 <rbasak> Congratulations ppisati!
16:36 <seb128> congrats!
16:36 <rbasak> Any volunteers for the ACL change and/or the announcement please?
16:36 <kanashiro[m]> congrats ppisati !
16:37 <ppisati> thanks guys, i'll be more careful wrt SRUs / regression potential
16:37 <kanashiro[m]> rbasak: I can take it
16:37 <rbasak> Thanks!
16:37 <rbasak> Checklist reminder: https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Actions_after_a_successful_application
16:37 <rbasak> #action kanashiro[m] to announce ppisati's successful application
16:37 * meetingology kanashiro[m] to announce ppisati's successful application
16:37 <kanashiro[m]> ack
16:37 <ppisati> ack
16:37 <rbasak> #action kanashiro[m] to make ACL changes for ppisati's approved application
16:37 * meetingology kanashiro[m] to make ACL changes for ppisati's approved application
16:38 <rbasak> ppisati: please do ask if it's not clear about the SRUs. Often it's just about mismatched expectations and talking is the easiest way to fix that :)
16:38 <ppisati> rbasak: i promise i'll do
16:38 <rbasak> Thanks!
16:38 <rbasak> #topic Review of previous action items
16:39 <rbasak> teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:39 <rbasak> rbased to document the decision on Keeping IRC meetings moving
16:39 <rbasak> Mine needs carrying over
16:39 <teward> same on mine
16:39 <teward> never enough cycles >.<
16:39 <rbasak> #action rbasak to document the decision on Keeping IRC meetings moving
16:39 * meetingology rbasak to document the decision on Keeping IRC meetings moving
16:39 <rbasak> #action teward follow up to get all application process wiki/docs to explain the process to be
16:39 * meetingology teward follow up to get all application process wiki/docs to explain the process to be
16:39 <rbasak> able to edit wiki pages, for applicants who don't yet have wiki edit access (carried
16:39 <rbasak> over)
16:39 <rbasak> Sorry for the bad paste
16:39 <rbasak> #undo
16:39 <meetingology> Removing item from minutes: ACTION
16:39 <rbasak> #action teward to  follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:39 * meetingology teward to  follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:40 <rbasak> #topic Outstanding mailing list requests to assign
16:40 <rbasak> I don't see any
16:40 <rbasak> #info No outstanding mailing list requests to assign
16:40 <rbasak> #topic Open TB bugs
16:41 <rbasak> #info
16:41 <rbasak> There are currently no open bugs.
16:41 <rbasak> #info There are currently no open bugs.
16:41 <rbasak> #topic AOB
16:41 <rbasak> AOB?
16:43 <kanashiro[m]> none
16:43 <rbasak> #endmeeting