19:03 <seb128> #startmeeting Developer Membership Board
19:03 <meetingology> Meeting started at 19:03:50 UTC.  The chair is seb128.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:03 <meetingology> Available commands: action, commands, idea, info, link, nick
19:04 <seb128> #link https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda
19:04 <seb128> #topic PPU Applications
19:04 <seb128> #subtopic Andrea Righi
19:05 <teward> can i make a note first
19:05 <seb128> sure?
19:05 <teward> if we want to have applications we need to have easy links to their applications, possibly even as part of the agenda page.  because sometimes emails doesn't show those links (i.e. junkmail thanks to how mailing lists work)
19:06 <teward> that's all just something to make a note of forward in the process
19:06 <teward> *lurks8
19:06 <seb128> ack
19:06 <seb128> #links https://wiki.ubuntu.com/AndreaRighi/DkmsUploadApplication
19:06 <seb128> for Andrea's one, but yes I think have the reference on the agenda section would make sense
19:07 <seb128> arighi, hey, you are around?
19:07 <arighi> seb128, yes, hi everyone
19:07 <seb128> great
19:07 <seb128> arighi, could you start by maybe introducing yourself?
19:08 <arighi> sure
19:08 <arighi> My name is Andrea and I am a member of the Ubuntu kernel team since 2019, my primary focus has been on kernel development / kernel packaging and, as a part of the team, I maintain the Ubuntu development kernels
19:09 <rbasak> Hi!
19:09 <arighi> I'm applying to get dkms upload rights so that we can speed up the release of new kernels in Ubuntu, since often new kernels are blocked by dkms fixes that need to be sponsored
19:09 <rbasak> I see you have a pile of sponsored uploads for DKMS build fixes. Thank you for that work!
19:09 <arighi> and also because of personal interest of contributing more in Ubuntu :)
19:11 <seb128> so do we have questions for arighi?
19:11 <seb128> it's quite an impressive list of uploads on the wikipage
19:11 <rbasak> arighi: are there times when it might be inappropriate to upload DKMS fixes to the development release?
19:11 <kanashiro[m]> sorry for the question, but someone could tell me which packages are part of the DKMS package set?
19:12 <rbasak> kanashiro[m]: https://ubuntu-archive-team.ubuntu.com/packagesets/lunar/kernel-dkms
19:12 <rbasak> (and similar for older series)
19:12 <arighi> rbasak, yes, after feature freeze it would be quite inappropriate to upload dkms fixes
19:12 <kanashiro[m]> rbasak thanks
19:12 <rbasak> arighi: what freeze applies to Lunar at the moment, and where can you find that information?
19:13 <arighi> rbasak, for lunar we can find all the relevant information about the release schedule here: https://discourse.ubuntu.com/t/lunar-lobster-release-schedule/27284
19:14 <rbasak> arighi: great, thanks. And do you know where to find the rules that determine what is and isn't permitted during feature freeze?
19:15 <arighi> rules are reported in the wiki, for example feature freeze: https://wiki.ubuntu.com/FeatureFreeze
19:15 <rbasak> Excellent.
19:15 <rbasak> Note that I think most DKMS packages fixes would be permitted during feature freeze.
19:16 <arighi> yeah, dkms are following a bit the kernel release, since they are still pieces of kernel in practice :)
19:16 <rbasak> And DKMS package build fixes for DKMS packages that are in universe would also be acceptable to be uploaded after final freeze.
19:16 <rbasak> (in universe and also unseeded I mean)
19:16 <arighi> right
19:16 <rbasak> Details here: https://wiki.ubuntu.com/FinalFreeze
19:17 <rbasak> OK, final question from me: to fix packages in the stable release, where is the process and policy documentation?
19:17 <arighi> rbasak, packages in the stable releas follow the SRU process, that is documented here: https://wiki.ubuntu.com/StableReleaseUpdates
19:18 <rbasak> Perfect. That's all my questions. Thank you!
19:18 <arighi> *release
19:19 <kanashiro[m]> no question from me, rbasak already covered what I had in mind
19:19 <teward> no questions from me
19:20 <seb128> I've one question
19:21 <seb128> arighi, taking a recent example of upload you did, https://bugs.launchpad.net/ubuntu/+source/librem-ec-acpi/+bug/2009511 you wrote
19:21 <seb128> > [ resync with Debian is not really needed to support linux 6.2, but it's better to keep this package aligned ]
19:21 <seb128> which is true
19:21 <seb128> but it seems your added a delta which wasn't forwarded to Debian (unless I'm checking the wrong place), any reason it was not forwarded to keep the package in sync?
19:22 <arighi> looking
19:23 <seb128> https://bugs.debian.org/cgi-bin/pkgreport.cgi?repeatmerged=no&src=librem-ec-acpi is empty and salsa doesn't have recent commits nor open merge requests
19:23 <arighi> in this particular case I think I opted for the resync + patches to support 6.2 on top, because the upstream code was carrying also some fixes
19:23 <seb128> any reason you didn't forward your debdiff to the BTS?
19:24 <seb128> one part of the change at least is in debian/ so could probably benefit them and reduce our merge work
19:24 <arighi> no specific reason, except that I got distracted by other high-priority tasks, it would have been better to send the debdiff upstream indeed :)
19:24 <seb128> alright, thanks
19:25 <seb128> no other question from me
19:25 <arighi> usuall I try to fix in debian and then request a resync when possible
19:25 <arighi> that means less work for us :)
19:25 <seb128> k, maybe I just got unlucky in the example I picked in your uploads, sorry about that!
19:25 <seb128> anyone else still having a question?
19:25 <utkarsh2102> none from me.
19:25 <arighi> seb128, no problem, it was actually a good question
19:26 <utkarsh2102> I hope my messages are visible this time?
19:26 <teward> yep
19:26 <utkarsh2102> Can someone on the IRC side confirm?
19:26 <teward> stop breaking your client utkarsh2102 ;)
19:26 <rbasak> I don't think it's a requirement for upload rights for this packageset, but do you know how to bring forward an Ubuntu delta to a newer Debian or upstream version should that be necessary?
19:26 <seb128> utkarsh2102, :)
19:26 <utkarsh2102> lmao :P
19:26 <arighi> utkarsh2102, I can see your messages :)
19:26 <utkarsh2102> super, thanks all
19:27 <rbasak> Ah it looks like you've done that before eg. https://launchpad.net/ubuntu/+source/librem-ec-acpi/0.9.1-4ubuntu1
19:27 <rbasak> Never mind!
19:28 <seb128> #vote Andrea Righi to get upload rights for the DKMS packageset
19:28 <meetingology> Please vote on: Andrea Righi to get upload rights for the DKMS packageset
19:28 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:28 <seb128> +1
19:28 <meetingology> +1 received from seb128
19:28 <kanashiro[m]> +1
19:28 <meetingology> +1 received from kanashiro[m]
19:28 <arighi> rbasak, in some packages we carry specific ubuntu patches (usually in debian/patches), when we move to a new Debian / upstream version we usually need to re-apply our patches (to provide certain specific ubuntu features for example) - not sure if this is what you were asking
19:28 <utkarsh2102> +1, very happy with the work. Keep it up!
19:28 <meetingology> +1, very happy with the work. Keep it up! received from utkarsh2102
19:28 <rbasak> +1 excellent track record of DKMS fixes, and good endorsements from relevant people. Thank you for your contributions!
19:28 <meetingology> +1 excellent track record of DKMS fixes, and good endorsements from relevant people. Thank you for your contributions! received from rbasak
19:28 <rbasak> I have one request for DKMS fix SRUs: please could you make sure to be explicit in a Test Plan in the SRU documentation which kernels the updated package will be tested against? For example in LP: #1981993 the SRU documentation didn't state it, but it looks like multiple kernels were tested in the end anyway. I think SRUs would have less chance of getting blocked on review if this was explicitly
19:29 <rbasak> stated.
19:29 <arighi> rbasak, ok, got i, I'll make my test plan more explicit
19:30 <utkarsh2102> teward: there?
19:30 <bdmurray> +1
19:30 <meetingology> +1 received from bdmurray
19:30 <teward> ye
19:30 <teward> +!
19:30 <teward> +1
19:30 <meetingology> +1 received from teward
19:30 <teward> had to type from my phone, irccloud froze on my computer
19:30 <seb128> #endvote
19:30 <meetingology> Voting ended on: Andrea Righi to get upload rights for the DKMS packageset
19:30 <meetingology> Votes for: 6, Votes against: 0, Abstentions: 0
19:30 <meetingology> Motion carried
19:30 <seb128> great
19:30 <seb128> arighi, congratulations!
19:31 <arighi> thank you for your time!
19:31 <utkarsh2102> teward: tch tch, stop breaking your client :P
19:31 <seb128> #action seb128 to send the mail about arighi 's approval
19:31 * meetingology seb128 to send the mail about arighi 's approval
19:31 <sil2100> Sorry for being late o/
19:31 <utkarsh2102> arighi: yay, congratulations!
19:31 <utkarsh2102> sil2100: o/
19:31 <seb128> k, so we are just on mid meeting mark and we said we would try to reduce the backlog by reviewing Amin's application if we had time
19:31 <arighi> utkarsh2102, thanks!
19:31 <seb128> so let's care on
19:32 <seb128> #topic Ubuntu Contributing Developers Applications
19:32 <seb128> #subtopic Amin Bandali (bandali)
19:32 <seb128> bandali, hey Amin, do you want to introduce yourself?
19:32 <seb128> #link https://wiki.ubuntu.com/bandali/contributing-developer-application
19:33 <seb128> sil2100, hey Lukasz :-)
19:33 <bandali> hey seb128, sure :) i'm Amin Bandali (or just bandali), and i'm part of the Desktop Team at Canonical since November 2022. i work mainly on the maintenance of Ubuntu's firefox packages (both deb and snap), as well as increasingly some other parts of Ubuntu (and its desktop)
19:33 <bandali> oh, and hi everyone else too! thanks for considering my application today :)
19:35 <seb128> is anyone having questions for Amin?
19:36 <seb128> no question from me at least
19:37 <rbasak> ..
19:37 <seb128> so, who is still around, can you state question/no question?
19:37 <rbasak> https://wiki.ubuntu.com/UbuntuDevelopers#ContribDev
19:37 <seb128> bdmurray, kanashiro, sil2100, teward, utkarsh2102 ?
19:38 <rbasak> That's what I think we need to consider for this application
19:38 <teward> *burps*
19:38 <sil2100> bandali: quick question: how was your +1 maintenance rotation? How did it go? Did you have more than one?
19:38 <rbasak> "have demonstrated significant and sustained contributions in the area of UbuntuDevelopment" is the only real criterion I think.
19:38 <sil2100> bandali: and hope you want to participate in the next ones!
19:39 <bandali> hey sil2100, so far i've only done one rotation, but i do indeed hope and plan to participate in more of them going into the future :) i think as my first one, it was pretty good
19:39 <bandali> i felt there wasn't too much work i could do in that particular week, but i did unblock a few packages and forwarded fixes to Debian and upstream projects
19:39 <bandali> (per bottom of https://lists.ubuntu.com/archives/ubuntu-devel/2023-February/042457.html)
19:40 <sil2100> Thanks o/
19:40 <bandali> cheers =)
19:40 <sil2100> No further questions from me
19:40 <rbasak> bandali: the earliest work I see is https://launchpad.net/ubuntu/+source/tiff/4.4.0-5ubuntu1 from 2022-11-23
19:40 <rbasak> Do you have any earlier examples than that?
19:40 <bandali> rbasak, i believe that would indeed be my very first [sponsored] upload/work in ubuntu
19:41 <bandali> i did participate a bit in debian circa 2020 (and am doing more of it now as well)
19:41 <rbasak> I think your examples demonstrate significant contributions - thank you for that!
19:41 <bandali> thank you for kind words rbasak
19:41 <bandali> *your kind words
19:42 <kanashiro[m]> no question from me
19:42 <rbasak> There is a requirement for "sustained" though, and the usual rule of thumb historically is six months or so AIUI.
19:42 <rbasak> I think I would be very happy to +1 your application for contributing developer if you had the track record you do, and had sustained it for six months.
19:42 <seb128> I feel like that rule-of-thumb could be mentioned on the wiki
19:42 <seb128> as a side comment
19:43 <bandali> oh? i wasn't aware of a particular minimum time length. and fwiw i do plan on sustaining my contributions going into the future, per my application :) but i understand where you're coming from, thanks
19:43 <seb128> it would be a valuable hint for applicants
19:44 <seb128> any else having questions there?
19:44 <rbasak> Yeah agreed.
19:44 <rbasak> It's mentioned at https://wiki.ubuntu.com/Membership/NewMember
19:44 <rbasak> Which is sort of what contributing developer is, specifically via the Ubuntu development route.
19:44 <seb128> ah, right
19:45 <rbasak> Sorry, I definitely agree the documentation and written guidance could be better there.
19:45 <seb128> should we vote or does that mean the application is technically invalid?
19:45 <rbasak> bandali's contributions do look excellent though, and if he continues to sustain his existing work, I'd definitely be +1 at six months.
19:45 <rbasak> It's not technically invalid at all.
19:46 <seb128> sorry I'm still new on the board and it's partially my fault for now realizing that Amin should have waited a bit more to apply
19:46 <rbasak> Exceptions are at our discretion, AIUI.
19:46 <seb128> k, so let's vote
19:46 <seb128> #vote
19:46 <meetingology> Please vote on:
19:46 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:46 <seb128> ups
19:46 <seb128> #undo
19:46 <meetingology> Removing item from minutes: LINK
19:46 <seb128> shrug
19:46 <rbasak> I'm not sure I have a good reason for an exception in this case though, sorry.
19:46 <seb128> #vote Amin Bandali application for Ubuntu Contributing Developer
19:46 <meetingology> Please vote on: Amin Bandali application for Ubuntu Contributing Developer
19:46 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:47 <rbasak> But I do want to emphasize that I'm basically automatically a +1 at six months unless bandali suddenly stops contributing or disappears or something :)
19:47 <seb128> +1 even if the it has been a bit less than the usual period I've confidence that Amin isn't going to vanish and he's going to keep contributing
19:47 <meetingology> +1 even if the it has been a bit less than the usual period I've confidence that Amin isn't going to vanish and he's going to keep contributing received from seb128
19:47 <rbasak> -1 for reasons above, but please keep up the good work and you'll have an automatic +1 from me soon!
19:47 <meetingology> -1 for reasons above, but please keep up the good work and you'll have an automatic +1 from me soon! received from rbasak
19:48 <kanashiro[m]> +1, it seems to me that the 6 months is a recommendation and not a requirement, Amin has a good track of work and I believe he will keep it up the good work
19:48 <meetingology> +1, it seems to me that the 6 months is a recommendation and not a requirement, Amin has a good track of work and I believe he will keep it up the good work received from kanashiro[m]
19:49 <bdmurray> +1
19:49 <meetingology> +1 received from bdmurray
19:49 <seb128> utkarsh2102, sil2100, teward ?
19:49 <teward> +1
19:49 <meetingology> +1 received from teward
19:49 <teward> reasons are already stated by everyone and i'm still typing via phone so lazy
19:50 <utkarsh2102> +1
19:50 <meetingology> +1 received from utkarsh2102
19:51 <seb128> sil2100, one minute if you want to vote still?
19:51 <sil2100> +1
19:51 <meetingology> +1 received from sil2100
19:51 <seb128> #endvote
19:51 <meetingology> Voting ended on: Amin Bandali application for Ubuntu Contributing Developer
19:51 <meetingology> Votes for: 6, Votes against: 1, Abstentions: 0
19:51 <meetingology> Motion carried
19:51 <rbasak> Congratulations bandali!
19:51 <seb128> thanks everyone
19:51 <seb128> bandali, congrats!
19:51 <bandali> my apologies about the minimum time length; i'd indeed missed that. but thank you very much to all of you folks, really appreciate it :)
19:52 <bandali> thanks seb128 rbasak (et. al) :)
19:52 <seb128> #action seb128 to announce bandali's being accepted as an Ubuntu Contributing Developer
19:52 * meetingology seb128 to announce bandali's being accepted as an Ubuntu Contributing Developer
19:52 <seb128> #topic Review of previous action items
19:52 <rbasak> No problem, and apologies it's not better documented! I'll edit the wiki at https://wiki.ubuntu.com/UbuntuDevelopers#ContribDev now.
19:53 <seb128> rbasak, thanks!
19:53 <seb128> teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access
19:53 <teward> that's continually held over
19:53 <seb128> teward, should that be carried over again?
19:53 <seb128> ack
19:53 <teward> because there's never enough cycles
19:53 <seb128> right, I know the feeling
19:53 <seb128> #topic Outstanding mailing list requests to assign
19:53 <teward> (and that's not a "task" problem that's just everyone has a ton to do)
19:53 <bandali> rbasak, thank you, and np :) coincidentally, helping improve the general state of ubuntu's docs is one of the contributions i'm hoping to make going into the future
19:54 <rbasak> (done)
19:54 <seb128> I don't think there is anything pending from the list
19:54 <seb128> oh, I forgot that one
19:54 <seb128> #topic Vote on Keeping IRC meetings moving
19:55 <seb128> are we ready to vote on that?
19:55 <seb128> let's give it a try
19:55 <utkarsh2102>19:55 <rbasak> I think we got five +1s via the ML
19:56 <rbasak> So I think it might be considered done and agreed already, unless others object?
19:56 <rbasak> I can take an action to document it.
19:56 <seb128> wfm
19:56 <seb128> #action rbasak to document the Keeping IRC meetings moving decision
19:56 * meetingology rbasak to document the Keeping IRC meetings moving decision
19:56 <seb128> rbasak, thanks
19:56 <utkarsh2102> sweet
19:56 <seb128> #topic Open TB bugs
19:57 <seb128> no bug in the list
19:57 <seb128> #topic AOB
19:57 <seb128> anyone?
19:57 <utkarsh2102> nah
19:57 <teward> yes
19:57 <utkarsh2102> good and super meeting!
19:57 <utkarsh2102> everyone around, too
19:57 <teward> update the wiki to say "please include a link to your application as well"
19:57 <seb128> teward, yes?
19:57 <teward> as i mentioned earlier
19:57 <sil2100> +1 on that
19:57 <seb128> ack, I can do that
19:58 <seb128> #action seb128 to update the wiki to ask for an url to the application
19:58 * meetingology seb128 to update the wiki to ask for an url to the application
19:58 <seb128> anything else?
19:58 <teward> but that's more an easy housekeeping request/task/ask ;)
19:58 <teward> nope i'm good
19:58 <teward> i actually have to disappear (hard stop!) for a meeting at DAYJOB so
19:58 <teward> o/
19:58 <seb128> alright, that's a wrap just on time then, thanks everyone!
19:58 <seb128> #endmeeting