16:05 <utkarsh21021> #startmeeting Developer Membership Board
16:05 <meetingology> Meeting started at 16:05:56 UTC.  The chair is utkarsh21021.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:05 <meetingology> Available commands: action, commands, idea, info, link, nick
16:06 <sil2100> huh, somehow I remember chairing not so long ago
16:06 * kanashiro[m] waves
16:06 <sil2100> Since I was fixing up dates on the Agenda as part of my post-chairing updates
16:06 <utkarsh21021> #link https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda
16:07 <utkarsh21021> #topic Core Dev Applications
16:07 <utkarsh21021> #subtopic Nick Rosbrook (enr0n)
16:07 <utkarsh21021> enr0n: hi! \o
16:07 <enr0n> o/
16:07 <utkarsh21021> #link https://wiki.ubuntu.com/enr0n/CoreDeveloperApplication
16:08 <utkarsh21021> enr0n: can you please introduce yourself?
16:08 <sil2100> o/
16:08 <enr0n> Hi! I'm Nick Rosbrook (enr0n). I am a Canonical employee, and have been working on the Foundations team for just over a year now.
16:09 <enr0n> I live in Vermont, USA :)
16:10 <rbasak> o/
16:11 <rbasak> Hi!
16:11 <teward> o/
16:11 <rbasak> Have you done any merges apart from procps and systemd?
16:12 <enr0n> I recently worked on one for pcre2, because I was TIL, but it turned out we were able to sync because the original FTBFS issue had gone away.
16:12 <rbasak> Have you been involved in any transitions?
16:12 <utkarsh21021> uh? is it a no-show?
16:12 <utkarsh21021> enr0n: hellu? are you around?
16:12 <teward> (rbasak stole my question lol)
16:13 <rbasak> utkarsh21021: I can see enr0n's messages
16:13 <teward> utkarsh21021: unignore everyone on your ignores
16:13 <enr0n> Yes, did you not see my last message?
16:13 <bdmurray> I did
16:13 <teward> utkarsh21021: then fetch me coffee :P
16:13 <enr0n> Ah, ok. I will continue with rbasak's question in the mean time.
16:13 <utkarsh21021> I mean if they were around, they'd have gotten back the first time :P
16:13 <utkarsh21021> there!
16:14 <utkarsh21021> rbasak is in a rush, I didn't even open the stage to questions
16:14 <enr0n> I have not worked on a "traditional" transition. A large part of my work is centered around systemd, and while systemd has a large number of revdeps, it does not trigger the type of transitions that I normally think of. E.g. new toolchain versions, soname bumps/ABI changes, etc/
16:15 <utkarsh21021> damn my IRC client
16:15 <sil2100> enr0n: I like it that you have endorsements from your most frequent sponsors. But I only see a few sponsorships from people from outside Foundations. Did you cooperate with other non-team-member uploaders on any uploads/changes to Ubuntu?
16:16 <bdmurray> Does my being on the QA team count?
16:16 <utkarsh21021> no :P
16:17 <enr0n> sil2100: During my +1 maintenance work, I typically put a note in #ubuntu-devel to see if anyone is interested in sponsoring (after also making sure the LP is the the sponsore queue, but that does not usually work). I also try to forward bugs to debian early, and often the Debian maintainer will pick up a change of mine, and it syncs to Ubuntu before a Ubuntu upload has happened
16:18 <utkarsh21021> enr0n: another question: why did you not get PPU for systemd, et al or perhaps a packageset?
16:18 <utkarsh21021> why straight to core-dev?
16:18 <sil2100> enr0n: ok, thanks!
16:18 <bdmurray> I'm pretty sure the Foundations team doesn't have any packagesets defined
16:19 * rbasak waits to ask more questions
16:19 <enr0n> utkarsh21021: While I do focus on systemd, I am also responsible for a lot of ubuntu-release-upgrader work. And since I am on the Foundations team, it would be more helpful if I could generally work on packages in main, and not just systemd et al.
16:20 <teward> (by the time i finish writing my questions rbasak or sil or utkarsh already ask the question so i'mma just sit and wait to ask any questions I have others don't ask)
16:20 <utkarsh21021> hahahaha
16:20 <seb128> sorry but I've to step out for ~30min, don't wait on my for reply/vote, I will catch up if I'm back before the end of meeting otherwise follow up via email if needed
16:20 <utkarsh21021> enr0n: ack, thanks
16:21 <utkarsh21021> I still feel getting upload rights to systemd and ubuntu-release-upgrader would have helped inspire some confidence :)
16:21 <utkarsh21021> rbasak: go!
16:21 <rbasak> What's the process you're using to do merges?
16:22 <bdmurray> utkarsh21021: Would it though? The questions I've seen have been about merges and transitions.
16:24 <enr0n> I first learned the grab-merge workflow for basic merges, but I have recently started getting familiar with the git-ubuntu merge workflow (while the pcre2 merge ended up being a sync, I used it to practice the git-ubuntu workflow). Specifically with systemd however, I use a typical `git merge debian/<tag>` workflow.
16:24 <rbasak> Do you check to see if any delta still being applied is still needed?
16:24 <sil2100> I think Nick is doing a lot of work around +1 maintenance, for which I think having a core-dev is rather useful
16:25 <utkarsh21021> bdmurray: I mean, in general, yes, it'd have been good to see a track record of uploads to the archive. If they're in good shape, it's a big +1.
16:25 <rbasak> Since you have only two merges uploaded (I appreciate one more was a sync), I looked at the procps one.
16:25 <utkarsh21021> fair & noted!
16:25 <enr0n> Yes, I make an effort to reduce Ubuntu delta whenever possible.
16:26 <rbasak> In the procps merge, it looks like rm_conffile on /etc/sysctl.d/protect-links.conf was no longer needed as the focal release pocket had a higher version.
16:27 <rbasak> And debian/compat 11 is being added but isn't mentioned in the changelog
16:29 <enr0n> rbasak: Thanks for that feedback. That was my first month on the job and I am confident that I have learned a lot since then.
16:29 <rbasak> Sure, it's not a major thing.
16:29 <rbasak> But it is a substantial part of your application here :-/
16:30 <kanashiro[m]> enr0n: have you touched seeds by any chance?
16:30 <utkarsh21021> the one we sow?
16:30 <utkarsh21021> at some point, everyone has, kanashiro :P
16:31 <enr0n> kanashiro[m]: I think so, but I cannot remember. Maybe when we removed acpi-support?
16:32 <rbasak> enr0n: have you done any SRUs?
16:33 <utkarsh21021> rbasak: lots of them mentioned on https://wiki.ubuntu.com/enr0n/CoreDeveloperApplication#My_involvement
16:33 <enr0n> rbasak: yes, I have done several. See the "SRU" section here: https://wiki.ubuntu.com/enr0n/CoreDeveloperApplication#Examples_of_my_work_.2F_Things_I.27m_proud_of
16:33 <utkarsh21021> 12 to be precise
16:33 <rbasak> Ah, sorry. I didn't see any on the sponsorship miner that didn't look like false positives for some reason
16:34 <enr0n> No worries
16:36 <rbasak> I remain concerned that your range of experience seems to be quite narrow.
16:36 <rbasak> And that when I dived into a random one, what I found wasn't great.
16:37 <enr0n> Into a random what, exactly?
16:37 <rbasak> Sorry, s/one/example/
16:37 <rbasak> The procps merge
16:38 <bdmurray> Isn't some of that on the sponsor who reviewed and uploaded it?
16:38 <rbasak> Indeed
16:39 <jawn-smith> That might have been me...
16:39 <utkarsh21021> :P
16:39 <rbasak> The thing is, if we discount that, then there are fewer examples to look at.
16:40 <rbasak> Like are we saying "look I did a merge once, surely that's good enough for core dev?"
16:40 <teward> rbasak raises a good point.
16:40 <kanashiro[m]> you could also have proded someone outside of your team to endorse your application, for instance Simon Quigley (some uploads sponsored by them)
16:41 <rbasak> IMHO, jumping direcly to core dev makes sense here, but equally that means that the application should be better than average.
16:41 <bdmurray> I haven't done a systemd merge but don't imagince that's particularly easy.
16:41 <rbasak> Sure. But a systemd merge is a bit special, and sounds like it uses a process that won't work for other packages.
16:41 <teward> kanashiro[m]: given that Simon's busy as heck and owes me about 100 things Lubuntu Council related I would sooner drag Simon through fixing and sponsoring the Lubuntu stuff he owes me and the Lubuntu Team before putting more general sponsor work on Simon to work on :p
16:41 <rbasak> Which is fine, but I'd like to see a broad understanding here, and a systemd merge cannot show it.
16:41 <teward> (i.e. Lubuntu Team related tasks)
16:41 <rbasak> This is the kind of situation where a systemd PPU might make more sense
16:42 <teward> rbasak: i think then that brings a bigger question that I have: what PPU do they need?  SystemD or more than that?
16:42 <teward> if there's only one or two more then for them to do regular work then I'm fine with that but once we start getting to a broader range it brings up the question of "scope of rights" and we're back to today
16:42 <teward> but that's also a requisite that they file a PPU application
16:43 <teward> right now we're here to act on coredev application, not a PPU application
16:43 <enr0n> rbasak: In my opinion, the important part of merges is not necessarily what tooling one uses, but there ability to read changelog/git history, test existing delta, etc. While you could say that I do not have significant experience using git-ubuntu (or some other thing) in particular, that does not change the fact that I understand what considerations need to be made during a merge.
16:43 <bdmurray> +1
16:44 <rbasak> I don't care what workflow you use, as long as the output is correct.
16:44 <rbasak> procps was not.
16:44 <sil2100> I don't use git-ubuntu for merges, and I don't think that made my merges particularly worse. I mean, any mistakes I do I could do either way
16:44 <rbasak> That's 50% of the merges on this application.
16:45 <enr0n> rbasak: Yes, that's the point I was trying to make.
16:46 <rbasak> OK, so in this application, the track record you're presenting does not demonstrate merges done properly, regardless of workflow. Sorry, it just doesn't.
16:46 <rbasak> So I'm not sure why people are talking about appropriate workflows.
16:46 <enr0n> (trying to catch up on all the messages while also typing)
16:46 <bdmurray> Okay, I think we all know rbasak's position now. Does anybody else have questions?
16:47 <enr0n> rbasak: Sorry, this message is what brought me in that direction: "Sure. But a systemd merge is a bit special, and sounds like it uses a process that won't work for other packages."
16:48 <rbasak> Oh, OK.
16:48 <enr0n> rbasak: I took that as a comment against my workflow.
16:49 <rbasak> What I mean there is that that doesn't really demonstrate how you would merge other packages, if procps is the closest (only) example I have of that to consider as well. I see what you're saying about understanding what is required being more important than workflow, but I can only go on actual examples presented to me.
16:50 <sil2100> hm, okay, I mean, I treat uploads from an applicant as demonstration of them being able to perform a given task to some extent. Small mistakes, especially if unnoticed by more experienced uploaders, aren't necesarily a bad sign for me, as long as the resulting merge doesn't drop patches or introduce broken changes. And it does represent knowledge of the process, so enough in my eyes to count as a
16:50 <sil2100> checkbox checked, especially with systemd in mind
16:51 <utkarsh21021> enr0n: suppose if you were to have a PPU for systemd and u-r-u, would that restrict you in anything except +1? because, I just see systemd all around (SRUs, Merges, Lukas' sponsored uploads, et al
16:51 <sil2100> But that's just how I see it
16:51 <rbasak> as long as the resulting merge doesn't drop patches or introduce broken changes> what's important to me is that this bar isn't passed "by accident", as might happen with an insufficiently reviewed MoM suggestion that gets uploaded
16:54 <enr0n> utkarsh21021: I suppose not in my typical day-to-day, but that doesn't change my intentions.
16:54 <kanashiro[m]> more work out off systemd and ubuntu-release-upgrader would be appreciated
16:56 <enr0n> kanashiro[m]: I suppose that's how I view +1 work.
16:58 <rbasak> +1 work is appreciated, but a catch is that it's quite narrow in some ways (while very broad in the range of packages to touch, of course)
16:58 <utkarsh21021> any more questions?
16:58 <rbasak> But core dev is a very wide ACL entry
16:58 <rbasak> And those things don't fit together well :-/
16:58 <utkarsh21021> wait, did my client stop again?
16:58 <teward> utkarsh21021: no, your client and Matrix are just slow as heck
16:58 <teward> go get an irccloud account :p
16:59 <utkarsh21021> hah
16:59 <utkarsh21021> we haven’t started voting, no?
16:59 <teward> no we haven't
16:59 <teward> not officially
16:59 <teward> i don't have any questions that haven't been asked by anyone else
17:00 <teward> i have literally only 5 minuites left and we're past our meeting time though i think
17:00 <teward> is there any reason we can't move to voting?
17:00 <utkarsh21021> should we proceed to vote?
17:00 <teward> (in 5 minutes I have a call with the CEO and IT Director at my FT job so)
17:01 <kanashiro[m]> let's vote
17:01 <utkarsh21021> teward: no fire today?
17:01 <bdmurray> I'm ready to vote
17:01 <teward> utkarsh21021: not today no, thank goodness
17:01 <utkarsh21021> hah, nice
17:01 <utkarsh21021> #vote Nick Rosbrook to get Core Dev rights
17:01 <meetingology> Please vote on: Nick Rosbrook to get Core Dev rights
17:01 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
17:01 <rbasak> -1 reasons to follow
17:01 <meetingology> -1 reasons to follow received from rbasak
17:03 <sil2100> +1 Decided to vote as even though Nick is part of my team, I did not endorse him nor am I working closely with him. I see sufficient understanding and involvement in the Ubuntu work, and I see potential in him making a difference with code-dev membership
17:03 <meetingology> +1 Decided to vote as even though Nick is part of my team, I did not endorse him nor am I working closely with him. I see sufficient understanding and involvement in the Ubuntu work, and I see potential in him making a difference with code-dev membership received from sil2100
17:04 <sil2100> (+ I have faith in the endorsers of his application)
17:05 <teward> -1 - reasons to follow (slow to type due to phone IRCing today)
17:05 <meetingology> -1 - reasons to follow (slow to type due to phone IRCing today) received from teward
17:05 <bdmurray> +1 as I trust Nick, his judgement and decision making skills. I believe he will continue to look for guidance when uploading packages.
17:05 <meetingology> +1 as I trust Nick, his judgement and decision making skills. I believe he will continue to look for guidance when uploading packages. received from bdmurray
17:06 <teward> While I have every confidence in enr0n being able to do SRUs and other +1 work, I don't see enough package coverage in the current set of items to be "enough work" outside of a niche packageset to justify full unrestricted core-dev upload rights.  I also would like to see more work on merges as I don't currently see enough evidence to support suitable merge knowledge regardless of workflow to justify unrestricted upload rights either.
17:07 <teward> (this doesn't preclude enr0n from reapplying at some point in the future for coredev, but at this time the aforementioned is my reasoning)
17:08 <teward> and while i have faith in the endorsers, I also want to see some evidence to back up that faith.
17:08 <teward> and I just don't see it at the moment.
17:09 <kanashiro[m]> -1, I believe more work on non systemd and ubuntu-release-upgrader packages should be done, also try to find sponsors out off the Foundations team and get an endorsement from them as well (not that Foundations members are not trustworthy, it is a matter to get a different point of view from people who are not working with you everyday). However, I do trust your technical skills and I do believe you should re-apply for core-dev
17:09 <meetingology> -1, I believe more work on non systemd and ubuntu-release-upgrader packages should be done, also try to find sponsors out off the Foundations team and get an endorsement from them as well (not that Foundations members are not trustworthy, it is a matter to get a different point of view from people who are not working with you everyday). However, I do trust your technical skills and I do believe you should re-apply for core-dev received from kanashiro[m]
17:09 <kanashiro[m]> once you have more data to show us.
17:09 <utkarsh21021> +0; I know this is not the preferred vote of the DMB but this is a hard decision to make. Whilst I trust Nick's work and judgement and their endorsers, the lack of work in other areas (outside systemd and u-r-u) makes it difficult to grant core-dev straight away. I am definitely +1 for PPU and +1 for core-dev once more set of packages are touched and worked on, esp. merges.
17:09 <meetingology> +0; I know this is not the preferred vote of the DMB but this is a hard decision to make. Whilst I trust Nick's work and judgement and their endorsers, the lack of work in other areas (outside systemd and u-r-u) makes it difficult to grant core-dev straight away. I am definitely +1 for PPU and +1 for core-dev once more set of packages are touched and worked on, esp. merges. received from utkarsh21021
17:09 <utkarsh21021> #endvote
17:09 <meetingology> Voting ended on: Nick Rosbrook to get Core Dev rights
17:09 <meetingology> Votes for: 2, Votes against: 3, Abstentions: 1
17:09 <meetingology> Motion denied
17:10 <teward> enr0n: feel free to hit me up as well if you need a sponsor to review things, always happy to help Foundations where it is needed, and though I may not be super active on sponsors just this moment, I do have spare cycles at times through the week to do oneoff sponsors (rather than track ubuntu-sponsors heh)
17:10 <utkarsh21021> unfortunately, the application hasn't made it through :(
17:11 <enr0n> teward: Thank you, I appreciate that, and I appreciate your feedback.
17:11 <rbasak> Much of the work you've been doing looks good, but I don't think there's a wide enough range of experience here to justify jumping straight to core dev. I expect everybody to make mistakes, but I expect the rate of errors from core dev applications to be low, and when considering an application I can only infer the rate from what is presented. Here, we have very little being presented as examples
17:11 <utkarsh21021> but yes, enr0n, whenever you're doing +1, just reach out to me, too
17:11 <rbasak> in some areas (eg. package merges), so that doesn't really help with that expectation when there seemed to be issues with one of the two package merges you presented. For someone to go straight to core dev on the Foundations team makes sense, but I think this really needs to come with a stronger application.
17:11 <utkarsh21021> for sponsorship^
17:11 <rbasak> To make progress, I suggest continuing to build your track record, particularly in the areas of package merges and transitions. I hope to see you become a core dev soon!
17:12 <enr0n> utkarsh21021: I will take you up on that this week ;)
17:13 <enr0n> rbasak: Thank you for your time and feedback
17:13 <utkarsh21021> enr0n: yes, please. Spam me in DMs
17:13 <enr0n> And thank you to the rest of the DMB as well.
17:14 <utkarsh21021> #action Utkarsh to send the mail about today's application
17:14 * meetingology Utkarsh to send the mail about today's application
17:14 <utkarsh21021> #endmeeting