19:01 <rbasak> #startmeeting Developer Membership Board
19:01 <meetingology> Meeting started at 19:01:41 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:01 <meetingology> Available commands: action, commands, idea, info, link, nick
19:02 <rbasak> Let's deal with the action items after our applicant, as the only person who has an action isn't here today anyway.
19:02 <rbasak> #topic Package Set/Per Package Uploader Applications
19:02 <rbasak> #subtopic Lena Voytek (2023-01-23 @ 19:00 UTC meeting)
19:03 <rbasak> So lvoytek is a colleague on my team, so my usual approach is to recuse myself unless I'm needed to make quorum after a unanimous +1 vote from everyone else. But now kanashiro[m] and utkarsh21021 are also close colleagues, so that might not be helpful.
19:03 <rbasak> Let's see how this goes. But I'll still leave the others to do the questioning I guess.
19:03 <rbasak> I also added an endorsement a few minutes ago.
19:03 <utkarsh21021> #link https://wiki.ubuntu.com/LenaVoytek/UbuntuServerDeveloperApplication
19:04 <rbasak> Thanks!
19:04 <rbasak> lvoytek: would you like to introduce yourself please?
19:04 <lvoytek> sure thing
19:04 <lvoytek> Hi all! I am Lena Voytek. I work on the Server Distro team at Canonical, focusing mostly on packages related to mysql, django, and libvirt, alongside various server packages that need fixes or merges. Today I'm applying for upload permissions for the ubuntu-server package set.
19:04 <utkarsh21021> whilst kanashiro and rbasak are direct colleagues, I am not ;)
19:05 <rbasak> Any questions for lvoytek please?
19:06 <kanashiro[m]> I am going to skip the questioning as well, nothing to ask to be honest
19:06 <sil2100> I see a lot of good endorsements
19:07 <sil2100> lvoytek: one question, just out of curiosity - did you ever had an upload sponsored by someone outside of your team?
19:08 <lvoytek> yes, when we created the virtualbmc package in Ubuntu Corey Bryant sponsored: https://launchpad.net/ubuntu/+source/virtualbmc/2.2.2-0ubuntu3
19:08 <sil2100> \o/
19:08 <utkarsh21021> I have sponsored her upload after moving to CPC :P
19:08 <lvoytek> Since this package ended up going to the openstack team for maintenance
19:08 <lvoytek> thats true too :)
19:09 <sil2100> Ah, I keep forgetting the mixture between teams ;p
19:09 <sil2100> lvoytek: ok, so more of a technical question: I'd like to ask you a bit about SRUs. What can you tell me about what an SRU needs additionally, besides what's needed for a regular devel series upload?
19:09 <seb128> hey, sorry I got delayed
19:10 <utkarsh21021> seb128: \o
19:10 <lvoytek> For an sru the fix for the bug must be in the development release. Then the SRU template must be filled out in the launchpad bug description above the original text, including the impact it will have when released, the plan for testing the fix, in depth info on where problems could arise.
19:11 <sil2100> lvoytek: good, what needs to be done after the upload is accepted into -proposed?
19:12 <lvoytek> The sru team will review it to make sure all is good and either continue the upload or block and request changes
19:12 <sil2100> That's true, but what about after the upload is already accepted? What needs to be done for it to land on the user's machines?
19:13 <lvoytek> It has to move to the release pocket then the user can update on their end to get the fix
19:14 <bdmurray> For a stable release would a package move to the release pocket?
19:14 <lvoytek> the -updates pocket specifically
19:15 <sil2100> What about validation of the update in -proposed? What do you, as the uploader, need to do to get this update into the -updates pocket?
19:16 <lvoytek> Ah, make sure all builds succeed and autopkgtests pass
19:17 <sil2100> That is important, yes, but is there something else needed for the update to be considered 'good-to-go'?
19:18 <lvoytek> Yes, the package fix must be validated by enabling proposed and testing accordingly
19:18 <sil2100> That's right o/
19:19 <sil2100> lvoytek: ok, another one about SRUs: let's say you have a need for a new upstream release of a package as an SRU, because of reasons™. Is that possible?
19:20 <lvoytek> Yes, specifically in the case of MREs - minor releases that make a stable release more stable. Working on that for bind9 right now
19:22 <sil2100> lvoytek: can you tell me what is required when preparing such an SRU? What are the requirements for the SRU bug and project/package that you are preparing?
19:22 <sil2100> In other words: what would be the accept/not-accept criterium for such an upload
19:24 <lvoytek> It also requires additional information in the report, some packages have special cases in this regard. The bugs that are being fixed should also be noted, along with security fixes. Releases after the current should also have a version >= the one being updated to
19:25 <sil2100> When in doubt, where would you look for more information about this?
19:26 <lvoytek> The sru wiki page shows special cases: https://wiki.ubuntu.com/StableReleaseUpdates For info on the release its best to look at the relevant upstream news or commits.
19:27 <sil2100> Thanks! No more questions from me
19:27 <lvoytek> Thanks!
19:28 <utkarsh21021> I have a quick q/general curiosity - is there a reason you've not shadowed in any +1 maintenance yet? Because I believe, you'd be net win for Ubuntu/Canonical in doing that.
19:28 <lvoytek> I haven't yet. Christian said it would be a good idea as I move toward core dev though
19:29 <lvoytek> Just need to set it up when there's time
19:30 <sil2100> Any other questions from other DMB members?
19:31 <utkarsh21021> none from me
19:31 <seb128> not from me
19:31 <bdmurray> not from me
19:32 <sil2100> rbasak: back to you then!
19:32 <rbasak> Great, thanks!
19:32 <rbasak> #vote Grant lvoytek membership of the ubuntu-server packageset
19:32 <meetingology> Please vote on: Grant lvoytek membership of the ubuntu-server packageset
19:32 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:33 <sil2100> +1 Solid endorsements and the experience/knowledge is there. PPU is a good start!
19:33 <meetingology> +1 Solid endorsements and the experience/knowledge is there. PPU is a good start! received from sil2100
19:35 <seb128> +1 the endorsements on the wiki are really positive feedback from trusted members, the replies to the questions here were great, ppu make sense as a start on the road to coredev
19:35 <meetingology> +1 the endorsements on the wiki are really positive feedback from trusted members, the replies to the questions here were great, ppu make sense as a start on the road to coredev received from seb128
19:36 <utkarsh21021> +1; super happy to see her application, I know she'd be a really good addition.
19:36 <meetingology> +1; super happy to see her application, I know she'd be a really good addition. received from utkarsh21021
19:37 <bdmurray> Sorry I'm in another meeting
19:37 <bdmurray> +1 from me
19:37 <meetingology> +1 from me received from bdmurray
19:37 <rbasak> #endvote
19:37 <meetingology> Voting ended on: Grant lvoytek membership of the ubuntu-server packageset
19:37 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
19:37 <meetingology> Motion carried
19:37 <rbasak> Congrats lvoytek! I don't think kanashiro[m] or I need to vote in this case.
19:38 <sil2100> lvoytek: congrats!
19:38 <lvoytek> Thanks everyone!
19:38 <rbasak> But I'm +1 obviously, since I endorsed you.
19:38 <kanashiro[m]> lvoytek: congrats :)
19:38 <rbasak> I can take the announcement and ACL actions, unless someone else wants to do it?
19:38 <kanashiro[m]> I am +1 too
19:39 <rbasak> #action rbasak to announce lvoytek's successful application
19:39 * meetingology rbasak to announce lvoytek's successful application
19:39 <rbasak> #action rbasak to make appropriate ACL changes to add lvoytek to
19:39 * meetingology rbasak to make appropriate ACL changes to add lvoytek to
19:39 <rbasak> #undo
19:39 <meetingology> Removing item from minutes: ACTION
19:39 <rbasak> #action rbasak to make appropriate ACL changes to add lvoytek to ~ubuntu-server-dev
19:39 * meetingology rbasak to make appropriate ACL changes to add lvoytek to ~ubuntu-server-dev
19:39 <rbasak> #topic Review of previous action items
19:39 <rbasak> teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:39 <rbasak> teward said he couldn't make it, so we can carry this over.
19:40 <rbasak> #action     teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:40 * meetingology teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:40 <rbasak> #topic Outstanding mailing list requests to assign
19:41 <teward> rbasak: fun fact, i just got hoem from the doctors appt i was at (emergency appts are not fun)
19:41 <teward> but yes carry that one over ;)
19:41 <rbasak> ack
19:41 <utkarsh21021> teward: I'd say exactly what I said last time: it's fun to see what you're up to usually around this time, haha ;)
19:41 <rbasak> The thread at https://lists.ubuntu.com/archives/devel-permissions/2022-November/002099.html still needs a reply from most other DMB members please.
19:42 <rbasak> Maybe we can discuss and vote on it in the next meeting that doesn't have applicants otherwise.
19:42 <rbasak> I don't see any other ML requests.
19:42 <rbasak> #topic Open TB bugs
19:43 <rbasak> #info There aren't any open TB bugs.
19:43 <rbasak> #topic AOB
19:43 <rbasak> Anyone?
19:44 <utkarsh21021> nothing from me
19:44 <rbasak> #endmeeting