16:01 <ddstreet> #startmeeting Ubuntu Backports Team
16:01 <meetingology> Meeting started at 16:01:50 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:01 <meetingology> Available commands: action, commands, idea, info, link, nick
16:02 <ddstreet> so, before we start (or instead of) the regular process, I'd like to suggest we devote today's meeting to discussing and voting on the Policies wiki page
16:03 <ddstreet> is that ok or do either of you want to go thru the normal agenda first?
16:03 <mapreri> ack, but one quick thing from me first:
16:03 <mapreri> I've merged this a couple days ago: https://git.launchpad.net/ubuntu-dev-tools/commit/?id=0f3d2fed2a4ed67b90b5d49aab25ca2bda5d9d37 - so now u-d-t should be "compliant" to our new policies.  if you spot anything else wrong please send patches/bugs.
16:04 <mapreri> Thanks to Krytarik Raido and Unit 193.
16:04 <mapreri> .
16:05 <mapreri> from me, anything else is as stated in the previous meeting, no updates, so I'm good with jumping over to charter, etc.
16:06 <ddstreet> thanks, i saw the MR email, glad you reviewed and merged it :)
16:06 <mapreri> there was a mail about it?
16:06 <mapreri> uh
16:06 <mapreri> well, nvm…
16:06 <ddstreet> no, i meant i got an email from LP saying there was a MR open
16:06 <ddstreet> automated email
16:06 <mapreri> but it was not sent through a formal MR
16:06 <mapreri> probably a commit notification?
16:07 <ddstreet> yeah probably so, my mistake :)
16:07 <ddstreet> but in any case, thanks :)
16:08 <ddstreet> ok let's discuss the policies
16:08 <ddstreet> #topic Discuss Policies proposal
16:08 <ddstreet> for reference:
16:08 <ddstreet> #link https://wiki.ubuntu.com/UbuntuBackports/Policies
16:09 <ddstreet> as you both know, there's been mailing list and in-meeting discussion on this for a while
16:09 <mapreri> should we go with policies first or charter, also because seb128 mailed the TB earlier today about the latter.
16:09 <mapreri> but I reckon you have a plan in mind, so just go ahead and ignore me :)
16:09 <ddstreet> my understanding from the discussion last meeting was that we'd vote on our own rules (i.e. policies wiki page) and the charter would be driven by the TB
16:10 <ddstreet> that's what i thought we agreed before - that our rules/policies should be 'detached' from our charter
16:10 <ddstreet> please correct me if either of you was thinking differently
16:11 <ddstreet> what i was hoping for today is to have discussion, if required, for the current wiki page, and hopefully hold an actual vote on approving those policies for the team
16:12 <mapreri> by "driven by the TB" you think we should just let them draft and do everything themselves?  Because i understood that yes, our previous one was pretty much no good, but they would still appreciate a draft from us?
16:13 <ddstreet> well, i don't know to what extent they want to drive it, vs, us driving drafts, but my understanding is at minimum they want to be involved in the drafting process
16:13 <mapreri> ok, then we can vote on the policy and make that one formal at least.
16:13 <mapreri> let's think about a charter later.
16:14 <ddstreet> so my hope is to finish reviewing and approving our own team policies; the charter will be a longer-term collaboration with the TB, I think
16:14 <ddstreet> yep
16:14 <ddstreet> ok so are there any comments or concerns around the team policies that we should discuss before voting?
16:15 <mapreri> one question that came to my mind recently: the policies currently don't have a single mention of our "quality standards", workflows, etc.  basically it's just about team management.  I don't know how come I never realized, but is that intentional?
16:18 <ddstreet> not intentional; i think it's because it 'evolved' from what i wanted to be our charter, which i took to focus mostly on team structure and operation
16:18 <ddstreet> said another way, a lot of what's in our policies today is what i personally think should be in a 'charter'
16:18 <mapreri> which is great by itself.
16:19 <ddstreet> i do agree we should have details on our process and quality, etc, however a lot of that is inherited e.g. the UbuntuBackports wiki page
16:19 <mapreri> so, should policies be only about the team, and leave the rest to the main page, more informally?  and/or perhaps move those things to a more formal page later on?
16:20 <ddstreet> the policies page does link to our wiki page as the 'team wiki page' for documentation
16:21 <ddstreet> so yeah, maybe we should keep the 'policies' page with details about team processes and rules, but actual docs about the backport process and rules elsewhere (but linked from the policies page)
16:21 <mapreri> the link to "documentation" is very generic, but I consider it fine as it is.
16:23 <mapreri> teward: do you have any input whatsoever about this document?
16:25 <ddstreet> teward or, are you ready to vote on approving it?
16:26 <ddstreet> or mapreri do you have any other discussion points for it?
16:26 <mapreri> no, that was my only one
16:26 <teward> stdby
16:26 <teward> playing catchup after a call from law enforcement partners the pastt 5 minutes
16:27 <teward> no input at the moment all has been good so far
16:28 <ddstreet> ok let's take a vote
16:29 <ddstreet> #vote Approve UbuntuBackports Policies
16:29 <meetingology> Please vote on: Approve UbuntuBackports Policies
16:29 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:29 <teward> +1
16:29 <meetingology> +1 received from teward
16:29 <ddstreet> and for recordkeeping, this is for this version (the latest, currently) of the wiki page:
16:29 <ddstreet> #link https://wiki.ubuntu.com/UbuntuBackports/Policies?action=recall&rev=16
16:29 <ddstreet> +1
16:29 <meetingology> +1 received from ddstreet
16:29 <mapreri> +1
16:29 <meetingology> +1 received from mapreri
16:29 <ddstreet> #endvote
16:29 <meetingology> Voting ended on: Approve UbuntuBackports Policies
16:29 <meetingology> Votes for: 3, Votes against: 0, Abstentions: 0
16:29 <meetingology> Motion carried
16:30 <ddstreet> great! :)
16:30 <ddstreet> that felt like a long process :-)
16:30 <ddstreet> i'll update the wiki page to remove the 'draft' header
16:30 <ddstreet> #action ddstreet update policies wiki page to remove 'draft' header
16:30 * meetingology ddstreet update policies wiki page to remove 'draft' header
16:31 <mapreri> and link in the main page somewhere
16:31 <ddstreet> main page being https://wiki.ubuntu.com/UbuntuBackports ?
16:32 <ddstreet> that's linked already in the 'definitions' section
16:32 <ddstreet> or you mean link to policies from that page?
16:32 <mapreri> the latter, yes
16:33 <ddstreet> ack
16:33 <ddstreet> #action ddstreet add link to policies wiki page, to main wiki page https://wiki.ubuntu.com/UbuntuBackports
16:33 * meetingology ddstreet add link to policies wiki page, to main wiki page https://wiki.ubuntu.com/UbuntuBackports
16:34 <ddstreet> one related issue, i basically inherited the 'chair' position from the team 'reboot' last year; but i'm happy to have an actual vote for chair if either of you want to
16:34 <mapreri> happy to leave as it is :)
16:35 <ddstreet> sounds good to me :)
16:36 <ddstreet> so we still have some time left, but i don't think there are many updates to our agenda items, shall we end the meeting now or do either of you want me to run thru the agenda items?
16:37 <mapreri> aside from the point I mentioned at the start, I don't have any other update, so I'm good
16:37 <mapreri> however, we may want to figure out quickly at least if we want to answer to seb?
16:38 <mapreri> https://lists.ubuntu.com/archives/technical-board/2023-January/002703.html
16:39 <ddstreet> #topic TB email for charter clarification
16:39 <ddstreet> sure someone should reply for clarification
16:40 <ddstreet> any thoughts on what the next steps for charter should be?
16:40 <ddstreet> should we drive the next steps or should we ask the TB to drive? Or ask the TB to at least provide some guidelines/template/etc for a draft we create?
16:41 <ddstreet> I feel like we need some kind of direction from the TB before we draft anything new
16:41 <mapreri> or at this point pick Robie's example and go from there…?
16:42 <ddstreet> i guess? so that would basically be asking Robie to draft a charter based on hs example that we could discuss?
16:44 <ddstreet> no matter the content, I think a key point of this will be who actually drives the charter
16:44 <ddstreet> and I don't personally want to do that
16:45 <mapreri> let me try something tomorrow about this, I'll draft an answer email and ask you to briefly review it (so that I don't write something that it's not "consensus")
16:45 <ddstreet> works for me, thanks!
16:45 <ddstreet> you want action item for that?
16:45 <mapreri> pls
16:46 <ddstreet> #action mapreri draft response email re: charter to TB
16:46 * meetingology mapreri draft response email re: charter to TB
16:46 <ddstreet> ok let's move to AOB before wrap?
16:46 <ddstreet> #topic AOB
16:46 <mapreri> none from me
16:46 <ddstreet> any final topics?
16:47 <ddstreet> ok last thing then is our next meeting, should we schedule for 4 weeks?
16:47 <ddstreet> i think that makes it Feb 15
16:47 <ddstreet> any objections?
16:47 <mapreri> nope, I'm good
16:48 <ddstreet> #action ddstreet schedule next mtg 2023-02-15 same time
16:48 * meetingology ddstreet schedule next mtg 2023-02-15 same time
16:48 <ddstreet> ok i think we're wrapped then! great meeting! :)
16:48 <ddstreet> #endmeeting