20:05 <sil2100> #startmeeting Technical Board
20:05 <meetingology> Meeting started at 20:05:40 UTC.  The chair is sil2100.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
20:05 <meetingology> Available commands: action, commands, idea, info, link, nick
20:05 <sil2100> #topic Welcome new TB members!
20:06 <rbasak-mobile> Welcome!
20:06 <sil2100> Hello seb128, amurray o/
20:06 <amurray> thanks
20:06 <sil2100> Glad to have you on board
20:06 <seb128> hey :)
20:06 <sil2100> #topic Action review
20:07 * sil2100 (everyone) review the Ubuntu Backports Team Charter for ratification
20:07 <seb128> thanks, I'm honored to be there :)
20:07 <sil2100> Let's start with action items, first one is this ^
20:08 <sil2100> hm, do we have any links for this topic to share with those that have no context?
20:08 <sil2100> (or forgot ;) )
20:08 <rbasak-mobile> It would be nice to make some more progress on this. The most recent discussion was a while back on the technical board mailing list.
20:08 <amurray> so this may sound dumb but I went looking everywhere and couldn't find the charter - there is a blank wiki page with that name - https://wiki.ubuntu.com/UbuntuBackports/Charter
20:09 <sil2100> I remember this being discussed on the mailing list. I'll try to find the link and add it to the agenda
20:10 <sil2100> But if anyone has it handy from the ML archives, feel free to post it here
20:10 <vorlon> sil2100: shoving an item onto the agenda wiki page late (sorry)
20:10 <vorlon> root of thread: https://lists.ubuntu.com/archives/technical-board/2022-March/002620.html
20:10 <rbasak-mobile> The best way to catch up might be to look at the mailing list archive and together with the history of that wiki page lined up by time
20:11 <sil2100> vorlon: thanks!
20:12 <sil2100> seb128, amurray: if you could go through the thread at some point, would be good if we could discuss that on the next meeting
20:12 <sil2100> I need to refresh my memory as well
20:12 <seb128> I will do before the next meeting
20:12 <amurray> sure, will do
20:12 <sil2100> It slipped through my hands a bit
20:12 * sil2100 rbasak to finalize third-party seeded snap security policy
20:12 <sil2100> rbasak-mobile: do you still need some time for that?
20:13 <sil2100> Ah, let me put the previous one as a carry over
20:13 <sil2100> #action (everyone) review the Ubuntu Backports Team Charter for ratification
20:13 * meetingology (everyone) review the Ubuntu Backports Team Charter for ratification
20:14 <sil2100> Ok, I'll assume that's the case and carry over it for now
20:14 <sil2100> There was a lot of progress done there so I'm not worried about it
20:14 <sil2100> #action rbasak to finalize third-party seeded snap security policy
20:14 * meetingology rbasak to finalize third-party seeded snap security policy
20:14 * sil2100 vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
20:14 <vorlon> I think we keep saying this is now superseded by the previous action item
20:14 <vorlon> but it hasn't gotten dropped from the agenda
20:14 <sil2100> True
20:15 <rbasak-mobile> This entire group of topics is making good progress.
20:15 <sil2100> Let's drop it then, it's related
20:15 * sil2100 sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
20:15 <sil2100> ...sadly, carry over. But I'd like to finally do this
20:15 <sil2100> #action sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
20:15 * meetingology sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
20:15 <rbasak-mobile> I'll need to catch Andy up on it. Seb already knows through the desktop team
20:15 * sil2100 rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
20:16 <sil2100> I think this is rather lower priority nowadays
20:16 <rbasak-mobile> No progress, focused on the other things
20:16 <sil2100> Do you think it still makes sense to have on the agenda?
20:16 <amurray> rbasak-mobile: i'm alex not andy :) sadly I don't play tennis
20:16 <rbasak-mobile> I think so. The other things are making good progress and I'm hoping to get them closed off soon
20:16 <sil2100> Or should we get back to it when we see issues with DMB inactivity?
20:16 <rbasak-mobile> Sorry!
20:16 <sil2100> rbasak-mobile: ACK
20:16 <sil2100> #action rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
20:16 * meetingology rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
20:17 * sil2100 cyphermox to figure out next steps to improve TB processes previously discussed
20:17 <sil2100> So cyphermox sadly is no longet part of the TB, so we need to move this to someone else
20:17 <sil2100> ...though the action item is very vague
20:17 <rbasak-mobile> This is related to the community bugs
20:17 <seb128> right, I was going to ask, what is 'previously discussed'?
20:18 <amurray> I can try and take it but would need more context
20:19 <rbasak-mobile> I don't remember the detail, sorry. It was something to do with making it easier for the general public to see what progress we were making by using the bug tracker of some form. We did already have a Launchpad project for this, but I think there was some talk of combining it with this other thing.
20:19 <sil2100> Okay, I sadly also don't remember the context, might have been that I was absent during the meeting
20:19 <sil2100> amurray: I'll assign this to you then, one of the tasks being 'figuring out exactly what it's all about' ;)
20:20 <amurray> ok I can try dig through the previous meeting logs and will see what I can find - first step then will be to familiarise myself with it all so I can try and report back next meeting on what I have found
20:20 <sil2100> #action amurray to figure out next steps to improve TB processes previously discussed - and to figure out what the previous discussion was about
20:20 * meetingology amurray to figure out next steps to improve TB processes previously discussed - and to figure out what the previous discussion was about
20:20 * sil2100 vorlon to reply to the Edubuntu ML thread with a description of what we need from Erich before we can proceed.
20:20 <vorlon> oops - carry over
20:20 <sil2100> Right, so Edubuntu
20:20 <sil2100> ACK o/
20:20 <sil2100> #action vorlon to reply to the Edubuntu ML thread with a description of what we need from Erich before we can proceed.
20:20 * meetingology vorlon to reply to the Edubuntu ML thread with a description of what we need from Erich before we can proceed.
20:21 * sil2100 sil2100 to follow up with the release team to establish consensus on Joshua's official flavour status for Cinammon.
20:21 <sil2100> ...still pinging people! I even pinged peeps yesterday ;)
20:21 <sil2100> I'll carry this over and continue poking vorlon, bdmurray and ginggs
20:22 <sil2100> #action sil2100 to follow up with the release team to establish consensus on Joshua's official flavour status for Cinammon.
20:22 * meetingology sil2100 to follow up with the release team to establish consensus on Joshua's official flavour status for Cinammon.
20:22 <sil2100> Phew, quite a lot of action items here
20:22 <sil2100> #topic Meeting schedule w/ new TB constitutency
20:22 <sil2100> ...is this about checking if the meeting schedule right now is good for everyone?
20:22 <vorlon> how does this time work for everyone?
20:22 <vorlon> yeah
20:23 <vorlon> fwiw my availability is again flipping to opposite weeks at the end of January
20:23 <seb128> the current time works fine for me
20:23 <sil2100> For me it's 'okayish', and I don't mind if the weeks need to be flipped
20:23 <amurray> the current time works for me too
20:23 <seb128> flipping weeks would also wfm
20:23 <amurray> same
20:23 <rbasak-mobile> +1
20:24 <sil2100> Excellent o/
20:24 <sil2100> #topic Scan the mailing list archive for anything we missed (standing item)
20:24 <rbasak-mobile> What will be the date of the next meeting then?
20:25 <sil2100> There is the new e-mail from Steve about the new Xubuntu Minimal flavor, but I think it's a no-action for the TB
20:25 <sil2100> rbasak-mobile: 24th I suppose? vorlon are you still fine to attend that one?
20:25 <vorlon> oh er sorry, as mentioned my attention is divided
20:25 <vorlon> I should've said that this time now overlaps on an ongoing basis with a team daily standup
20:26 <vorlon> would 30 minutes later work for people?
20:26 <rbasak-mobile> +1
20:26 <amurray> 30 mins later wfm
20:26 <sil2100> I think it would be okay
20:26 <vorlon> sil2100: yes, 24th is ok, but then I would need it changed for February
20:26 <seb128> I prefer the current time, I could do it later but I might have to drop before the end sometimes
20:27 <sil2100> vorlon: ok, let me add an action item to deal with the schedule change
20:27 <sil2100> I'll assign it to vorlon ! ;)
20:27 <vorlon> haha ok
20:27 <sil2100> #action vorlon to request change of the meeting weeks for the TB meeting starting February
20:27 * meetingology vorlon to request change of the meeting weeks for the TB meeting starting February
20:28 <sil2100> As for the hour change, hmm
20:28 <sil2100> Let's maybe do this at the same time as we switch weeks, how about that?
20:29 <vorlon> seb128 mentioned possibly having to leave early if we move it a half hour later
20:29 <rbasak-mobile> Sure
20:29 <sil2100> Maybe we can poke Matthieu to move the standup or something
20:29 <vorlon> are there *later* times that would work well for all the European folks?
20:29 <sil2100> And then no change to the meeting hour would be needed
20:29 <vorlon> (amurray and I can obviously do plenty later)
20:30 <sil2100> I'd recommend everyone think about this for the next meeting, and we'll discuss this as part of the above action item
20:30 <sil2100> But as said, maybe no hour change might be needed
20:30 <vorlon> I can ask Matthieu; I'm sure the concern will be that he can't move it *every* day so having inconsistency on just Tuesdays might not be preferred
20:30 <seb128> no, the reason I mentioned dropping is that the current time is ending up at 10pm which is getting late to be at the computer without creating personal conflicts
20:31 <vorlon> seb128: ok
20:32 <sil2100> Okay, let's move on for now and get back to this next time. I'll chat with Matthieu as well
20:32 <sil2100> #topic Check up on community bugs (standing item)
20:32 <sil2100> ...no new bugs
20:32 <sil2100> #topic Select a chair for the next meeting
20:32 <sil2100> Any volunteers?
20:33 <vorlon> since you did it today, should we just pick up from there w/ the rotation?
20:34 <sil2100> Okay, makes sense. Looking at how people are ordered by name on the LP page, next person would be amurray !
20:34 <sil2100> #topic AOB
20:34 <sil2100> Any other business?
20:35 <vorlon> nothing from me
20:36 <amurray> nor me
20:36 <seb128> not from me
20:36 <sil2100> If there's anything to discuss, remember you can always use the techboard ML
20:36 <sil2100> #endmeeting