20:04 <rbasak> #startmeeting Technical Board
20:04 <meetingology> Meeting started at 20:04:59 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
20:05 <meetingology> Available commands: action, commands, idea, info, link, nick
20:05 <rbasak> #topic Action review
20:05 * rbasak (everyone) review the Ubuntu Backports Team Charter for ratification
20:05 <rbasak> Still pending? There was some discussion in the backporters meeting the other day, but they basically punted it, too.
20:05 * rbasak rbasak to finalize third-party seeded snap security policy
20:06 <rbasak> I intend to resume this in January, assuming I get re-elected.
20:06 * rbasak sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
20:06 <rbasak> Still pending?
20:06 * rbasak rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
20:06 <rbasak> Still pending
20:06 * rbasak cyphermox to figure out next steps to improve TB processes previously discussed
20:06 <rbasak> cyphermox: I'm not sure what that refers to?
20:08 <cyphermox> that was about the launchpad bugs and whatnot
20:08 <cyphermox> carry please
20:08 <rbasak> OK thanks
20:08 <rbasak> Ah right
20:08 <rbasak> OK so I guess we can just consider all actions carried
20:09 <rbasak> #topic Scan the mailing list archive for anything we missed (standing item)
20:09 <rbasak> I think there are two
20:09 <rbasak> #subtopic Ubuntu Cinnamon for Official Flavor Status
20:09 <rbasak> Ɓukasz said he'd check in with other members of the release team. vorlon did you hear anything?
20:10 <vorlon> no
20:10 <rbasak> From my POV, I'm interested to hear what recommendation the release team have on this.
20:10 <rbasak> vorlon maybe you could opine now?
20:10 <vorlon> I haven't had a chance to review the application yet; I'm generally in favor but need to check over details to satisfy myself that things are ready
20:11 <rbasak> OK. How about I reply to the ML with an update for now, and we can continue in the new year.
20:11 <vorlon> ok
20:11 <rbasak> #subtopic Edubuntu Revival
20:11 <Eickmeyer> o/
20:11 <rbasak> o/
20:11 <vorlon> I have a lot to say on this one that I haven't had a chance to yet
20:12 <vorlon> my biggest concern is how edubuntu is going to be defined
20:12 <rbasak> I have essentially the same question here - I'm very happy to see this proposal, but I think it's mostly up to the release team to find Erich and Amy a point of contact and make a recommendation.
20:12 <vorlon> the original Edubuntu was an oddball in a lot of ways wrt our flavors, a lot of the work was around LTSP
20:12 <vorlon> and providing something that would be either a client or server for LTSP
20:13 <vorlon> I don't imagine that's the intent of the current team, so I would like to see a clearer explanation of the purpose of this as a flavor
20:13 <vorlon> (that's not something we have in the guidelines for flavors; maybe we should; nevertheless it's a major concern I have)
20:14 <Eickmeyer> If I may?
20:14 <vorlon> please
20:15 <rbasak> The model some of the newest flavors (and proposed flavors) have been following is to have it "done" first, and then making it official. That helps to demonstrate the intent pretty clearly. I wonder if that's possible/practical here?
20:15 <rbasak> Eickmeyer: indeed - please :)
20:16 <Eickmeyer> I don't think LTSP is part of the current vision. Amy is from the early childhood background, and envisions having something that preschoolers can have in the classroom without too much administrative overehead.
20:16 <Eickmeyer> Additionally, Elementary education could benefit from something similar, by having something children could get dirty by coding on.
20:17 <Eickmeyer> More and more elementary schools, my son's in particular, are getting into coding, and what better than Linux to get them started on?
20:17 <Eickmeyer> And that continues into secondary as well.
20:17 <Eickmeyer> The framework is already in the seed and just needs to be honed a little bit and made up-to-date.
20:18 <vorlon> the previous edubuntu seeds?
20:18 <Eickmeyer> If LTSP is a thing, it would be secondary.
20:18 <Eickmeyer> vorlon: Indeed. They're only current as of Bionic.
20:18 <sil2100> o/
20:19 <sil2100> Apologies for being late
20:19 <vorlon> ok.  from my pov this needs to be an ongoing conversation as you dig into the edubuntu seeds and clean them up for what you've identified as the current target (which to me sounds like two: "a selection of installed-by-default software for ECE", "a selection of installed-by-default software for elementary students")
20:20 <vorlon> and are you going to provide this as installer media with install options for different metapackages, etc
20:20 <Eickmeyer> vorlon: I'd throw secondary in there as well, and tertiary (college level) is also a seed that produces a meta.
20:21 <vorlon> ok - that's for you as a team to determine :)
20:21 <Eickmeyer> vorlon: That's the goal, possibly using the new installer as the framework. If not, then it would do like Ubuntu Studio and install everything, with a remover that removes what the machine doesn't need.
20:21 <vorlon> but I would like to see that some active curation is being done, rather than it being whatever was current 5 years ago
20:22 <Eickmeyer> vorlon: Yes, Amy and I have been sitting down and trying to go over some of what existed 5 years ago to determine what is relevant today.
20:22 <Eickmeyer> She has a degree in this field.
20:22 * vorlon nods
20:22 <sil2100> Just a touch re: the topic that I missed: Ubuntu Cinnamon. I asked internally around the release team but I actually didn't get any reply from anyone besides Utkarsh
20:22 <Eickmeyer> We might also enlist the help of Aaron Prisk as he has asked if there's anything he can do to help.
20:22 <sil2100> (who is not formally release team)
20:23 <vorlon> do you want me to scribble some of this down on the list?
20:23 <vorlon> sil2100: oh, I don't think I saw you ask :)
20:23 <utkarsh21021> sil2100: yes, so should I still comment?
20:24 <sil2100> vorlon: I poked internally on the 30th of November
20:24 <sil2100> ginggs commented, but he didn't see the e-mail actually
20:24 <sil2100> Ah, hm, and I think Joshua in the end didn't send it to a non-TB ML
20:25 <vorlon> the TB ML is open to the public
20:25 <rbasak> Could we stick with Eickmeyer's topic for now please, as he's here, and then circle back to the other one when done?
20:25 <sil2100> ACK
20:25 <rbasak> On Edubuntu, are we clear on what the next steps are yet?
20:26 <rbasak> I'll take that as a no? :)
20:26 <vorlon> Eickmeyer: do you need us as TB to sort out any permissions/memberships to unblock you wrt moving forward with work on the seeds?
20:27 <Eickmeyer> vorlon: We currently need Edubuntu Council to own ~edubuntu-dev on Launchpad to unblock us.
20:27 <vorlon> "Edubuntu Council" - defined?
20:27 <vorlon> https://launchpad.net/~edubuntu-council ?
20:28 <vorlon> per your email yes
20:28 <Eickmeyer> Yes. Amy and I are now Admins on Edubuntu Council, so that will allow us to own ~edubuntu-dev which unlocks the old repo.
20:28 <Eickmeyer> Also we need ownership of the seed if possible.
20:28 <rbasak> It looks like you indirectly own it already?
20:29 <Eickmeyer> rbasak: edubuntu-dev-owner is owned by the TB.
20:29 <Eickmeyer> Er, the DMB, for whatever reason.
20:29 <rbasak> ~edubuntu-dev is owned by edubuntu-dev-owner
20:29 <vorlon> I'm not clear if standard practice is to have other bodies own these teams as opposed to being administrators of them
20:29 <rbasak> And ~edubuntu-council is a member of ~edubuntu-dev-owner
20:30 <Eickmeyer> Yeah, this changed recently then.
20:30 <rbasak> As well as an admin
20:30 <vorlon> but in any event, yes, https://launchpad.net/~edubuntu-dev-owner/+members shows edubuntu-council is a member of edubuntu-dev-owner, since 2011
20:30 <Eickmeyer> Ok, then this looks like a recent change as this was owned by the TB last I checked.
20:30 <vorlon> since 2011
20:30 <Eickmeyer> Interesting. Ok, then all that's left is the seed.
20:30 <vorlon> the owner of edubuntu-dev-owner is not relevant, the membership is
20:31 <rbasak> ~edubuntu-dev-owner is *owned* by the DMB
20:31 <vorlon> as for the seed, once you populate the membership of ~edubuntu-dev, you can push the git branch yourselves
20:31 <rbasak> But it has ~edubuntu-council as a member and administrator, so that should be enough for permissions
20:32 <Eickmeyer> Excellent. Then I should be able to push to the seed?
20:32 <vorlon> you can push to a new git branch under ~edubuntu-dev namespace
20:32 <rbasak> Yeah did you just add yourself?
20:32 <Eickmeyer> I just added myself.
20:32 <rbasak> I think that should be sufficient
20:33 <vorlon> and once that branch exists, tell the release team the URL so we can add it to scripts
20:33 <Eickmeyer> Will do. Thanks everyone!
20:33 <Eickmeyer> Anything else you need from me?
20:34 <rbasak> What does "add it to scripts" mean please?
20:34 <rbasak> What effect would that have?
20:34 <sil2100> I'd like clarity on that too
20:34 <vorlon> rbasak: there's one script, actually owned by ubuntu-archive rather than ubuntu-release, that identifies seeds that get mirrored into the archive to populate Task fields
20:35 <rbasak> vorlon: is that the same as having official flavour status?
20:35 <vorlon> rbasak: and there's another script that mirrors the seeds to people.u.c/~ubuntu-archive ... actually also owned by ubuntu-archive... and runs germinate
20:35 <vorlon> rbasak: not really
20:35 <sil2100> hm, has edubuntu been discussed with the release team? Since I think we should first do that before we proceed?
20:35 <rbasak> Like are you considering the flavour to still exist and just being resurrected - will this mean that Edubuntu will now participate?
20:36 <vorlon> running germinate centrally is a convenience service for developers and doesn't say anything about what's official
20:36 <rbasak> To be clear I'm not objecting - just trying to understand how this fits in with everything
20:36 <rbasak> OK
20:36 <vorlon> this is just mechanics, not policy :)
20:37 <rbasak> Got it, thanks. Eickmeyer, are you happy with that for now? Is there anything further you require or are expecting?
20:37 <sil2100> I guess I wouldn't mind that then, as long as the actual flavor existence is still something we want to discuss before proceeding o/
20:37 <Eickmeyer> rbasak: No, that's all I was expecting for now. Was not seeking complete resurrection just yet, that would be an email for a later time once the necessary packages are back in the repo.
20:37 <rbasak> Like for example does Eickmeyer need a liason person from the release team nominated?
20:38 <Eickmeyer> Though, ^ That would be nice to navigate this.
20:38 <vorlon> is that a thing we do?
20:38 <rbasak> That was my proposal when clearing up the "new flavour process". I thought we had general agreement on that.
20:38 <sil2100> I think this will happen after the release team discusses the participation first
20:39 <rbasak> But I haven't finished updating the draft and announcing the changes yet.
20:39 <vorlon> right, I didn't recall this detail
20:39 <sil2100> I'd say we first need to say "yes/no/maybe" and then assign somenone
20:39 <sil2100> s/none/one/
20:39 <Eickmeyer> Happy to be the guinea pig for that.
20:39 <rbasak> I'd like to be clear on where we stand wrt. to that.
20:40 <rbasak> Either we're "not yet, need <X>" (eg. a clearer definition/description that vorlon asked above), or "no because <Y>" (seems unlikely), or "yes and your liason person is <Z>".
20:40 <rbasak> Which of those are we at right now?
20:40 <sil2100> I'd say first option
20:41 <rbasak> OK, so an action for Erich and Amy then to complete that, and get back to us?
20:41 <rbasak> vorlon, could you perhaps reply to the ML thread to explain exactly what you want wrt. that?
20:41 <vorlon> yes
20:41 <sil2100> Yes, I think this definition clarification would also be useful for the release team to make a decision
20:41 <rbasak> Thanks!
20:42 <rbasak> #action vorlon to reply to the Edubuntu ML thread with a description of what we need from Erich before we can proceed.
20:42 * meetingology vorlon to reply to the Edubuntu ML thread with a description of what we need from Erich before we can proceed.
20:42 <rbasak> Thanks I think that's clear now. Eickmeyer: are you good with that?
20:43 <Eickmeyer> Yes, that seems perfectly reasonable. I'll go ahead and explain in the ML thread what I explained here so that there's a paper trail for the release team to follow, if I understand the purpose.
20:43 <rbasak> That sound great. Thank you all for your patience. I just wanted to make sure everyone was completely clear and agreed on what was expected next.
20:43 <rbasak> Let's go back to Cinammon then.
20:44 <rbasak> #subtopic Ubuntu Cinnamon for Official Flavor Status
20:44 <rbasak> From the earlier discussion it sounds like the release team need to figure out an answer between themselves.
20:44 <sil2100> o/
20:45 <sil2100> Yeah, hm, could you add an action item for me for this? Since I asked once but didn't follow up on that
20:45 <rbasak> Which is fine, especially it being the vacation period now, I think it's OK for it to take us through to January.
20:45 <rbasak> Yes please.
20:45 <sil2100> I guess I need to poke people again
20:45 <sil2100> Apologies, dropped the ball on that one
20:45 <rbasak> #action sil2100 to follow up with the release team to establish consensus on Joshua's official flavour status for Cinammon.
20:45 * meetingology sil2100 to follow up with the release team to establish consensus on Joshua's official flavour status for Cinammon.
20:45 <rbasak> Cinnamon?
20:46 <rbasak> Anyway, yeah, thanks. I'd like to hear from the release team on their opinion - I don't really have one yet, apart from being keen to see this get through.
20:46 <rbasak> Any further discussion on Cinnammon?
20:47 <rbasak> Anything else on the ML that we need to discuss?
20:47 <rbasak> #topic Check up on community bugs (standing item)
20:47 <rbasak> #info No open bugs
20:48 <rbasak> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
20:48 <rbasak> The next meeting would be on 27/12. I propose that we skip it due to the vacation. Any objection?
20:48 <vorlon> no objection
20:48 <rbasak> That means that I can't really select a chair since the following meeting would be with the new board.
20:48 <cyphermox> nope. I will not be near a computer that day
20:49 <rbasak> #agreed We will skip the meeting on 27/12.
20:49 <meetingology> AGREED: We will skip the meeting on 27/12.
20:49 <rbasak> #info The next chair will depend on the new board.
20:49 <rbasak> #topic AOB
20:49 <rbasak> AOB?
20:50 <rbasak> #endmeeting