19:05 <utkarsh2102> #startmeeting Developer Membership Board
19:05 <meetingology> Meeting started at 19:05:51 UTC.  The chair is utkarsh2102.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:05 <meetingology> Available commands: action, commands, idea, info, link, nick
19:06 <seb128> hey, sorry for being a bit late!
19:06 <utkarsh2102> #link https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda
19:06 <utkarsh2102> #topic Ubuntu MOTU Developer Applications
19:07 <utkarsh2102> Frank Heimes is still pending.
19:07 <utkarsh2102> bdmurray: :)
19:07 <bdmurray> I was out sick and then had some holidays
19:07 <bdmurray> Will definitely get to it this week
19:08 <utkarsh2102> should we just conclude that it, unfortunately, did not make it through?
19:08 <utkarsh2102> as per the rules we have^
19:08 <rbasak> I'm not sure I exactly follow the current set of rules, but I'm fine with that outcome. Better to stop it leaving hanging :-/
19:08 <utkarsh2102> I read somewhere in the wiki - but anyway, what do others think?
19:08 <utkarsh2102> aah, okay
19:08 <utkarsh2102> I just read it
19:09 <utkarsh2102> thank you, bdmurray :)
19:09 <utkarsh2102> keep well, too! \o/
19:09 <utkarsh2102> moving on..
19:10 <utkarsh2102> wait - my client is acting up
19:10 <utkarsh2102> I am getting texts in weird fashion
19:10 <utkarsh2102> what do we conclude? should we announce the unsuccessful application or wait a bit more?
19:11 <seb128> if bdmurray really gets to it this week I would wait a few more days...
19:11 <seb128> announce it by the end of the week one way or another?
19:11 <bdmurray> thanks I'd appreciate the extra days
19:11 <bdmurray> that works for me
19:11 <utkarsh2102> okeydoke, sounds good
19:12 <utkarsh2102> #agreed we'll announce the application status by EOW, whatever the outcome is.
19:12 <meetingology> AGREED: we'll announce the application status by EOW, whatever the outcome is.
19:12 <utkarsh2102> thanks, let's move on
19:13 <utkarsh2102> #topic AOB
19:13 <utkarsh2102> #subtopic Vote on Proposal to change the maximum number of applicants per meeting.
19:13 <utkarsh2102> #link https://lists.ubuntu.com/archives/devel-permissions/2022-September/002030.html
19:13 <rbasak> This thread is nearly three months old now :-(
19:13 <utkarsh2102> bdmurray: you had something to add, no? if so, the stage is yours ;)
19:15 <bdmurray> I really don't understand why we end up playing a game of quiz show with applicants for upload rights instead of putting more stock in the endorsements.
19:16 <rbasak> We've had a number of concerning applications recently where many DMB members were clearly concerned that the applicant wasn't ready; yet they had good endorsements.
19:17 <rbasak> That's something that we need to fix, I think, but in the meantime, I think the opinion of the DMB seems to be that they do want to ask these questions, and the answers do quite significantly affect their opinion.
19:18 <rbasak> The DMB is elected; each member decides for themselves what they want to ask (or not ask) during an application meeting. And we can of course share our opinions and influence each other on that.
19:19 <rbasak> But for now, clearly we need more time. Accepting more applicants than we are fitting into a meeting isn't going to help with that.
19:19 <bdmurray> Alright, to speed up the voting process is there some way we can signal that we are ready to vote to avoid waiting for one person to have all of their questions answered?
19:19 <seb128> could we also maybe ask those questions via email before the meeting?
19:20 <seb128> rather having to sit and wait in front of IRC for ages for each answer, that's just really inefficient
19:20 <rbasak> bdmurray: I'm not sure I follow. How would signaling that you are ready to vote help speed up the voting process if others are still asking questions?
19:20 <bdmurray> I guess it wouldn't because we don't know how they are going to vote.
19:20 <seb128> I end up never asking questions because by the point of the meeting where I could it's the end of the hour or I've been bored enough sitting there waiting for things to happen that I can't be bothered anymore
19:20 <rbasak> seb128: I prefer to ask in realtime, so on IRC. Email-only applications have been discussed before, and I'm opposed to doing it that way because I think a realtime conversation does expose issues not obvious in a (slow) email thread.
19:21 <rbasak> One thing that does frustrate me is how long people in meetings take to respond. It's like they aren't paying attention during a meeting. But there's nothing I can do about that besides not do it myself.
19:21 <utkarsh2102> +1 to that^
19:21 <utkarsh2102> what rbasak said.
19:21 <rbasak> IMHO, that's what really drags out the meeting times.
19:22 <utkarsh2102> +1, again
19:22 <rbasak> But again, it's not something I can fix, and in the meantime, limiting meetings to one application each is going to make the experience immediately better for applicants.
19:22 <rbasak> I should add that the email vs. IRC application thing has long been a point of contention on the DMB. But that's OK - we're a board and are supposed to have different opinions.
19:23 <seb128> could we maybe mix?
19:23 <seb128> let those who want to ask via email earlier ask and then keep a live part?
19:23 <rbasak> I would note that when an application goes to email, it often takes *far, far longer* to reach a resolution anyway.
19:23 <seb128> or are you concerned that giving thinking time to applicant skew what you want to know?
19:23 <rbasak> Oh, sure. By all means people should feel free to ask questions in an email thread in advance. I have no objection to that.
19:24 <seb128> I would also recommend DMB members to have their questions prepared before the meeting even if they ask live
19:24 <seb128> or maybe recommend is the wrong wording, but that would be nice
19:24 <rbasak> But I myself would like to continue asking in the IRC meeting, and I try not to hold things up there.
19:24 <seb128> it would also help lowering the delays
19:25 <rbasak> Yes - I usually have things ready to copy and paste.
19:25 <utkarsh2102> no objections, either. But certainly, they have time to look up, interact with colleagues or other people to answer something that they might not know (which might or might not be concerning), so there's always that.
19:25 <seb128> rather than taking 3 min to word questions, copy/paste things prepared
19:25 <utkarsh2102> that's why I prefer IRC, apart from it being quick.
19:25 <utkarsh2102> so it saves time in the back and forth discussion whenever there's one.
19:25 <rbasak> But anyway, I think this is a bit orthogonal to my proposal. Yes, I agree that we should talk about and try to make meetings quicker.
19:25 <seb128> utkarsh2102, that's also true from an IRC conversation, they could have a collegue in /query or someone sitting with them at the computer
19:26 <rbasak> But the fact is that right now they're not, and a step forward would be to limit the number of applicants further, regardless of what else we might want to do to make meeting times quicker.
19:26 <seb128> right
19:26 <seb128> so focussing on your point I'm +1 with limiting to 1 by meeting, manage expectations
19:27 <seb128> it's not realistic that we do more with the current setup and delays
19:27 <rbasak> I'd like for us to agree on doing that, at least. I don't mean to dismiss other options to make meetings quicker, but I think we need to be talking about those separately.
19:27 <seb128> ack
19:27 <utkarsh2102> bdmurray: are you ready to vote?
19:27 <bdmurray> Yes
19:27 <utkarsh2102> sil2100: you, too?
19:28 <sil2100> Yeah
19:28 <utkarsh2102> #vote on limiting to 1 applicant per meeting
19:28 <meetingology> Please vote on: on limiting to 1 applicant per meeting
19:28 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:28 <rbasak> +1
19:28 <meetingology> +1 received from rbasak
19:28 <bdmurray> +1
19:28 <meetingology> +1 received from bdmurray
19:29 <utkarsh2102> #voters rbasak seb128 bdmurray utkarsh2102 sil2100
19:29 <meetingology> Current voters: bdmurray, rbasak, seb128, sil2100, utkarsh2102
19:29 <utkarsh2102> +1
19:29 <meetingology> +1 received from utkarsh2102
19:29 <seb128> +1
19:29 <meetingology> +1 received from seb128
19:30 <sil2100> +1
19:30 <meetingology> +1 received from sil2100
19:30 <utkarsh2102> #endvote
19:30 <meetingology> Voting ended on: on limiting to 1 applicant per meeting
19:30 <meetingology> Votes for: 5, Votes against: 0, Abstentions: 0
19:30 <meetingology> Motion carried
19:31 <utkarsh2102> \o/
19:31 <utkarsh2102> rbasak: will you please announce that and put it in the wiki somewhere?
19:31 <rbasak> ack
19:32 <rbasak> I've updated the wiki already
19:32 <utkarsh2102> #action rbasak to announce the results of this proposal and document this somewhere in the wiki.
19:32 * meetingology rbasak to announce the results of this proposal and document this somewhere in the wiki.
19:32 <rbasak> I think it's sufficient to just reply to the thread? Applicants adding themselves will presumably see the instructions in the wiki already, like they previous did.
19:32 <rbasak> We have some time left.
19:32 <utkarsh2102> yep
19:32 <rbasak> If we'd like to discuss other ways of making meetings quicker?
19:32 <utkarsh2102> nothing in the agenda that I see, at least. Anything else?
19:33 <utkarsh2102> bdmurray: you had a thing you wanted to bring up last week (but I ended the meeting), do you want to bring that up now, maybe?
19:33 <seb128> I would like to make the meeting less 'sit and wait', unsure if we can find improvements which can be enforced or at least recommendations
19:34 <utkarsh2102> I do have another thing - about us using +0 whilst voting - but I am too tired to bring it up. So maybe next time, unless rbasak wants to bring that up? :)
19:34 <rbasak> Obviously thinking and typing takes time, but I don't understand why people seem to take longer than that to respond.
19:34 <utkarsh2102> seb128: we all can try, by all means - being prepared for the meeting is a start. Do you have more such recommendations?
19:34 <teward[m]> *yawns* what've i missed (other than my headache)
19:35 <utkarsh2102> oooh, hi, teward! \o
19:35 <rbasak> I wonder if it would help if people could make it clear that a (slow) response is coming?
19:35 <bdmurray> Oh, right I was talking to Paul Sladen at Ubuntu Summit and their coredev lapsed because they lost their single sign on information. In light of our decision regarding Scott Moser I wonder if there is a way for Paul to get their core dev ack.
19:35 <rbasak> Like maybe just "..." or something as a shorthand for that?
19:36 <rbasak> I'm in favour of giving their core dev back as long as there's a reasonable explanation and they're otherwise active in the community (showing up to the Ubuntu Summit counts, IMHO).
19:36 <utkarsh2102> bdmurray: they are already approved till  2023-03-10
19:36 <seb128> I wonder if we should also have rules like 'if you take more than 3 minutes to reply something back then there is a problem and you are clearly not available to focus on the meeting and shouldn't delay it by pretending you are'
19:36 <utkarsh2102> what do you mean? :)
19:36 <rbasak> But I think they should email devel-pemissions@ to ask, at least, so there's an easily searchable record of what decisions the DMB is taking and why.
19:36 <teward[m]> rbasak: this 100%
19:36 <teward[m]> (I know i'm late sorry)
19:37 <rbasak> seb128: we don't really have the ability to sanction each other, as each of us is individually elected.
19:37 <bdmurray> utkarsh2102: Oh, I hadn't looked.
19:38 <utkarsh2102> hehe
19:38 <rbasak> It's very similar to the problem we have had with DMB absenteeism in the past.
19:38 <bdmurray> I think seb128 meant the candidates
19:38 <rbasak> I don't think the candidates are usually slow, are they?
19:38 <seb128> either, candidate or DMB members
19:38 <utkarsh2102> https://launchpad.net/~ubuntu-core-dev/+members#active
19:38 <utkarsh2102> not really
19:38 <rbasak> My impression is that it's DMB members who vanish, not the applicants.
19:38 <utkarsh2102> mostly us :/
19:39 <seb128> rbasak, we can't really 'sanction' but we can socially encourage people who aren't available to not waste everyone's time and just maybe not ask their question
19:39 <teward[m]> bdmurray i assume that Paul has been in contact with SSO support to try and get access back.  Unless they're stuck behind 2FA chaos in which case yeah good luck on that one
19:39 <teward[m]> not having SSO is something that's a concern as well
19:39 <seb128> it's easy to do 3 things at the same time and type and move to $other thing for 5 minutes
19:39 <teward[m]> (for Launchpad, etc.)
19:39 <teward[m]> seb128: especially when still doing $DAYJOB (which is my excuse)
19:40 <rbasak> seb128: sure, we can do that. Maybe we need to give more support to the chair to be able to move the meeting along.
19:40 <teward[m]> (mostly because I am still at $dayjob xD)
19:40 <seb128> but maybe reminding people that it was everyone's else time so nx5 minutes for the board would help them to fix it
19:40 <rbasak> Which in practice means less patience for slow-to-respond DMB members I guess.
19:41 <seb128> teward[m], we all have good reasons when we are stepping away from the keyboard or the channel usually
19:41 <rbasak> I don't so much mind a DMB member being unavailable for a meeting, or saying that they're struggling to do two things at once. As long as they don't hold up a meeting.
19:41 <seb128> it doesn't change the fact that's un-nice to everyone's else and that it might be better if people who aren't on capacity to focus on the meeting to not block others
19:42 <seb128> rbasak, right, same
19:42 <rbasak> As long as we remain quorate, etc.
19:43 <utkarsh2102> :P
19:43 <rbasak> I wonder what we do following this discussion that's actually actionable.
19:44 <rbasak> What if we say that if there's a three minute or longer delay in a DMB member responding, the chair should move on, assuming they're now unavailable? Unless they've excused themselves for a long thought, research, answer or similar. Which they can do just by saying "...".
19:45 <rbasak> That would mean ending a vote after three minutes, for example, even if we're not quorate.
19:45 <rbasak> We'll treat that member as absent from the vote, and do whatever we'd have done had they not been present.
19:45 <seb128> I would be in favor of that
19:46 <rbasak> That would help set the culture that slow response isn't OK.
19:47 <teward[m]> no objections though i would suggest we extend that to 5 minutes, etc. when the vote decision is on an application
19:47 <teward[m]> because sometimes it takes a bit for us to get everything put together for long reasons
19:47 <rbasak> IMHO, five minutes is too long for *no* response at all.
19:47 <utkarsh2102> sounds reasonable
19:47 <rbasak> But as I say, if you're going to take five minutes, just say "..." every three :-)
19:47 <utkarsh2102> just for the voting bit, it's OK
19:47 <utkarsh2102> the faster, the better
19:48 <rbasak> Take "..." to mean "I'm still here, working on an answer, extending my timeout by another three minutes, thanks"
19:48 <utkarsh2102> hah, what rbasak said^ :)
19:48 <utkarsh2102> DMB lingo :D
19:49 <rbasak> This would best be documented. I can write something up on the ML I guess.
19:49 <seb128> thanks!
19:50 <utkarsh2102> nice! \o/
19:50 <utkarsh2102> rbasak: before documenting, make sure everyone in the DMB is on the same page ;)
19:50 <rbasak> Yeah I'll write a suggestion to the ML first.
19:51 <utkarsh2102> yep, perfect
19:51 <utkarsh2102> anything else?
19:51 <seb128> rbasak, 👍
19:51 <rbasak> Nothing from me thanks.
19:52 <rbasak> I'm a bit puzzled by seb128's question though. Were you asking if I had anything else, or something else?
19:52 <seb128> which question?
19:52 <rbasak> 19:51 <seb128> rbasak, ?
19:52 <seb128> oh, that was a thumb-up emoji
19:53 <seb128> I guess your client doesn't like that
19:53 <seb128> ?
19:53 <rbasak> Oh.
19:53 <teward[m]> confirmed a thumbs up emoji here on matrix
19:53 <rbasak> Sorry, yes. My IRC unicode is broken. I need to fix it!
19:53 <seb128> :)
19:53 <rbasak> Now you can understand why I was puzzled :-)
19:54 <seb128> any other topic for the few minutes remaining?
19:54 <utkarsh2102> nice, another minute and 3 minutes would've passed since I asked if there's anything else
19:54 <utkarsh2102> I'm going to assume there's nothing more and I'll wrap up
19:54 <seb128> did you have more to discuss on Sladen's renewal?
19:54 <utkarsh2102> he's already "active" until March, 2023 :P
19:54 <utkarsh2102> s/he/they/ :)
19:55 <seb128> ah, right, someone said that :p
19:55 <seb128> thanks
19:55 <utkarsh2102> bah, s/he's/they're/
19:55 <seb128> I think we can wrap there then :)
19:55 <utkarsh2102> \o/
19:55 <utkarsh2102> awesome!
19:55 <utkarsh2102> #endmeeting