16:04 <utkarsh2102> #startmeeting Developer Membership Board
16:04 <meetingology> Meeting started at 16:04:16 UTC.  The chair is utkarsh2102.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:04 <meetingology> Available commands: action, commands, idea, info, link, nick
16:04 <utkarsh2102> hi, everyone! \o
16:04 <utkarsh2102> I'll dive into the application bits straightaway
16:04 <utkarsh2102> #topic MOTU Applications
16:05 <utkarsh2102> #subtopic Frank Heimes
16:05 <utkarsh2102> it's been a while on that one
16:05 <utkarsh2102> the voting moved to ML
16:05 <bdmurray> That's my fault and I'm sorry. I was away for quite a bit but will look at it this week.
16:06 <utkarsh2102> okeydoke, thank you! :)
16:06 <utkarsh2102> #action bdmurray to vote on the application.
16:06 * meetingology bdmurray to vote on the application.
16:06 <utkarsh2102> (otherwise no more Indian hot sauce for you, heh :))
16:06 <utkarsh2102> next..
16:06 <utkarsh2102> #subtopic Dave Jones
16:06 <utkarsh2102> #link https://wiki.ubuntu.com/DaveJones/MOTUApplication
16:07 <utkarsh2102> waveform: hellu! \o
16:07 <waveform> hello!
16:07 <utkarsh2102> please introduce yourself, meanwhile we'll go through the application!
16:07 <waveform> certainly...
16:07 <rbasak> o/ I'm a personal friend of waveform's, so I intend to abstain.
16:07 <waveform> bah, there goes one vote ;)
16:08 <waveform> (to be read in the voice of Troy McClure); Hi! I'm Dave. You may remember me from such disasters as "Eoan Ermine -- breaking USB on the most popular Pi at the time", or "Focal Fossa -- how not to structure a Pi's boot config". I work for the Ubuntu Foundations team, wrangling our favourite little SBC, and trying not to break too many things in the process (with varying degrees of success)
16:09 <bdmurray> I was ready to vote but then I heard that elevator pitch
16:09 <waveform> I'm applying for MOTU to avoid my current Pi PPU inexorably expanding to cover the known universe as I bung more and more hardware-enablement packages for various bits of hardware into the archive :)
16:09 <utkarsh2102> hehe, nice
16:09 <utkarsh2102> https://udd.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=&sponsor_search=name&sponsoree=dave.jones%40canonical.com&sponsoree_search=email -> holy shiz
16:10 <waveform> meh, most of it is an absolute pile of rebuilds sponsored by ginggs to do with a nasty dh bug I helped fix
16:10 <utkarsh2102> >> Areas of Improvement
16:10 <utkarsh2102> > One. He should have applied for MOTU/Core Dev earlier.
16:10 <waveform> (so you can ignore a lot of it)
16:10 <utkarsh2102> * > > Areas of Improvement
16:10 <utkarsh2102> > One. He should have applied for MOTU/Core Dev earlier.
16:10 <utkarsh2102> nice!
16:11 <utkarsh2102> okeydoke
16:11 <utkarsh2102> I'll open the floor for questions
16:12 * utkarsh2102 stomps the floor thrice
16:12 <utkarsh2102> there^ :)
16:13 <utkarsh2102> waveform: have you done any +1 maintenance or shadowed any?
16:13 <teward> i'm split between this and a work call so patience will be needed on my front
16:13 <waveform> utkarsh2102, no I haven't -- and I'm in no particular rush to add to my already amply overflowing plate
16:14 <utkarsh2102> ok, fair!
16:14 <bdmurray> waveform: But I am correct in thinking you've done proposed migration work for Foundations packages?
16:14 <waveform> yes
16:15 <bdmurray> In that case do you feel like you are familiar with the +1 maint process?
16:15 <chiluk> o/
16:16 <utkarsh2102> waveform: ok, what if you don't get your answers in update_excuses.html whilst doing proposed migration? where do you look or what do you do next?
16:16 <waveform> bdmurray, if it's anything like proposed migration, then ... maybe. As noted in the application however I've never handled a transition
16:17 <waveform> utkarsh2102, usually digging into the logs of the particular failure. For instance, last week I was assigned distro-info which was blocking ... erm ... distro-info. In the end that turned out to be a failure of its test-suite and several packages down the chain was python3-wrapt which was the actual failure
16:17 <waveform> (a casualty of a deprecated piece of inspect getting removed in py 3.11)
16:18 <utkarsh2102> I meant, what if you don't find anything relevant in there and everything is passing but still the package hasn't migrated.
16:18 <utkarsh2102> can such a case arise?
16:19 <waveform> presumably -- in fact I think I've even seen it in the dim and distant past but I can't recall what was going on on that occasion
16:20 <utkarsh2102> uh, okay!
16:20 <waveform> at that point I'd probably go and ask one of the deeply grey-bearded members of the team what on earth was going on
16:21 <utkarsh2102> okeydoke
16:21 <utkarsh2102> I don't really have a grey beard yet, it's gonna be a while but you can ask me :)
16:21 <kanashiro[m]> waveform: since you did not work on any transition yet, what would you do to make sure you are not triggering one when uploading a package?
16:22 <waveform> the reverse dependencies; reverse-depends src: is a handy check but much of the time it's pretty obvious if there are none (e.g. I know nothing deps on rpi-imager)
16:23 <waveform> (and likewise I know even though debhelper has seemingly few reverse-deps messing with it involves *lots* of rebuilds!)
16:23 <kanashiro[m]> but is there anything that you can look in the package to make sure a transition will not be triggered?
16:26 <waveform> in the package itself? Nothing guaranteed that I can think of
16:28 <kanashiro[m]> in the case of a library you could check if there is a soname bump for instance
16:29 <waveform> sure, the soname may change, but if nothing in the archive depends on it, presumably that's not a transition?
16:30 <kanashiro[m]> you are right, but then there is no reason to have a shared library :)
16:31 <waveform> there's plenty of libraries with zero rev-deps because they're not used by anything packaged in the archive; take a look at python3-rpi.gpio -- it's got almost zero rev-deps but it's used by *hundreds* of pi projects
16:31 <utkarsh2102> I'd still call it a transition, albeit a super small one! :)
16:32 <kanashiro[m]> fair enough
16:32 <waveform> heh -- it's one I'd always be super-careful of messing with because I know just how much "silently" depends on it outside of our archive
16:33 <bdmurray> I'm ready to vote.
16:33 <teward> no questions here, ready to vote as well
16:33 <kanashiro[m]> me too
16:35 <utkarsh2102> sil2100:^
16:35 <sil2100> No questions here!
16:35 <chiluk> Are you folks voting for MOTU or Core Dev?  As one of the few non-canonicalers, I see enough here that core dev should be on the table.
16:35 <utkarsh2102> are
16:35 <utkarsh2102> you
16:35 <utkarsh2102> ready
16:35 <utkarsh2102> to
16:35 <utkarsh2102> vote?
16:35 <utkarsh2102> okeydoke, awesome
16:36 <teward> chiluk: unless they've requested Core Dev, MOTU
16:36 <utkarsh2102> #vote Dave Jones to get MOTU rights
16:36 <meetingology> Please vote on: Dave Jones to get MOTU rights
16:36 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:37 <utkarsh2102> #voters sil2100 kanashiro teward bdmurray utkarsh2102
16:37 <meetingology> Warning: 'kanashiro' not in channel
16:37 <kanashiro[m]> +1
16:37 <utkarsh2102> go, go, go
16:37 <meetingology> Current voters: bdmurray, kanashiro, sil2100, teward, utkarsh2102
16:37 <sil2100> +1
16:37 <meetingology> +1 received from sil2100
16:37 <bdmurray> +1
16:37 <meetingology> +1 received from bdmurray
16:38 <utkarsh2102> +1; comments to follow
16:38 <meetingology> +1; comments to follow received from utkarsh2102
16:39 <utkarsh2102> comment: great work, waveform. I am sure you'll be an awesome MOTU but in case you have doubts or questions, please don't hesitate to ask - your colleagues or on IRC. With that, I'll let you celebrate, congratulations. :)
16:39 <utkarsh2102> teward:^^
16:40 <kanashiro[m]> waveform seems to me a cautious guy and I am not too worried about him messing the archive :) but feel free to ask when needed
16:40 <utkarsh2102> seconded!
16:40 <waveform> woohoo! (and double woohoo for not getting core-dev thrust unwittingly upon me!)
16:41 <chiluk> with great power yadda yadda..
16:41 <teward> i just had a network crash
16:41 <teward> +1
16:41 <meetingology> +1 received from teward
16:41 * waveform tries not to cackle evily...
16:41 <utkarsh2102> I am unsure whether to proceed or wait for teward. :)
16:41 <utkarsh2102> there :)
16:41 <utkarsh2102> #endvote
16:41 <meetingology> Voting ended on: Dave Jones to get MOTU rights
16:42 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
16:42 <meetingology> Motion carried
16:42 <teward> utkarsh2102: this was a 'network broke due to me kicking a cable, switching to mobile hotspot' situation ;()
16:42 <utkarsh2102> #action utkarsh2102 to announce the successful application. \o/
16:42 * meetingology utkarsh2102 to announce the successful application. \o/
16:42 <utkarsh2102> ahahahaha
16:42 <utkarsh2102> more coffee needed
16:43 <utkarsh2102> moving on..
16:43 <utkarsh2102> #topic AOB
16:43 <utkarsh2102> Vote on Proposal to change the maximum number of applicants per meeting.
16:43 <utkarsh2102> #link https://lists.ubuntu.com/archives/devel-permissions/2022-September/002030.html
16:43 <utkarsh2102> should we just vote? or do we still need to discuss?
16:44 <bdmurray> I didn't expand on my point that we take too long to evaluate candidates.
16:45 <bdmurray> Given there aren't currently a plethora of candidates could we defer that vote?
16:45 <utkarsh2102> do you need more time to do that? should we vote on this the next time?
16:45 <utkarsh2102> yes!
16:45 <utkarsh2102> although it's trivial, but sure, we can absolutely defer
16:45 <bdmurray> Yes, I'd like to try and write some words.
16:46 <utkarsh2102> okeydoke, sounds good!
16:46 <utkarsh2102> how to carry-over something? meh
16:47 <utkarsh2102> I'll just pretend it happened
16:47 <utkarsh2102> so I'll wrap up, unless someone has something to bring up?
16:47 <utkarsh2102> I do, one thing
16:48 <bdmurray> I have one thing also
16:48 <utkarsh2102> we did a good job today. We have 15ish minutes remaining and a successful application. Yay.
16:48 <utkarsh2102> done, anything else? :)
16:48 <utkarsh2102> 5
16:48 <utkarsh2102> 4
16:48 <utkarsh2102> 3
16:49 <utkarsh2102> 2
16:49 <utkarsh2102> 1
16:49 <utkarsh2102> #endmeeting