15:02 <ddstreet> #startmeeting Ubuntu Backporters
15:02 <meetingology> Meeting started at 15:02:37 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:02 <meetingology> Available commands: action, commands, idea, info, link, nick
15:03 <ddstreet> ok let's run thru the previous action items...i am pretty sure almost all of mine are carry-over
15:03 <ddstreet> #topic previous action items
15:03 <mapreri> same, likely…
15:03 <ddstreet> #subtopic ddstreet update tooling, requestbackport, backportpackage (carried over)
15:03 <mapreri> such horrible 2.5 weeks for me :(
15:03 <ddstreet> #action ddstreet update tooling, requestbackport, backportpackage (carried over)
15:03 * meetingology ddstreet update tooling, requestbackport, backportpackage (carried over)
15:03 <ddstreet> i'm hoping to get started on some of my other items once the charter/policies is done
15:04 <ddstreet> but also, summertime is not great for getting things done :)
15:04 <ddstreet> #subtopic ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:04 <ddstreet> #action ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:04 * meetingology ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:04 <ddstreet> #subtopic ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:04 <ddstreet> #action ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:04 * meetingology ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:04 <ddstreet> #subtopic ddstreet schedule next mtg Oct 5 15:00 UTC
15:04 <ddstreet> i did this one! ;-)
15:04 <mapreri> :P
15:04 <ddstreet> #subtopic mapreri upload (more of) all the tools (carried over, in progress)
15:05 <mapreri> carried over, nothing done I believe
15:05 <ddstreet> #action mapreri upload (more of) all the tools (carried over, in progress)
15:05 * meetingology mapreri upload (more of) all the tools (carried over, in progress)
15:05 <mapreri> (I mean, nothing new in the last month)
15:05 <ddstreet> #subtopic mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:05 <ubottu> Debian bug 1001399 in lintian "lintian: adjust backports-upload-has-incorrect-version-number for ubuntu" [Normal, Open]
15:05 <mapreri> the new lintian maintainer is busy with other projects, apparently :|
15:05 <mapreri> will chase him down again
15:06 <ddstreet> hopefully they are less busy over the fall/winter
15:06 <ddstreet> #action mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:06 * meetingology mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:06 <ddstreet> #subtopic mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
15:06 <mapreri> carried over
15:06 <ddstreet> #action mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
15:06 * meetingology mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
15:07 <ddstreet> #subtopic mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
15:07 <ddstreet> #action mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
15:07 * meetingology mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
15:07 <ddstreet> assumed carry over for that too
15:07 <mapreri> yap
15:07 <ddstreet> #subtopic mapreri poke unit193 about yt-dlp dep on dh-python
15:07 <mapreri> uh, this I actually forgot
15:07 <ddstreet> lol thats ok :)
15:08 <ddstreet> should we carry it?
15:08 <ddstreet> or drop it?
15:08 <mapreri> but I now too time has passed, need to look what the thing was again
15:08 <mapreri> please leave it
15:08 <ddstreet> ok
15:08 <ddstreet> #action mapreri poke unit193 about yt-dlp dep on dh-python
15:08 * meetingology mapreri poke unit193 about yt-dlp dep on dh-python
15:08 <mapreri> If it's there probably there was a good reason from past me
15:08 <ddstreet> there's a bug associated, lemme at least link that for reference
15:08 <mapreri> don't worry, I'll find it
15:08 <ddstreet> ok
15:08 <ddstreet> that's all previous action items
15:09 <ddstreet> #topic open mailing list threads
15:09 <ddstreet> #subtopic clarification on specific wording for no-bug-required backport exceptions
15:09 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2022-February/022680.html
15:09 <ddstreet> i think we can carry this over too
15:09 <mapreri> checked, still in inbox
15:09 <ddstreet> #action clarification on specific wording for no-bug-required backport exceptions
15:09 * meetingology clarification on specific wording for no-bug-required backport exceptions
15:10 <ddstreet> #subtopic charter/policies
15:10 <mapreri> (I also found in inbox the thread about dh-python, fwiw)
15:10 <ddstreet> thanks for reviewing charter/policies! i just saw your email
15:10 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2022-October/022945.html
15:10 <ddstreet> for reference
15:11 <mapreri> yeah, of course I send such emails right before the meeting, what did you expect? :P
15:11 <ddstreet> on quick read of your comments, the changes sound fine to me
15:11 <ddstreet> lol
15:11 <ddstreet> instead of trying to modify it now and re-review, i can update it after the meeting and send another email, and we can defer the vote to next meeting
15:11 <ddstreet> if that sounds ok to you?
15:12 <mapreri> sounds good.
15:12 <mapreri> just checking
15:12 <mapreri> electing the chair: super or simple majority?
15:12 <ddstreet> #action ddstreet update charter/policies from mapreri review email, send new email asking for review again
15:12 * meetingology ddstreet update charter/policies from mapreri review email, send new email asking for review again
15:13 <ddstreet> i'm fine with either way, i think
15:13 <mapreri> I also don't have a strong opinion on that one myself
15:13 <mapreri> if you think simple may be easier, go with that (in my mail I wrote super)
15:13 <ddstreet> i think i lean to just a simple majority
15:14 <ddstreet> yeah, a simple majority for both appoint/approving, as well as removal, is probably best i think
15:15 <mapreri> ack
15:15 <ddstreet> ok i'll update the policies to state simple majority for chair add/remove
15:15 <mapreri> …charter?
15:15 <ddstreet> and we can tweak that pretty easy before the vote if we change our mind
15:15 <ddstreet> oh charter right sorry
15:15 <mapreri> good :)
15:15 <ddstreet> yeah the charter currently says 'see the policies' but i agree it's easier to reduce cross-referencings
15:15 <mapreri> next topic
15:15 <mapreri> also, the policies don't say :P
15:16 <ddstreet> yeah, clearly an oversight :)
15:16 <ddstreet> i mean...i was testing you! lol
15:16 <mapreri> :>
15:16 <ddstreet> ok that's all ml threads
15:16 <ddstreet> #topic open bugs
15:16 <mapreri> I haven't kept up with the current bugs in the past month
15:17 <mapreri> but looking at them now, I see it's the same set of open bugs from a month ago, so…
15:17 <ddstreet> yep, one waiting on an upload
15:17 <ddstreet> #link https://bugs.launchpad.net/ubuntu/jammy/+source/limnoria/+bug/1983415
15:17 <ubottu> Launchpad bug 1983415 in limnoria (Ubuntu Jammy) "[BPO] limnoria 2022.6.23-1 to jammy" [Undecided, New]
15:17 <ddstreet> oh wait i think someone did upload that
15:17 <mapreri> I *believe* that's already uploaded, just need checking
15:17 <mapreri> yeah, unit193 msg'd me on irc a week or so ago about it
15:17 <mapreri> so it's on my todo, but if you want to take it, go ahead
15:18 <ddstreet> the limnoria one is done, i approved it earlier this week
15:18 <ddstreet> i'll mark it
15:18 <mapreri> ah good good ^^
15:18 <ddstreet> and one more bug
15:18 <ddstreet> #link https://bugs.launchpad.net/ubuntu/focal/+source/ipmctl/+bug/1968076
15:18 <ubottu> Launchpad bug 1968076 in ipmctl (Ubuntu Focal) "[BPO] ipmctl with support for CPS hardware" [Undecided, New]
15:18 <ddstreet> i think this needs a sponsor
15:19 <mapreri> yes
15:19 <ddstreet> i think teward was going to sponsor it
15:19 <ddstreet> i'll add a ping comment for him
15:19 <mapreri> I guess we should either be hardliner and unsub us, or jfdi and sponsor it…?
15:19 <mapreri> great
15:20 <mapreri> handing out tasks to absentees... I love it! :D
15:20 <ddstreet> i guess we can give it a bit more time before unsub
15:20 <ddstreet> lol, he volunteered for it before so i'm re-purposing that :)
15:20 <ddstreet> that's all the open bugs i see
15:21 <ddstreet> #topic AOB
15:21 <ddstreet> ok any other topics?
15:21 <mapreri> about the other bug https://bugs.launchpad.net/ubuntu/+source/ubuntu-dev-tools/+bug/1959115 - unit193 has some unpublished private patches I need to look at
15:21 <ubottu> Launchpad bug 1959115 in ubuntu-dev-tools (Ubuntu) "update backportpackage and requestbackport scripts to behave according to new backport process" [High, New]
15:21 <ddstreet> ah crap i moved topics too fast
15:21 <ddstreet> ok that's excellent!
15:22 <mapreri> also just had a quick look at the queues, I haven't spotted pending uploads
15:22 <ddstreet> i'll add an action in the bugs topic section, i had assumed there was no movement on that one
15:22 <ddstreet> hmm i guess we should have a topic section for pending uploads
15:22 <mapreri> those patches are drowned on my IRC scrollback, so I guess I need to either go fishing or ask about them -.-
15:22 <ddstreet> i think we've been pretty good about reviewing fairly regularly though
15:22 <mapreri> yeah
15:22 <mapreri> I think we are fine atm
15:23 <ddstreet> #action mapreri review ubuntu-dev-tools patches for https://bugs.launchpad.net/ubuntu/+source/ubuntu-dev-tools/+bug/1959115
15:23 * meetingology mapreri review ubuntu-dev-tools patches for https://bugs.launchpad.net/ubuntu/+source/ubuntu-dev-tools/+bug/1959115
15:23 <ubottu> Launchpad bug 1959115 in ubuntu-dev-tools (Ubuntu) "update backportpackage and requestbackport scripts to behave according to new backport process" [High, New]
15:23 <ddstreet> anything else before we decide on next mtg date?
15:23 <mapreri> nope, I'm good
15:23 <ddstreet> #subtopic next mtg date
15:24 <mapreri> about this…
15:24 <mapreri> uh
15:24 <mapreri> IRL meeting in prague?
15:24 <ddstreet> you'll be in prague?
15:24 <ddstreet> in nov?
15:24 <mapreri> I'm unavailable the week before the summit (for another IRL event), and the week with the summit is no good for irc (probably), so either the week after or…?
15:24 <mapreri> yes, I'll be
15:25 <ddstreet> ah the ubuntu summit
15:25 <ddstreet> i will likely not be there
15:25 <mapreri> :(
15:25 <ddstreet> i'm not sure if teward will
15:25 <mapreri> would have loved to meet you there :)
15:26 <ddstreet> yeah, since i'm no longer with canonical, i'll probably not travel to many ubuntu conf
15:26 <ddstreet> i would have too!
15:26 <ddstreet> i'll try to plan farther out to attend a future one
15:26 <mapreri> you are still an active core-dev, so it shouldn't matter much since the whole idea was to gather a bit of community?  (at least, that's the public reason)
15:27 <mapreri> but well, probably too late for planning?
15:27 <ddstreet> sure, right, i just mean canonical use to pay for my travel to (some) confs
15:27 <ddstreet> yeah i suspect it's too late for me to plan attending this one
15:27 <ddstreet> just 1 month out
15:27 <mapreri> so anyway, let's set for Nov 16th, 5 pm CET? (so… 16 UTC I believe)?
15:27 <mapreri> since there is DST change…
15:27 <mapreri> or do we want to keep the same?
15:27 <mapreri> oh wait
15:28 <ddstreet> nov 16 works for me
15:28 <mapreri> actually 4pm CET is no good for me…, but 5pm CET is, so…
15:29 <ddstreet> and i can do either, follow DST or not
15:29 <ddstreet> so 5pm CET is 16:00 UTC on nov 16 right?
15:29 <ddstreet> we're currently at 15:00 UTC for the mtg
15:29 <ddstreet> right?
15:29 <mapreri> going forward I have a recurring event on Wednesday that ends at 4pm CET (and then need to commute home)
15:30 <mapreri> right, so let's move it to 16 UTC / 17 CET ?
15:30 <ddstreet> sounds good, nov 16 at 16:00 UTC
15:30 <ddstreet> #action ddstreet schedule next mtg nov 16 at 16:00 UTC
15:30 * meetingology ddstreet schedule next mtg nov 16 at 16:00 UTC
15:31 <ddstreet> any last topic before we end?
15:31 <mapreri> I'm good
15:31 <ddstreet> #endmeeting