15:02 <ddstreet> #startmeeting Ubuntu Backporters Team
15:02 <meetingology> Meeting started at 15:02:04 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:02 <meetingology> Available commands: action, commands, idea, info, link, nick
15:02 <ddstreet> #topic previous action items
15:02 <ddstreet> i'm carrying over most of my items...i was out on vac last 2 weeks
15:03 <ddstreet> #action ddstreet update tooling, requestbackport, backportpackage (carried over)
15:03 * meetingology ddstreet update tooling, requestbackport, backportpackage (carried over)
15:03 <ddstreet> #action ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:03 * meetingology ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:03 <ddstreet> #action ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:03 * meetingology ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:03 <ddstreet> #subtopic ddstreet send ML reply to continue thread re: clarification on specific wording for no-bug-required backport exceptions
15:03 <ddstreet> i think i did send a reply for this, but i probably need to again
15:04 <mapreri> did you?
15:04 <ddstreet> #action ddstreet send ML reply to continue thread re: clarification on specific wording for no-bug-required backport exceptions
15:04 * meetingology ddstreet send ML reply to continue thread re: clarification on specific wording for no-bug-required backport exceptions
15:04 <mapreri> obviously wrong season for emails
15:04 <ddstreet> honestly i forget :)
15:04 <mapreri> as if there is a good season
15:04 <teward> itnever hurts to send out a second email in case you didn't send the first
15:04 <ddstreet> yep
15:05 <ddstreet> #subtopic ddstreet rework charter and internal policies documentation, have drafts for next mtg
15:05 <ddstreet> ok, for this one, i did rework the charter wiki page
15:05 <ddstreet> i did not have time to update the policies page yet though
15:06 <ddstreet> i have time to do that today though, so i'll just send a ML email once they are both ready to review
15:06 <ddstreet> unless either of you want to discuss the updated charter wiki page now?
15:06 <mapreri> nope
15:06 <ddstreet> awesome
15:07 <mapreri> I haven't looked at whatever you've done, tbh
15:07 <ddstreet> #action ddstreet finish updating charter/policies, send email to ML to request team review
15:07 * meetingology ddstreet finish updating charter/policies, send email to ML to request team review
15:07 <mapreri> and I won't be able for a while more…
15:07 <ddstreet> yep that's totally fine
15:07 <ddstreet> i think we are currently ok handling our team mission, uploads are getting reviewed, etc
15:07 <ddstreet> but i think good to finish up the charter/policies eventually
15:08 <ddstreet> ok on to your items
15:08 <mapreri> well, we don't have much uploads flowing around, so it's hard to actually judge it ^^
15:08 <ddstreet> yeah it's relatively small number
15:08 <ddstreet> but at least for now, i dont think any upload is getting stuck for 'too long'...couple weeks at most
15:09 <ddstreet> #subtopic mapreri upload (more of) all the tools (carried over, in progress)
15:09 <mapreri> it's coming along, not quickly, but it's happening
15:09 <ddstreet> ack
15:09 <ddstreet> #action mapreri upload (more of) all the tools (carried over, in progress)
15:09 * meetingology mapreri upload (more of) all the tools (carried over, in progress)
15:09 <ddstreet> #subtopic mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:09 <ubottu> Debian bug 1001399 in lintian "lintian: adjust backports-upload-has-incorrect-version-number for ubuntu" [Normal, Open]
15:10 <mapreri> I've pinged the new maintainer, it seems they have other priorities atm, but I'm much more optimistic than last year :3  after all the new maintainer came around less than 2 months ago i think
15:10 <mapreri> I reckon they'll fix it once they stumble upon that one set of changelog checks
15:11 <ddstreet> that's good news :)
15:11 <ddstreet> we should still carry over until it's done right?
15:11 <mapreri> yes please
15:11 <ddstreet> #action mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:11 * meetingology mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:11 <ubottu> Debian bug 1001399 in lintian "lintian: adjust backports-upload-has-incorrect-version-number for ubuntu" [Normal, Open]
15:11 <mapreri> else it'll be forgotten
15:12 <ddstreet> #subtopic mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor
15:12 <mapreri> carry over pls
15:12 <ddstreet> #action mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor
15:12 * meetingology mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor
15:12 <ddstreet> #subtopic mapreri start thread on ML about how to use bug status to define meaing in process
15:12 <mapreri> ditto
15:12 <ddstreet> #action mapreri start thread on ML about how to use bug status to define meaing in process
15:12 * meetingology mapreri start thread on ML about how to use bug status to define meaing in process
15:13 * mapreri loves these meetings, but it's a constant reminder of failure to keep up, so ugly :(
15:13 <ddstreet> #subtopic discuss charter/policies drafts
15:13 <ddstreet> i think we can drop this, falls under my action to email the ML
15:13 <ddstreet> ok that's all the previous actions
15:13 <teward> just an FYI with lintian, i believe Debian/upstream is looking for maintainers as well
15:14 <teward> so it's in that odd 'not really updated' state there :P
15:14 <mapreri> well, it *has* a new maintainer since ~2 months
15:14 <teward> oh it does?  I missed emails then
15:14 <mapreri> for sure he would love more helping hands however :P
15:14 <mapreri> yes, Axel Beckert
15:14 <teward> *puts mapreri on that* (but i digres)
15:14 <teward> digress*
15:14 <bittin> https://lists.debian.org/debian-qa/2022/07/msg00001.html ?
15:15 <mapreri> bittin: nope, that's about the website (well, the thing that runs lintian continuously on all uploaded packages), which is a separate thing from the lintian program itself.
15:15 <teward> that's related but i can find the specific item in my inbox (> 400 emails a week)
15:15 <mapreri> although it was… normally maintained by the same time, it fell into a sorry state last year
15:16 <teward> but i digress, that's outside the backporters purview just wanted to make a note but then i was updated :)
15:16 <bittin> mapreri, alright sorry
15:16 <mapreri> bittin: here is the "adoption" mail: https://bugs.debian.org/1012289#22
15:16 <ubottu> Debian bug 1012289 in wnpp "RFH: lintian -- Debian package checker" [Normal, Open]
15:16 <bittin> ah
15:17 <mapreri> right
15:17 <mapreri> ddstreet: I think you can continue with the agenda :3
15:17 <teward> yep
15:17 <ddstreet> #topic open ML threads
15:18 <ddstreet> #subtopic clarification on specific wording for no-bug-required backport exceptions
15:18 <ddstreet> i think this is covered by my action item to reply
15:18 <ddstreet> i'll leave it in the open ml threads section tho, as it is still an open topic
15:19 <ddstreet> #action clarification on specific wording for no-bug-required backport exceptions
15:19 * meetingology clarification on specific wording for no-bug-required backport exceptions
15:19 <ddstreet> #subtopic TB ML thread for charter
15:19 <ddstreet> let's drop this, as i'll start a new thread to review the updated pages
15:19 <ddstreet> any other ML threads we should discuss?
15:20 <ddstreet> ok let's move on
15:20 <ddstreet> #topic open bugs
15:20 <mapreri> sure
15:20 <mapreri> here
15:20 <mapreri> 1. https://bugs.launchpad.net/ubuntu/+source/dh-python/+bug/1983414
15:20 <ubottu> Launchpad bug 1983414 in dh-python (Ubuntu) "[BPO] dh-python 5.20220403 to focal" [Undecided, New]
15:20 <mapreri> do you see any potential problem with dh-python?  IME it's very much backward-friendly, so I'm +1, but I'd check with you
15:21 <mapreri> the new version needed for supporting pyproject is quite a relevant feature (maybe not right now, but soon it will be clear)
15:21 <ddstreet> i haven't looked closely at this, but my understanding is dh-python is essentially only a metapkg that basically specifies what the default minor version of py is
15:21 <mapreri> nope
15:22 <mapreri> it ships pybuild (debhelper buildsystem) and dh_python3 (debhelper addon)
15:22 <bittin> "dh-python: Debian helper tools for packaging Python libraries and applications"
15:22 <ddstreet> ah pybuild
15:23 <mapreri> that's why I say a closer look might be warranted.  but my knowledge of the tool is that it should be quite safe.
15:23 <ddstreet> yeah i assume it will retain backwards compatibility for building so *should* be safe
15:23 <ddstreet> but i agree the changes should have a closer look to be sure
15:24 <mapreri> so that's it, I'm just dropping the ball here!
15:24 <mapreri> 2. https://bugs.launchpad.net/ubuntu/focal/+source/ipmctl/+bug/1968076
15:24 <ubottu> Launchpad bug 1968076 in ipmctl (Ubuntu Focal) "[BPO] ipmctl with support for CPS hardware" [Undecided, New]
15:24 <mapreri> … kilobyte can't find a sponsor, apparently?
15:24 <mapreri> should we just close our eyes (for now, at least?)
15:25 <ddstreet> i hate to do that, but i dont think we would be able to keep up with sponsoring backport requests
15:25 <ddstreet> at least with our current team
15:26 <ddstreet> i mean i think it's fine for us to volunteer to sponsor stuff if we want to
15:26 <bittin> https://www.pcworld.com/article/821256/intel-kills-optane-memory.html but i guess people have still bought Optane memory keept :D
15:26 <mapreri> yeah, I also don't really want to give the impression that we are happy to sponsor things, so I'm afraid of setting "a precedent" (such a grave word in this context!)
15:26 <ddstreet> but i dont think we should feel responsible for sponsoring, no?
15:26 <teward> no that's not our job
15:26 <mapreri> ddstreet: we should not, indeed.
15:27 <teward> mapreri: i did tell him that he can ask me to help him sponsor
15:27 <teward> i owe kilobyte a few hundred favors for signing my DM application :P
15:27 <teward> independently from backporters
15:27 <mapreri> teward: well, he also subscribed ~ubuntu-sponros!
15:27 <teward> ye well sponsors are not aware of the new process entirely
15:27 <teward> but meh
15:27 <bittin> ~ubuntu-sponsors*
15:27 <teward> in the case of that package do we have a problem with the backport?
15:28 <teward> assuming i sponsor him as -sponsors not -backporters
15:28 <teward> (because i'm happy to let you all handle the actual review)
15:28 <ddstreet> i'm not sure how effective the ubuntu-sponsors team is these days, but that probably is the best option, currently
15:28 <mapreri> teward: I haven't looked at it myself, but seeing how you NACKed one upload, I figured you'd be on top of it, more or less.
15:28 <teward> check this is likely buried
15:28 <teward> it was NACK'd because he targeted an Unstable version instead of Ubuntu bpo policy so
15:29 <teward> i'll reivew that one, put me on it
15:29 <mapreri> but we should also figure a point after which we drop ~ubuntu-backports saying "re-subscribe when it's uploaded", since it's not our responsibility.
15:29 <teward> mapreri: my 2 cents is,the moment that it has no uploads and we see that, we should drop backporters
15:29 <teward> IMO
15:30 <teward> (but i'm much more harsh heh)
15:30 <ddstreet> teward ok it's yours - i dont think we have a specific way to indicate a reviewer though unless you want to take the 'assigned to' field
15:31 <ddstreet> mapreri yep agreed - i think that should fall into the 'bug status defining process meaning' discussion?
15:31 <mapreri> ack
15:31 <mapreri> so, I think this bug is "taken care of", for what the meeting is concerned
15:32 <ddstreet> there is https://bugs.launchpad.net/ubuntu/jammy/+source/limnoria/+bug/1983415
15:32 <ubottu> Launchpad bug 1983415 in limnoria (Ubuntu Jammy) "[BPO] limnoria 2022.6.23-1 to jammy" [Undecided, New]
15:32 <ddstreet> i have not looked at it yet
15:32 <mapreri> that one's ok
15:32 <ddstreet> that's all the bugs then
15:32 <mapreri> (in the sense, it's trivial doesn't need team-wide discussion)
15:32 <mapreri> (and I'm a maintainer of that, so I'm biased :>)
15:33 <ddstreet> #topic AOB
15:33 <ddstreet> any other stuff to discuss?
15:33 <mapreri> FYI: I'll be totally afk (camping without reception) for 2 weeks starting saturday
15:34 <ddstreet> nice, have fun! i haven't been camping in a long time
15:34 <mapreri> also FYI: I'm now core-dev, if you missed it!
15:34 <mapreri> BUT
15:34 <ddstreet> AH congrats!!!! that's awesome!
15:34 <mapreri> teward: you haven't added me to ~core-dev and whatever else is needed to reflect my new status! :>
15:34 <teward> ye i've been exceptionally busy
15:34 <teward> ERR:SWAMPED
15:35 <ddstreet> ok if there's nothing else, let's wrap up?
15:35 <mapreri> teward: I recommend taking a completely afk vacation of at least 1 week (like I'm doing).  that's going to unload your mind completely, and no matter the size of your todo list, it won't feel much :P
15:35 <bittin> next meeting time etc?
15:36 <ddstreet> bittin ah right
15:36 <mapreri> sep 7th?
15:36 <ddstreet> #topic administrative items
15:36 <mapreri> or the 31st?
15:36 <ddstreet> #subtopic schedule next mtg
15:36 <bittin> Aug 31? as September does only have 30 days
15:36 <ddstreet> i can do either
15:37 <bittin> Aug 31 works best for me
15:37 <ddstreet> aug 31 is 4 weeks, so our 'standard' interval
15:37 <mapreri> same, both days currently are very good
15:37 <ddstreet> ok let's do aug 31
15:37 <mapreri> same time?
15:37 <bittin> works
15:37 <ddstreet> same time, 15:00 UTC?
15:37 <mapreri> sure
15:38 <ddstreet> #action ddstreet sched next meeting for aug 31 15:00 UTC
15:38 * meetingology ddstreet sched next meeting for aug 31 15:00 UTC
15:38 <ddstreet> i'll update the agenda page
15:38 <ddstreet> anything else?
15:38 <bittin> not from me
15:38 <bittin> anyone else?
15:39 <mapreri> none from me
15:39 <ddstreet> ok let's wrap!
15:39 <ddstreet> #endmeeting