19:02 <rbasak> #startmeeting Developer Membership Board
19:02 <meetingology> Meeting started at 19:02:43 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:02 <meetingology> Available commands: action, commands, idea, info, link, nick
19:02 <rbasak> #topic Review of previous action items
19:02 <rbasak> kanashiro to update our wiki documentation with respect to our agreed packageset creation criteria (done)
19:03 <rbasak> sil2100 update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
19:03 <rbasak> teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:03 <rbasak> rbasak to add schopin to core-dev
19:03 <rbasak> rbasak to announce schopin's successful application
19:03 <rbasak> ^ mine are done
19:03 <teward> carry mine over.
19:03 <teward> just never enough time in the day/week
19:03 <rbasak> OK
19:04 <rbasak> #action sil2100 update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
19:04 * meetingology sil2100 update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
19:04 * genii 's ears perk up for a moment
19:04 <rbasak> #action teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:04 * meetingology teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:04 <rbasak> I think that's all the actions?
19:04 <rbasak> Since we have no applications today...
19:04 <rbasak> #topic Long-term action items (do not need to be mentioned in regular meetings)
19:04 <teward> * rbasak to send teward all the coffee
19:05 <rbasak> Is anyone available to take any of these?
19:05 <teward> that's missing :P
19:05 <bdmurray> I am not
19:05 <rbasak> In particular, the automated packageset stuff could do with some coding (rather than meeting attendence) attention
19:06 <rbasak> #topic Outstanding mailing list requests to assign
19:06 <rbasak> #info No recent ML activity
19:06 <rbasak> #topic Open TB bugs
19:06 <rbasak> #info
19:06 <rbasak> There are currently no open bugs.
19:07 <rbasak> #info There are currently no open bugs.
19:07 <rbasak> #topic AOB
19:07 <rbasak> AOB from anyone?
19:07 <seb128> speaking about packageset, I think we ended up not doing any refresh before the LTS right?
19:07 <rbasak> I guess not
19:07 <seb128> L_aney replied to my questions on the list with details but I never found the time to digest that and do something about it
19:07 <rbasak> I've on occasion manually added packages that are obviously correct
19:08 <rbasak> Yeah it's not really trivial :-/
19:08 <seb128> does anyone understand how that works better than me to work on doing a refresh?
19:08 <seb128> if not I will try to read L_aney's reply again and figure out what the changes listed are like they are
19:09 <seb128> I wonder if we should just go with it or if that's buggy and needs some sort of fixing though
19:11 <rbasak> I don't think anyone currently on the DMB does understand it in detail. I roughly understand what it does, but that's it.
19:11 <teward> ^^ that's about right
19:11 <seb128> :-(
19:11 <teward> i don't think anyone really understands the tooling and it's probably much overdue for a rewrite, etc.
19:11 <teward> but nobody has the time for it
19:11 <rbasak> Right
19:11 <seb128> k, so more targetted question
19:11 <seb128> I'm interested to see the desktop set refreshed to include new things we had over the recent cycles
19:12 <rbasak> I'd like to see it refactored to Python set arithmetic, and then we could easily have tests for specific cases that need fixing manually.
19:12 <seb128> should I just try to add those individual item in a first time? do we have a review process of some sort for such changes?
19:12 <rbasak> But, I'm not volunteering, so that's just a suggestion.
19:13 <rbasak> seb128: please do! There's no review process - we just ask each other as we feel appropriate.
19:13 <seb128> would be nice, but seeing how the carry over items already kept beeing carried over again and again I doubt a more complex project is going to do better
19:13 <seb128> rbasak, ok, thanks, will do
19:13 <rbasak> Really it's the packageset changes that you push that you're taking responsibility as a DMB member for IMHO.
19:13 <rbasak> And the tooling is just a way of helping with that.
19:13 <rbasak> Thanks Seb!
19:14 <seb128> thanks!
19:14 <seb128> that was all from me
19:14 <rbasak> Oh one sec
19:15 <rbasak> You mean add the packageset packages manually, rather than working on the tooling?
19:15 <rbasak> I think that's fine for you to just do as well, but maybe leave a note to devel-permissions@ to explain what changes you made?
19:16 <rbasak> In other words, I'm fine with you using your judgement to decide that packages should be in the desktop packageset, but please leave a record of what you decided on the ML.
19:16 <seb128> right, well I will read L_aney's email again and see if I can figure out something better
19:16 <rbasak> Sure. Thanks!
19:16 <rbasak> Any other AOB?
19:17 <seb128> but if I don't find the time to work on that I will go the easy way and suggest the changes to fix the desktop set to match what we current provide
19:17 <rbasak> +1
19:17 <rbasak> Thanks all!
19:17 <rbasak> #endmeeting